Firmar digitalmente un proyecto de macro

Nota: Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

En este artículo se describe cómo se puede firmar digitalmente un proyecto de macros mediante certificado. Si aún no tiene ningún certificado digital, debe obtener uno. Para probar los proyectos de macro en su propio equipo, puede crear su propio certificado de firma con la herramienta Selfcert.exe.

Puede obtener un certificado digital de una entidad emisora de certificados comercial o del administrador de seguridad o de un profesional de las tecnologías de la información de su organización.

Para obtener más información sobre entidades emisoras de certificados que ofrecen servicios para productos de Microsoft, consulte la lista de Miembros del Programa de certificados raíz de Microsoft.

Dado que el certificado digital que crea no está emitido por una entidad de certificación formal de confianza, los proyectos de macro firmados con dichos certificados se conocen como proyectos con firma propia. Microsoft Office confía en los certificados de firma propia únicamente en los equipos que contienen el certificado de firma propia agregado en la carpeta de certificación raíz de confianza en el almacén de certificados del usuario actual.

Para obtener información sobre la creación de un certificado de firma propia, consulte la sección siguiente.

  1. Vaya a c:\Archivos de programa (x86) \Microsoft Office\root\Office16.

  2. Haga clic en SelfCert.exe. Aparece el cuadro Crear certificado digital.

  3. En el cuadro Nombre del certificado, escriba un nombre descriptivo para el certificado.

  4. Haga clic en Aceptar.

  5. Cuando se observe el mensaje SelfCert se ha creado correctamente, haga clic en Aceptar.

  1. Vaya a C:\Archivos de programa\Microsoft Office\<versión de Office>\.

  2. Haga clic en SelfCert.exe. Aparece el cuadro Crear certificado digital.

  3. En el cuadro Nombre del certificado, escriba un nombre descriptivo para el certificado.

  4. Haga clic en Aceptar.

  5. Cuando se observe el mensaje SelfCert se ha creado correctamente, haga clic en Aceptar.

  1. Haga clic en el botón Inicio, elija Todos los programas, haga clic en Microsoft Office, en Herramientas de Microsoft Office y después en Certificado digital para proyectos de VBA.
    Aparece el cuadro crear certificado digital .

  2. En el cuadro Nombre del certificado, escriba un nombre descriptivo para el certificado.

  3. Haga clic en Aceptar.

  4. Cuando se observe el mensaje SelfCert se ha creado correctamente, haga clic en Aceptar.

Cuadro de diálogo Crear firma digital

Para ver el certificado en el almacén de certificados personales, siga este procedimiento:

  1. Abra Internet Explorer.

  2. En el menú Herramientas, haga clic en Opciones de Internet y después en la pestaña Contenido.

  3. Haga clic en Certificados y después en la pestaña Personal.

  1. Abra el archivo que contiene el proyecto de macro que desee firmar.

  2. En la pestaña Programador, en el grupo Código, haga clic en Visual Basic.

    Nota: Si la pestaña Programador no está disponible: haga clic en la pestaña Archivo. Haga clic en Opciones. Haga clic en Personalizar cinta de opciones. En la lista Personalizar la Cinta, seleccione Programador y después haga clic en Aceptar.

  3. En Visual Basic, en el menú Herramientas haga clic en Firma digital.

  4. Se observa el cuadro de diálogo Firma digital.

  5. Seleccione un certificado y haga clic en Aceptar.

    Nota: Si no ha seleccionado un certificado digital o quiere usar otro, haga clic en elegir. Seleccione un certificado y haga clic en Aceptar.

    Notas: 

    • Se recomienda firmar las macros solamente después de haber probado la solución y de que esta esté lista para ser distribuida: cuando se modifica de algún modo el código de un proyecto de macro firmado, se elimina la firma digital. Sin embargo, si tiene el certificado digital válido que anteriormente se usó para firmar el proyecto en el equipo, el proyecto de macro se firmará automáticamente al guardarlo.

    • Si desea evitar que los usuarios de su solución cambien accidentalmente su proyecto de macro e invaliden su firma, bloquee el proyecto de macro antes de firmarlo. Su firma digital implica que garantiza que el proyecto no se ha manipulado desde que lo firmó. La firma digital no demuestra que usted escribió el proyecto. Por lo tanto, bloquear el proyecto de macros no impide que otro usuario Reemplace la firma digital con otra firma. Los administradores corporativos pueden volver a firmar las plantillas y los complementos para poder controlar los usuarios que se ejecutan en sus equipos.

    • Si crea un complemento que agrega código a un proyecto de macro, el código debe determinar si el proyecto se ha firmado digitalmente e informar al usuario de las consecuencias de modificar un proyecto firmado antes de continuar.

    • Cuando firme macros digitalmente, es importante que obtenga una marca de tiempo para que otros usuarios puedan comprobar la firma si el certificado utilizado para la firma ha caducado o ha sido revocado después de firmar. Si firma macros sin ninguna marca de tiempo, la firma solo será válida durante el período de validez del certificado.

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×