Saltar al contenido principal

FIELDVALUE (función FIELDVALUE)

Nota: Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Puede usar la función FIELDVALUE para recuperar los datos del campo de tipos de datos vinculados como los tipos de datos Cotizaciones o Geografía. Hay métodos más fáciles para escribir fórmulas que hacen referencia a los tipos de datos, por lo que la función FIELDVALUE debe usarse principalmente para crear cálculos condicionales basados en los tipos de datos vinculados.

Nota: 28 de marzo de 2019: los tipos de datos se han publicado para todos los suscriptores de Windows Office 365. Si es un suscriptor de Office 365, asegúrese de tener instalada la versión más reciente de Office.

Detalles técnicos

Sintaxis

=FIELDVALUE(value, field_name)

La sintaxis de la función FIELDVALUE tiene los siguientes argumentos:

argumento

Descripción

value

La función devuelve todos los campos coincidentes en el tipo de datos vinculado especificado en el argumento de valor.

field_name

Los nombres de los campos de los que desea extraer el tipo de datos vinculado

Descripción

Ejemplos

En el siguiente ejemplo básico, la fórmula =FIELDVALUE(A2,"Precio") extrae el campo Precio del tipo de datos de cotizaciones para JM Smucker Co.

Recuperar un precio de cotizaciones de empresa con =FIELDVALUE(A2,"Precio")

El siguiente es un ejemplo más habitual de la función FIELDVALUE. Se usa la función SI.ERRROR para comprobar si hay errores. Si no hay un nombre de compañía en la celda A2, la fórmula FIELDVALUE devuelve un error y en ese caso queremos que no se muestre nada (""). Sin embargo, si hay un nombre de compañía, queremos recuperar el precio del tipo de datos en A2 con =SI.ERROR(FIELDVALUE($A2,B$1),"").

Recuperar un precio de cotizaciones de empresa y omitir errores con =SI.ERROR(FIELDVALUE($A2,B$1),"")

Tenga en cuenta que la función FIELDVALUE le permite hacer referencia a celdas de la hoja de cálculo para el argumento field_name, por lo que la fórmula anterior hace referencia a la celda B1 para Precio en lugar de escribir manualmente "Precio" en la fórmula.  

Observaciones

Si intenta recuperar datos de un campo tipo de datos que no existe, la función FIELDVALUE devolverá el error #FIELD!. Por ejemplo, es posible que haya escrito "precios" cuando el campo tipo de datos real se denomina "precio". Vuelva a comprobar la fórmula para asegurarse de que está usando un nombre de campo válido. Si desea mostrar una lista de nombres de campo para un registro, seleccione la celda del registro y presione Alt + Mayús + F10.

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Vea también

Tipos de datos Geografía y Cotizaciones

Cómo escribir fórmulas que hagan referencia a tipos de datos

Error #CAMPO!

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider