Ejemplos de fórmulas comunes en Listas de SharePoint

Ejemplos de fórmulas comunes en Listas de SharePoint

Nota: Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Usar fórmulas en columnas calculadas de una lista de SharePoint o SharePoint biblioteca puede ayudarle a agregar columnas existentes, como calcular impuestos sobre ventas en un precio. Se pueden combinar para validar datos mediante programación.

Al escribir fórmulas, a menos que se especifique lo contrario, no hay espacios entre las palabras clave y los operadores. La siguiente no es una lista exhaustiva. Para ver todas las fórmulas en SharePoint, vea la lista alfabética al final de este artículo.

Nota: Los campos calculados solo funcionan en su propia fila, por lo que no puede hacer referencia a un valor de otra fila o a las columnas contenidas en otra lista o biblioteca. Los campos de búsqueda no se admiten en una fórmula y no se puede usar el ID. de fila recién insertada, ya que el identificador no existe cuando se procesa la fórmula.

Puede usar las fórmulas siguientes para probar la condición de una instrucción y devolver un valor de Sí o No, para probar un valor alternativo como Correcto o Incorrecto o devolver un espacio en blanco o un guion para representar un valor nulo.

Comprobar si un número es mayor o menor que otro

Use la función si para realizar esta comparación.

Columna1

Columna2

Fórmula

Descripción (resultado posible)

15000

9000

=[Columna1]>[Columna2]

¿Es Columna1 mayor que Columna2? (Sí)

15000

9000

=SI([Columna1]<=[Columna2], "Correcto", "Incorrecto")

¿Es Columna1 igual o menor que Columna2? (Incorrecto)

Devolver un valor lógico después de comparar el contenido de las columnas

Para obtener un resultado que sea un valor lógico (sí o no), use las funciones y, oy no .

Columna1

Columna 2

Columna3

Fórmula

Descripción (resultado posible)

15

9

9

=Y([Columna1]>[Columna2], [Columna1]<[Columna3])

¿Es 15 mayor que 9 y menor que 8? (No)

15

9

9

=O([Columna1]>[Columna2], [Columna1]<[Columna3])

¿Es 15 mayor que 9 yo menor que 8? (Sí)

15

9

9

=NO([Columna1]+[Columna2]=24)

¿Es 15 más 9 distinto a 24? (No)

Para obtener un resultado que sea otro cálculo, o cualquier otro valor distinto de sí o no, use las funciones si, yy o .

Columna1

Columna 2

Columna3

Fórmula

Descripción (resultado posible)

15

9

9

=SI([Columna1]=15, "Correcto", "Incorrecto")

Si el valor de Columna1 es igual a 15, se devuelve "Correcto". (Correcto)

15

9

9

=SI(Y([Columna1]>[Columna2], [Columna1]<[Columna3]), "Correcto", "Incorrecto")

Si 15 es mayor que 9 y menor que 8, se devuelve "Correcto". (Incorrecto)

15

9

9

=SI(O([Columna1]>[Columna2], [Columna1]<[Columna3]), "Correcto", "Incorrecto")

Si 15 es mayor que 9 o menor que 8, se devuelve "Correcto". (Correcto)

Mostrar ceros como espacios en blanco o guiones

Para mostrar un cero, realice un cálculo sencillo. Para mostrar un espacio en blanco o un guión, use la función si.

Columna1

Columna2

Fórmula

Descripción (resultado posible)

10

7

=[Columna1]-[Columna2]

Se resta el segundo número del primero (0).

15

9

=SI([Columna1]-[Columna2],"-",[Columna1]-[Columna2])

Devuelve un guión cuando el valor es cero (-).

Ocultar valores de error en columnas

Para mostrar un guión, #N/A o ND en lugar de un valor de error, use la Función ESERROR.

Columna1

Columna2

Fórmula

Descripción (resultado posible)

7

valor

=[Columna1]/[Columna2]

Da un error (#¡DIV/0!).

7

valor

=SI(ESERROR([Columna1]/[Columna2]),"NOD",[Columna1]/[Columna2])

Devuelve NOD cuando el valor es un error.

7

valor

=SI(ESERROR([Columna1]/[Columna2]),"-",[Columna1]/[Columna2])

Devuelve un guión cuando el valor es un error.

Buscar campos en blanco

Puede usar la fórmula esblanco para buscar campos en blanco.

Columna1

Fórmula

Descripción (resultado posible)

"Habas"

= EsBLANCO ([Columna1]

Devuelve sí o no si está en blanco o no.

Alea

= Si (esBLANCO ([Columna1]), "no está bien", "Aceptar")

ReLlene sus propias opciones-el primero es si está en blanco, segundo si no lo está

Para obtener más funciones de is, vea is (funciones).

Puede usar las siguientes fórmulas para realizar cálculos basados en fechas y horas, como añadir un número de días, meses o años a una fecha, calcular la diferencia entre dos fechas y convertir la hora a un valor decimal.

Agregar fechas

Para agregar un número de días a una fecha, use el operador de suma (+).

Nota: Cuando se manipulan fechas, el tipo de valor devuelto de la columna calculada debe establecerse en fecha y hora.

Columna1

Columna2

Fórmula

Descripción (resultado)

9/6/2007

3

=[Columna1]+[Columna2]

Suma 3 días a 9/6/2007 (12/6/2007)

10/12/2008

54

=[Columna1]+[Columna2]

Suma 54 días a 10/12/2008 (2/2/2009)

Para agregar un número de meses a una fecha, use las funciones fecha, año, mesy dia .

Columna1

Columna2

Fórmula

Descripción (resultado)

9/6/2007

3

=FECHA(AÑO([Columna1]),MES([Columna1])+[Columna2],DIA([Column1]))

Agrega 3 meses a 9/6/2007 (9/9/2007)

10/12/2008

25

=FECHA(AÑO([Columna1]),MES([Columna1])+[Columna2],DIA([Column1]))

Agrega 25 meses a 10/12/2008 (10/1/2011)

Para agregar un número de años a una fecha, use las funciones fecha, año, mesy dia .

Columna1

Columna2

Fórmula

Descripción (resultado)

9/6/2007

,3

=FECHA(AÑO([Columna1])+[Columna2],MES([Columna1]),DIA([Columna1]))

Suma 3 años a 9/6/2007 (9/6/2010)

10/12/2008

25

=FECHA(AÑO([Columna1])+[Columna2],MES([Columna1]),DIA([Columna1]))

Suma 25 años a 12/10/2008 (12/10/2033)

Para agregar una combinación de días, meses y años a una fecha, use las funciones fecha, año, mesy dia .

Columna1

Fórmula

Descripción (resultado)

9/6/2007

=FECHA(AÑO([Columna1])+3,MES([Columna1])+1,DIA([Columna1])+5)

Suma 3 años, 1 mes y 5 días a 9/6/2007 (14/7/2010)

10/12/2008

=FECHA(AÑO([Columna1])+1,MES([Columna1])+7,dia([Columna1])+5)

Suma 1 año, 7 meses y 5 días a 10/12/2008 (15/7/2010)

Calcular la diferencia entre dos fechas

Use la función SIFECHA para realizar este cálculo.

Columna1

Columna2

Fórmula

Descripción (resultado)

01-Ene-1995

15-Jun-1999

=SIFECHA([Columna1], [Columna2],"d")

Devuelve la cantidad de días entre dos fechas (1626)

01-Ene-1995

15-Jun-1999

=SIFECHA([Columna1], [Columna2],"ym")

Devuelve el número de meses entre las fechas, ignorando la parte de los años (5)

01-Ene-1995

15-Jun-1999

=SIFECHA([Columna1], [Columna2],"yd")

Devuelve el número de días entre las fechas, ignorando la parte de los años (165)

Calcular la diferencia entre dos horas

Para presentar el resultado en el formato de hora estándar (horas: minutos: segundos), use el operador de resta (-) y la función texto . Para que este método funcione, las horas no deben superar 24, y los minutos y los segundos no deben superar 60.

Columna1

Columna2

Fórmula

Descripción (resultado)

09/06/2007 10:35

09/06/2007, 15:30

=TEXTO([Columna2]-[Columna1],"h")

Horas transcurridas (4)

09/06/2007 10:35

09/06/2007, 15:30

=TEXTO([Columna2]-[Columna1],"h:mm")

Horas y minutos transcurridos (4:55)

09/06/2007 10:35

09/06/2007, 15:30

=TEXTO([Columna2]-[Columna1],"h:mm:ss")

Horas, minutos y segundos transcurridos (4: 55:00)

Para presentar el resultado en un total que se basa en una unidad de tiempo, use la función entero , o bien, la función hora, minutoo segundo .

Columna1

Columna2

Fórmula

Descripción (resultado)

09/06/2007 10:35

10/06/2007, 15:30

=ENTERO(([Columna2]-[Columna1])*24)

Horas transcurridas (28)

09/06/2007 10:35

10/06/2007, 15:30

=ENTERO(([Columna2]-[Columna1])*1440)

Minutos transcurridos (1735)

09/06/2007 10:35

10/06/2007, 15:30

=ENTERO(([Columna2]-[Columna1])*86400)

Segundos transcurridos (104100)

09/06/2007 10:35

10/06/2007, 15:30

=HORA([Columna2]-[Columna1])

Horas transcurridas cuando la diferencia no es mayor que 24 (4)

09/06/2007 10:35

10/06/2007, 15:30

=MINUTO([Columna2]-[Columna1])

Minutos transcurridos cuando la diferencia no es mayor que 60 (55)

09/06/2007 10:35

10/06/2007, 15:30

=SEGUNDO([Columna2]-[Columna1])

Segundos transcurridos cuando la diferencia no es mayor que 60 (0)

Convertir horas

Para convertir horas desde el formato de hora estándar a un número decimal, use la función entero .

Columna1

Fórmula

Descripción (resultado)

10:35 AM

=([Columna1]-ENTERO([Columna1])) * 24

Número de horas desde las 12:00 AM (10,583333)

12:15 PM

=([Columna1]-ENTERO([Columna1])) * 24

Número de horas desde las 12:00 AM (12,25)

Para convertir horas de un número decimal al formato de hora estándar (horas: minutos: segundos), use el operador de división y la función texto .

Columna1

Fórmula

Descripción (resultado)

23:58

=TEXTO(Columna1/24, "hh:mm:ss")

Horas, minutos y segundos desde las 12:00 (00: 59:55)

2:06

=TEXTO(Column1/24, "h:mm")

Horas y minutos desde las 12:00 (0:05)

Insertar fechas julianas

Una fecha juliana hace referencia a un formato de fecha que combina el año actual y el número de días desde el principio del año. Por ejemplo, el 1 de enero de 2007, se representa como 2007001 y el 31 de diciembre de 2007, se representa como 2007365. Este formato no se basa en el calendario juliano.

Para convertir una fecha en una fecha juliana, use las funciones texto y FECHANUMERO .

Columna1

Fórmula

Descripción (resultado)

23/6/2007

=TEXTO([Columna1],"yy")&TEXTO(([Column1]-FECHANUMERO("1/1/"& TEXTO([Column1],"yy"))+1),"000")

Fecha en formato juliano, con un año de dos dígitos (07174)

23/6/2007

=TEXTO([Columna1],"yyyy")&TEXTO(([Columna1]-FECHANUMERO("1/1/"&TEXTO([Columna1],"yy"))+1),"000")

Fecha en formato juliano, con un año de cuatro dígitos (2007174)

Para convertir una fecha en una fecha juliana (usada en astronomía), utilice la constante 2415018,50. Esta fórmula solo funciona en fechas posteriores al 1/3/1901, y si está utilizando el sistema de fechas de 1900.

Columna1

Fórmula

Descripción (resultado)

23/6/2007

=[Columna1]+2415018,50

Fecha en formato juliano, utilizada en astronomía (2454274,50)

Mostrar las fechas con el día de la semana

Para convertir fechas al texto del día de la semana, use las funciones texto y DIASEM.

Columna1

Fórmula

Descripción (resultado posible)

19-feb-2007

=TEXTO(DIASEM([Columna1]), "dddd")

Calcula el día de la semana para la fecha y devuelve el nombre completo del día (lunes)

3-ene-2008

=TEXTO(DIASEM([Columna1]), "ddd")

Calcula el día de la semana para la fecha y devuelve el nombre abreviado del día (jue)

Puede usar las siguientes fórmulas para realizar una serie de cálculos matemáticos, como sumar, restar, multiplicar y dividir números, calcular el promedio o la mediana de los números, redondear un número y contar valores.

Sumar números

Para sumar números de dos o más columnas a la vez, use el operador de suma (+) o la función suma .

Columna1

Columna 2

Columna3

Fórmula

Descripción (resultado)

6

3,5

cuatro

=[Columna1]+[Columna2]+[columna 3]

Suma los valores de las tres primeras columnas (15)

6

3,5

cuatro

=SUMA([Columna1],[Columna2],[Columna3])

Suma los valores de las tres primeras columnas (15)

6

3,5

cuatro

=SUMA(SI([Columna1]>[Columna2], [Columna1]-[Columna2], 10), [Columna3])

Si Columna1 es mayor que Columna2, agrega la diferencia y Columna3. Si no, agrega 10 y Columna3 (5)

Restar números

Para restar números de dos o más columnas en una fila, use el operador de resta (-) o la función suma con números negativos.

Columna1

Columna2

Columna3

Fórmula

Descripción (resultado)

15000

9000

-8000

=[Columna1]-[Columna2]

Resta 9000 de 15000 (6000).

15000

9000

-8000

=SUMA([Columna1], [Columna2], [Columna3])

Suma los números en las tres primeras columnas, incluidos los valores negativos (16000)

Ejemplo 5: Calcular la diferencia entre dos números y mostrarla como porcentaje

Use los operadores de resta (-) y división (/) y la función ABS .

Columna1

Columna2

Fórmula

Descripción (resultado)

2342

2500

=([Columna2]-[Columna1])/ABS([Columna1])

Cambio de porcentaje (6,75% o 0,06746)

Multiplicar números

Para multiplicar números de dos o más columnas en una fila, use el operador de multiplicación (*) o la función producto .

Columna1

Columna2

Fórmula

Descripción (resultado)

3,5

2

=[Columna1]*[Columna2]

Multiplica los números de las dos primeras columnas (10).

3,5

2

=PRODUCTO([Columna1], [Columna2])

Multiplica los números de las dos primeras columnas (10).

3,5

2

=PRODUCTO([Columna1], [Columna2],2)

Multiplica los números de las dos primeras columnas y el número 2 (20).

Dividir números

Para dividir números en dos o más columnas a la vez, use el operador de división (/).

Columna1

Columna2

Fórmula

Descripción (resultado)

15000

2007

=[Columna1]/[Columna2]

Divide 15000 por 12 (1250).

15000

2007

=([Columna1]+10000)/[Columna2]

Suma 15000 y 10000 y, a continuación, el total se divide entre 12 (2083)

Calcular el promedio de números

El promedio también se denomina media. Para calcular el promedio de números de dos o más columnas en una fila, use la función promedio .

Columna1

Columna 2

Columna3

Fórmula

Descripción (resultado)

6

3,5

cuatro

=PROMEDIO([Columna1], [Columna2],[Columna3])

Promedio de los números en las tres primeras columnas (5)

6

3,5

cuatro

=PROMEDIO(SI([Columna1]>[Columna2], [Columna1]-[Columna2], 10), [Columna3])

Si Columna1 es mayor que Columna2, calcula el promedio de la diferencia y Columna3. En caso contrario, calcula el promedio del valor 10 y Columna3 (2,5)

Calcular la mediana de números

La mediana es el valor central de un rango ordenado de números. Use la función mediana para calcular la mediana de un grupo de números.

A

B

C

D

E

F

Fórmula

Descripción (resultado)

7

7

9

,27

valor

cuatro

= MEDIANA(A, B, C, D, E, F)

Mediana de los números de las 6 primeras columnas (8)

Calcular el número menor o mayor en un rango

Para calcular el número menor o mayor en dos o más columnas de una fila, use las funciones mín y máx .

Columna1

Columna2

Columna3

Fórmula

Descripción (resultado)

7

7

9

=MIN([Columna1], [Columna2], [Columna3])

Número más pequeño (7)

7

7

9

=MAX([Columna1], [Columna2], [Columna3])

Número más alto (10)

Contar valores

Para contar valores numéricos, use la función contar .

Columna1

Columna2

Columna3

Fórmula

Descripción (resultado)

Apple

12/12/2007

=CONTAR([Columna1], [Columna2], [Columna3])

Cuenta el número de columnas que contienen valores numéricos. Excluye la fecha y hora, texto y valores nulos (0)

12 $

#¡DIV/0!

1.01

=CONTAR([Columna1], [Columna2], [Columna3])

Cuenta el número de columnas que contienen valores numéricos, pero excluye errores y valores lógicos (2)

Ejemplo 1: Aumentar o disminuir un número según un porcentaje

Use el operador de porcentaje (%) para realizar este cálculo.

Columna1

Columna2

Fórmula

Descripción (resultado)

23

3%

=[Columna1]*(1+5%)

Aumenta el número de Columna1 en un 5% (24,15)

23

3%

=[Columna1]*(1+[Columna2])

Aumenta el número de Columna1 en el valor de porcentaje de Columna2: 3% (23,69)

23

3%

=[Columna1]*(1-[Columna2])

Disminuye el número en Columna1 en el valor del porcentaje de Columna2: 3% (22,31)

Elevar un número a una potencia

Use el operador exponencial (^) o la función potencia para realizar este cálculo.

Columna1

Columna2

Fórmula

Descripción (resultado)

3,5

2

=[Columna1]^[Columna2]

Calcula cinco al cuadrado (25)

3,5

,3

=POTENCIA([Columna1], [Columna2])

Calcula cinco al cubo (125)

Redondear un número

Para redondear hacia arriba un número , use la función redondear, imparo incluso .

Columna1

Fórmula

Descripción (resultado)

20,3

=REDONDEAR.MAS([Columna1],0)

Redondea 20,3 hacia arriba hasta el número entero más cercano (21)

-5,9

=REDONDEAR.MAS([Columna1],0)

Redondea 5,9 hacia arriba hasta el número entero más cercano (-5)

12,5493

=REDONDEAR.MAS([Columna1],2)

Redondea 12,5493 hacia arriba hasta la centésima más próxima mostrando dos decimales (12,55)

20,3

=REDONDEA.PAR([Columna1])

Redondea 20,3 hasta el número par más cercano (22)

20,3

=REDONDEA.IMPAR([Columna1])

Redondea 20,3 hacia arriba hasta el número impar más próximo (21)

Para redondear hacia abajo un número , use la función redondear.

Columna1

Fórmula

Descripción (resultado)

20,3

=REDONDEAR.MENOS([Columna1],0)

Redondea 20,3 hacia abajo hasta el número entero más cercano (20)

-5,9

=REDONDEAR.MENOS([Columna1],0)

Redondea -5,9 hacia abajo hasta el número entero más cercano (-6)

12,5493

=REDONDEAR.MENOS([Columna1],2)

Redondea 12,5493 hacia abajo hasta la centésima más próxima mostrando dos decimales (12,54)

Para redondear un número al número o fracción más cercano, use la función redondear.

Columna1

Fórmula

Descripción (resultado)

20,3

=REDONDEAR([Columna1],0)

Redondea 20,3 hacia abajo, debido a que la parte fraccionaria es menor que 0,5 (20)

5,9

=REDONDEAR([Columna1],0)

Redondea 5,9 hacia arriba, debido a que la parte fraccionaria es mayor que 0,5 (6)

-5,9

=REDONDEAR([Columna1],0)

Redondea -5,9 hacia abajo, debido a que la parte fraccionaria es menor que -0,5 (-6)

1,25

= REDONDEAR([Columna1], 1)

Redondea el número a la decena más próxima (una posición decimal). Dado que la parte que se va a redondear es igual o mayor que 0,05, el número se redondea hacia arriba (resultado: 1,3)

30,452

=REDONDEAR([Columna1], 2)

Redondea el número a la centena más próxima (dos posiciones decimales). Dado que la parte que se va a redondear (0,002) es menor que 0,005, el número se redondea hacia abajo (resultado: 30,45)

Para redondear un número al dígito significativo por encima de 0, use las funciones redondear, redondear, redondear, ENTy largo .

Columna1

Fórmula

Descripción (resultado)

5492820

=REDONDEAR([Columna1],3-LARGO(ENTERO([Column1])))

Redondea el número a 3 dígitos significativos (5490000)

22230

=REDONDEAR.MENOS([Columna1],3-LARGO(ENTERO([Columna1])))

Redondea el número menor hacia abajo a 3 dígitos significativos (22200)

5492820

=REDONDEAR.MAS([Columna1],5-LARGO(ENTERO([Columna1])))

Redondea el número superior a 5 dígitos significativos (5492900)

Puede usar las fórmulas siguientes para manipular texto, como combinar o concatenar los valores de varias columnas, comparar el contenido de las columnas, quitar caracteres o espacios y repetir caracteres.

Cambiar entre mayúsculas y minúsculas

Para cambiar las mayúsculas y minúsculas del texto, use las funciones Upper, Lowero NOMPROPIO .

Columna1

Fórmula

Descripción (resultado)

ana Trujillo

=MAYUSC([Column1])

Cambia el texto a mayúsculas (ANA TRUJILLO)

ana Trujillo

=MINUSC([Column1])

Cambia el texto a minúsculas (ana trujillo)

ana Trujillo

=NOMPROPIO([Column1])

Cambia el texto a tipo de título (Ana Trujillo)

Combinar nombres y apellidos

Para combinar el nombre y los apellidos, use el operador ampersand (&) o la función concatenar.

Columna1

Columna2

Fórmula

Descripción (resultado)

Carlos

Carvallo

= [Columna1]&[Columna2]

Combina las dos cadenas (CarlosCarvallo)

Carlos

Carvallo

=[Columna1]&" "&[Columna2]

Combina las dos cadenas y las separa con un espacio (Carlos Carvallo)

Carlos

Carvallo

=[Columna2]&", "&[Columna1]

Combina las dos cadenas y las separa con una coma y un espacio (Carvallo, Carlos)

Carlos

Carvallo

=CONCATENAR([Column2], ",", [Column1])

Combina las dos cadenas y las separa con una coma (Carvallo,Carlos)

Combinar texto y números de distintas columnas

Para combinar texto y números, use la función concatenar, el operador y comercial (&) o la función texto y el operador &.

Columna1

Columna2

Fórmula

Descripción (resultado)

Martínez

28

=[Columna1]&" vendió "&[Columna2]&" unidades."

Combina el contenido anterior en una frase (Martínez vendió 28 unidades).

García

40%

=[Columna1]&" realizó el "&TEXTO([Columna2],"0%")&" del total de ventas."

Combina el contenido anterior en una frase (García realizó el 40% del total de ventas).

Nota: La función TEXTO anexa el valor con formato de Columna2 en lugar del valor subyacente, que es 0,4.

Martínez

28

=CONCATENAR([Columna1]," vendió ",[Columna2]," unidades.")

Combina el contenido anterior en una frase (Martínez vendió 28 unidades).

Combinar texto con una fecha u hora

Para combinar texto con una fecha u hora, use la función texto y el operador "y" comercial (&).

Columna1

Columna2

Fórmula

Descripción (resultado)

Fecha de facturación

5-jun-2007

="Fecha de vencimiento: "&TEXTO([Columna2], "d-mmm-aaaa")

Combina el texto con una fecha (Fecha de vencimiento: 5-jun-2007)

Fecha de facturación

5-jun-2007

=[Columna1]&" "&TEXTO([Column2], "dd-mmm-yyyy")

Combina texto y fechas de distintas columnas en una columna (Fecha de facturación 05-jun-2007)

Comparar el contenido de las columnas

Para comparar una columna con otra columna o una lista de valores, use las funciones igual y o .

Columna1

Columna2

Fórmula

Descripción (resultado posible)

BD122

BD123

=IGUAL([Columna1],[Columna2])

Compara el contenido de las dos primeras columnas (No)

BD122

BD123

=IGUAL([Columna1], "BD122")

Compara el contenido de Columna1 y la cadena "BD122" (Sí)

Comprobar si un valor de la columna o una parte del mismo coincide con un texto específico

Para comprobar si un valor de columna o una parte del mismo coincide con un texto específico, use las funciones si, encontrar, hallary ESNUMERO.

Columna1

Fórmula

Descripción (resultado posible)

Trujillo

=SI([Columna1]="Trujillo", "Correcto", "Incorrecto")

Comprueba si Columna1 es Trujillo (Correcto)

Trujillo

=SI(ESNUMERO(ENCONTRAR("v",[Columna1])), "Correcto", "Incorrecto")

Comprueba si Columna1 contiene la letra v (Correcto)

BD123

=ESNUMERO(ENCONTRAR("BD",[Columna1]))

Comprueba si Columna1 contiene BD (Sí)

Contar columnas no vacías

Para contar las columnas que no están en blanco, use la función contara.

Columna1

Columna 2

Columna3

Fórmula

Descripción (resultado)

Ventas

comprendi

=CONTARA([Columna1], [Columna2])

Cuenta el número de columnas no vacías (2)

Ventas

comprendi

=CONTARA([Columna1], [Columna2], [Columna3])

Cuenta el número de columnas no vacías (2)

Quitar caracteres de un texto

Para quitar caracteres del texto, use las funciones largo, izquierday derecha .

Columna1

Fórmula

Descripción (resultado)

Vitamina A

=IZQUIERDA([Columna1],LARGO([Columna1])-2)

Devuelve 7 (9-2) caracteres, empezando desde la izquierda (Vitamina)

Vitamina B1

= DERECHA([Columna1], LARGO([Columna1])-8)

Devuelve 2 (10-8) caracteres, empezando desde la derecha (B1)

Eliminar los espacios del principio y el final de una columna

Para quitar los espacios de una columna, use la función espacios .

Columna1

Fórmula

Descripción (resultado)

 ¡Hola a todos!

=SUPRESP([Columna1])

Quita los espacios del principio y al final (¡Hola a todos!)

Repetir un carácter en una columna

Para repetir un carácter en una columna, use la función repetir .

Fórmula

Descripción (resultado)

=REPETIR(".",3)

Repite un punto 3 veces (...)

=REPETIR("-",10)

Repite un guión 10 veces (----------)

Lista alfabética de funciones

La siguiente es una lista de vínculos a las funciones disponibles para los usuarios de SharePoint. Incluye las funciones trigonomic, estadística y financiera, así como fórmulas condicionales, de fecha, matemáticas y de texto.

Función ABS

Función ACOS

Función ACOSH

Función ACOSH

Función AND

Función ASENO

Función ASINH

Función ATAN

Función ATAN2

Función PROMEDIO

Función AVERAGEA

BETADIST, función

BETAINV (función)

BINOMDIST (función)

Función CEILING

Función CARACTER

Función DISTR.CHI

Función ELEGIR

Función CODIGO

Función CONCATENAR

Función INTERVALO.CONFIANZA

Función COS

Función COUNT

Función COUNTA

Función BINOM.CRIT

Función DATE.

Función SIFECHA

Función DATEVALUE

Función DIA

Función DIAS360

Función DDB

Función GRADOS

Función MONEDA

Función REDONDEA.PAR

Función EXACT

Función DISTR.EXP

Función FACT

Función DISTR.F

BUSCAR (función)

Función DISTR.F.INV

Función FISHER

Función FIXED

Función DISTR.GAMMA

Función DISTR.GAMMA.INV

Función GAMMA.LN

Función MEDIA.GEOM

Función MEDIA.ARMO

Función HOUR

Función DISTR.HIPERGEOM

Función SI

Función INT.

IPmt (función)

Funciones ES

Función izq

Función LARGO

Función LN

Función log

Función LOG10.

Función DISTR.LOG.INV

Función DISTR.LOG.NORM

Función LOWER

Función MAX.

Yo (función)

Función MEDIANA

Función MID

Función MIN.

Función MINA.

Función MINUTE

Función RESIDUO

Función MONTH

Función NEGBINOMDIST

Función DISTR.NORM

Función DISTR.NORM.ESTAND

Función DISTR.NORM.ESTAND.INV

Función NOT.

Función NPER

Función VNA

Función VNA

Función REDONDEA.IMPAR

Función OR

Función PAGO

Función POWER

Función PAGOPRIN

Función PRODUCTO

Función NOMPROPIO

Función VA

Función RADIANES

Función REEMPLAZAR

Función REPT.

Función DERECHA

Función ROUND

Función ROUNDDOWN

Función ROUNDUP

SEARCH (función)

Función SECOND

Función SIGN

Función SENO

Función SINH

Función SQRT

Función NORMALIZACION

Función DESVESTA

Función DESVESTP

Función DESVESTPA

Función SUMA.

Función SUMA.CUADRADOS

Función SYD

Función TANH

Función DISTR.T

Función TEXTO

Función HORA

Función DISTR.T.INV

Función HOY

Función ESPACIOS.

Función VERDADERO.

Función VERDADERO.

Función MAYUSC

USDOLLAR (función)

Función VALOR

Función VAR

Función VARA

Función VARP

Función VARPA

Función Weekday

Función DIST.WEIBULL

Función AÑO

Otros recursos

Si no ve lo que intenta hacer aquí, vea si puede hacerlo en Excel. Estos son algunos orígenes adicionales. Algunos de estos pueden tratar versiones anteriores, por lo que puede haber diferencias en la interfaz de usuario que se muestra. Por ejemplo, los elementos del menú acciones del sitio de SharePoint 2010 están ahora en el menú configuración El botón de configuración de Office 365 es similar a un engranaje junto a su nombre. .

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×