Crear un modelo de base de datos (también denominado diagrama Relación de entidades)

Crear un modelo de base de datos (también denominado diagrama Relación de entidades)

Con la plantilla Diagrama de modelo de base de datos, puede crear un nuevo modelo o aplicar ingeniería inversa a una base de datos existente en un modelo usando conceptos de modelado relacionales o relacionales de objeto. Use la galería de símbolos Relación entre entidades para modelar bases de datos que se basen en el estándar SQL92 y anteriores. Use la galería de símbolos Relacional de objetos, que tiene formas adicionales para trabajar con tipos, para modelar bases de datos que se basan en el estándar SQL99 y posteriores.

Ejemplo de modelo de base de datos

Nota: El diagrama de modelo de base de datos solo está disponible en algunas versiones de Visio. Vea ¿No encuentra las características de modelado de base de datos? para obtener más información.

Con la plantilla Diagrama de modelo de base de datos, puede crear un nuevo modelo o aplicar ingeniería inversa a una base de datos existente en un modelo usando conceptos de modelado relacionales o relacionales de objeto. Use la galería de símbolos Relación entre entidades para modelar bases de datos que se basen en el estándar SQL92 y anteriores. Use la galería de símbolos Relacional de objetos, que tiene formas adicionales para trabajar con tipos, para modelar bases de datos que se basan en el estándar SQL99 y posteriores.

En este artículo se describe cómo puede crear un modelo de base de datos y qué puede hacer con el modelo después de crearlo.

  1. Para iniciar un diagrama de modelo de base de datos, siga uno de estos procedimientos:

    Crear un diagrama de modelo desde cero

    Si no tiene una base de datos que desee usar como punto de partida, puede empezar con un modelo de base de datos en blanco y agregar sus propias tablas y relaciones.

    1. Haga clic en la pestaña Archivo.

    2. Haga clic en Nuevo > Software y bases de datos y después haga doble clic en Diagrama de modelo de base de datos.

    3. En la pestaña Base de datos, en el grupo Administrar haga clic en Mostrar opciones.

    4. En el cuadro de diálogo Opciones de documentos de la base de datos, seleccione el símbolo establecido que quiera usar y otras opciones de tabla y relación y después haga clic en Aceptar.

    Usar una base de datos existente como punto de partida

    Si tiene una base de datos que desee modelar para poder comprenderla mejor o usarla como punto de partida para un nuevo modelo, puede usar el Asistente de ingeniería inversa para extraer el esquema o la estructura de la base de datos y crear un nuevo modelo.

    Antes de iniciar el asistente:

    1. Si utiliza ingeniería inversa en un libro de Microsoft Excel, antes de iniciar el asistente deberá abrir el libro y asignar un nombre al grupo (o rango) de celdas que contiene los encabezados de columna. Si quiere usar más de una hoja de cálculo, asigne un nombre al grupo de celdas de la columna en cada hoja de cálculo. Estos rangos se consideran como tablas en el asistente. Para obtener más información sobre cómo asignar un nombre a un rango de celdas, consulte el tema en la Ayuda de Excel titulado Definir rangos o referencias de celdas con nombre.

    2. Para obtener mejores resultados, configure el controlador predeterminado para la base de datos de destino en la que desea efectuar ingeniería inversa antes de ejecutar el Asistente de ingeniería inversa. Este paso garantiza que el asistente asigne los tipos de datos nativos correctamente y que todo el código que extrae el asistente se muestre correctamente en la ventana Código.

    3. Haga clic en la pestaña Archivo.

    4. Haga clic en Nuevo > Software y bases de datos y después haga doble clic en Diagrama de modelo de base de datos.

    5. En la pestañaBase de datos, en el grupo Modelo, haga clic en Ingeniería inversa.

    6. En la primera pantalla del Asistente para ingeniería inversa, siga estos pasos:

      1. Seleccione el controlador de base de datos de su sistema de administración de base de datos (DBMS). Si aún no ha asociado el controlador de la base de datos de Visio con un determinado origen de datos ODBC, haga clic en Configuración.

        Nota: Si aplica ingeniería inversa a una hoja de cálculo de Excel, elija el Controlador ODBC genérico.

      2. Seleccione el origen de datos de la base de datos que quiera actualizar. Si aún no ha creado un origen de datos de la base de datos existente, haga clic en Nuevo para hacerlo.

        Al crear un nuevo origen, su nombre se agregará a la lista Orígenes de datos.

      3. Cuando esté conforme con la configuración, haga clic en Siguiente.

    7. Siga las instrucciones en los cuadros de diálogo específicos del controlador.

      Por ejemplo, en el cuadro de diálogo Conectar origen de datos, escriba el nombre de usuario y la contraseña y después haga clic en Aceptar.

      Nota: Si usa el Controlador ODBC genérico, es posible que reciba un mensaje de error que indica que la información de ingeniería inversa puede estar incompleta. En la mayoría de los casos, no es un problema, simplemente haga clic en Aceptar y continúe con el asistente.

    8. Seleccione las casillas para el tipo de información que desea extraer y después haga clic en Siguiente.

      Nota: Es posible que algunos elementos no estén disponibles (aparecen atenuados) porque no todos los sistemas de administración de base de datos admiten todos los tipos de elementos que puede extraer el asistente.

    9. Seleccione las casillas de las tablas (y las vistas, si procede) que desea extraer, o haga clic en Seleccionar todo para extraerlas todas y después haga clic en Siguiente.

      Nota: Si aplica ingeniería inversa a una hoja de cálculo de Excel y no ve nada en esta lista, es probable que deba asignar un nombre al rango de celdas que contiene los encabezados de columna en la hoja de cálculo.

    10. Si seleccionó la casilla Procedimientos almacenados, seleccione los procedimientos que desea extraer, o haga clic en Seleccionar todo para extraerlas todas y después haga clic en Siguiente.

    11. Seleccione si desea que los elementos de ingeniería inversa se agreguen automáticamente a la página actual.

      Nota: Puede hacer que el Asistente cree automáticamente el dibujo, además de crear una lista de los elementos a los que se aplicó ingeniería inversa de la ventana Tablas y vistas. Si opta por que no se cree el dibujo automáticamente, puede arrastrar los elementos desde la ventana Tablas y vistas a la página de dibujo para ensamblar manualmente el modelo de base de datos.

    12. Revise sus selecciones para asegurarse de que extrae la información que desea y después haga clic en Finalizar.

      El asistente extrae la información seleccionada y muestra notas sobre el proceso de extracción en la ventana Resultados.

    Importar y restringir un modelo existente

    Si tiene un modelo de VisioModeler o PLATINUM ERwin existente, es posible que pueda importarlo para crear un diagrama de modelo de base de datos de Visio. Esta capacidad está limitada solo a archivos del modelo de diccionario (.imd) de VisioModeler 2.0 o versiones posteriores y a archivos .erx de PLATINUM ERwin 2.6, 3.0 y 3.52.

    1. Haga clic en la pestaña Archivo.

    2. Haga clic en Nuevo > Software y bases de datos y después haga doble clic en Diagrama de modelo de base de datos.

    3. En la pestaña Base de datos, en el grupo Modelo, haga clic en Importar y después haga clic en el tipo de modelo.

    4. Escriba la ruta y el nombre de archivo para el modelo que desea importar o haga clic en el botón Examinar para buscar el archivo del modelo y después haga clic en Abrir.

    5. En el cuadro de diálogo Importar, haga clic en Aceptar.

      Visio importará el archivo y mostrará su progreso en la ventana Resultados. Las tablas importadas se muestran en la ventana Tablas y vistas.

    6. En la ventana Tablas y vistas, seleccione las tablas que desea modelar y arrástrelas hasta la página de dibujo.

  2. Después de crear un diagrama de modelo de base de datos, comenzará el trabajo de restringir el diagrama. Puede agregar y personalizar tablas y vistas, crear relaciones y personalizar columnas y tipos de datos.

    Tablas

    Use la forma Entidad para crear una tabla en el diagrama.

    1. Desde la galería de símbolos Relación entre entidades o Relacional de objetos, arrastre una forma Entidad al dibujo.

    2. Haga doble clic en la forma para abrir la ventana Propiedades de la base de datos.

    3. En Categorías, haga clic en Definición y escriba un nombre para la tabla.

    4. En Categorías, haga clic en Columnas, escriba un nombre y elija un tipo de datos.

    5. Seleccione la casilla Requerido de las columnas que no tienen valores nulos.

    6. Seleccione la casilla CP (clave principal) para las columnas que identifican exclusivamente cada fila de la tabla de base de datos.

    7. En Categorías, haga clic en Índices, Desencadenadores, Comprobar o Extendidos para crear estos elementos opcionales.

    Columnas

    Use la ventana Propiedades de la base de datos para agregar o cambiar las propiedades de columnas, incluidos los tipos de datos y las claves principales.

    1. Haga doble clic en la tabla en el diagrama.

    2. En la ventana Propiedades de la base de datos, en Categorías, haga clic en Columnas.

    3. Haga clic en la primera celda Nombre físico vacía y escriba un nombre.

    4. Para cambiar el tipo de datos de una columna, haga clic en el campo Tipo de datos de la columna y después seleccione un tipo de datos de la lista o escríbalo en la lista. Por ejemplo, puede escribir decimal(8,2) o char(30).

    5. Para evitar valores nulos, seleccione la casilla Requerido.

    6. Para especificar que la columna es una clave principal, seleccione la casilla CP.

    7. Para ver otras propiedades de la columna además de las que aparecen al hacer clic en la categoría Columnas, seleccione la columna y después haga clic en Editar.

    Relaciones

    Las relaciones usan claves principales y externas para permitir a las bases de datos hacer coincidir una fila de una tabla con una fila de una tabla relacionada. Puede mostrar las relaciones en el diagrama. Además, puede establecer su cardinalidad (por ejemplo, uno a varios) y usar notación de Crow's feet, relacional o de IDEF1X para mostrar la cardinalidad. No puede mostrar las relaciones de varios a varios con cualquiera de estas notaciones en la plantilla Diagrama de modelo de base de datos.

    1. Cree una relación entre tablas:

      1. Asegúrese de que ambas tablas están visibles en el diagrama. Si creó el modelo mediante ingeniería inversa a partir de una base de datos existente, es posible que deba arrastrar uno o ambos desde la ventana Tablas y vistas hasta la página de dibujo.

      2. Haga doble clic en la tabla que desee para el lado de la clave principal de la relación.

      3. En la ventana Propiedades de la base de datos, en Categorías, haga clic en Columnas.

      4. En la cuadrícula, haga clic en la columna que desea usar para identificar de forma única cada fila de la tabla y seleccione la casilla CP para establecerla como la clave principal.

      5. Desde la galería de símbolos Relacional de objetos o Relación entre entidades, arrastre una forma Relación y colóquela en un espacio en blanco en la página.

      6. Conecte el extremo superior a la tabla con la tabla principal.

      7. Conecte el otro extremo a la tabla secundaria.

        Si la segunda tabla no contiene una columna con el mismo nombre que la clave principal, el modelador la agrega a la segunda tabla como una clave externa.

        Nota: Si las líneas de relación desaparecen, en la pestaña Base de datos, en el grupo Administrar haga clic en Mostrar opciones. En la pestaña Relaciones, en Mostrar, seleccione la casilla Relaciones.

    2. Establezca la cardinalidad de la relación:

      1. Haga doble clic en la relación.

      2. En la ventana Propiedades de la base de datos, en Categorías, haga clic en Varios.

      3. En Cardinalidad, elija la que mejor se adapte a la relación. Para las relaciones de uno a varios, la mejor opción es Cero o más o Uno o más. Para las relaciones de uno a uno, la mejor opción es Cero o más o Exactamente uno.

  3. Para realizar otros ajustes al diagrama (como crear índices, comprobar cláusulas y agregar desencadenadores) puede hacer lo siguiente:

    Crear índices

    Los índices mejoran el rendimiento o la velocidad de la base de datos al ejecutar una consulta.

    1. Abra el diagrama de modelo de base de datos.

    2. Haga doble clic en la tabla a la que desea agregar un índice y, en la ventana Propiedades de la base de datos, en la lista Categorías, haga clic en Índices.

    3. Haga clic en Nuevo.

    4. En el cuadro de diálogo Crear índice, escriba un nombre para el índice y después haga clic en Aceptar.

    5. En la lista Tipo de índice, seleccione una opción para crear un índice único o no único.

    6. En la lista Columnas disponibles, seleccione el nombre de cada columna que desea incluir en este índice y después haga clic en Agregar >.

    7. En la lista columnas indizadas, seleccione la casilla Asc para crear un índice en orden ascendente o desactive la casilla para crear un índice en orden descendente.

      Se actualizará el diagrama de modelo de base de datos.

    Crear vistas

    Una vista se puede considerar como una consulta guardada. Las vistas son especialmente útiles si necesita acceder repetidamente a la misma información de varias tablas o si desea exponer datos a los usuarios sin que puedan cambiar las tablas reales.

    Desde la galería de símbolos Relación entre entidades o Relacional de objetos, arrastre una forma Ver a la página de dibujo.

    Establecer las propiedades extendidas de tablas y vistas

    Según el sistema de administración de base de datos (DBMS), es posible que pueda establecer las propiedades extendidas de tablas o vistas para determinar dónde se almacenan.

    Haga doble clic en la tabla o vista de la que desea configurar las propiedades extendidas y, en la ventana Propiedades de la base de datos, en la lista Categorías, haga clic en Extendidas.

    Crear cláusulas de comprobación

    Use las cláusulas de comprobación para garantizar que los datos escritos en una columna están dentro de un rango de valores concreto. Por ejemplo, puede crear una cláusula de comprobación que requiera que los datos de una columna denominada "Edad" sean valores superiores a 65.

    1. Haga doble clic en la tabla para abrir la ventana Propiedades de la base de datos.

    2. En Categorías, haga clic en Columnas y después haga clic en la columna a la que desea agregar una cláusula de comprobación.

    3. Haga clic en Editar.

    4. En la pestaña Comprobar del cuadro de diálogo Propiedades de la columna, escriba las restricciones que desee.

      La cláusula de comprobación se agregará en Código local en la ventana Código.

    Crear procedimientos almacenados y funciones definidas por el usuario

    Use procedimientos almacenados y funciones definidas por el usuario para crear paquetes de código que pueda volver a usar para realizar las mismas acciones repetidamente. La principal diferencia entre los dos es que una función definida por el usuario devuelve un valor, mientras que el procedimiento almacenado ejecuta el código sin devolver un valor.

    1. En la pestaña Base de datos, en el grupo Mostrar u ocultar, seleccione la casilla Código para abrir la ventana Código.

    2. Haga clic en Código global y después haga clic en Nuevo.

    3. En la pestaña Propiedades del Editor de código, haga clic en el tipo de código que desea crear y escriba un nombre para el código.

    4. En la pestaña Cuerpo, escriba el código y después haga clic en Aceptar.

    Crear desencadenadores

    Los desencadenadores hacen que el código SQL que especifique en el desencadenador se ejecute cuando se produzca un evento determinado en la base de datos.

    1. Haga doble clic en la tabla para abrir la ventana Propiedades de la base de datos.

    2. En Categorías, haga clic en Desencadenadores y después haga clic en Agregar.

    3. En la pestaña Propiedades, escriba un nombre para el desencadenador.

    4. En la pestaña Cuerpo, escriba el código y después haga clic en Aceptar.

      El desencadenador se agregará en Código local en la ventana Código.

En este artículo se describe cómo puede crear un modelo de base de datos y qué puede hacer con el modelo después de crearlo. Para un inicio rápido, en el menú Archivo, seleccione Nuevo, seleccione Software y base de datos y después haga clic en Diagrama de modelo de base de datos.

¿No encuentra la característica de modelo de base de datos?

Lo más probable es que la edición de Microsoft Office Visio no incluya las características que busca. Para saber qué edición de Visio tiene, haga clic en Acerca de Microsoft Office Visio en el menú Ayuda. El nombre de la edición está en la línea superior de texto del cuadro de diálogo.

  • Microsoft Office Visio Standard no incluye la plantilla Diagrama de modelo de base de datos.

  • Microsoft Office Visio Profesional admite las características de ingeniería inversa de la plantilla Diagrama de modelo de base de datos (es decir, usa una base de datos existente para crear un modelo en Visio), pero no admite la ingeniería directa (es decir, utilizar un modelo de base de datos de Visio para generar código SQL).

  • Encontrará el conjunto completo de características de modelado de base de datos, como ingeniería inversa y directa, en Visio for Enterprise Architects. Visio for Enterprise Architects se incluye en MSDN Premium Subscription, disponible en las ediciones basadas en roles Visual Studio Professional y Visual Studio Team System.

  1. Para iniciar un diagrama de modelo de base de datos, siga uno de estos procedimientos:

    Crear un diagrama de modelo desde cero

    Si no tiene una base de datos que desee usar como punto de partida, puede empezar con un modelo de base de datos en blanco y agregar sus propias tablas y relaciones.

    1. En el menú Archivo, seleccione Nuevo, seleccione Software y base de datos y después haga clic en Diagrama de modelo de base de datos.

    2. En el menú Base de datos, seleccione opciones y después haga clic en Documento.

    3. En el cuadro de diálogo Opciones de documentos de la base de datos, seleccione el símbolo establecido que quiera usar y otras opciones de tabla y relación y después haga clic en Aceptar.

    Usar una base de datos existente como punto de partida

    Si tiene una base de datos que desee modelar para poder comprenderla mejor o usarla como punto de partida para un nuevo modelo, puede usar el Asistente de ingeniería inversa para extraer el esquema o la estructura de la base de datos y crear un nuevo modelo.

    Nota: Antes de iniciar el asistente:

    1. Si utiliza ingeniería inversa en un libro de Microsoft Office Excel, antes de iniciar el asistente, deberá abrir el libro y asignar un nombre al grupo (o rango) de celdas que contiene los encabezados de columna. Si quiere usar más de una hoja de cálculo, asigne un nombre al grupo de celdas de la columna en cada hoja de cálculo. Estos rangos se consideran como tablas en el asistente. Para obtener más información sobre cómo asignar un nombre a un rango de celdas, vea el tema en la Ayuda de Microsoft Office Excel titulado Definir rangos o referencias de celdas con nombre.

    2. Para obtener mejores resultados, configure el controlador predeterminado para la base de datos de destino en la que desea efectuar ingeniería inversa antes de ejecutar el Asistente de ingeniería inversa. Este paso garantiza que el asistente asigne los tipos de datos nativos correctamente y que todo el código que extrae el asistente se muestre correctamente en la ventana Código.

    3. En el menú Archivo, seleccione Nuevo, seleccione Software y base de datos y después haga clic en Diagrama de modelo de base de datos.

    4. En el menú Base de datos, haga clic en Ingeniería inversa.

    5. En la primera pantalla del Asistente para ingeniería inversa, siga estos pasos:

      1. Seleccione el controlador de base de datos de Microsoft Office Visio de su sistema de administración de base de datos (DBMS). Si aún no ha asociado el controlador de la base de datos de Visio con un determinado origen de datos ODBC, haga clic en Configuración.

        Nota: Si aplica ingeniería inversa a una hoja de cálculo de Excel, elija el Controlador ODBC genérico.

      2. Seleccione el origen de datos de la base de datos que quiera actualizar. Si aún no ha creado un origen de datos de la base de datos existente, haga clic en Nuevo para hacerlo.

        Al crear un nuevo origen, su nombre se agregará a la lista Orígenes de datos.

      3. Cuando esté conforme con la configuración, haga clic en Siguiente.

    6. Siga las instrucciones en los cuadros de diálogo específicos del controlador.

      Por ejemplo, en el cuadro de diálogo Conectar origen de datos, escriba un nombre de usuario y contraseña y después haga clic en Aceptar. Si el origen de datos no está protegido con contraseña, haga clic en Aceptar.

      Nota: Si usa el Controlador ODBC genérico, es posible que reciba un mensaje de error que indica que la información de ingeniería inversa puede estar incompleta. En la mayoría de los casos, no es un problema, simplemente haga clic en Aceptar y continúe con el asistente.

    7. Seleccione las casillas para el tipo de información que desea extraer y después haga clic en Siguiente.

      Nota: Es posible que algunos elementos no estén disponibles (aparecen atenuados) porque no todos los sistemas de administración de base de datos admiten todos los tipos de elementos que puede extraer el asistente.

    8. Seleccione las casillas de las tablas (y las vistas, si procede) que desea extraer, o haga clic en Seleccionar todo para extraerlas todas y después haga clic en Siguiente.

      Nota: Si aplica ingeniería inversa a una hoja de cálculo de Excel y no ve nada en esta lista, es probable que deba asignar un nombre al rango de celdas que contiene los encabezados de columna en la hoja de cálculo.

    9. Si seleccionó la casilla Procedimientos almacenados en el paso 5, seleccione los procedimientos que desea extraer, o haga clic en Seleccionar todo para extraerlas todas y después haga clic en Siguiente.

    10. Seleccione si desea que los elementos de ingeniería inversa se agreguen automáticamente a la página actual.

      Nota: Puede hacer que el Asistente cree automáticamente el dibujo, además de crear una lista de los elementos a los que se aplicó ingeniería inversa de la ventana Tablas y vistas. Si opta por que no se cree el dibujo automáticamente, puede arrastrar los elementos desde la ventana Tablas y vistas a la página de dibujo para ensamblar manualmente el modelo de base de datos.

    11. Revise sus selecciones para asegurarse de que extrae la información que desea y después haga clic en Finalizar.

      El asistente extrae la información seleccionada y muestra notas sobre el proceso de extracción en la ventana Resultados.

    Importar y restringir un modelo existente

    Si tiene un modelo de VisioModeler o PLATINUM ERwin existente, es posible que pueda importarlo para crear un diagrama de modelo de base de datos de Visio. Esta capacidad está limitada solo a archivos del modelo de diccionario (.imd) de VisioModeler 2.0 o versiones posteriores y a archivos .erx de PLATINUM ERwin 2.6, 3.0 y 3.52.

    1. En el menú Archivo, seleccione Nuevo, seleccione Software y base de datos y después haga clic en Diagrama de modelo de base de datos.

    2. En el menú Base de datos, seleccione Importar y después haga clic en Importar <tipo de modelo>.

    3. Escriba la ruta y el nombre de archivo para el modelo que desea importar o haga clic en el botón Examinar para buscar el archivo del modelo y después haga clic en Abrir.

    4. En el cuadro de diálogo Importar, haga clic en Aceptar.

      Visio importará el archivo y mostrará su progreso en la ventana Resultados. Las tablas importadas se muestran en la ventana Tablas y vistas.

    5. En la ventana Tablas y vistas, seleccione las tablas que desea modelar y arrástrelas hasta la página de dibujo.

  2. Después de crear un diagrama de modelo de base de datos, comenzará el trabajo de restringir el diagrama. Puede agregar y personalizar tablas y vistas, crear relaciones y personalizar columnas y tipos de datos.

    Tablas

    Use la forma Entidad para crear una tabla en el diagrama.

    1. Desde la galería de símbolos Relación entre entidades o Relacional de objetos, arrastre una forma Entidad al dibujo.

    2. Haga doble clic en la forma para abrir la ventana Propiedades de la base de datos.

    3. En Categorías, haga clic en Definición y escriba un nombre para la tabla.

    4. En Categorías, haga clic en Columnas, escriba un nombre y elija un tipo de datos.

    5. Seleccione la casilla Requerido de las columnas que no tienen valores nulos.

    6. Seleccione la casilla CP (clave principal) para las columnas que identifican exclusivamente cada fila de la tabla de base de datos.

    7. En Categorías, haga clic en Índices, Desencadenadores, Comprobar o Extendidos para crear estos elementos opcionales.

    Columnas

    Use la ventana Propiedades de la base de datos para agregar o cambiar las propiedades de columnas, incluidos los tipos de datos y las claves principales.

    1. Haga doble clic en la tabla en el diagrama.

    2. En la ventana Propiedades de la base de datos, en Categorías, haga clic en Columnas.

    3. Haga clic en la primera celda Nombre físico vacía y escriba un nombre.

    4. Para cambiar el tipo de datos de una columna, haga clic en el campo Tipo de datos de la columna y después seleccione un tipo de datos de la lista o escríbalo en la lista. Por ejemplo, puede escribir decimal(8,2) o char(30).

    5. Para evitar valores nulos, seleccione la casilla Requerido.

    6. Para especificar que la columna es una clave principal, seleccione la casilla CP.

    7. Para ver otras propiedades de la columna además de las que aparecen al hacer clic en la categoría Columnas, seleccione la columna y después haga clic en Editar.

    Relaciones

    Las relaciones usan claves principales y externas para permitir a las bases de datos hacer coincidir una fila de una tabla con una fila de una tabla relacionada. Puede mostrar las relaciones en el diagrama. Además, puede establecer su cardinalidad (por ejemplo, uno a varios) y usar notación de Crow's feet, relacional o de IDEF1X para mostrar la cardinalidad. No puede mostrar las relaciones de varios a varios con cualquiera de estas notaciones en la plantilla Diagrama de modelo de base de datos.

    1. Cree una relación entre tablas:

      1. Asegúrese de que ambas tablas están visibles en el diagrama. Si creó el modelo mediante ingeniería inversa a partir de una base de datos existente, es posible que deba arrastrar uno o ambos desde la ventana Tablas y vistas hasta la página de dibujo.

      2. Haga doble clic en la tabla que desee para el lado de la clave principal de la relación.

      3. En la ventana Propiedades de la base de datos, en Categorías, haga clic en Columnas.

      4. En la cuadrícula, haga clic en la columna que desea usar para identificar de forma única cada fila de la tabla y seleccione la casilla CP para establecerla como la clave principal.

      5. Desde la galería de símbolos Relacional de objetos o Relación entre entidades, arrastre una forma Relación y colóquela en un espacio en blanco en la página.

      6. Conecte el extremo superior a la tabla con la tabla principal.

      7. Conecte el otro extremo a la tabla secundaria.

        Si la segunda tabla no contiene una columna con el mismo nombre que la clave principal, el modelador la agrega a la segunda tabla como una clave externa.

        Nota: Si desaparece una línea de relación, en el menú Base de datos, seleccione Opciones y después haga clic en Documento. En la pestaña Relaciones, en Mostrar, seleccione la casilla Relaciones.

    2. Establezca la cardinalidad de la relación:

      1. Haga doble clic en la relación.

      2. En la ventana Propiedades de la base de datos, en Categorías, haga clic en Varios.

      3. En Cardinalidad, elija la que mejor se adapte a la relación. Para las relaciones de uno a varios, la mejor opción es Cero o más o Uno o más. Para las relaciones de uno a uno, la mejor opción es Cero o más o Exactamente uno.

  3. Para realizar otros ajustes al diagrama (como crear índices, comprobar cláusulas y agregar desencadenadores) puede hacer lo siguiente:

    Crear índices

    Los índices mejoran el rendimiento o la velocidad de la base de datos al ejecutar una consulta.

    1. Abra el diagrama de modelo de base de datos.

    2. Haga doble clic en la tabla a la que desea agregar un índice y, en la ventana Propiedades de la base de datos, en la lista Categorías, haga clic en Índices.

    3. Haga clic en Nuevo.

    4. En el cuadro de diálogo Crear índice, escriba un nombre para el índice y después haga clic en Aceptar.

    5. En la lista Tipo de índice, seleccione una opción para crear un índice único o no único.

    6. En la lista Columnas disponibles, seleccione el nombre de cada columna que desea incluir en este índice y después haga clic en Agregar >.

    7. En la lista columnas indizadas, seleccione la casilla Asc para crear un índice en orden ascendente o desactive la casilla para crear un índice en orden descendente.

      Se actualizará el diagrama de modelo de base de datos.

    Crear vistas

    Una vista se puede considerar como una consulta guardada. Las vistas son especialmente útiles si necesita acceder repetidamente a la misma información de varias tablas o si desea exponer datos a los usuarios sin que puedan cambiar las tablas reales.

    Desde la galería de símbolos Relación entre entidades o Relacional de objetos, arrastre una forma Ver a la página de dibujo.

    Establecer las propiedades extendidas de tablas y vistas

    Según el sistema de administración de base de datos (DBMS), es posible que pueda establecer las propiedades extendidas de tablas o vistas para determinar dónde se almacenan.

    Haga doble clic en la tabla o vista de la que desea configurar las propiedades extendidas y, en la ventana Propiedades de la base de datos, en la lista Categorías, haga clic en Extendidas.

    Crear cláusulas de comprobación

    Use las cláusulas de comprobación para garantizar que los datos escritos en una columna están dentro de un rango de valores concreto. Por ejemplo, puede crear una cláusula de comprobación que requiera que los datos de una columna denominada "Edad" sean valores superiores a 65.

    1. Haga doble clic en la tabla para abrir la ventana Propiedades de la base de datos.

    2. En Categorías, haga clic en Columnas y después haga clic en la columna a la que desea agregar una cláusula de comprobación.

    3. Haga clic en Editar.

    4. En la pestaña Comprobar del cuadro de diálogo Propiedades de la columna, escriba las restricciones que desee. Para obtener más información sobre las opciones, consulte Cuadro de diálogo de Propiedades de campo y columna (pestaña Comprobar).

      Las cláusulas de comprobación se agregarán a la ventana Código en Código local.

    Crear procedimientos almacenados y funciones definidas por el usuario

    Use procedimientos almacenados y funciones definidas por el usuario para crear paquetes de código que pueda volver a usar para realizar las mismas acciones repetidamente. La principal diferencia entre los dos es que una función definida por el usuario devuelve un valor, mientras que el procedimiento almacenado ejecuta el código sin devolver un valor.

    1. En el menú Base de datos, seleccione Vista y después haga clic en Código para abrir la ventana Código.

    2. Haga clic en Código global y después haga clic en Nuevo.

    3. En la pestaña Propiedades del Editor de código, haga clic en el tipo de código que desea crear y escriba un nombre para el código.

    4. En la pestaña Cuerpo, escriba el código y después haga clic en Aceptar.

    Crear desencadenadores

    Los desencadenadores hacen que el código SQL que especifique en el desencadenador se ejecute cuando se produzca un evento determinado en la base de datos.

    1. Haga doble clic en la tabla para abrir la ventana Propiedades de la base de datos.

    2. En Categorías, haga clic en Desencadenadores y después haga clic en Agregar.

    3. En la pestaña Propiedades, escriba un nombre para el desencadenador.

    4. En la pestaña Cuerpo, escriba el código y después haga clic en Aceptar.

      El desencadenador se agregará en Código local en la ventana Código.

¿No encuentra las características de modelado de base de datos?

Lo más probable es que la edición de Visio no incluya las características que busca. Para saber qué edición de Visio tiene, haga clic en Acerca de Microsoft Office Visio en el menú Ayuda. El nombre de la edición está en la línea superior de texto del cuadro de diálogo.

Visio Standard no incluye la plantilla Diagrama de modelo de base de datos.

Visio Profesional y Visio Premium admiten las características de ingeniería inversa de la plantilla Diagrama de modelo de base de datos (es decir, el uso de una base de datos existente para crear un modelo en Visio), pero no admiten la ingeniería directa (es decir, el uso de un modelo de base de datos de Visio para generar código SQL). Para obtener más información, vea el tema Ingeniería inversa de una base de datos existente.

Si usa Visio Online Plan 2 y quiere obtener información sobre cómo convertir una base de datos existente en un modelo de base de datos, vea el tema Ingeniería inversa de una base de datos existente.

Vea también

Definir una relación en un diagrama de modelo de base de datos

Crear o editar vistas en diagramas de modelo de base de datos

Agregar tablas y columnas a diagramas de modelo de base de datos

Establecer y editar tipos de datos en diagramas de modelo de base de datos

Ingeniería inversa de una base de datos existente

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×