Cómo corregir un error #¡VALOR! en la función TRANSPONER

Nota: Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

En este tema, se proporciona información sobre cómo resolver el error #¡VALOR! en TRANSPONER.

Problema: La fórmula no se ha escrito como una fórmula de matriz

Consulte el ejemplo siguiente donde hemos usado:

=TRANSPONER(B2:C8)

Error #¡VALOR! en la función TRANSPONER

La fórmula da como resultado un #VALUE. al escribir la fórmula =SUMA(C2:C3 E4:E6).

Solución: Necesitará convertir la fórmula en una fórmula de matriz de un rango que coincida con el rango de origen en tamaño. Para ello:

  1. Seleccione un rango de celdas vacías en la hoja de cálculo. Recuerde siempre que el número de celdas en blanco que seleccione debe ser igual al número de celdas que está intentando copiar. En este caso, seleccionaremos un rango de 7 columnas de ancho por 2 columnas de alto.

  2. Esta es una fórmula de matriz y necesita escribirse con CTRL+MAYÚS+ENTRAR. Excel colocará automáticamente la fórmula entre llaves {}. Si intenta escribirlas de manera manual, Excel mostrará la fórmula como texto.

El error #¡VALOR! se resuelve cuando presiona Ctrl+Alt+Entrar

Nota: Si tiene una versión actual de Office 365, simplemente puede escribir la fórmula en la celda superior izquierda del rango de salida y, a continuación, presionar entrar para confirmar la fórmula como una fórmula de matriz dinámica. En caso contrario, la fórmula debe especificarse como una fórmula de matriz heredada, seleccionando primero el rango de salida, introduciendo la fórmula en la celda superior izquierda del rango de salida y pulsando Ctrl + Mayús + entrar para confirmarla. Excel insertará llaves al principio y al final de la fórmula. Para obtener más información sobre las fórmulas de matriz, vea Directrices y ejemplos de fórmulas de matriz.

¿Necesita más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Vea también

Corregir un error #¡VALOR!

Función TRANSponer

Información general sobre fórmulas en Excel

Cómo evitar la ruptura de

Detectar errores en

Todas las funciones de Excel (por orden alfabético)

Todas las funciones de Excel (por categoría)

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×