Saltar al contenido principal

Cómo corregir un error #¡VALOR! en la función SI

Nota: Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

SI es una de las funciones más versátiles y conocidas de Excel, y a menudo se usa varias veces en una fórmula, así como junto con otras funciones. Debido a la complejidad con la que pueden crearse las instrucciones IF, es bastante fácil que provoque un error #¡VALOR!. Normalmente puede suprimir el error agregando funciones específicas de control de errores como ESERROR, ESERR o SI.ERROR a la fórmula.

Problema: El argumento hace referencia a valores de error

Cuando existe una referencia de celda en un valor de error, SI muestra el error #¡VALOR!.

Solución: puede usar cualquiera de las fórmulas de control de errores como ESERROR, ESERR o si. error, junto con si. En los temas siguientes se explica cómo usar si, esERROR y ESERR o si. error en una fórmula cuando el argumento hace referencia a valores de error.

Notas: 

  • Si. error se introdujo en Excel 2007 y es mucho más preferible a isError o ESERR, ya que no es necesario construir una fórmula de forma redundante. EsERROR y ESERR obligan a que una fórmula se calcule dos veces, primero para ver si se evalúa como un error y después vuelve a obtener el resultado. Si. error solo se calcula una vez.

  • =SI.ERROR(Fórmula,0) es mucho mejor que =SI(ESERROR(Fórmula,0,Fórmula))

Problema: La sintaxis no es correcta

Si la sintaxis de una función no se ha creado correctamente, puede devolver un error #¡VALOR!.

Solución: Asegúrese de que está creando la sintaxis correctamente. Aquí se muestra un ejemplo de una fórmula bien creada que anida una función SI dentro de otra función SI para calcular las deducciones en función del nivel de ingresos.

=SI(E2<31500,E2*15%,SI(E2<72500,E2*25%,E2*28%))

Ejemplo de una instrucción SI bien creada

Básicamente esto significa: SI (el valor de la celda A5 es menor que 31500, multiplique el valor por 15 %. Pero, SI no lo es, compruebe si el valor es menor que 72500. Si lo es, multiplique por 25 %; de lo contrario, multiplique por 28 %).

Para usar SI.ERROR con una fórmula existente, simplemente ajuste la fórmula completa con SI.ERROR:

=SI.ERROR(SI(E2<31500,E2*15%,SI(E2<72500,E2*25%,E2*28%)),0)

Lo que indica que SI cualquier parte de la fórmula original evalúa un error, entonces muestra 0; de otro modo, devuelve el resultado de la instrucción SI. Algunas personas escriben sus fórmulas completas con el control de errores al principio, pero no es un buen procedimiento, ya que el controlador de errores suprimirá cualquier error potencial por lo que no sabrá necesariamente si la fórmula está funcionando correctamente o no. Si necesita agregar un control de errores, es mejor agregarlo cuando esté seguro de que la fórmula funciona correctamente.

Nota: Los valores de evaluación en las fórmulas no tienen comas. Si las agrega, la función SI intentará usarlas como argumentos y Excel se lo indicará. Por otro lado, los multiplicadores de porcentaje tienen el símbolo %. Esto le indica a Excel que quiere que esos valores se vean como porcentajes. De otro modo, necesitaría escribirlos como sus valores actuales de porcentaje, como "E2*0,25".

Mensaje de Excel cuando agrega una coma en un valor

¿Tiene alguna pregunta específica acerca de la función?

Publique una pregunta en el foro de la comunidad de Excel

Ayudarnos a mejorar Excel

¿Tiene alguna sugerencia sobre cómo podemos mejorar la próxima versión de Excel? Si es así, vea los temas en el sitio de UserVoice de Excel

Vea también

Corregir un error #¡VALOR!

Función SI

Función SI.ERROR

Funciones ES

Función IFS (Office 365 o Excel 2016 o posterior)

Función SI: Fórmulas anidadas y evitar problemas

Vídeo: Funciones SI anidadas

Información general sobre fórmulas en Excel

Cómo evitar la ruptura de las fórmulas

Detectar errores en fórmulas

Todas las funciones de Excel (por orden alfabético)

Funciones de Excel (por categoría)

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider