Cómo corregir un error #¡VALOR! en la función CONCATENAR

Importante: En Excel 2016, Excel Mobile y Excel para la Web, CONCATENAr ha sido reemplazado por la función CONCAt. Aunque la función CONCATENAR sigue estando disponible para garantizar la compatibilidad con versiones anteriores, le recomendamos que use la función CONCAT ya que es una función más sólida.

Uno de los escenarios más comunes donde encontrará el error #¡VALOR! con la función CONCATENAR es cuando intenta crear una cadena que incluye una referencia de celda que tiene un error, como #¡VALOR!.

En el siguiente ejemplo, queremos concatenar D2, E2 y F2, donde E2 tiene un #VALUE! .

Error #¡VALOR! en la función CONCATENAR

El error en E2 hace que la función muestre el #VALUE! . Para que funcione correctamente, tendrá que reemplazar el error con un valor que no sea el error. Puede crear una fórmula que compruebe si hay un error en la referencia de celda y, si es así, Mostrar la cadena de texto donde aparece un 0 en lugar del error (o puede sustituir su propio texto por 0, pero tendrá que ajustar el texto entre comillas, "su texto").

Funcionará una fórmula como esta:

=SI(ESERROR(E2),CONCATENAR(D2," ",0," ",F2))

Funciones si y ESERROR utilizadas como solución alternativa para concatenar una cadena con el #VALUE! error

¿Cómo funciona? La función SI usa la función SI.ERROR para determinar si existe un error en E2, y si lo hay, la función CONCATENAR combina los valores de D2, E2 y F2 (la función reemplaza el error por un 0), y muestra la cadena de texto resultante. Tenga en cuenta que la fórmula también usa espacios (" ") para ayudar a separar los valores.

Corregir el error #¡VALOR! con la función CONCATENAR en Excel 2003 y versiones anteriores

Si obtiene el error #¡VALOR! en Office Excel 2003 o en versiones anteriores, necesitará desactivar la opción Evaluación de fórmulas de transición (TFE) en Excel. Siga los pasos descritos en #VALUE! error al concatenar celdas para resolver el problema.

¿Tiene alguna pregunta específica acerca de la función?

Publique una pregunta en el foro de la comunidad de Excel

Ayudarnos a mejorar Excel

¿Tiene alguna sugerencia sobre cómo podemos mejorar la siguiente versión de Excel? Si es así, consulte los temas en Excel User Voice.

Vea también

Corregir un error #¡VALOR! error

Función CONCATENAR

Función CONCAT

Información general sobre fórmulas en Excel

Cómo evitar la ruptura de las fórmulas

Detectar errores en fórmulas

Todas las funciones de Excel (orden alfabéticos)

Funciones de Excel (por categoría)

Nota:  Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido le resulte útil. ¿Podría decirnos si la información le resultó útil? Aquí puede consultar el artículo en inglés.

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×