Saltar al contenido principal

Cómo corregir errores de fórmula en Excel para Mac

Si es #¡VALOR!, #¡NOMBRE! o un problema con BUSCARV, la siguiente información puede ayudarle a corregir el error.

BUSCARV

Si recibe errores o resultados inesperados con BUSCARV, descargue la Referencia rápida de sugerencias para la solución de problemas de BUSCARV.

Error #¡VALOR!

El origen de este problema suele estar relacionado con tener una mezcla de valores numéricos y de texto. Para obtener más información, consulte Corregir un error #¡VALOR!.

Error #¿NOMBRE?

Asegúrese de escribir los nombres correctamente, entrecomillar cualquier texto o entrecomillar los nombres de hoja con comillas simples ('). Para otras causas y soluciones, consulte Error #¿NOMBRE?.

Error #¡NUM!

Esto puede suceder si ha escrito caracteres adicionales en una fórmula. Por ejemplo, no escriba 1.000 $ en una fórmula. En su lugar, escriba 1000. Para otras causas y soluciones, consulte Corregir un error #¡NUM!.

Error #N/A

Cuando una fórmula no puede encontrar un valor al que hace referencia, devuelve el error #N/A. Para obtener más información, vea Corregir un error #N/A.

Error #¡REF!

Excel muestra este error cuando una fórmula contiene una referencia de celda que no es válida. Para obtener más información, vea Corregir un error #¡REF!.

Error #¡DIV/0!

Esto ocurre cuando un número se divide entre cero (0), o cuando una fórmula hace referencia a una celda que tiene 0 o está en blanco. Para obtener más información, consulte Error #¡DIV/0!.

Hacer referencia a otras hojas y libros

Si se hace referencia a otro nombre de hoja, escriba ! después del nombre y, a continuación, escriba una celda o rango. Si el nombre de hoja tiene espacios, escriba el nombre entre comillas simples. Por ejemplo: =SUMA('Informe de Ventas'!A1:A8).

Cuando se haga referencia a otro libro externo:

  • Incluya el nombre del libro entre corchetes [ ].

  • Escriba la ruta completa al archivo.

  • Escriba la ruta entre comillas simples (al principio de la ruta y después del nombre de la hoja de cálculo, antes del signo de exclamación).

    Ejemplo: =SUMA('/Usuarios/sunombre/escritorio/[Operaciones T2.xlsx]Ventas'!A1:A8)

Otras soluciones rápidas que podrían ser de ayuda

  • Iniciar todas las fórmulas con el signo igual (=). Ejemplo: =SUMA(A1:A8)

  • Usar el símbolo * para multiplicar números, no una X. Ejemplo: =A1*A8

  • Hacer que coincidan todos los paréntesis de apertura y de cierre para que estén en pares. Este ejemplo tiene dos pares: =SI(40>50,SUMA(G2:G5),0)

  • Escribir todos los argumentos necesarios. El Generador de fórmulas puede ayudarle con esto. Empiece a escribir una fórmula con un nombre de función y, a continuación, pulse CONTROL + A para ver el Generador de fórmulas.

  • Usar comillas antes y después del texto de las fórmulas. Ejemplo: =SI(A2>B2,"Presupuesto excedido";"Correcto")

  • Cambiar el tipo de datos de una celda a la que se hace referencia. Pulse COMANDO + 1 y, a continuación, seleccione Número.

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider