Y (función Y)

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Use la función y , una de las funciones lógicas, para determinar si todas las condiciones de una prueba son VERDADERO.

Ejemplo

Ejemplos de la función Y

La función y devuelve VERDADERO si todos sus argumentos se evalúan como VERDADERO y devuelve FALSO si uno o más argumentos se evalúan como FALSO.

Un uso común de la función Y es expandir la utilidad de otras funciones que realizan pruebas lógicas. Por ejemplo, la función SI realiza una prueba lógica y, luego, devuelve un valor si la prueba se evalúa como VERDADERO y otro valor si la prueba se evalúa como FALSO. Con la función Y como argumento prueba_lógica de la función SI, puede probar varias condiciones diferentes en lugar de solo una.

Sintaxis

Y (Valor_lógico1, [valor_lógico2],...)

La sintaxis de la función y tiene los siguientes argumentos:

Argumento

Descripción

Valor_lógico1

Requerido. La primera condición que quiere probar que puede evaluarse como VERDADERO o FALSO.

Valor_lógico2, ...

Opcional. Condiciones adicionales que desee para comprobar que pueden evaluar como VERDADERO o FALSO, hasta un máximo de 255 condiciones.

Observaciones

  • Los argumentos deben evaluarse como valores lógicos, como VERDADERO o FALSO, o bien deben ser matrices o referencias que contengan valores lógicos.

  • Si un argumento matricial o de referencia contiene texto o celdas vacías, dichos valores se pasarán por alto.

  • Si el rango especificado no contiene valores lógicos, la función y devuelve #VALUE! error.

Ejemplos

Estos son algunos ejemplos de uso y por sí mismo y junto con la función SI generales.

Ejemplos de usar las funciones SI con Y

Fórmula

Descripción

= Y(A2>1,A2<100)

Muestra TRUE si A2 es mayor que 1 y menor que 100, de lo contrario muestra FALSE.

=SI(Y(A2<A3,A2<100),A2,"El valor está fuera del rango")

Muestra el valor en la celda A2 si es menor que A3 y menor que 100, en caso contrario, muestra el mensaje "el valor está fuera del intervalo".

=SI(Y(A3>1,A3<100),A3,"El valor está fuera del rango")

Muestra el valor en la celda A3 si lo contrario es mayor que 1 y menor que 100, que se muestra un mensaje. Puede sustituir los mensajes de su elección.

Cálculo bonificación

Aquí es bastante habitual donde se necesita calcular si ventas personas están cualificados para una bonificación mediante IF y AND.

Ejemplo de calcular el bonus de ventas con las funciones SI e Y.  La fórmula de la celda E14 es =SI(Y(B14>=$B$7,C14>=$B$5),B14*$B$8,0)
  • = SI (y (B14 > = $B$ 7, C14 > = $B$ 5), B14 * $B$ 8,0) - IF de ventas totales son mayores o iguales (> =) para el objetivo de ventas, y cuentas son mayor o igual que (> =) el objetivo de la cuenta, multiplicar ventas totales por el porcentaje de bonificación, en caso contrario, devuelven 0.

¿Tiene alguna pregunta específica acerca de la función?

Publicar una pregunta en el foro de la comunidad de Excel

Ayudarnos a mejorar Excel

¿Tiene sugerencias sobre cómo podemos mejorar la próxima versión de Excel? Si es así, por favor, consulte los temas de Voz de usuario de Excel

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Vea también

Ver un vídeo sobre cómo usar la función SI

Obtener información sobre cómo usar funciones anidadas en una fórmula

Función SI

Función O

Función NO

Información general de fórmulas en Excel

Cómo evitar las fórmulas rotas

Usar la comprobación de errores para detectar errores en las fórmulas

Métodos abreviados de teclado en Excel 2016 para Windows

Métodos abreviados de teclado en Excel 2016 para Mac

Funciones lógicas (referencia)

Funciones de Excel (orden alfabético)

Funciones de Excel (por categoría)

Compartir Facebook Facebook Twitter Twitter Enviar por correo electrónico Enviar por correo electrónico

¿Le ha sido útil esta información?

De acuerdo. ¿Algún comentario más?

¿Cómo podemos mejorarlo?

¡Gracias por sus comentarios!

×