Y (función Y)

Use la función Y, una de las funciones lógicas, para determinar si todas las condiciones de una prueba son VERDADERAS.

Ejemplo

Ejemplos de la función Y

La función Y devuelve VERDADERO si todos sus argumentos se evalúan como VERDADERO y devuelve FALSO si uno o más argumentos se evalúan como FALSO.

Un uso común de la función Y es expandir la utilidad de otras funciones que realizan pruebas lógicas. Por ejemplo, la función SI realiza una prueba lógica y, luego, devuelve un valor si la prueba se evalúa como VERDADERO y otro valor si la prueba se evalúa como FALSO. Con la función Y como argumento prueba_lógica de la función SI, puede probar varias condiciones diferentes en lugar de solo una.

Sintaxis

Y(valor_lógico1, [valor_lógico2], ...)

La sintaxis de la función Y tiene los siguientes argumentos:

Argumento

Descripción

Valor_lógico1

Requerido. La primera condición que quiere probar que puede evaluarse como VERDADERO o FALSO.

Valor_lógico2, ...

Opcional. Las condiciones adicionales que desea probar que pueden evaluarse como VERDADERO o FALSO, hasta un máximo de 255 condiciones.

Comentarios

  • Los argumentos deben evaluarse como valores lógicos, como VERDADERO o FALSO, o bien deben ser matrices o referencias que contengan valores lógicos.

  • Si un argumento matricial o de referencia contiene texto o celdas vacías, dichos valores se pasarán por alto.

  • Si el rango especificado no contiene valores lógicos, la función Y devuelve el error #¡VALOR!.

Ejemplos

Aquí se muestran algunos ejemplos generales del uso de Y por sí mismo y junto a la función SI.

Ejemplos de usar las funciones SI con Y

Fórmula

Descripción

= Y(A2>1,A2<100)

Muestra VERDADERO si A2 es superior a 1 Y es inferior a 100, de otro modo, muestra FALSO.

=SI(Y(A2<A3,A2<100),A2,"El valor está fuera del rango")

Muestra el valor de la celda A2 si es inferior a A3 Y es inferior a 100, de otro modo muestra el mensaje "El valor está fuera del rango".

=SI(Y(A3>1,A3<100),A3,"El valor está fuera del rango")

Muestra el valor de la celda A3 si es superior a 1 Y es inferior a 100, de otro modo muestra un mensaje. Puede sustituir cualquier mensaje de su elección.

Cálculo de bonificación

Aquí se muestra un escenario bastante común donde necesitamos calcular si el personal de ventas puede optar a una bonificación mediante SI e Y.

Ejemplo de calcular el bonus de ventas con las funciones SI e Y.  La fórmula de la celda E14 es =SI(Y(B14>=$B$7,C14>=$B$5),B14*$B$8,0)
  • =SI(Y(B14>=$B$7,C14>=$B$5),B14*$B$8,0): SI el valor de Ventas totales es superior o igual (>=) al de Objetivo de las ventas, Y el valor de Cuentas es Superior o Igual (>=) al de Objetivo de la cuenta, se multiplicará el valor de Ventas totales por el % de Bonificación. Si no, se devolverá el valor 0.

¿Necesita más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Vea también

Ver un vídeo sobre cómo usar la función SI

Obtener información sobre cómo usar funciones anidadas en una fórmula

Función SI

Función O

Función NO

Información general de fórmulas en Excel

Cómo evitar las fórmulas rotas

Usar la comprobación de errores para detectar errores en las fórmulas

Métodos abreviados de teclado en Excel 2016 para Windows

Métodos abreviados de teclado en Excel 2016 para Mac

Funciones lógicas (referencia)

Funciones de Excel (orden alfabético)

Funciones de Excel (por categoría)

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×