Vídeo: buscar un registro en un formulario seleccionando un valor de una lista

Su explorador no admite vídeo. Instale Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Mediante el Asistente para cuadros combinados, puede crear de manera rápida una lista desplegable que permite buscar un registro en un formulario. Por ejemplo, para buscar un registro en un formulario que muestra información de contacto de un empleado, puede seleccionar el nombre del empleado de un cuadro combinado en la parte superior del formulario y, a continuación, el formulario muestra el registro del empleado.

Nota:  El Asistente para cuadros combinados está deshabilitado para formularios compatibles con web, por lo que el procedimiento que se incluye en este vídeo solo se puede llevar a cabo en formularios de cliente. Si no está seguro de cuál es el tipo de formulario con el que trabaja, mire el icono del mismo en el panel de navegación. Los objetos compatibles con web se distinguen porque hay un globo pequeño en el icono del objeto.

En el vídeo

Agregar el cuadro combinado al formulario

  1. En el panel de navegación, haga clic con el botón secundario en el formulario y, a continuación, haga clic en la vista Presentación.

  2. En el grupo Controles de la ficha Diseño, haga clic en la flecha abajo de la Galería de controles y asegúrese de que está seleccionada la opción Utilizar Asistentes para controles.

  3. En la Galería de controles, haga clic en el control Cuadro combinado y, a continuación, haga clic en el encabezado del formulario donde desea colocar el cuadro combinado.

    Si Access muestra un cuadro de diálogo Aviso de seguridad en ese punto, haga clic en Abrir para iniciar el asistente.

  4. En la primera página del Asistente para cuadros combinados, seleccione Buscar un registro en el formulario según el valor que he seleccionado en el cuadro de lista o cuadro combinado. Si no ve esta opción, consulte la sección Si la opción Buscar un registro... no está disponible.

  5. En la siguiente página del asistente, en la lista Campos disponibles, seleccione el campo que desea mostrar en el cuadro combinado y use el botón de flecha para agregarlo a la lista Campos seleccionados.

Nota:  Puede agregar varios campos al cuadro combinado, pero solo se usará el primer campo para buscar el registro. Asegúrese de que el campo que elija identifique de manera única cada registro. Si selecciona un campo como Apellido y hay varios registros con el mismo apellido, Access solo buscará el primer registro que coincida con el apellido, aun si ha agregado el Nombre al cuadro combinado. Una buena técnica es crear un campo calculado en el origen del registro del formulario que concatena dos o más campos juntos y, a continuación, usar este campo calculado como el valor del cuadro combinado. Para obtener más información sobre la creación de campos calculados, consulte la sección Ver también de este artículo.

  1. En la siguiente página, el asistente muestra el aspecto que tendrá la lista cuando se cree.

    • Asegúrese de que está seleccionada la casilla Ocultar la columna clave.

    • Ajuste los anchos de columna, si es necesario, y desplace hacia abajo la lista para asegurarse de que todos los valores se ajustan.

  2. En la siguiente página del asistente, escriba una etiqueta para el cuadro combinado, como “Buscar contacto”.

  3. Haga clic en Finalizar.

    Access coloca el cuadro combinado en el formulario. Asegúrese de que se muestra en el encabezado del formulario. Si es necesario, use los comandos Insertar, Dividir o Combinar en la ficha Organizar para crear celdas adecuadas en el encabezado del formulario para el nuevo cuadro combinado.

  1. En el grupo Vistas, de la ficha Inicio, haga clic en lavista Formulario. Pruebe el cuadro combinado para asegurarse de que funciona de la manera prevista.

Principio de página

Ordenar los valores del cuadro combinado

En la mayoría de los casos, los valores del cuadro combinado no se ordenan. Para agregar el orden que desee, siga este procedimiento:

  1. En el grupo Vistas, de la ficha Inicio, haga clic en la vista Presentación.

  2. Seleccione el cuadro combinado.

  3. Si no aparece la Hoja de propiedades, presione F4 para mostrarla.

  4. En la ficha Todas de la Hoja de propiedades, en el cuadro de propiedad Origen de la fila, haga clic en el botón Generar Imagen del botón .


Access abrirá el Generador de consultas. El campo que elija en el paso 5 del procedimiento anterior se muestra en su propia columna en la cuadrícula de la consulta.

  1. En la filaOrdenar del campo que ha elegido para el cuadro combinado, seleccione el orden de clasificación que desee (Ascendente o Descendente).

  2. Haga clic en Cerrar en la cinta de opciones y, a continuación, haga clic en para guardar los cambios.

  3. En el grupo Vistas, de la ficha Inicio, haga clic en la vista Formulario. Pruebe el cuadro combinado para asegurarse de que funciona de la manera prevista.

Principio de página

Si la opción Buscar un registro… no está disponible

Si la opción Buscar un registro en el formulario según el valor que he seleccionado en el cuadro de lista o cuadro combinado no se muestra en la primera página del asistente, probablemente se deba a que el formulario no es dependiente de una tabla o de una consulta guardada. El formulario debe ser dependiente de un objeto que esté disponible en el panel de navegación en Tablas o Consultas.

Lleve a cabo el siguiente procedimiento para comprobar si un formulario es dependiente de una tabla o de una consulta guardada:

  1. Haga clic en Cancelar para cerrar el asistente.

  2. Haga clic con el botón secundario del cuadro de lista o cuadro combinado que ha creado anteriormente y, a continuación, haga clic en Eliminar.

  3. Si no aparece la Hoja de propiedades, presione F4 para mostrarla.

  4. Seleccione Formulario de la lista que hay en la parte superior de la hoja de propiedades.

  5. En la ficha Datos de la hoja de propiedades, mire el cuadro de propiedad Origen de registros. Este cuadro debe incluir el nombre de una tabla o consulta guardada antes de poder realizar el procedimiento descrito en este artículo. Si el cuadro está en blanco, puede seleccionar una tabla o consulta existente como origen de registros, o puede crear una nueva consulta que funcione como origen de registros. Si el cuadro incluye una instrucción SELECT, tiene la opción adicional de convertir la instrucción en una consulta guardada. Una vez haya finalizado estas tareas, la siguiente vez que ejecute el Asistente para cuadros combinados/cuadros de lista, aparecerá la opción Buscar un registro....

  6. Realice uno de estos procedimientos según sus preferencias:

    • Opción 1: Seleccionar una tabla o consulta existente como origen de registros

    Si sabe que hay una tabla o consulta existente en su base de datos que incluye los registros que desea buscar, siga este procedimiento para enlazar el formulario a ese objeto.

    Nota:  Si el cuadro de propiedad Origen de registros incluye una instrucción SELECT, este procedimiento eliminará la instrucción de manera permanente. Es posible que desee copiar la instrucción en un archivo de texto u otro programa de procesamiento de texto en caso de que quiera restaurarlo.

    1. Haga clic en el cuadro de propiedad Origen de registros y, a continuación, haga clic en la flecha desplegable que aparece.

    2. Seleccione una de las tablas o consultas disponibles. Si no hay disponible ninguna tabla o consulta adecuada, debe crear una antes de continuar. Para obtener más información, consulte los artículos Introducción a las tablas o Introducción a las consultas.

    3. Guarde el formulario y, a continuación, repita el procedimiento indicado al principio de este artículo. El asistente debería mostrar ahora la opción Buscar un registro en el formulario según el valor que he seleccionado en el cuadro de lista o cuadro combinado.

      • Opción 2: Crear una nueva consulta guardada o convertir una instrucción SELECT en una consulta guardada

      Si los datos que desea buscar están incluidos en más de una tabla, deberá enlazar el formulario a una consulta que seleccione los datos de esas tablas.

  1. En el cuadro de propiedad Origen de registros, haga clic en el botón Generar Imagen del botón .

    Access abrirá el Generador de consultas.

    • Si el cuadro de propiedad Origen de registros está vacío inicialmente, el Generador de consultas muestra el cuadro de diálogo Mostrar tabla y puede empezar a crear una nueva consulta. Para obtener más información, consulte el artículo Introducción a las consultas. Cuando haya acabado de generar la consulta, siga con el paso 2.

    • Si el cuadro de propiedad Origen de registros incluye inicialmente una instrucción SELECT, esta consulta se muestra en el Generador de consultas. Siga con el paso 2 para convertirla en una consulta guardada.

  2. En el grupo Cerrar, de la ficha Diseño, haga clic en Guardar como.

  3. En el cuadro de diálogo Guardar como, escriba un nombre para la consulta en el cuadro Guardar 'Nombredeconsulta' en:.

  4. Asegúrese de que Consulta está seleccionada en el cuadro Como y, a continuación, haga clic en Aceptar.

  5. En el grupo Cerrar, de la ficha Diseño, haga clic en Cerrar.

  6. Haga clic en para guardar los cambios realizados en la consulta y actualizar la propiedad.

    Access muestra el formulario en la vista Diseño y cambia la propiedad Origen de registros de modo que se muestra el nombre de la nueva consulta guardada.

  7. Guarde el formulario y, a continuación, repita el procedimiento que se indica al principio de este artículo. El asistente debería mostrar ahora la opción Buscar un registro en el formulario según el valor que he seleccionado en el cuadro de lista o cuadro combinado.

Principio de página

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×