Utilizar valores de una base de datos de Access para rellenar un cuadro de lista, cuadro de lista desplegable o cuadro combinado

Nota:  Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

En un formulario de InfoPath, puede rellenar un cuadro de lista, cuadro de lista desplegable o cuadro combinado con datos de una conexión de datos de consulta a una base de datos de Microsoft Office Access 2007 (formato .accdb) o una base de datos de Access que se guardó en una versión anterior (.mdb formato).

En este artículo

Información general

Consideraciones de compatibilidad

Antes de empezar

Paso 1: Agregue una conexión de datos de consulta

Paso 2: Configure el control

Opcional: Establezca un filtro para limitar los elementos en el control

Información general

Un cuadro de lista, cuadro de lista desplegable o cuadro combinado muestra los elementos que los usuarios puedan seleccionar al rellenar un formulario de InfoPath. Al diseñar una plantilla de formulario, puede configurar estos tipos de controles para mostrar datos de una conexión de datos secundaria a una base de datos de Access.

Una conexión de datos secundaria es cualquier conexión de datos a un origen de datos externo que agrega a una plantilla de formulario. Puede configurar conexiones de datos secundarios para recuperar datos que los usuarios necesitan para rellenar formularios basados en la plantilla de formulario o para enviar datos del formulario a un origen de datos externos, como un servicio Web.

Cuando agrega una conexión de datos secundaria que consulta datos a la plantilla de formulario, InfoPath crea un secundario origen de datos que contiene los campos de datos y grupos que se corresponden a la forma en que los datos se almacenan en la base de datos. La conexión de datos de consulta recupera datos desde el servicio Web y, a continuación, almacena los datos de origen de datos secundarios del formulario.

Puede configurar la conexión de datos secundaria para guardar los resultados de la consulta en los equipos de los usuarios para que los usuarios tengan acceso a los datos aunque sus equipos no están conectados a una red. Según la naturaleza de los datos, es recomendable mostrar los resultados de la consulta solo cuando los usuarios están conectados a una red.

Nota de seguridad: Si está utilizando una conexión de datos secundaria para recuperar datos confidenciales desde un origen de datos externos, desea deshabilitar esta característica para ayudar a proteger los datos de uso no autorizado en caso de que se robe o se pierda el equipo. Si deshabilita esta característica, los datos estará disponibles únicamente si el usuario está conectado a la red.

Si desea limitar el número de elementos en un control de cuadro de lista, puede usar un filtro. Usar un filtro cuando necesite mostrar un subconjunto de los datos devueltos por una consulta que se basa en criterios seleccionadas por el usuario. Que criterios pueden ser un elemento que está seleccionado en otro control (por ejemplo, un cuadro de lista, cuadro combinado, cuadro de lista desplegable o cuadro de texto) enlazado a un campo en el origen de datos.

Dado que la estructura de datos en el origen de datos secundario debe coincidir con la forma en que los datos se almacenan en la base de datos, no puede modificar los campos existentes o grupos en el origen de datos secundario. En la sección Vea también de este artículo encontrará vínculos a más información sobre las conexiones de datos y orígenes de datos.

Volver al principio

Consideraciones de compatibilidad

Puede agregar una conexión de datos de consulta a una base de datos de Access solo si está diseñando una plantilla de formulario que no es un plantilla de formulario compatible con el explorador.

Volver al principio

Antes de empezar

Antes de que puede usar valores de una base de datos de Access para rellenar un control en la plantilla de formulario, necesita la siguiente información al administrador de la base de datos:

  • El nombre y la ubicación de la base de datos.

    Nota: Si va a otros usuarios de la red crear formularios basados en esta plantilla de formulario, asegúrese de que la base de datos es accesible para esos usuarios.

  • El nombre de la tabla o consulta que proporciona los valores para los controles. Esta tabla o consulta que usa como la tabla principal al configurar la conexión de datos de la consulta.

  • Los nombres de las otras tablas o consultas desde el que la tabla principal o consulta puede requerir datos. En la mayoría de los casos, las relaciones de tabla ya establecidas en la base de datos. Si necesita establecer manualmente las relaciones entre la tabla principal o consulta y otra tabla o consulta, necesitará los nombres de campo relacionados de ambas tablas o consultas.

Volver al principio

Paso 1: Agregue una conexión de datos de consulta

Si no tiene una conexión de datos de consulta existente que puede usar en la plantilla de formulario, use el siguiente procedimiento para agregar una conexión de datos secundaria que consulta datos a la plantilla de formulario. Si la plantilla de formulario ya tiene una conexión de datos secundaria que puede usar, puede omitir esta sección y vaya a paso 2: Configure el control.

  1. En el menú Herramientas, haga clic en Conexiones de datos.

  2. En el cuadro de diálogo Conexiones de datos, haga clic en Agregar.

  3. En el Asistente para la conexión de datos, haga clic en crear una nueva conexión para, haga clic en recibir datos y, a continuación, haga clic en siguiente.

  4. En la siguiente página del asistente, haga clic en base de datos (Microsoft SQL Server o Microsoft Office Access) y, a continuación, haga clic en siguiente.

  5. En la siguiente página del asistente, haga clic en Seleccionar base de datos.

  6. En el cuadro de diálogo Seleccionar origen de datos, vaya a la ubicación de la base de datos.

    Nota: Si la base de datos esté almacenada en una ubicación de red, vaya a la ruta de nomenclatura universal (UNC) convención de la ubicación. No se vaya a la ubicación de red a través de una unidad de red. Si usa una unidad de red (que es, asignar una letra de una unidad de red, como altura o Z:), formularios que los usuarios creen que se basan en esta plantilla de formulario buscará la base de datos en esa unidad de red asignada específica. Si el usuario no tiene unidad de red asignada en la misma manera, el formulario no encuentra la base de datos.

  7. Haga clic en el nombre de la base de datos y, a continuación, haga clic en Abrir.

  8. En el cuadro de diálogo Seleccionar tabla, haga clic en la tabla principal o consulta que desee usar y, a continuación, haga clic en Aceptar.

  9. En la siguiente página del asistente, active la casilla de verificación Mostrar columnas de tabla.

    De forma predeterminada, todos los campos de la tabla o consulta se agregan al origen de datos principal de la plantilla de formulario.

  10. Desactive las casillas de verificación para los campos que no desea incluir en el origen de datos principal.

  11. Agregar otras tablas o consultas que desea incluir en la conexión de datos de la consulta.

    ¿Cómo?

    1. Haga clic en Agregar tabla.

    2. En el cuadro de diálogo Agregar tabla o consulta, haga clic en el nombre de la tabla secundaria y, a continuación, haga clic en siguiente. InfoPath intenta establecer las relaciones haciendo coincidir los nombres de campo en ambas tablas. Si no desea usar la relación sugerida, seleccione la relación y, a continuación, haga clic en Quitar relación. Para agregar una relación, haga clic en Agregar relación. En el cuadro de diálogo Agregar relación, haga clic en el nombre de cada campo relacionado en la columna correspondiente y, a continuación, haga clic en Aceptar.

    3. Haga clic en Finalizar.

    4. Para agregar tablas secundarias adicionales, repita estos pasos.

  12. Haga clic en Siguiente.

  13. Para que los resultados de la conexión de datos de consulta disponibles cuando el formulario no está conectado a una red, seleccione la casilla de verificación almacenar una copia de los datos de la plantilla de formulario.

    Nota de seguridad: Si activa esta casilla, almacena los datos en el equipo del usuario cuando el formulario usa esta conexión de datos. Si el formulario está recuperando los datos confidenciales de esta conexión de datos, es recomendable deshabilitar esta característica para ayudar a proteger los datos en caso de que se robe o se pierda el equipo o en caso contrario, se tiene acceso a un usuario no autorizado.

  14. Haga clic en Siguiente.

  15. En la siguiente página del asistente, escriba un nombre descriptivo para esta conexión de datos secundaria y, a continuación, compruebe que la información en la sección de Resumen es correcta.

  16. Para configurar el formulario para que reciban los datos automáticamente cuando se abre, seleccione la casilla de verificación recuperar datos automáticamente cuando se abre un formulario.

Volver al principio

Paso 2: Configure el control

  1. Si la plantilla de formulario tiene varias vistas, haga clic en nombre de la vista en el menú Ver para ir a la vista con el control que desea mostrar los datos de origen de datos secundario.

  2. Haga doble clic en el cuadro de lista, cuadro de lista desplegable o control de cuadro combinado en la plantilla de formulario que desea configurar.

  3. Haga clic en la pestaña Datos.

  4. En entradas del cuadro de lista, haga clic en Buscar valores desde un origen de datos externos.

  5. En la lista de origen de datos, haga clic en el origen de datos que desea usar.

  6. Haga clic en Seleccionar XPath Imagen del botón , junto al cuadro entradas.

  7. En el cuadro de diálogo Seleccionar un campo o grupo, especifique el campo o grupo cuyos campos contienen los datos que se muestran para el usuario y los datos que se enviarán al origen de datos externo siguiendo uno de estos procedimientos.

    Especificar que los datos que verá el usuario son los mismos datos que enviará el usuario

    • Haga clic en un campo y, a continuación, haga clic en Aceptar.

    Especificar que los datos que el usuario verá están diferentes de los datos que se enviará el usuario

    Nota: En este escenario, los datos que el usuario verá proceden de uno de los campos en el grupo y los datos que se enviará el usuario se encuentran en otro campo en el mismo grupo.

    1. Haga clic en un grupo y, a continuación, haga clic en Aceptar.

    2. En el cuadro de diálogo Propiedades del Control, haga clic en Seleccionar XPath Imagen del botón , junto al cuadro valor.

    3. En el cuadro de diálogo Seleccionar un campo o grupo, haga clic en un campo que contiene los datos que el usuario enviar al origen de datos externos y, a continuación, haga clic en Aceptar.

    4. En el cuadro de diálogo Propiedades del Control, haga clic en Seleccionar XPath Imagen del botón , junto al cuadro nombre para mostrar.

    5. En el cuadro de diálogo Seleccionar un campo o grupo, haga clic en un campo que contiene los datos que aparecen en el control y a continuación, haga clic en Aceptar.

  8. Si el campo en el cuadro nombre para mostrar tiene valores con nombres para mostrar similares y desea mostrar sólo nombres únicos, active la casilla de verificación Mostrar solamente las entradas con nombres de presentación únicos.

Volver al principio

Volver al principio

Opcional: Establezca un filtro para limitar los elementos en el control

  1. Haga doble clic en el cuadro de lista, cuadro de lista desplegable o control de cuadro combinado en la plantilla de formulario que desea configurar.

  2. Haga clic en la pestaña Datos.

  3. Haga clic en Seleccionar XPath Imagen del botón junto al cuadro entradas.

  4. En el cuadro de diálogo Seleccionar un campo o grupo, haga clic en el campo o grupo que contiene los campos que proporcionarán los valores para el control y, a continuación, haga clic en Filtrar datos.

  5. En el cuadro de diálogo Filtrar datos, haga clic en Agregar.

    Nota: Si desea agregar una condición a un filtro existente, haga clic en el filtro que desea aplicar y, a continuación, haga clic en Modificar.

  6. En el primer cuadro en el cuadro de diálogo Especificar condiciones de filtro, haga clic en el nombre del campo cuyos datos que desea filtrar.

  7. En el segundo cuadro, haga clic en el tipo de filtro que desea usar.

  8. En el tercer cuadro, haga clic en el tipo de condición que desea aplicar el filtro y, a continuación, escriba la condición.

  9. Para configurar más de una condición para el filtro, haga clic en y y, a continuación, siga uno de estos procedimientos:

    • Para aplicar la condición existente y la nueva condición al filtro, haga clic en y y, a continuación, agregue la nueva condición.

    • Para aplicar la condición existente o la nueva condición al filtro, haga clic en o y, a continuación, agregue la condición adicional.

  10. Haga clic en Aceptar para cerrar los cuadros de diálogo.

  11. Para probar sus cambios, haga clic en Vista previa en la barra Estándar, o presione CTRL+MAYÚS+B.

    Se abre la plantilla de formulario en una ventana nueva.

  12. En la ventana de vista previa, seleccione varios valores en el control de filtro para comprobar que el filtro funciona correctamente.

    El filtro no funciona correctamente

    Si los valores en el control que contiene un filtro no son correctos, ya sea porque hay demasiadas valores o insuficiente, pruebe lo siguiente:

    • Si usa varias condiciones en el filtro, quitar una sola condición para comprobar que se devuelven los valores correctos de esa única condición. Si la primera condición devuelve los valores correctos, agregar otra condición y probarlo.

    • Filtros de distinguir entre mayúsculas y minúsculas. Si desea mostrar datos que comienzan con un carácter en mayúscula o minúscula, crear un filtro con una condición de mayúsculas, seleccione o en el cuadro de diálogo Especificar condiciones de filtro y, a continuación, cree una condición de letra minúscula.

    • Si los valores filtrados son exactamente opuestos de lo que espera, por ejemplo, los productos de todas la visualización de proveedores en lugar de los productos de un único proveedor, cambiar el tipo de filtro en la condición. Por ejemplo, si utiliza el tipo de filtro es igual a la condición y obtenga demasiados productos, pruebe utilizando el tipo de filtro no es igual a.

Volver al principio

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×