Use SUMAPRODUCTO para sumar el producto de valores correspondientes en uno o más rangos

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

SUMAPRODUCTO usa rangos de celdas (o matrices) como argumentos (las partes de una fórmula que hacen que funcione). Multiplica los elementos de las matrices y suma el resultado.

En esta lista de la compra de ejemplo, una matriz contiene el precio de cada elemento y la otra contiene la cantidad de elementos a comprar.

Precios y cantidades que se deben multiplicar y, posteriormente, sumar

  1. Para crear la fórmula, escriba =SUMAPRODUCTO(B3:B6,C3:C6) y presione Entrar.

Se multiplicará cada celda de la columna B por su celda correspondiente de la misma fila en la columna C y luego se sumarán los resultados. La suma total de los precios de los productos es de 17,02 €

  1. Escribir una fórmula más larga que proporciona el mismo resultado, escriba = B3 * C3 + B4 * C4 + B5 * C5 + B6 * C6 y presione ENTRAR.

Después de presionar ENTRAR, el resultado es el mismo: 17,02 €. La celda B3 se multiplica por C3, y el resultado se suma al resultado de B4 multiplicado por C4, y así sucesivamente. Puede imaginarse lo útil que es SUMAPRODUCTO cuando tenga centenares (o incluso miles) de filas.

Notas: 

  • Las filas o columnas (matrices) deben tener la misma longitud.

  • Si hay texto (en lugar cifras) en una celda, este se considera cero.

Ejemplo

Si quiere familiarizarse con SUMAPRODUCTO y las matrices, aquí tiene un libro de Excel Online con datos distintos a los usados en este artículo..

Copie los datos de ejemplo en la tabla siguiente y péguelos en la celda A1 de una hoja de cálculo nueva de Excel. Para que las fórmulas muestren los resultados, selecciónelas, presione F2 y luego ENTRAR. Si lo necesita, puede ajustar el ancho de las columnas para ver todos los datos.

Un

A

D

E

3

4

2

7

8

6

6

7

1

9

5

3

Fórmula

Resultado

'=SUMAPRODUCTO(A2:B4,D2:E4)

=SUMAPRODUCTO(A2:B4,D2:E4)

Multiplica todos los componentes de las dos matrices (A2:B4 y D2:E4) y después suma los productos, es decir, 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156).

Si desea aprender más, también puede abrir este libro en Excel. Haga clic en el icono de Excel en la esquina inferior derecha del libro  Icono de Excel en Excel Online , guarde el archivo en un sitio cómodo de su equipo, y ábralo.

Volver al principio

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×