Usar un libro compartido para trabajar en colaboración

En Excel 2010, aproveche la función que permite guardar libros en un sitio de SharePoint. Excel Web App, disponible en el servidor que usa la tecnología de Microsoft SharePoint 2010, permite a varios usuarios editar datos de una hoja de cálculo en el navegador de forma simultánea.
Lea una entrada de blog o pruebe Office 365.

Puede crear un libro compartido y copiarlo en una ubicación de red donde varios usuarios puedan editar el contenido de forma simultánea. Por ejemplo, si los usuarios de su grupo de trabajo administran varios proyectos cada uno y quiere conocer el estado de los proyectos de sus compañeros, el grupo puede usar un libro compartido para realizar un seguimiento del estado de los proyectos. Todas las personas implicadas podrán especificar la información sobre sus proyectos en el mismo libro.

Como propietario del libro compartido, puede administrarlo quitando usuarios del mismo y resolviendo los cambios que estén en conflicto con otros. Cuando se hayan incluido todos los cambios, puede dejar de compartir el libro.

Compartir datos de Excel

¿Qué desea hacer?

Compartir un libro

Modificar un libro compartido

Quitar un usuario de un libro compartido

Resolver conflictos de cambios en un libro compartido

Dejar de compartir un libro

Compartir un libro

  1. Cree un nuevo libro e escriba los datos que desea proporcionar o abra un libro existente que desea que esté disponible para su modificación por varios usuarios.

    Nota: En los libros compartidos, no todas las características están disponibles. Si quiere incluir alguna de las características siguientes, tendrá que agregarlas antes de guardar el libro como libro compartido: celdas combinadas, formatos condicionales, validación de datos, gráficos, imágenes, objetos (incluidos los objetos de dibujo), hipervínculos, escenarios, esquemas, subtotales, tablas de datos, informes de tabla dinámica, protección de libros y hojas de cálculo, y macros. No se pueden realizar cambios en estas características después de compartir el libro.

    Características no compatibles en los libros compartidos

En los libros compartidos no se puede

Pero es posible que se pueda hacer lo siguiente

Crear una tabla de Excel

Nada

Insertar o eliminar bloques de celdas

Insertar filas y columnas completas.

Eliminar hojas de cálculo

Nada

Combinar celdas o dividir celdas combinadas

Nada

Agregar o cambiar formatos condicionales

Los formatos condicionales existentes siguen apareciendo a medida que cambian los valores de celda, pero no se pueden modificar ni se pueden volver a definir las condiciones.

Agregar o cambiar validación de datos

Las celdas siguen validándose al escribir nuevos valores, pero no se puede cambiar la configuración de validación de datos existente.

Crear o cambiar gráficos o informes de gráfico dinámico

Ver los gráficos e informes existentes.

Insertar o cambiar imágenes u otros objetos

Ver las imágenes y otros objetos existentes.

Insertar o cambiar hipervínculos

Los hipervínculos existentes siguen funcionando.

Utilizar herramientas de dibujo

Ver los dibujos y gráficos existentes.

Asignar, cambiar o quitar contraseñas

Las contraseñas existentes permanecen activas.

Proteger o desproteger hojas de cálculo o el libro

La protección existente permanece activa.

Crear, cambiar o ver escenarios

Nada

Agrupar o esquematizar datos

Seguir utilizando los esquemas existentes.

Insertar subtotales automáticos

Ver los subtotales existentes.

Crear tablas de datos

Ver las tablas de datos existentes.

Crear o cambiar informes de tabla dinámica

Ver los informes existentes.

Escribir, grabar, cambiar, ver o asignar macros

Ejecutar las macros existentes que no tengan acceso a funciones no disponibles. Registrar las operaciones del libro compartido en una macro almacenada en otro libro no compartido.

Agregar o cambiar hojas de diálogo de Microsoft Excel 4

Nada

Cambiar o eliminar fórmulas de matriz

Las fórmulas de matriz existentes siguen realizando los cálculos correctamente.

Usar un formulario de datos para agregar nuevos datos

Puede utilizar un formulario de datos para buscar un registro.

Trabajar con datos XML, que incluye:

  • Importar, actualizar y exportar datos XML

  • Agregar, cambiar el nombre o eliminar asignaciones XML

  • Asignar celdas a elementos XML

  • Usar el panel de tareas Origen XML, la barra de tareas XML o los comandos XML del menú Datos

Nada

  1. En la pestaña Revisar, en el grupo Cambios, haga clic en Compartir libro.

    Imagen de la cinta de Excel

  2. En la ficha Edición, active la casilla de verificación Permitir la modificación por varios usuarios a la vez. Esto también permite combinar libros.

  3. En la ficha Avanzadas, seleccione las opciones que desea utilizar para realizar un seguimiento de los cambios y actualizarlos; a continuación, haga clic en Aceptar.

  4. Siga uno de los procedimientos siguientes:

    • Si es un libro nuevo, escriba un nombre en el cuadro Nombre de archivo.

    • Si se trata de un libro existente, haga clic en Aceptar para guardar el libro, haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y, después, haga clic en Guardar como.

  5. En un equipo que ejecute Windows Vista    

    • En la barra de direcciones, seleccione una ubicación de red a la que tengan acceso los usuarios previstos y, después, haga clic en Guardar.

      En un equipo que ejecute Microsoft Windows XP    

    • En el cuadro Guardar en, seleccione una ubicación de red a la que puedan tener acceso los usuarios previstos y haga clic en Guardar.

      Nota: Debe utilizar una carpeta de red compartida, no un servidor Web.

  6. Si el libro contiene vínculos a otros libros o documentos, compruebe los vínculos y actualice los que estén rotos; por último, haga clic en Guardar Imagen del botón en la barra de herramientas de acceso rápido, o presione CTRL+G.

    Barra de herramientas de acceso rápido

    Cómo comprobar y actualizar los vínculos a otros libros o documentos

    1. En la pestaña Datos, en el grupo Conexiones, haga clic en Modificar vínculos.

      Imagen de la cinta de Excel

      El comando Modificar vínculos no está disponible si el archivo no contiene información vinculada.

    2. Haga clic en Comprobar estado para revisar el estado de todos los vínculos de la lista.

      Esta operación puede tardar si hay muchos vínculos o si el libro de origen de los vínculos está en una ubicación de red y la red es lenta.

    3. Compruebe el estado en la columna Estado, haga clic en el vínculo y, después, realice la acción necesaria.

Si el estado es

Realice esta acción

Correcto

No es necesario realizar ninguna acción. El vínculo funciona y está actualizado.

Desconocido

Haga clic en Comprobar estado para actualizar el estado de todos los vínculos de la lista.

N/D

El vínculo usa vinculación e incrustación de objetos (OLE) o intercambio dinámico de datos (DDE).

Microsoft Office Excel no puede comprobar el estado de estos tipos de vínculos.

Error: no se ha encontrado el origen

Haga clic en Cambiar origen y seleccione otro libro.

Error: no se ha encontrado la hoja de cálculo

Haga clic en Cambiar origen y seleccione otra hoja de cálculo. Es posible que se haya movido el origen o que se le haya cambiado el nombre.

Advertencia: valores no actualizados

Haga clic en Actualizar valores. El vínculo no se actualizó al abrirse el libro.

Advertencia: Haga clic en Abrir origen y presione F9 para actualizar el libro

El libro se puede configurar en cálculo manual. Para establecer el libro en cálculo automático, haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y, después, haga clic en Opciones de Excel. En la categoría Fórmulas, debajo de Opciones de cálculo, haga clic en Automáticamente.

Advertencia: Algunos nombres no se pueden resolver hasta que se abra el libro de origen

Haga clic en Abrir origen, vuelva al libro de destino y, después, haga clic en Comprobar estado. Si este procedimiento no resuelve el problema, asegúrese de que el nombre esté incluido y de que no esté mal escrito. Cambie al libro de origen y, en la pestaña Fórmulas, en el grupo Celdas con nombre, haga clic en Administrador de nombres y busque el nombre.

Advertencia: haga clic en Abrir origen

El vínculo no se puede actualizar hasta que se abra el origen.

El origen está abierto

No se puede comprobar el estado de un vínculo.

Valores actualizados desde nombre de archivo

No es necesario realizar ninguna acción. Se han actualizado los valores.

Advertencia: Excel no puede determinar el estado del vínculo

Es posible que el origen no contenga hojas de cálculo o que se guardara en un formato de archivo no admitido. Haga clic en Actualizar valores.

  • Todos los usuarios con acceso al recurso compartido de red tienen acceso total al libro compartido a menos que bloquee celdas y proteja la hoja de cálculo para restringir el acceso. Para proteger un libro compartido, haga clic en Proteger y compartir libro en el grupo Cambios de la ficha Revisar. Al proteger un libro compartido, puede establecer una contraseña que deben escribir todos los usuarios para abrir el libro.

  • Para poder modificar el libro compartido, todos los usuarios deben alguno de los siguientes programas instalados en sus equipos: Microsoft Office Excel, Excel 97 o posterior, o Microsoft Excel 98 o posterior para Macintosh.

  • No todas las características de Excel son compatibles con los libros compartidos. Para obtener más información, vea la tabla "Características no compatibles en los libros compartidos" más arriba.

Principio de página

Modificar un libro compartido

Después de abrir un libro compartido, puede especificar y cambiar los datos igual que en un libro normal.

  1. Abra el libro compartido.

    Cómo abrir un libro compartido

    1. Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y, después, en Abrir.

    2. En un equipo que ejecute Windows Vista    

      • En la barra de direcciones, busque la ubicación de red donde se almacenó el libro compartido y, a continuación, haga clic en el libro compartido.

        En un equipo que ejecute Microsoft Windows XP    

        • En el cuadro Buscar en, busque la ubicación de red donde está almacenado el libro compartido y, a continuación, haga clic en el libro compartido.

    3. Haga clic en Abrir.

      También puede ir a la ubicación de red en la que está almacenado el libro compartido y hacer doble clic en el libro compartido para abrirlo.

  2. Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y, después, haga clic en Opciones de Excel.

  3. En la categoría Más frecuentes, bajo Personalizar la copia de Office, en el cuadro Nombre de usuario, escriba el nombre de usuario que desea utilizar para identificar su trabajo en el libro compartido y haga clic en Aceptar.

  4. Especifique y modifique datos en las hojas de cálculo de forma habitual.

    1. Las siguientes funciones no se pueden agregar ni modificar: celdas combinadas, formatos condicionales, validación de datos, gráficos, imágenes, objetos (incluidos los de dibujo), hipervínculos, escenarios, esquemas, subtotales, tablas de datos, informes de tabla dinámica, protección de libros y hojas de cálculo, y macros.

  5. Aplique cualquier filtro y configuración de impresión que desee para su uso personal. De forma predeterminada, la configuración de cada usuario se guarda por separado.

    1. También puede usar los filtros o la configuración de impresión preparados por el propietario del libro cuando lo abra.

    2. Cómo usar los filtros y la configuración de impresión originales

      1. En la pestaña Revisar, en el grupo Cambios, haga clic en Compartir libro.

      2. Imagen de la cinta de Excel

      3. En la pestaña Avanzadas, debajo de Incluir en vista personal, desactive la casilla Configuración de impresora o Configuración de filtro y, después, haga clic en Aceptar.

  6. Para guardar los cambios realizados en el libro y ver los cambios guardados por otros usuarios desde la última vez que guardó el libro, haga clic en Guardar Imagen del botón en la barra de herramientas de acceso rápido, o presione CTRL+G.

    Barra de herramientas de acceso rápido

    Si aparece el cuadro de diálogo Resolución de conflictos, resuelva los conflictos.

    Para resolver los conflictos, vea Resolver conflictos de cambios en un libro compartido en este tema.

    • Puede ver quién más tiene abierto el libro mediante la ficha Edición del cuadro de diálogo Compartir libro (ficha Revisar, grupo Cambios, botón Compartir libro).

    • Puede elegir si desea obtener de manera automática las actualizaciones de los cambios de los demás usuarios periódicamente, guardadas o sin guardar, bajo Actualizar cambios en la ficha Avanzadas del cuadro de diálogo Libro compartido.

Principio de página

Quitar un usuario de un libro compartido

Si es necesario, puede desconectar usuarios de un libro compartido.

Nota: Antes de desconectar usuarios, asegúrese de que han completado su trabajo en el libro. Si quita un usuario activo, se perderá todo el trabajo que no se haya guardado.

  1. En la pestaña Revisar, en el grupo Cambios, haga clic en Compartir libro.

Imagen de la cinta de Excel

  1. En la ficha Edición, dentro de la lista Los siguientes usuarios tienen abierto este libro, revise los nombres de los usuarios.

  2. Seleccione el nombre del usuario al que desea desconectar y haga clic en Quitar usuario.

Aunque esta acción desconecta al usuario del libro compartido, no impide a dicho usuario modificar de nuevo el libro compartido.

  1. Para eliminar la configuración de vista personal del usuario quitado, haga lo siguiente:

    1. En la pestaña Vista, en el grupo Vistas de libro, haga clic en Vistas personalizadas.
      Imagen de la cinta de Excel

    2. En la lista Vistas, seleccione la vista de otro usuario y haga clic en Eliminar.

Principio de página

Resolver conflictos de cambios en un libro compartido

Cuando dos usuarios modifican el mismo libro compartido y tratan de guardar cambios que afectan a la misma celda se produce un conflicto. Excel sólo puede conservar uno de los cambios realizados en la celda. Cuando el segundo usuario guarda el libro, Excel muestra el cuadro de diálogo Resolución de conflictos.

  1. En el cuadro de diálogo Resolución de conflictos, lea la información acerca de cada cambio y los cambios conflictivos realizados por el otro usuario.

  2. Para mantener uno de sus cambios o el de otro usuario y continuar con el siguiente cambio en conflicto, haga clic en Aceptar los míos o en Aceptar otros.

    Para conservar todos los cambios restantes que ha realizado o todos los de otro usuario, haga clic Aceptar todos los míos o en Aceptar todos los otros.

  3. Para que sus cambios anulen el resto de los cambios sin que se vuelva a mostrar el cuadro de diálogo Resolución de conflictos, haga lo siguiente:

    1. En la pestaña Revisar, en el grupo Cambios, haga clic en Compartir libro.
      Imagen de la cinta de Excel

    2. En la pestaña Avanzadas, debajo de En caso de cambios conflictivos entre usuarios, haga clic en Prevalecen los cambios guardados y, después, haga clic en Aceptar.

  4. Para ver cómo se han solucionado los conflictos anteriores de los usuarios, haga lo siguiente:

    1. En el grupo Cambios de la pestaña Revisar, haga clic en Control de cambios y, a continuación, en Resaltar cambios.

    2. En la lista Cuándo, seleccione Todos.

    3. Desactive las casillas de verificación Quién y Dónde.

    4. Active la casilla de verificación Mostrar cambios en una hoja nueva y haga clic en Aceptar.

    5. En la hoja de cálculo Historial, desplácese hacia la derecha para ver las columnas Tipo de acción y Cambio perdedor.

      Los cambios conflictivos que se han mantenido tienen la palabra Prevalece en Tipo de acción. Los números de fila incluidos en la columna Cambio perdedor identifican las filas con información acerca de los cambios conflictivos que no se mantuvieron, incluidos los datos eliminados.

      Para guardar una copia del libro con todos sus cambios, haga clic en Cancelar en el cuadro de diálogo Resolución de conflictos, haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office , haga clic en Guardar como y, después, escriba un nombre nuevo para el archivo.

Principio de página

Dejar de compartir un libro

Antes de dejar de compartir el libro, asegúrese de que todos los demás usuarios han completado su trabajo. Se perderán todos los cambios no guardados. Puesto que también se eliminará el historial de cambios, puede que desee empezar por imprimir la hoja de cálculo Historial o por copiarla en otro libro.

  1. Para conservar una copia de la información del historial de cambios, haga lo siguiente:

    1. En la pestaña Revisar, en el grupo Cambios, haga clic en Control de cambios y, después, haga clic en Resaltar cambios.
      Imagen de la cinta de Excel

    2. En la lista Cuándo, seleccione Todos.

    3. Desactive las casillas de verificación Quién y Dónde.

    4. Active la casilla de verificación Mostrar cambios en una hoja nueva y haga clic en Aceptar.

    5. Siga uno o ambos de los procedimientos siguientes:

      • Para imprimir la hoja de cálculo Historial, haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y, después, haga clic en Imprimir.

      • Para copiar el historial en otro libro, seleccione las celdas que desea copiar, haga clic en Copiar Imagen del botón en la ficha Inicio, en el grupo Portapapeles; a continuación, pase a otro libro, haga clic en el lugar donde desea colocar los datos copiados y, por último, haga clic en Pegar Imagen del botón en la ficha Inicio, en el grupo Portapapeles.

        Imagen de la cinta de Excel

        Nota: Puede que también desee guardar o imprimir la versión actual del libro, puesto que estos datos de historial tal vez no se apliquen a versiones posteriores del libro. Por ejemplo, las ubicaciones de las celdas, incluidos los números de las filas, del historial copiado podrían dejar de estar actualizadas.

  2. En el libro compartido, en la ficha Revisar, en el grupo Cambios, haga clic en Compartir libro.

  3. En la ficha Edición, asegúrese de que es el único usuario que aparece en la lista Los siguientes usuarios tienen abierto este libro.

    Para quitar usuarios adicionales, vea Quitar un usuario de un libro compartido en este tema.

  4. Desactive la casilla Permitir la modificación por varios usuarios a la vez. Esto también permite combinar libros.

    Nota: Si esta casilla de verificación no está disponible, primero debe desproteger el libro. Para quitar la protección del libro compartido, haga lo siguiente:

    1. Haga clic en Aceptar para cerrar el cuadro de diálogo Compartir libro.

    2. En la pestaña Revisar, en el grupo Cambios, haga clic en Desproteger libro compartido.

    3. Si se le pide, escriba la contraseña y, después, haga clic en Aceptar.

    4. En el grupo Cambios de la pestaña Revisar, haga clic en Compartir libro.

    5. En la ficha Edición, desactive la casilla de verificación Permitir la modificación por varios usuarios a la vez. Esto también permite combinar libros.

  5. Cuando se le pregunte sobre los efectos que esta acción puede tener en los demás usuarios, haga clic en .

Principio de página

¿Le ha sido útil esta información?

¿Cómo podemos mejorarlo?

¿Cómo podemos mejorarlo?

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!