Usar informes para medir el rendimiento y el uso de un sitio

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Si se encarga de administrar un sitio, es probable que se le hagan algunas preguntas comunes sobre el sitio, como:

  • ¿Cuántas personas visitan el sitio?

  • ¿Cómo ha cambiado el tráfico del sitio con el tiempo?

  • ¿Quiénes son los principales usuarios del sitio?

  • ¿De dónde procede el tráfico del sitio?

  • ¿Cuáles son los recursos y las páginas más visitados en el sitio?

  • ¿Cómo se comprueba la ubicación de los documentos y otros recursos en el flujo de trabajo?

Asimismo, como administrador de un sitio, a menudo tendrá preguntas a las que desea obtener una respuesta, como::

  • ¿Hay recursos en el sitio que se pueden quitar porque no se usan o son antiguos?

  • ¿Cómo se detectan los problemas de un sitio (como archivos no vinculados, páginas lentas e hipervínculos rotos) antes de que los detecten y notifiquen los usuarios?

Estas preguntas pueden parecen abrumadoras, pero con Microsoft Office SharePoint Designer 2007 y un sitio de Windows SharePoint Services 3.0 o un sitio de Microsoft Office SharePoint Server 2007, podrá responder fácilmente a estas preguntas mediante los informes de Office SharePoint Designer 2007. En este artículo se muestra cómo usar los informes para medir el rendimiento y el uso de los sitios.

Importante: Los datos para los informes generados por Office SharePoint Designer 2007 se guardan en el servidor donde se aloja el sitio. Los administradores de sitio pueden conceder o denegar el acceso a estos informes. Si los informes solicitados no contienen datos, póngase en contacto con el administrador del servidor. Para ejecutar los informes de uso, deberá tener el permiso Ver datos de uso y el administrador del servidor deberá activar la recopilación de los datos de uso en el servidor. De manera predeterminada, está desactivada la recopilación de los datos de uso en el servidor.

¿Qué desea hacer?

Ver el informe de resumen del sitio

Ver informes acerca de los archivos

Ver informes sobre el contenido compartido

Ver informes sobre problemas

Ver el informe de resumen de uso

Ver informes de uso detallados

Gráfico de los resultados de datos de uso

Ordenar un informe

Filtrar un informe

Copiar un informe

Guardar un informe

Ver el informe Resumen del sitio

El informe Resumen del sitio proporciona información general de alto nivel del sitio, así como vínculos a informes más detallados. Por ejemplo, se puede generar un informe Resumen del sitio como el que se muestra en la siguiente ilustración.

Informe Resumen del sitio

Para generar un informe Resumen del sitio:

  1. Abra el sitio para el que desee ejecutar el informe en Office SharePoint Designer 2007.

  2. En el menú Sitio, elija Informes y, a continuación, haga clic en Resumen del sitio.

    Se generará el informe.

Nota: Puede hacer clic en los hipervínculos de la columna Nombre para ir a informes más detallados. Por ejemplo, haga clic en Hipervínculos rotos para ir directamente al informe Hipervínculos rotos.

Volver al principio

Ver informes sobre los archivos

Puede generar informes que muestren todos los archivos, archivos agregados recientemente, archivos modificados recientemente o archivos antiguos. Por ejemplo, si desea resaltar el contenido nuevo en la página principal de un sitio o en un boletín que promocione el sitio, puede usar el informe Archivos agregados recientemente para identificar rápidamente el nuevo contenido. Asimismo, puede usar el informe Archivos antiguos para identificar el contenido antiguo susceptible de ser actualizado o quitado.

Para ejecutar informes sobre los archivos, especifique primero las definiciones de los archivos recientes y antiguos, y especifique el número de meses que deben mostrarse en los informes por mes:

  1. Abra el sitio Web para el que desee ejecutar el informe en Office SharePoint Designer 2007.

  2. En el menú Herramientas, haga clic en Opciones de la aplicación.

  3. Haga clic en la ficha Vista Informes.

    Cuadro de diálogo Opciones de la aplicación con la ficha Vista Informes

  4. En el cuadro Los archivos "recientes" tienen menos de, especifique el número de días que identifiquen una página reciente.

  5. En el cuadro Los archivos "antiguos" tienen más de, especifique el número de días que identifiquen una página antigua.

  6. En el cuadro Número de meses mostrados, especifique el número de meses que deben mostrarse en los informes por mes.

  7. Haga clic en Aceptar.

    Ahora puede ejecutar los informes.

  8. En el menú Sitio, elija Informes, elija Archivos y, a continuación, haga clic en el informe que desee ejecutar.

    • Todos los archivos     Muestra una lista de todos los archivos del sitio.

    • Archivos agregados recientemente     Muestra una lista de los archivos agregados al sitio dentro del número de días especificado en el paso 4.

    • Archivos modificados recientemente     Muestra una lista de los archivos modificados en el sitio dentro del número de días especificado en el paso 4.

    • Archivos antiguos     Muestra una lista de los archivos que se consideran "antiguos" según el número de días especificado en el paso 5.

    • Estado de desprotección     Muestra una lista de los archivos del sitio junto con el actual Estado de desprotección de cada archivo. (Este informe incluye asimismo las columnas Desprotegido por, Versión y Fecha de bloqueo.)

      En el caso de los informes sobre archivos, en la vista Informes, puede hacer clic en las opciones de la lista para cambiar rápidamente la configuración de los archivos antiguos o recientes.

      Vista Informes con menú de filtro por antigüedad de archivo

Volver al principio

Ver informes sobre el contenido compartido

El contenido compartido puede incluir páginas maestras, páginas personalizadas y otras páginas especificadas en la definición de sitio, así como vínculos a hojas de estilos. Office SharePoint Designer 2007 permite buscar con facilidad el contenido compartido. Por ejemplo, si desea cambiar un logotipo en todas las páginas de un sitio Web y usa páginas maestras para controlar el formato de las páginas, podrá usar el informe Páginas maestras para buscar todas las páginas maestras en las que deba cambiar el logotipo. También podrá usar el informe Vínculos de hoja de estilos para buscar todas las hojas de estilos que deba actualizar para reflejar un cambio de fuente o formato que desee aplicar a todo el sitio.

  1. Abra el sitio Web para el que desee ejecutar el informe en Office SharePoint Designer 2007.

  2. En el menú Sitio, elija Informes, elija Contenido compartido y, a continuación, haga clic en el informe que desee ejecutar.

    • Plantillas Web dinámicas     Muestra una lista de todas las páginas del sitio, en la que la columna Plantilla Web dinámica indica si cada página está asociada a una plantilla Web dinámica (y si es así, indica cuál es).

    • Páginas maestras     Muestra una lista de todas las páginas del sitio, en la que la columna Página maestra indica si cada página está asociada a una página maestra (y si es así, indica cuál es).

    • Páginas personalizadas     Muestra una lista de todas las páginas del sitio, en la que la columna Personalizado indica si las páginas basadas en la definición de sitio han sido personalizadas.

    • Vínculos de hoja de estilos     Muestra una lista de todas las páginas del sitio, en la que la columna Vínculos de hoja de estilos indica si cada página está asociada a una hoja de estilos.

      Nota: Los vínculos de hoja de estilos son vínculos estáticos (etiquetas <link>). Este informe no incluye vínculos de hoja de estilos dinámicos generados por los controles de Microsoft ASP.NET (como <SharePoint:CssLink>).

Volver al principio

Ver informes sobre los problemas

Los informes de Office SharePoint Designer 2007 sobre los problemas pueden ayudar a anticipar posibles problemas y resolverlos antes de que se vean afectados los usuarios. Por ejemplo, podrá usar estos informes para identificar páginas lentas, hipervínculos rotos y archivos susceptibles de ser eliminados porque no están vinculados a otros archivos. Para ejecutar los informes Problemas, configure primero la definición de páginas lentas.

  1. Abra el sitio Web para el que desee ejecutar el informe en Office SharePoint Designer 2007.

  2. En el menú Herramientas, haga clic en Opciones de la aplicación.

  3. Haga clic en la ficha Vista Informes.

    Cuadro de diálogo Opciones de la aplicación con la ficha Vista Informes

  4. En el cuadro Las "páginas lentas" tardan al menos, especifique el número de segundos que definen cuánto tiempo se tarda en descargar una página lenta.

  5. En el cuadro Asumir una velocidad de conexión de, especifique el número de kilobits por segundo (Kbps) de la velocidad de conexión media del usuario.

  6. Haga clic en Aceptar.

    Ahora puede ejecutar los informes.

  7. Haga clic en Sitio, elija Informes, elija Problemas y, a continuación, haga clic en el informe que desee ejecutar.

    • Archivos no vinculados     Muestra una lista de todos los archivos del sitio a los que no hay ningún vínculo. Esta lista puede ayudar a buscar los archivos no utilizados que deban quitarse del sitio. Observe que este informe no tiene en cuenta los vínculos generados por los controles ASP.NET, como el elemento Web Tabla de contenido en los sitios de Office SharePoint Server 2007.

    • Páginas lentas     Muestra una lista de las páginas del sitio identificadas como lentas al cargar según la definición especificada en el paso 3 y la velocidad de conexión media especificada en el paso 4. Observe que este informe refleja el tiempo necesario para cargar el marcado de las páginas. No tiene en cuenta el contenido dinámico generado por los controles ASP.NET.

    • Hipervínculos     Muestra una lista de todos los hipervínculos del sitio. Después de ejecutarse este informe, aparece un cuadro de diálogo en el que se pregunta si desea comprobar los hipervínculos del sitio. Haga clic en si desea que Office SharePoint Designer 2007 compruebe cada uno de los hipervínculos. El resultado de este proceso es una lista de hipervínculos en la que se indica junto a cada hipervínculo Correcto o Roto. Para modificar un vínculo roto, haga clic en el vínculo en el informe y, a continuación, haga clic en Editar hipervínculo en la barra de herramientas que aparece en la esquina superior derecha de la ventana de documento en la vista Informes.

      Nota:  Cuadro de diálogo Editar hipervínculo

    • Errores del componente     Muestra una lista de todos los componentes, como botones interactivos o el contador de visitas a la página (anteriormente se conocían por la denominación genérica Webbots o bots), que están generando errores. Para ver una lista de los componentes Web, haga clic en Componente Web en el menú Insertar.

Volver al principio

Ver el informe Resumen de uso

Los informes de uso del sitio ayudan a responder a algunas de las preguntas más urgentes que tienen los propietarios acerca de su sitio, como cuántas personas están usando el sitio, cuáles son los recursos más usados, quién usa más el sitio y desde dónde los usuarios visitan el sitio. El informe Resumen de uso incluye un resumen del número total de visitas, las visitas a las páginas, los bytes descargados, etc.

Informe Resumen de uso

Siga estos procedimientos para ejecutar el informe Resumen de uso:

  1. Abra el sitio Web para el que desee ejecutar el informe en Office SharePoint Designer 2007.

  2. En el menú Sitio, elija Informes, elija Uso y, a continuación, haga clic en Resumen de uso.

    Se generará el informe. Podrá hacer clic en cualquiera de los elementos con hipervínculo de la columna Nombre para ver los informes detallados.

Volver al principio

Ver informes de uso detallados

Puede ejecutar los informes de uso detallados para obtener una respuesta a sus preguntas sobre cómo los usuarios obtienen acceso al sitio. Por ejemplo, si bien el informe Resumen de uso generado en la anterior sección muestra el número total de visitas a las páginas, en el informe Visitas mensuales a la página se muestra información detallada sobre el número de visitas a cada una de las páginas del sitio. A continuación se describen los pasos que hay que dar para ejecutar los informes de uso detallados:

  1. Abra el sitio Web para el que desee ejecutar el informe en Office SharePoint Designer 2007.

  2. En el menú Sitio, elija Informes, elija Uso y, a continuación, haga clic en el informe que desee ejecutar.

    • Resumen mensual     Incluye un resumen del número de visitas únicas, visitas, total de visitas y tamaño de la descarga del sitio por mes.

    • Resumen semanal     Incluye un resumen del número de visitas únicas, visitas, total de visitas y tamaño de la descarga del sitio por semana.

    • Resumen diario     Incluye un resumen del número de visitas únicas, visitas, total de visitas y tamaño de la descarga del sitio por día.

    • Visitas mensuales a la página     Incluye un resumen del número total de visitas y del número de visitas por mes de cada página del sitio Web.

    • Visitas semanales a la página     Incluye un resumen del número total de visitas y del número de visitas por semana de cada página del sitio Web.

    • Visitas diarias a la página     Incluye un resumen del número total de visitas y del número de visitas por día de cada página del sitio Web.

    • Usuarios visitantes     Incluye un resumen del número de usuarios visitantes y su porcentaje del total para el mes seleccionado.

    • Sistemas operativos     Incluye un resumen del número de sistemas operativos de los usuarios visitantes y su porcentaje del total para el mes seleccionado.

    • Exploradores     Incluye un resumen del número de exploradores de los usuarios visitantes y su porcentaje del total para el mes seleccionado.

    • Dominios de referencia     Incluye un resumen del número de visitas que proceden de un dominio determinado así como su porcentaje del total para el mes seleccionado.

    • URL de referencia     Incluye un resumen del número de visitas que proceden de una dirección URL determinada así como su porcentaje del total para el mes seleccionado.

    • Cadenas de búsqueda     Muestra el número de cadenas de búsqueda escritas en el cuadro de búsqueda del sitio así como su porcentaje del total para el mes seleccionado.

Volver al principio

Representar gráficamente los resultados de los datos de uso

Podrá crear fácilmente un gráfico para representar gráficamente los datos de uso, de modo que le resulte más fácil detectar determinadas tendencias e identificar los modelos de uso.

  1. En el menú Sitio, elija Informes, elija Uso y, a continuación, haga clic en el informe que desee ejecutar.

  2. En la barra de herramientas situada en la esquina superior derecha de la ventana de documento, en la lista Gráfico, haga clic en el tipo de gráfico que desee crear, como un Gráfico de columnas.

    Barra de herramientas en la vista Informes con la lista de gráficos

    El informe se abrirá en una nueva ventana.

    Gráfico de los datos de uso

    Nota: De manera predeterminada, los datos del gráfico se generan junto con los informes de uso. Si no encuentra los datos del gráfico cuando intente ejecutar el informe, en el menú Herramientas, haga clic en Opciones de la aplicación, haga clic en la ficha Vista Informes y, a continuación, asegúrese de que esté activada la casilla de verificación Incluir gráfico cuando se guarde el informe de uso.

Volver al principio

Ordenar un informe

En la vista Informes, podrá ordenar un informe haciendo clic en los encabezados de columna.

Volver al principio

Filtrar un informe

Podrá restringir los resultados de un informe para ver sólo la información que desee. Podrá filtrar por una sola columna o filtrar por varias columnas para crear un filtro progresivo.

  1. En el menú Sitio, elija Informes y, a continuación, haga clic en el informe que desee ejecutar.

  2. Haga clic en la flecha situada junto al encabezado de la columna por la que desee filtrar y, a continuación, haga clic en los datos por los que desee filtrar.

    Por ejemplo, si desea filtrar por tipo de archivo, haga clic en la flecha situada junto al encabezado de columna Tipo y, a continuación, haga clic en bmp para que se muestren en el informe únicamente los archivos de mapa de bits.

    Columna Tipo con menú de filtro

  3. Si desea filtrar por varias columnas, repita el paso 2 para cada columna.

  4. Para crear un filtro personalizado en una columna, haga clic en la flecha situada junto al encabezado de columna y, a continuación, haga clic en (Personalizado). Especifique los criterios de búsqueda y, a continuación, haga clic en Aceptar.

    Por ejemplo, podrá usar un autofiltro personalizado para identificar todos los archivos de imagen .bmp y .gif del sitio.

    Cuadro de diálogo Personalizar autofiltro

  5. Para borrar un filtro de una columna, haga clic en la flecha situada junto al encabezado de esa columna y, a continuación, haga clic en (Todos).

Nota: La configuración de filtro aplicada se guarda cuando se cierra el sitio. Si no encuentra archivos en un informe recién ejecutado, puede que los filtros aplicados en una sesión anterior oculten esos archivos.

Para quitar todos los filtros de un informe, haga clic con el botón secundario del mouse (ratón) en cualquier encabezado de columna y, a continuación, haga clic en Quitar filtros en el menú contextual.

Volver al principio

Copiar un informe

Tras ejecutar un informe, quizás desee copiar y pegar los resultados en un mensaje de correo electrónico o en otro documento (por ejemplo, una hoja de cálculo de Microsoft Office Excel). Se puede copiar cualquier informe, salvo el informe Resumen del sitio.

  1. Haga clic con el botón secundario del mouse en cualquier encabezado de columna del informe ejecutado y, a continuación, haga clic en Copiar informe en el menú contextual.

    Menú de la columna Nombre con el comando Copiar informe seleccionado

  2. Pegue los datos en el documento o mensaje.

Volver al principio

Guardar un informe

Podrá guardar los informes si desea usar Microsoft Office Excel 2007 para ver y analizar los resultados o para crear gráficos personalizados a partir de los resultados.

  1. En el menú Sitio, elija Informes y, a continuación, haga clic en el informe que desee ejecutar.

  2. En el menú Archivo, haga clic en Guardar o presione CTRL+G.

  3. En el cuadro Nombre de archivo, escriba un nombre para el informe y, a continuación, haga clic en Guardar. El informe se guardará como un archivo .htm en el sitio.

    Informe abierto en Excel

  4. Para abrir el informe, haga doble clic en él.

    El informe se abrirá en Office Excel 2007.

Volver al principio

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×