Usar funciones anidadas en una fórmula

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Usar una función como uno de los argumentos en una fórmula de que usa una función se denomina anidamiento, y nos referiremos a esta función como una función anidada. Por ejemplo, si se anidan las funciones PROMEDIO y SUMA en los argumentos de la función SI, la siguiente fórmula suma un conjunto de números (G2:G5) solo si el promedio de otro conjunto de números (F2:F5) es mayor que 50. De lo contrario, devuelve 0.

Funciones anidadas

Las funciones promedio y suma están anidadas dentro de la función si.

Puede anidar hasta 64 niveles de funciones en una fórmula.

  1. Haga clic en la celda en la que desea escribir la fórmula.

  2. Para iniciar la fórmula con la función, haga clic en Insertar función Imagen del botón en la barra de fórmulas Imagen del botón .

    Excel se encarga de insertar el signo igual (=).

  3. En el cuadro O seleccionar una categoría, seleccione Todo.

    Si está familiarizado con las categorías de la función, también puede seleccionar una categoría.

    Si no está seguro de qué función usar, puede escribir una pregunta que describa lo que desea hacer en el cuadro Buscar una función (por ejemplo, "sumar números" devuelve la función SUMA).

  4. Para escribir otra función como argumento, escriba la función en el cuadro de argumento que desee.

    Las partes de la fórmula mostradas en el cuadro de diálogo Argumentos de función reflejan la función seleccionada en el paso anterior.

    Si hace clic en SI, en el cuadro de diálogo Argumentos de función se muestran los argumentos de la función SI. Para anidar otra función, se puede escribirla en el cuadro del argumento. Por ejemplo, se puede escribir SUMA(G2:G5) en el cuadro Valor_si_verdadero de la función SI.

  5. Escriba todos los argumentos adicionales necesarios para completar la fórmula..

    En lugar de escribir referencias de celda, también puede seleccionar las celdas a las que desea hacer referencia. Haga clic en Imagen del botón para minimizar el cuadro de diálogo, seleccione las celdas a las que desea hacer referencia y después haga clic en Imagen del botón para expandir el cuadro de diálogo de nuevo.

    Sugerencia: Para más información sobre la función y sus argumentos, haga clic en Ayuda sobre esta función.

  6. Tras completar los argumentos de la fórmula, haga clic en Aceptar.

  1. Haga clic en la celda en la que desea escribir la fórmula.

  2. Para iniciar la fórmula con la función, haga clic en Insertar función Imagen del botón en la barra de fórmulas Imagen del botón .

  3. En el cuadro de diálogo Insertar función, en el cuadro Elija una categoría, seleccione todo.

    Si está familiarizado con las categorías de la función, también puede seleccionar una categoría.

  4. Para escribir otra función como argumento, introduzca la función en el cuadro de argumento en el generador de fórmulas o directamente en la celda.

  5. Escriba todos los argumentos adicionales necesarios para completar la fórmula..

  6. Después de completar los argumentos de la fórmula, presione ENTRAR.

Ejemplos

A continuación, le mostramos un ejemplo del uso de las funciones SI anidadas para asignar una letra de calificación a la puntuación numérica de una prueba.

Copie los datos de ejemplo en la tabla siguiente y péguelos en la celda A1 de una hoja de cálculo nueva de Excel. Para que las fórmulas muestren los resultados, selecciónelas, presione F2 y luego ENTRAR. Si lo necesita, puede ajustar el ancho de las columnas para ver todos los datos.

Puntuación

45

90

78

Fórmula

Descripción

Resultado

'=SI(A2>89,"A",SI(A2>79,"B", SI(A2>69,"C",SI(A2>59,"D","F"))))

Usa condiciones SI anidadas para asignar una letra de calificación a la puntuación de la celda A2.

=SI(A2>89,"A",SI(A2>79,"B",SI(A2>69,"C",SI(A2>59,"D","F"))))

'=SI(A3>89,"A",SI(A3>79,"B", SI(A3>69,"C",SI(A3>59,"D","F"))))

Usa condiciones SI anidadas para asignar una letra de calificación a la puntuación de la celda A3.

=SI(A3>89,"A",SI(A3>79,"B",SI(A3>69,"C",SI(A3>59,"D","F"))))

'=SI(A4>89,"A",SI(A4>79,"B", SI(A4>69,"C",SI(A4>59,"D","F"))))

Usa condiciones SI anidadas para asignar una letra de calificación a la puntuación de la celda A4.

=SI(A4>89,"A",SI(A4>79,"B",SI(A4>69,"C",SI(A4>59,"D","F"))))

Sugerencias: 

¿Necesita más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Vea también

Vídeo: Funciones si anidadas

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×