Usar el argumento table_array en una función de búsqueda

Nota:  Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Cuando se crea una fórmula que usa las funciones BUSCARV o BUSCARH , escriba un argumento matriz_buscar_en, que es un rango de celdas, como D2:F39. La función busca ese rango de los datos que está tratando de encontrar.

El argumento table_array siempre es el segundo argumento en una función BUSCARV o BUSCARH (el primero es el valor que está tratando de encontrar), y las funciones no funcionan sin él.

El primer argumento puede ser un valor específico como " 41" o "smith," o puede ser una referencia de celda, como F2. El primer argumento tendría el siguiente aspecto:

=BUSCARV(F2,...

El argumento table_array siempre sigue al valor de búsqueda, como se muestra:

=BUSCARV(F2,B4:D39, ...

El rango de celda mostrado en el argumento table_array puede usar referencias de celda relativas o absolutas. Si va a copiar su fórmula a otras celdas, tiene que usar referencias de celda absolutas (observe el signos $), como se muestra aquí:

=BUSCARV(F2,$B$2:BD$39, ...

Si las celdas del argumento table_array están en otra hoja de cálculo en su libro, el argumento debe incluir el nombre de la hoja seguido de un signo de exclamación. La fórmula tendría el siguiente aspecto:

=BUSCARV(F2,Sheet2!$C$14:E$42, ...

La columna que tiene los valores que está tratando de encontrar es el tercer argumento que se introduce. Esto se denomina la columna de búsqueda. Si los valores que desea ver están en la columna D (la tercera columna de table_array), el último argumento es un 3.

=BUSCARV(F2,B4:D39,3)

A pesar de que es opcional, se recomienda que use un cuarto argumento, Falso o Verdadero. Use Falso si busca una coincidencia exacta.

=BUSCARV("F2"; B4:D39; 3; FALSO)

Si usa Verdadero o deja el cuarto argumento en blanco, la función devuelve una coincidencia aproximada con el valor del primer argumento. Por tanto, para continuar el ejemplo, si el primer argumento es "smith" y usa Verdadero, la función devolverá "Smith," "Smithberg," etc. Sin embargo, si usa Falso, la función solo devuelve "Smith," una coincidencia exacta, y eso es lo que la mayoría de los usuarios desean.

El uso de Verdadero es incluso más delicado, ya que, si su columna de búsqueda —la columna que especifica en el tercer argumento— no está ordenada en orden ascendente (de la A a la Z o de menor a mayor), la función puede devolver un resultado incorrecto.

Para obtener más información sobre las funciones BUSCARV y BUSCARH, vea funciones de búsqueda y referencia (referencia).

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×