Usar consultas para eliminar uno o varios registros de una base de datos

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

En este artículo se explica cómo eliminar datos de una base de datos Microsoft Office Access 2007 mediante la actualización y las consultas de eliminación. Usar una consulta de actualización para eliminar campos individuales de los registros de una base de datos y usar una consulta de eliminación cuando tenga que quitar registros completos de una base de datos, incluidos el valor de clave que hace que el registro sea único. Durante el proceso, recuerde que Access también proporciona varias maneras de eliminar parte de un registro o manualmente.

Para obtener más información sobre cómo eliminar registros manualmente, vea el artículo eliminar uno o varios registros de una base de datos.

En este artículo

Usar las consultas para eliminar datos

Planear la eliminación

Evitar que el modo deshabilitado bloquee una consulta

Eliminar registros parciales (campos de uno o más)

Eliminar registros completos

Criterios de ejemplo para consultas de selección

Usar las consultas para eliminar datos

Puede usar dos tipos de consultas para eliminar datos de una base de datos de Access. La consulta que usa depende del tipo de eliminación que tenga que realizar.

  • Cuando necesite eliminar campos individuales de los registros de una o más tablas, use una consulta de actualización que cambie los valores existentes a un valor nulo (es decir, sin datos) o una cadena de longitud cero (un par de comillas dobles sin espacio entre ellas).

    Usar una consulta de actualización para eliminar datos de campos individuales porque, de forma predeterminada, las consultas de eliminación solo quitan todo filas. El proceso de usar una consulta de actualización para "Borrar" datos sigue estos pasos generales: crear una consulta de selección y asegúrese de que devuelva solamente los datos que desea eliminar. Convertir la consulta a una consulta de actualización con NULL o una cadena de longitud cero como valor de actualización y, a continuación, ejecute la consulta para actualizar los datos existentes.

  • Cuando necesite quitar registros enteros (filas), utilice una consulta de eliminación.

    De forma predeterminada, las consultas de eliminación quitan todos los datos de cada campo, junto con el valor de clave que hace que un registro único. Cuando se ejecuta la consulta, siempre se quita toda la fila de la tabla. El proceso sigue estos pasos generales: crear una consulta de selección, asegúrese de que devuelve los registros que desea eliminar y, a continuación, convertir la consulta en una consulta de eliminación y ejecutarla para eliminar los datos.

Durante el proceso, recuerde que si los registros que desea eliminar residen en el lado "uno" de una relación uno a varios, va a cambiar primero una propiedad de la relación antes de ejecutar la consulta. Preparativos para eliminar datos relacionados, más adelante en este artículo se explica cómo llevar a cabo esta tarea. Debe realizar los cambios adicionales porque de forma predeterminada, Access impide eliminar datos del lado "uno" de una relación uno a varios.

Si necesita más información acerca de las relaciones uno a varios, vea los artículos conceptos básicos del diseño de base de datos y crear, modificar o eliminar una relación.

Además, recuerde que después de actualizar o eliminar un registro o una parte, no se puede deshacer los cambios, por lo que debe siempre una copia de los datos antes de ejecutar una consulta de eliminación. Vea realizar copias de seguridad de la base de datos, más adelante en este artículo para obtener más información.

Los procedimientos en las siguientes secciones explica cómo crear consultas de actualización que quite datos de campos individuales, y cómo crear eliminar consultas que quiten registros completos.

Nota: Normalmente, use actualizar y eliminar consultas únicamente cuando necesite cambiar o quitar grandes cantidades de datos rápidamente. Si desea quitar un pequeño número de registros, cualquier cantidad que sea fácil de eliminar manualmente, puede abrir la tabla en la vista Hoja de datos, seleccione los campos o filas que desea eliminar y presione SUPRIMIR.

Para obtener más información sobre otras formas de eliminar datos, vea el artículo eliminar uno o varios registros de una base de datos.

Principio de página

Planear la eliminación

El proceso de usar una consulta para eliminar registros sigue estos pasos generales:

  • Planear la eliminación. Asegúrese de que tiene los permisos necesarios para eliminar los datos, asegúrese de que todos los demás usuarios han cerrado todos los objetos que usen las tablas afectadas y, a continuación, realizar una copia de la base de datos.

  • Asegúrese de que la base de datos se encuentra en una ubicación de confianza o que está firmado digitalmente. Si aplica ninguna de estas condiciones, puede confiar en la base de datos para la sesión actual. Recuerde que, de forma predeterminada, Access bloquea todas las consultas de acción (consultas de eliminación, actualización y creación de tabla) a menos que confíe en primer lugar la base de datos. Para obtener información sobre cómo confiar en una base de datos, consulte Detener el modo deshabilitado bloquee una consulta, más adelante en este artículo.

  • Si desea eliminar datos de más de una tabla y esas tablas están relacionadas, habilite las opciones Integridad referencial y Eliminar en cascada los registros relacionados para cada relación. Esto permite la consulta eliminar datos de las tablas de los lados "uno" y "varios" de la relación.

  • Crear una consulta de selección y, a continuación, agregue criterios según sea necesario hasta que la consulta devuelve el conjunto de registros correcto.

  • Si desea eliminar campos individuales de una tabla, convertir la consulta de selección en una consulta de actualización, especifique NULL o una cadena de longitud cero ("") como criterios de actualización y ejecutar la consulta.

  • Si desea eliminar registros completos, convertir la consulta de selección en una consulta de eliminación y, a continuación, ejecute la consulta.

Preparativos generales

Antes de eliminar registros completos o parciales de una base de datos, realice las siguientes tareas:

  • Asegúrese de que la base de datos no es de solo lectura. Para ello, en el Explorador de Windows, haga clic en el archivo de base de datos (archivo .accdb o .mdb) y, a continuación, haga clic en Propiedades en el menú contextual. En el cuadro de diálogo Propiedades, asegúrese de que el de sólo lectura está desactivada.

  • Compruebe que dispone de los permisos necesarios para eliminar registros de la base de datos. Si no está seguro, póngase en contacto con el administrador del sistema o el diseñador de la base de datos.

  • Póngase en contacto con otros usuarios de la base de datos para asegurarse de que la eliminación no les afectará negativo.

  • Pida a los usuarios de la base de datos para cerrar todas las tablas, formularios, consultas e informes que usan los datos que desea eliminar. Esto ayuda a evitar violaciones de bloqueo.

    Sugerencia: Si un gran número de usuarios que se conecta a la base de datos, debe cerrar la base de datos y, a continuación, vuelva a abrir en modo exclusivo. Siga este procedimiento:

    1. Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y, después, haga clic en Abrir.

    2. Busque y seleccione la base de datos, haga clic en la flecha situada junto al botón Abrir y, a continuación, haga clic en Abrir en modo exclusivo.

      Abrir un archivo en modo exclusivo

  • Realizar una copia de la base de datos antes de modificar o eliminar registros. Algunas operaciones de eliminación se pueden invertir, pero realizar una copia de seguridad garantiza que puede invertir siempre los cambios.

    Realizar copias de seguridad de la base de datos

    1. Haga clic en el Microsoft Office Imagen del botón de Microsoft Office, seleccione Administrar, y a continuación, en Administrar esta base de datos, haga clic en Copia de seguridad de base de datos.

    2. En el cuadro de diálogo Guardar como, especifique un nombre y una ubicación para la copia de seguridad y, a continuación, haga clic en Guardar.

      Access cierra el archivo original, crea una copia de seguridad y, a continuación, vuelve a abrir el archivo original.

      Para revertir a una copia de seguridad, cierre el archivo original y cambie su nombre, de modo que se pueda usar el nombre de la versión original para la copia de seguridad. Asigne el nombre de la versión original a la copia de seguridad y, después, ábrala con el nombre cambiado en Access.

Preparativos para eliminar datos relacionados

Si necesita eliminar datos en tablas relacionadas, recuerde esta regla: si los datos residen en el lado "varios" de una relación uno a varios, puede eliminar los datos sin tener que alterar la relación. Sin embargo, si los datos residen en el lado "uno" de una relación uno a varios, primero debe alterar la relación o Access bloquea la eliminación.

El proceso de eliminación de datos relacionados sigue estos pasos generales:

  • Averigüe qué registros residen en el lado "uno" de la relación y cuáles residen en el lado "varios".

  • Si necesita eliminar registros del lado "uno" de la relación y los registros relacionados del lado "varios", será necesario habilitar un conjunto de reglas denominado Integridad referencial y, también, la eliminación en cascada. En esta sección se explica la integridad referencial y se indica cómo llevar a cabo ambas tareas.

  • Si necesita eliminar registros únicamente del lado "uno" de la relación, elimine primero esa relación y, después, los datos.

    O

    Si necesita eliminar datos únicamente del lado "varios" de la relación, puede crear y ejecutar una consulta de eliminación sin tener que alterar la relación.

En las siguientes secciones se explica cómo preparar los datos relacionados para la eliminación.

Determinar qué registros residen en los lados "uno" y "varios" de una relación

  1. En el grupo Mostrar u ocultar de la ficha Herramientas de base de datos, haga clic en Relaciones.

    La ficha relaciones aparece y muestra todas las tablas en la base de datos así como las relaciones entre cada tabla y todas las demás tablas. Cada relación aparece como una línea que conecta las tablas entre los campos.

    En la siguiente ilustración se muestra una relación típica. La mayoría de las relaciones de una base de datos, si no todas, tienen un lado "uno" y un lado "varios". En el diagrama de relaciones se indica el lado "uno" con el número 1 y el lado "varios" con el símbolo del infinito ().

    Relación entre dos tablas

    Una regla, al eliminar registros en el lado "uno" de la relación, también elimina todos los registros relacionados del lado "varios" de la relación. Sin embargo, cuando se eliminan registros del lado "varios" de una relación, normalmente no se eliminan registros del lado "uno".

    Además, de forma predeterminada, Access aplica un conjunto de reglas denominado integridad referencial. Estas reglas garantizan que las claves externas en una base de datos contienen los valores correctos. Una clave externa es una columna cuyos valores coinciden con los valores de la columna de clave principal de otra tabla.

    Obtenga más información sobre las reglas de la integridad referencial

    • Regla 1: No se puede especificar un valor en el campo de clave externa de una tabla relacionada, a menos que ya existe ese valor en la clave principal de la tabla principal. Sin embargo, puede escribir un valor nulo en el campo de clave externa.

    • Regla 2: No se puede eliminar todo el registro de una tabla principal si existen registros coincidentes en una tabla relacionada.

      Recuerde que puede evitar esta regla si habilita una propiedad en la relación entre las tablas primaria y secundarias. Para obtener más información acerca de cómo hacerlo, vea el siguiente procedimiento, modificar la relación.

    • Regla 3: No se puede cambiar un valor de clave principal de la tabla principal si ese registro tiene registros relacionados.

      Sin embargo, también puede trabajar alrededor de esta regla si habilita una propiedad en la relación entre las tablas primaria y secundarias.

      A menos que se indique lo contrario, Access aplica estas reglas cada vez que agregar, modificar o eliminar datos en la base de datos. Cuando una acción infringe una regla, Access muestra un mensaje, como se muestra en la siguiente ilustración y cancela la acción.

      Mensaje: El registro no se puede eliminar o cambiar

    Durante el proceso, recuerde que, si bien Access habilita la integridad referencial de forma predeterminada en la mayoría de los casos, una base de datos en primer lugar debe cumplir las siguientes condiciones:

    • El campo coincidente de la tabla principal debe ser una clave principal o tener un índice único.

    • Los campos relacionados en la tabla principal y relacionado deben ambos tener los mismos datos tipo.

      Nota: Access proporciona dos excepciones a esta regla. Un campo Autonumeración puede deberse a un campo numérico si ese campo número tiene un valor de la propiedad tamaño del campo de Tipo entero largo. Además, un campo Autonumeración que tiene un valor de la propiedad tamaño del campo Id. de Réplica puede deberse a un campo numérico que tiene un valor de la propiedad tamaño del campo Id. de Réplica.

    • Ambas tablas deben pertenecer a la misma base de datos de Access.

      Nota: Si las tablas están vinculadas, deben estar en formato de Access. Además, debe abrir la base de datos que contiene las tablas vinculadas y, a continuación, habilite la integridad referencial. No se puede aplicar las reglas de la integridad referencial para tablas vinculadas de bases de datos en otros formatos, como libros Microsoft Office Excel 2007. Para obtener información acerca de cómo habilitar la integridad referencial, consulte los pasos de la siguiente sección.

  2. Nota los nombres de los campos de tabla en cada lado de la relación.

  3. Abra cada tabla y revise los datos de cada campo para comprobar que los campos contienen los datos que desea eliminar.

  4. Mantenga abierto el panel relaciones y continúe con los pasos de la siguiente sección.

Modificar la relación

Siga estos pasos únicamente cuando necesite eliminar datos del lado "uno" y del lado "varios" de una relación.

  1. Si aún no lo ha hecho, abra el panel Relaciones.

    En el grupo Mostrar u ocultar de la ficha Herramientas de base de datos, haga clic en Relaciones.

  2. Haga clic con el botón secundario en la relación (línea) que conecta las tablas implicadas en la acción de eliminación y, después, haga clic en Modificar relación en el menú contextual.

    Aparece el cuadro de diálogo Modificar relaciones.

  3. Asegúrese de que está seleccionada la casilla de verificación Exigir integridad referencial.

  4. Active la casilla Eliminar en cascada los registros relacionados.

    Nota: Hasta que vuelva a deshabilitar esta propiedad, cuando se elimine un registro del lado "uno" de la relación, se eliminarán todos los registros relacionados del lado "varios" de la relación.

  5. Haga clic en Aceptar, cierre el panel Relaciones y continúe con los siguientes pasos.

Eliminar una relación

  1. Si aún no lo ha hecho, abra el panel Relaciones.

    En el grupo Mostrar u ocultar de la ficha Herramientas de base de datos, haga clic en Relaciones.

  2. Observe los campos implicados en la relación de modo que podrá restaurar la relación después de eliminar los datos.

  3. Haga clic con el botón secundario en la relación (línea) que conecta las tablas implicadas en la acción de eliminación y, después, haga clic en Eliminar en el menú contextual.

    O

    Seleccione la relación y presione SUPRIMIR.

Nota: Para restaurar la relación, siga los pasos anteriores para abrir el panel Relaciones y, luego, arrastre el campo de clave principal de la tabla del lado "uno" para colocarlo en el campo de clave externa de la tabla del lado "varios". Se abrirá el cuadro de diálogo Modificar relación. Si la relación antigua exigía integridad referencial, seleccione Exigir integridad referencial y haga clic en Crear. Si no, haga clic sencillamente en Crear.

Principio de página

Evitar que el modo deshabilitado bloquee una consulta

De forma predeterminada, Access impide que se ejecute ninguna consulta de acción si abre una base de datos que no sea de confianza o no resida en una ubicación de confianza.

Si intenta ejecutar una consulta de acción y parece que no sucede nada, compruebe si en la barra de estado de Access aparece el siguiente mensaje:

El modo deshabilitado ha bloqueado la acción o el evento

Si ve este mensaje, siga los pasos siguientes:

Habilitar contenido bloqueado

  • En la barra de mensajes, haga clic en Opciones.

    Aparecerá el cuadro de diálogo Opciones de seguridad de Microsoft Office.

  • Haga clic en Habilitar este contenido y, a continuación, en Aceptar.

  • Ejecute la consulta otra vez.

Si no ve la barra de mensajes

  • Haga clic en la ficha Herramientas de base de datos y, en el grupo Mostrar u ocultar, haga clic en Barra de mensajes.

Para obtener más información sobre el modo deshabilitado y la seguridad de Access, vea el artículo proteger una base de datos de Access 2007.

Eliminar registros parciales (campos de uno o más)

En esta sección se explica cómo usar una consulta de actualización para eliminar registros parciales (campos individuales) de tablas en el lado "varios" de una relación uno a varios. También puede seguir estos pasos para eliminar datos de las tablas que no están relacionadas con otros datos. Recuerde que ejecuta una consulta de actualización para eliminar datos cambia los valores existentes en NULL o una cadena de longitud cero (un par de comillas dobles sin espacio entre), según los criterios que especifique. Para obtener más información sobre cómo usar las consultas de actualización, vea el artículo crear una consulta de actualización.

Crear una consulta de selección

  1. En el grupo Otros de la pestaña Crear, haga clic en Diseño de consulta.

    Se abre el Diseñador de consultas, aparece la ficha Diseño y aparece el cuadro de diálogo Mostrar tabla.

  2. Seleccione la tabla que contiene los datos que desea eliminar, haga clic en Agregar y, a continuación, haga clic en Cerrar.

    La tabla aparece como una ventana en la sección superior de la cuadrícula de diseño de consulta. La ventana enumera todos los campos de la tabla. Esta ilustración muestra una tabla típica en el diseñador.

    Una tabla en el diseñador de consultas

  3. Agregue los campos que desee establecer en NULL a la fila campo del diseñador. Puede haga doble clic en cada campo o arrastrar y colocar cada campo.

  4. Si lo desea, especifique criterios para uno o varios campos en la fila criterios del diseñador.

    Usar criterios para devolver solo los registros que desea eliminar. En caso contrario, la consulta de actualización se establece en NULL todos los registros en cada uno de los campos de la consulta. Para obtener más información sobre el uso de criterios, vea criterios de ejemplo para consultas de selección, más adelante en este artículo.

  5. En el grupo Resultados de la pestaña Diseño, haga clic en Ejecutar.

    Compruebe que la consulta devuelve los registros que desee establecer en NULL o una cadena de longitud cero. Según sea necesario, repita los pasos 3 a 5 y modificar los campos o criterios hasta que la consulta devuelva solamente los datos que desea cambiar.

  6. Mantener abierta la consulta y, a continuación, vaya a los siguientes pasos.

Convertir la consulta de selección en una consulta de actualización

  1. Haga clic en Vista Diseño para cambiar de la hoja de datos al diseñador de consultas.

  2. En la ficha Diseño, en el grupo Tipo de consulta, haga clic en Actualizar.

    Access convierte la consulta de selección en una consulta de actualización, oculta la fila Mostrar en la sección inferior de la cuadrícula de diseño y agrega la fila Actualizar a.

    En la fila Actualizar a de cada campo, especifique NULL o una cadena de longitud cero, un par de comillas dobles sin espacio entre ellas ("").

  3. Haga clic en Ejecutar Imagen del botón.

    Access le pedirá que confirme los cambios.

    Asegúrese que va a cambiar los valores y, a continuación, haga clic en para cambiar los datos.

Principio de página

Eliminar registros completos

En esta sección se explica cómo usar una consulta de eliminación para eliminar registros completos de una tabla.

Crear una consulta de selección

  1. En el grupo Otros de la pestaña Crear, haga clic en Diseño de consulta.

    Se abre el Diseñador de consultas, aparece la ficha Diseño y aparece el cuadro de diálogo Mostrar tabla.

  2. Seleccione la tabla del lado "uno" de la relación, haga clic en Agregar y, a continuación, haga clic en Cerrar.

    La tabla aparece como una ventana en la sección superior de la cuadrícula de diseño de consulta. La ventana enumera todos los campos de la tabla. Esta ilustración muestra una tabla típica en el diseñador.

    Una tabla en el diseñador de consultas

  3. Haga doble clic en el asterisco (*) para agregar todos los campos de la tabla a la cuadrícula de diseño.

    Agregar todos los campos de tabla, permite la consulta de eliminación quitar registros enteros (filas) de la tabla.

  4. Opcionalmente, agregue un campo de tabla que le permite especificar criterios.

    Por ejemplo, suponga que un cliente cierra su negocio y debe quitar todos los pedidos pendientes de ese cliente. Para buscar únicamente esos registros, agregue los campos de identificador de cliente y la fecha de pedido a la cuadrícula de diseño.

  5. Si ha seguido el paso anterior, especifique los criterios en la fila criterios de la cuadrícula de diseño.

    Usar criterios para devolver solo los registros que desea eliminar. En caso contrario, la consulta de eliminación quita todos los registros de la tabla. Para continuar con el ejemplo del paso anterior, escriba el número de identificación del cliente que está fuera de la empresa y la fecha en la que ya no es válidos pedidos de ese cliente.

    Para obtener más información sobre el uso de criterios, vea criterios de ejemplo para consultas de selección, más adelante en este artículo.

  6. Si ha seguido el paso anterior, desactive la casilla de verificación Mostrar de cada campo de criterio.

  7. En el grupo Resultados de la pestaña Diseño, haga clic en Ejecutar.

    Compruebe que la consulta devuelve los registros que desea eliminar.

  8. Mantener abierta la consulta y, a continuación, vaya a los siguientes pasos.

Convertir la consulta de selección en una consulta de eliminación y eliminar datos

  1. Haga clic en Vista Diseño para cambiar de la hoja de datos al diseñador de consultas.

  2. En la ficha Diseño, en el grupoTipo de consulta, haga clic en Eliminar.

    Access cambie la consulta de selección a una consulta de eliminación, oculta la fila Mostrar en la sección inferior de la cuadrícula de diseño y agrega la fila Eliminar.

    Asegúrese de que muestra en la fila Eliminar en la columna * (todos los campos). La palabra donde debe aparecer en todas las columnas que se usa para los criterios.

  3. Asegúrese de que desea eliminar los datos y, a continuación, haga clic en Ejecutar Imagen del botón.

    Access le pedirá que confirme la eliminación.

    Haga clic en para eliminar los datos.

Principio de página

Criterios de ejemplo para consultas de selección

La siguiente tabla enumera algunos criterios de ejemplo que puede usar en Seleccione consultas para asegurarse de que elimina únicamente los datos correctos. Puede adaptar estos ejemplos para su uso con sus propios datos. Algunos de estos ejemplos usan caracteres comodín.

Para obtener más información sobre cómo usar caracteres comodín, vea el artículo referencia caracteres comodín en Access.

Criterios

Efecto

> 234

Devuelve todos los números mayores que 234. Para buscar todos los números menores que 234, utilice < 234.

>="Díaz"

Devuelve todos los registros desde Díaz hasta el final del alfabeto.

Entre #02.02.2007# Y #01.12.2007#

Devuelve las fechas de 2 de febrero de 2007 a través de 1 de diciembre de 2007 (ANSI-89). Si la base de datos usa los caracteres comodín ANSI-92, use comillas simples (') en lugar del signo (#). Ejemplo: Entre ' 2/2/2007' y ' 12/1/2007 '

Sin "Alemania"

Encuentra todos los registros en los que el contenido exacto del campo no sea exactamente igual a "Alemania". El criterio devolverá registros que contengan caracteres además de "Alemania," como "Alemania (euro)" o "Europa (Alemania)".

Sin "T*"

Busca todos los registros, salvo los que empiezan por T. Si la base de datos usa los caracteres comodín ANSI-92, use el signo de porcentaje (%) en vez del asterisco (*).

No "*t"

Busca todos los registros que no terminen en t. Si la base de datos utiliza el juego de caracteres comodín ANSI-92, use el signo de porcentaje (%) en vez del asterisco (*).

En(Canadá,Reino Unido)

En una lista, busca todos los registros que contengan Canadá o Reino Unido.

Como "[A-D]*"

En un campo de texto, busca todos los registros que comienzan con las letras A D. Si la base de datos usa los caracteres comodín ANSI-92, use el signo de porcentaje (%) en vez del asterisco (*).

Como "*ar*"

Busca todos los registros que incluyan la secuencia de letras "ar". Si la base de datos usa el juego de caracteres comodín ANSI-92, use el signo de porcentaje (%) en vez del asterisco (*).

Como "Casa Dewe?"

Busca todos los registros que empiecen por "Casa" y contengan una segunda cadena de 5 letras, cuyas cuatro primeras letras son "Dewe" y cuya última letra se desconoce. Si la base de datos usa el juego de caracteres comodín ANSI-92, use el carácter de subrayado (_) en vez del signo de interrogación (?).

#02.02.2007#

Busca todos los registros de 2 de febrero de 2007. Si la base de datos usa los caracteres comodín ANSI-92, incluya la fecha entre comillas simples en lugar de los signos de número (' 2/2/2007').

< Fecha() - 30

Usa la función Fecha para devolver todas las fechas con una antigüedad de más de 30 días.

Fecha()

Usa la función Fecha para devolver todos los registros que contienen la fecha actual.

Entre Fecha() Y AgregFecha("M", 3, Fecha())

Usa las funciones Fecha y AgregFecha para devolver todos los registros entre la fecha actual y tres meses a partir de la fecha actual.

Es Nulo

Devuelve todos los registros que contengan un valor nulo (en blanco o sin definir).

No es nulo

Devuelve todos los registros que contengan algún valor (que no sea nulo).

""

Devuelve todos los registros que contengan una cadena de longitud cero. Las cadenas de longitud cero se usan cuando es necesario agregar un valor a un campo obligatorio, pero aún no se conoce el valor. Un ejemplo sería un campo que necesita un número de fax cuando hay algunos clientes que no tienen fax. En ese caso, en vez de especificar un número, se incluye un par de comillas dobles sin espacios entre ellas ('''').

Principio de página

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

¿Le ha sido útil esta información?

¿Cómo podemos mejorarlo?

¿Cómo podemos mejorarlo?

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!