Transmitir confianza agregando una firma digital

Nota: Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Puede mostrar que cree que una base de datos es segura y que su contenido puede ser de confianza agregando un firma digital a la base de datos. Esto ayuda a las personas que usan la base de datos a decidir si desean confiar en ella y su contenido.

El proceso que se usa para firmar digitalmente una base de datos depende de si la base de datos usa un formato de archivo más reciente, como un archivo. accdb o un formato anterior, como un archivo. mdb. Sin embargo, ambos procesos requieren que use un certificado de seguridad.

Puede usar un certificado de seguridad comercial o puede crear el suyo propio. En este tema se explica cómo crear su propio certificado de seguridad.

En este artículo

Antes de empezar

Empaquetar, firmar y distribuir una base de datos de Access

Firmar digitalmente una base de datos de una versión anterior

Antes de empezar

Para agregar una firma digital, primero debe obtener o crear un certificado de seguridad. Considere un certificado de seguridad como un lápiz que usted usa para firmar elementos digitalmente o un precinto de cera que solo usted pueda aplicar.

Si no tiene un certificado de seguridad, puede crear uno mediante la herramienta SelfCert (incluido con Microsoft Office).

Crear un certificado autofirmado

  1. En Microsoft Windows, haga clic en el botón Inicio , elija todos los programas, seleccione Microsoft Office, seleccione herramientas de Microsoft Officey, a continuación, haga clic en certificado digital para proyectos de VBA.

    -o bien-

    Vaya a la carpeta que contiene los archivos de programa de Microsoft Office.

    Tendrá que buscar el archivo ejecutable, SelfCert. exe, y la ubicación puede variar en función de varias condiciones, como si utiliza un sistema operativo Windows de 32 bits o 64 bits o si está usando una versión de suscripción de Office 365.

    Si usa Office 2019 u Office 2016, pruebe una de estas ubicaciones:

    • C:\Archivos de Programa\microsoft Office\Office16

    • C:\Archivos de programa (x86) \Microsoft Office\Office16

    Si está usando Office 365, pruebe una de estas ubicaciones:

    • C:\Archivos de Programa\microsoft Office\root\Office16

    • C:\Archivos de programa (x86)\Microsoft Office\root\Office16.

    Si está usando Office 2013, busque la carpeta Office15 de las opciones anteriores. Si está usando Office 2010, busque la carpeta Office14. Si está usando Office 2007, busque la carpeta Office12.

    Busque la carpeta correcta y haga doble clic en SelfCert. exe.

    Aparece el cuadro de diálogo Crear certificado digital.

  2. En el cuadro Nombre del certificado, escriba un nombre para el nuevo certificado.

  3. Haga clic en Aceptar dos veces.

Nota: Si no ve el comando Certificado digital para proyectos de VBA o no puede encontrar SelfCert.exe, es posible que tenga que instalar SelfCert.

Instalar SelfCert.exe

  1. Inicie el CD de instalación de Microsoft Office o cualquier otro medio de instalación.

  2. En el programa de instalación, haga clic en Agregar o quitar funciones y después en Continuar.

    Nota: Si trabaja en un entorno en el que Microsoft Office está instalado en equipos individuales por los administradores de TI en lugar de mediante un CD, siga estos pasos:

    1. En Microsoft Windows, haga clic en el botón Inicio y, a continuación, haga clic en Panel de control.

    2. Haga doble clic en Agregar o quitar programas.

    3. Seleccione la versión de Microsoft Office y, a continuación, haga clic en cambiar.

      El programa de instalación se inicia.

    4. Haga clic en Agregar o quitar funciones y después en Continuar.

    5. Continúe con los pasos siguientes.

  3. Expanda los nodos Microsoft Office y Funciones compartidas de Office haciendo clic en los signos más (+) junto a ellos.

  4. Haga clic en Certificado digital para proyectos de VBA.

  5. Haga clic en Ejecutar desde mi PC.

  6. Haga clic en Continuar para instalar el componente.

Solo debe usar SelfCert para crear firmas para usarlas dentro de su propia organización. Si desea firmar digitalmente una base de datos y, a continuación, distribuir esa base de datos en el mercado, debe obtener un certificado de seguridad comercial de una entidad EMISORa de certificados comercial.

Empaquetar, firmar y distribuir una base de datos de Access

Access hace que sea fácil y rápido firmar y distribuir una base de datos. Al crear un archivo .accdb o .accde, puede empaquetar el archivo, aplicarle una firma digital al paquete y después distribuir el paquete firmado a otros usuarios. La herramienta de Empaquetar y firmar coloca la base de datos en un archivo implementación de Access (.accdc), firma el archivo y después coloca el paquete firmado en la ubicación que determine. Los usuarios pueden extraer la base de datos del paquete y trabajar directamente en ella (no en el archivo de paquete).

Durante el proceso, recuerde los siguientes puntos:

  • Empaquetar una base de datos y firmar el paquete es una forma de transmitir confianza. Al empaquetar y firmar una base de datos, la firma digital confirma que la base de datos no se ha modificado después de crear el paquete.

  • Después de extraer la base de datos del paquete, ya no hay ninguna conexión entre el paquete firmado y la base de datos extraída.

  • Puede usar la herramienta empaquetar y firmar solo con las bases de datos guardadas en un formato de archivo más reciente (. accdb,. accde,...). Access también proporciona herramientas para firmar y distribuir bases de datos que tengan un formato de archivo anterior. Debe usar la herramienta de firma digital apropiada para el formato de archivo de base de datos que está utilizando.

  • Solo puede agregar una base de datos a un paquete.

  • El proceso firma digitalmente un paquete que contiene toda la base de datos, no solo macros o módulos.

  • El proceso comprime el archivo de paquete para ayudar a reducir los tiempos de descarga.

  • Puede extraer bases de datos de los archivos de paquete que se encuentran en servidores que ejecutan Windows SharePoint Services 3.0 o una versión posterior.

Los pasos descritos en las siguientes secciones explican cómo crear un archivo de paquete firmado y cómo extraer y usar la base de datos de un archivo de paquete firmado.

Crear un paquete firmado

  1. Abra la base de datos que quiere empaquetar y firmar.

  2. Haga clic en archivo _GT_ Guardar comopaquete > e inicie sesión

    Aparece el cuadro de diálogo Seleccionar certificado.

  3. Seleccione un certificado y después haga clic en Aceptar.

    Aparece el cuadro de diálogo crear paquete firmado de Microsoft Access .

  4. En la lista Guardar en, seleccione una ubicación para el paquete firmado de base de datos.

  5. Escriba un nombre para el paquete firmado en el cuadro Nombre de archivo y después haga clic en Guardar.

    Access crea el archivo .accdc y lo coloca en la ubicación que ha elegido.

Extraer y usar un paquete firmado

  1. Haga clic en Archivo > Abrir > Examinar. Aparece el cuadro de diálogo Abrir

  2. Seleccione paquetes firmados de Microsoft Access (*. accdc) como tipo de archivo.

  3. Busque la carpeta que contiene el archivo. accdc, seleccione el archivo y, a continuación, haga clic en abrir.

  4. Siga uno de los siguientes procedimientos:

    • Si decide confiar en el certificado de seguridad usado para firmar el paquete de implementación, aparece el cuadro de diálogo Extraer base de datos a. Vaya al paso siguiente.

    • Si ha elegido no confiar en el certificado de seguridad, aparece el siguiente mensaje.

      Mensaje de advertencia

      Si confía en la base de datos, haga clic en Abrir. Si confía en cualquier certificado del proveedor, haga clic en Confiar en todo contenido del editor. Aparece el cuadro de diálogo Extraer base de datos a.

      Nota: Si usa un certificado autofirmado para firmar un paquete de base y después hace clic en Confiar en todo contenido del editor al abrir ese paquete, siempre serán de confianza los paquetes firmados usados con sus certificados autofirmados.

  5. Opcionalmente, en la lista Guardar en, seleccione una ubicación para la base de datos extraída y después, en el cuadro Nombre de archivo, escriba otro nombre para la base de datos extraída.

    Sugerencia: Si extrae la base de datos a una ubicación de confianza, su contenido se habilitará automáticamente cada vez que la abra. Si elige una ubicación que no es de confianza, algún contenido de la base puede estar deshabilitado de forma predeterminada.

  6. Haga clic en Aceptar.

Si no está seguro de si debe confiar en un certificado, el artículo Cómo saber si una firma digital es de confianza proporciona información general sobre la comprobación de fechas y otros elementos de un certificado para ayudar a garantizar que es válido.

Volver al principio

Firmar digitalmente una base de datos de una versión anterior

Importante: Los pasos de esta sección no se aplican a las bases de datos que usan uno de los nuevos formatos de archivo.

Para las bases de datos que usan los formatos de archivo. mdb o. MDE, puede aplicar un firma digital a los componentes de la base de datos. Una firma digital confirma que las macros, los módulos de código y otros componentes ejecutables de la base de datos se han originado con el firmante y que nadie los ha modificado desde se firmó la base de datos.

Para aplicar una firma a su base de datos, primero necesita un certificado digital. Si crea bases de datos para distribución comercial, debe obtener un certificado de una entidad emisora de certificados comercial (CA). Las entidades emisoras de certificados realizan comprobaciones exhaustivas para verificar que las personas que crean contenido (como bases de datos) son programadores acreditados.

Si desea usar una base de datos para escenarios personales o de grupo de trabajo limitados, Access proporciona una herramienta para crear un certificado autofirmado. Los pasos descritos en las siguientes secciones explican cómo instalar y usar una herramienta denominada SelfCert.exe para crear un certificado autofirmado.

Código para firmar una base de datos

Nota: Recuerde que estos pasos solo se aplican cuando usa bases de datos que usan uno de los formatos de archivo de base de datos anteriores, como un archivo. mdb. Para firmar bases de datos nuevas, consulte la sección empaquetar, firmar y distribuir una base de datos de Access.

  1. Abra la base de datos que quiere firmar.

  2. En la pestaña Herramientas de base de datos, en el grupo Macro, haga clic en Visual Basic para iniciar el Editor de Visual Basic.

    Método abreviado de teclado  Presione ALT+F11.

  3. En la ventana Explorador de proyectos, seleccione la base de datos o el proyecto de Visual Basic para Aplicaciones (VBA) que quiere firmar.

  4. En el menú Herramientas, haga clic en Firma digital.

    Aparece el cuadro de diálogo Firma digital.

  5. Haga clic en Elegir para seleccionar el certificado de prueba.

    Aparece el cuadro de diálogo Seleccionar certificado.

  6. Seleccione el certificado que quiere aplicar.

    Si ha seguido los pasos de la sección anterior, seleccione el certificado que ha creado con SelfCert.

  7. Haga clic en Aceptar para cerrar el cuadro de diálogo seleccionar certificado y haga clic en Aceptar de nuevo para cerrar el cuadro de diálogo firma digital .

Sugerencias para firmar bases de datos de versiones anteriores

  • Si quiere evitar que los usuarios de su solución de modifique accidentalmente su proyecto VBA e invalidar su firma, bloquee el proyecto VBA antes de firmarlo.

    Nota: El bloqueo del proyecto VBA no evita que otro usuario reemplace la firma digital con otra firma. Los administradores corporativos pueden volver a firmar las plantillas y los complementos para que puedan controlar exactamente lo que los usuarios pueden ejecutar en sus equipos.

  • Al firmar digitalmente un proyecto VBA, piense en obtener una marca de tiempo para que otros usuarios puedan comprobar su firma incluso después de que el certificado usado para la firma haya caducado.

Principio de página

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×