TIPO.DE.ERROR (función TIPO.DE.ERROR)

En este artículo se describen la sintaxis de la fórmula y el uso de la función TIPO.DE.ERROR en Microsoft Excel.

Descripción

Devuelve un número que corresponde a uno de los valores de error de Microsoft Excel o devuelve el error #N/A si no existe ningún otro. Use TIPO.DE.ERROR en una función SI para probar un valor de error y devolver en su lugar una cadena de texto, como un mensaje.

Sintaxis

TIPO.DE.ERROR(valor_de_error)

La sintaxis de la función TIPO.DE.ERROR tiene los siguientes argumentos:

  • Valor_de_error    Obligatorio. Es el valor de error cuyo número identificador desea buscar. Aunque valor_de_error puede ser un valor de error real, por lo general es una referencia a una celda que contiene la fórmula que desea probar.

Si valor_de_error es

TIPO.DE.ERROR devuelve

#¡NULO!

1.

#¡DIV/0!

2.

#¡VALOR!

3.

#¡REF!

4.

#¿NOMBRE?

5.

#¡NUM!

6.

#N/A

7.

#OBTENIENDO_DATOS

(8)

Otro valor

#N/A

Ejemplo

Copie los datos de ejemplo en la tabla siguiente y péguelos en la celda A1 de una hoja de cálculo nueva de Excel. Para que las fórmulas muestren los resultados, selecciónelas, presione F2 y luego ENTRAR. Si lo necesita, puede ajustar el ancho de las columnas para ver todos los datos.

Datos

#¡NULO!

#¡DIV/0!

Fórmula

Descripción

Resultado

=TIPO.DE.ERROR(A2)

Número del error #NULO!(1).

1.

=SI(TIPO.DE.ERROR(A3)<3;ELEGIR(TIPO.DE.ERROR(A3);"Los rangos no se intersecan";"El divisor es cero"))

Comprueba la celda A3 para averiguar si contiene el valor de error #¡NULO! o el valor de error #¡DIV/0!. Si es el caso, se usa el número del valor de error en la función de hoja de cálculo ELEGIR para mostrar uno de los dos mensajes; de lo contrario, se devuelve el valor de error #N/A.

El divisor es cero

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×