Sumar valores basados en varias condiciones

Si desea sumar valores que tengan más de una condición, como la suma de ventas de un determinado producto en una región determinada, debe usar la función SUMAR.SI.CONJUNTO en una fórmula.

A continuación, exponemos un ejemplo que tiene dos condiciones: queremos la suma de las ventas de Meat (Carne) (de la columna C) en la región Sur (South) (de la columna A).

Datos en una hoja de cálculo de Excel

La fórmula que debe usar es la siguiente:

=SUMAR.SI.CONJUNTO(D2:D11,A2:A11,”South”,C2:C11,”Meat”)El resultado es 14719. Ahora explicaremos cómo funciona la fórmula.

=SUMAR.SI.CONJUNTO es una fórmula aritmética. Calcula números que, en este caso, están en la columna D. Así que empezaremos indicando a la fórmula dónde están los números:

  • =SUMAR.SI.CONJUNTO(D2:D11,

O sea, quiere que la fórmula sume números de la columna si cumplen las condiciones. El rango de celdas es el primer argumento o datos que la función tiene que ejecutar.

Ahora necesita encontrar datos que cumplan las dos condiciones; por eso especifica la primera condición indicando a la función dónde residen los datos (A2:A11) y cuál es la condición; en este caso, es “South” (Sur). Observe que los argumentos están separados por comas.

  • =SUMAR.SI.CONJUNTO(D2:D11,A2:A11,”South”,

Al poner "South" entre comillas está indicando a Excel que usa datos de texto.

Por último, especifique los argumentos de la segunda condición: el rango de celdas (C2:C11) que tiene la palabra “carne”, más la palabra en sí (entre comillas) para que Excel pueda encontrar resultados. Acabe la fórmula con un paréntesis de cierre) y después presione Entrar para obtener el resultado de 14719.

  • =SUMAR.SI.CONJUNTO(D2:D11,A2:A11,”South”,C2:C11,”Meat”)

A medida que escriba la función SUMAR.SI.CONJUNTO, si no recuerda los argumentos, puede usar la ayuda que tiene a mano. Después de escribir =SUMAR.SI.CONJUNTO( aparece Fórmula Autocompletar debajo de la fórmula, con la lista de argumentos en el orden correcto.

Si miramos la imagen de Fórmula Autocompletar y la lista de argumentos, en nuestro ejemplo rango_sumaes D2:D11, la columna de números que desea sumar; rango_criterios1es A2.A11, la columna de datos donde criterios1 “South” reside.

Uso de la fórmula Autocompletar para especificar la función SUMAR.SI.CONJUNTO

A medida que escriba, el resto de los argumentos aparecerá en Fórmula Autocompletar; rango_criterios2 es C2:C11, la columna de datos donde reside criterios2 "Carne".

Inténtelo

Copie todas las celdas de la tabla de abajo y péguelas en la celda A1 de una nueva hoja de cálculo. Quizás desee ajustar anchos de columna para ver mejor las fórmulas.

Región

Comercial

Tipo

Ventas

Sur

Ito

Bebidas

3.571

Oeste

Lannin

Lácteos

3.338

Este

Makovec

Bebidas

5.122

Norte

Makovec

Lácteos

6.239

Sur

Jordan

Verdura

8.677

Sur

Lannin

Carnes

45,0

Sur

Lannin

Carnes

7.673

Este

Makovec

Verdura

664

Norte

Lannin

Verdura

1.500

Sur

Jordan

Carnes

6.596

Fórmula

 

Descripción

Resultado

'=SUMAR.SI.CONJUNTO(D2:D11,A2:A11,
"Sur", C2:C11,"Carnes")

Suma las ventas de carnes en la
Columna C en la región sur
en la Columna A (el resultado es 14.719).

=SUMAR.SI.CONJUNTO(D2:D11,A2:A11,
"Sur", C2:C11,"Carnes")

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×