Sumar datos mediante una consulta

Sumar datos mediante una consulta

En este artículo se explica cómo usar un tipo de función denominado función de agregado para sumar los datos en un conjunto de resultados de la consulta. Este artículo explica también brevemente cómo usar otras funciones de agregado, por ejemplo, contar y promedio para contar o calcular el promedio de los valores de un conjunto de resultados. Además, en este artículo se explica cómo usar la fila Total, una característica de Access que se usa para sumar datos sin tener que cambiar el diseño de las consultas.

¿Qué desea hacer?

Información sobre las formas de sumar datos

Preparar algunos datos de ejemplo

Sumar datos con una fila de total

Calcular los totales generales con una consulta

Calcular los totales de grupo con una consulta de totales

Sumar datos de varios grupos con una consulta de tabla de referencias cruzadas

Referencia de la función de agregado

Información sobre las formas de sumar datos

Puede sumar una columna de números en una consulta con un tipo de función que se denomina función de agregado. Las funciones de agregado realizan un cálculo en una columna de datos y devuelven un valor único. Access proporciona una variedad de funciones de agregado, como Suma, Cuenta, Promedio (para calcular promedios), Mín y Máx. Sume datos al agregar la función Suma a la consulta, contabilice datos con la función Cuenta, etc.

Además, Access proporciona varias maneras de agregar suma y otras funciones de agregado a una consulta. Puedes:

  • Abra la consulta en la vista Hoja de datos y agregar una fila Total. La fila Total, una característica de Access, le permite usar una función de agregado en una o más columnas de un conjunto sin tener que cambiar el diseño de la consulta de resultados de consulta.

  • Crear una consulta de totales. Una consulta de totales calcula subtotales en grupos de registros; una fila de total calcula los totales generales de una o varias columnas (campos) de datos. Por ejemplo, si quiere calcular el subtotal de todas las ventas por ciudad o por trimestre, use una consulta de totales para agrupar los registros por la categoría que quiera y, después, sume las cifras de ventas.

  • Crear una consulta de tabla de referencias cruzadas. Una consulta de tabla de referencias cruzadas es un tipo especial de consulta que muestra los resultados en una cuadrícula que se parece a una hoja de cálculo de Excel. Consultas de referencias cruzadas resumen los valores y, a continuación, los agrupan por dos conjuntos de hechos: uno establece el lado (encabezados de fila) y otro en la parte superior (encabezados de columna). Por ejemplo, puede usar una consulta de tabla de referencias cruzadas para mostrar los totales de ventas de cada ciudad durante los últimos tres años, como se muestra en la tabla siguiente:

Ciudad

2003

2004

2005

París

254 556

372 455

467 892

Sídney

478 021

372 987

276 399

Yakarta

572 997

684 374

792 571

...

...

...

...

Nota: En las secciones de procedimientos de este documento se destaca el uso de la función Suma, pero recuerde que puede usar otras funciones de agregado en las filas de total y en las consultas. Para más información sobre el uso de las otras funciones de agregado, vea la sección Referencia de la función de agregado más adelante en este artículo.

Para más información sobre cómo usar las funciones de agregado, vea el artículo Mostrar totales de columna en una hoja de datos.

Los pasos descritos en las siguientes secciones explican cómo agregar una fila de total, usar una consulta de totales para sumar los datos entre grupos y cómo usar una consulta de tabla de referencias cruzadas que calcula el subtotal de datos entre grupos e intervalos de tiempo. Durante el proceso, recuerde que muchas de las funciones de agregado funcionan solo en datos de campos establecidos con un tipo de datos específico. Por ejemplo, la función SUMA solo funciona con campos establecidos con los tipos de datos Número, Decimal o Moneda. Para más información sobre los tipos de datos que necesita cada función, vea la sección Referencia de la función de agregado más adelante en este artículo.

Para información general sobre los tipos de datos, vea el artículo Modificar o cambiar el conjunto de tipo de datos de un campo.

Principio de página

Preparar algunos datos de ejemplo

Las secciones de procedimientos en este artículo proporcionan tablas de datos de ejemplo. En los pasos de los procedimientos se usan las tablas de ejemplo con el fin de ayudarle a comprender cómo funcionan las funciones de agregado. Si lo prefiere, puede agregar de forma opcional las tablas de ejemplo a una base de datos nueva o existente.

Access proporciona varias maneras de agregar estas tablas de ejemplo a una base de datos. Puede introducir los datos manualmente, puede copiar cada tabla en un programa de hoja de cálculo como Excel y, a continuación, importar las hojas de cálculo en Access, o puede pegar los datos en un editor de texto como el Bloc de notas e importar los datos de los archivos de texto resultantes.

En esta sección se explica cómo introducir datos manualmente en una hoja de datos en blanco y cómo copiar las tablas de ejemplo en un programa de hoja de cálculo y, a continuación, importar dichas tablas en Access. Para obtener más información sobre la creación y la importación de datos de texto, vea el artículo importar o vincular a datos en un archivo de texto.

Los pasos de los procedimientos de este artículo usan las tablas siguientes. Use estas tablas para crear los datos de ejemplo:

La tabla Categorías:

Categoría

Muñecos

Juegos y puzles

Imágenes y marcos

Videojuegos

DVD y películas

Modelos y aficiones

Deportes

La tabla Productos:

Nombre del producto

Precio

Categoría

Figura de acción Programador

12,95 $

Muñecos

Diversión con C# (un juego de mesa para toda la familia)

15,85 $

Juegos y puzles

Diagrama de base de datos relacional

22,50 $

Imágenes y marcos

El chip mágico (500 piezas)

32,65 $

Juegos y puzles

Access, el juego

22,95 $

Juegos y puzles

Apasionados de la informática y criaturas mitológicas

78,50 $

Videojuegos

Ejercicio para apasionados de la informática, el DVD

14,88 $

DVD y películas

Pizza voladora definitiva

36,75 $

Deportes

Unidad de disquete de 5,25 pulgadas externa (escala de 1:4)

65,00 $

Modelos y aficiones

Figura Burócrata

78,88 $

Muñecos

Tristeza

53,33 $

Videojuegos

Cree su propio teclado

77,95 $

Modelos y aficiones

La tabla Pedidos:

Fecha del pedido

Fecha de envío

Ciudad de envío

Gastos de envío

14/11/2005

15/11/2005

Yakarta

55,00 $

14/11/2005

15/11/2005

Sídney

76,00 $

16/11/2005

17/11/2005

Sídney

87,00 $

17/11/2005

18/11/2005

Yakarta

43,00 $

17/11/2005

18/11/2005

París

105,00 $

17/11/2005

18/11/2005

Stuttgart

112,00 $

18/11/2005

19/11/2005

Viena

215,00 $

19/11/2005

20/11/2005

Miami

525,00 $

20/11/2005

21/11/2005

Viena

198,00 $

20/11/2005

21/11/2005

París

187,00 $

21/11/2005

22/11/2005

Sídney

81,00 $

23/11/2005

24/11/2005

Yakarta

92,00 $

La tabla Detalles de pedidos:

Id. de pedido

Nombre del producto

Id. de producto

Precio unitario

Cantidad

Descuento

1

Cree su propio teclado

12

77,95 $

9

5 %

1

Figura Burócrata

2

78,88 $

4

7,5 %

2

Ejercicio para apasionados de la informática, el DVD

7

14,88 $

6

4 %

2

El chip mágico

4

32,65 $

8

0

2

Apasionados de la informática y criaturas mitológicas

6

78,50 $

4

0

3

Access, el juego

5

22,95 $

5

15 %

4

Figura de acción Programador

1

12,95 $

2

6 %

4

Pizza voladora definitiva

8

36,75 $

8

4 %

5

Unidad de disquete de 5,25 pulgadas externa (escala de 1:4)

9

65,00 $

4

10 %

6

Diagrama de base de datos relacional

3

22,50 $

1,2

6,5 %

7

Tristeza

11

53,33 $

6

8 %

7

Diagrama de base de datos relacional

3

22,50 $

4

9 %

Nota: Recuerde que, en una base de datos típica, una tabla de detalles de pedidos contendrá solo un campo de Id. de producto, no un campo de Nombre de producto. La tabla de ejemplo usa un campo de Nombre de producto para facilitar la lectura de los datos.

Escribir los datos de ejemplo manualmente

  1. En la pestaña Crear, en el grupo Tablas, haga clic en Tabla.

    Access agrega una nueva tabla en blanco a su base de datos.

    Nota: No es necesario seguir este paso si abre una base de datos en blanco, pero tendrá que seguirlo cada vez que necesite agregar una tabla a la base de datos.

  2. Haga doble clic en la primera celda de la fila de encabezado y escriba el nombre del campo en la tabla de ejemplo.

    De manera predeterminada, Access indica los campos en blanco en la fila de encabezado con el texto Agregar nuevo campo, así:

    Un nuevo campo en una hoja de datos

  3. Use las teclas de dirección para ir a la siguiente celda de encabezado en blanco y escriba el nombre del segundo campo (también puede presionar la tecla TAB o hacer doble clic en la nueva celda). Repita este paso hasta que haya escrito todos los nombres de campo.

  4. Escriba los datos en la tabla de ejemplo.

    A medida que escriba los datos, Access deduce un tipo de datos para cada campo. Si no conoce las bases de datos relacionales, tiene que establecer un tipo de datos específico (como Número, Texto o Fecha y hora) para cada uno de los campos de las tablas. Establecer el tipo de datos ayuda a garantizar una entrada de datos precisa y también ayuda a evitar errores, como el uso de un número de teléfono en un cálculo. Para estas tablas de ejemplo, tiene que permitir que Access deduzca el tipo de datos.

  5. Cuando termine de escribir los datos, haga clic en Guardar.

    Método abreviado de teclado: presione CTRL+G.

    Aparecerá el cuadro de diálogo Guardar como.

  6. En el cuadro Nombre de tabla, escriba el nombre de la tabla de ejemplo y luego haga clic en Aceptar.

    Use el nombre de cada tabla de ejemplo, ya que las consultas en las secciones de procedimientos usan esos nombres.

  7. Repita estos pasos hasta que cree todas las tablas de ejemplo que aparecen al principio de esta sección.

Si no quiere escribir los datos manualmente, complete los pasos siguientes para copiar los datos a un archivo de hoja de cálculo y, después, importe los datos del archivo de hoja de cálculo en Access.

Crear las hojas de cálculo de ejemplo

  1. Inicie el programa de hoja de cálculo y cree un archivo en blanco. Si usa Excel, el programa ya crea un libro en blanco de manera predeterminada.

  2. Copie la primera tabla de ejemplo indicada anteriormente y péguela en la primera hoja de cálculo, empezando por la primera celda.

  3. Con la técnica proporcionada por el programa de hoja de cálculo, cambie el nombre de la hoja de cálculo. Asigne a la hoja de cálculo el mismo nombre que tenga la tabla de ejemplo. Por ejemplo, si la tabla de ejemplo se denomina Categorías, asigne el mismo nombre a la hoja de cálculo.

  4. Repita los pasos 2 y 3, copie cada tabla de ejemplo en una hoja de cálculo en blanco y cambie el nombre de la hoja de cálculo.

    Nota: Es posible que tenga que agregar hojas de cálculo al archivo de hoja de cálculo. Para obtener información sobre cómo realizar esta tarea, vea la ayuda de su programa de hoja de cálculo.

  5. Guarde el libro en una ubicación adecuada en su equipo o red y, después, vaya al siguiente conjunto de pasos.

Crear tablas de base de datos a partir de las hojas de cálculo

  1. En la pestaña Datos externos, en el grupo Importar, haga clic en Excel.

    -o-

    Haga clic en Más y luego seleccione un programa de hoja de cálculo de la lista.

    Aparece el cuadro de diálogo Obtener datos externos: Hoja de cálculo de <nombre de programa>.

  2. Haga clic en Examinar, abra el archivo de hoja de cálculo que creó en los pasos anteriores y luego haga clic en Aceptar.

    Se inicia el Asistente para importación de hojas de cálculo.

  3. De manera predeterminada, el asistente selecciona la primera hoja de cálculo del libro (la hoja de cálculo Clientes, si ha seguido los pasos de la sección anterior) y los datos de la hoja de cálculo aparecen en la sección inferior de la página del asistente. Haga clic en Siguiente.

  4. En la página siguiente del asistente, haga clic en La primera fila contiene encabezados de columna y después haga clic en Siguiente.

  5. De manera opcional, en la siguiente página, use los cuadros de texto y las listas en Opciones de campo para cambiar los tipos de datos y nombres de campo u omitir campos de la operación de importación. En caso contrario, haga clic en Siguiente.

  6. Deje la opción Permitir a Access agregar la clave principal seleccionada y luego haga clic en Siguiente.

  7. De manera predeterminada, Access aplica el nombre de la hoja de cálculo a la nueva tabla. Acepte el nombre o escriba otro nombre y después haga clic en Finalizar.

  8. Repita los pasos 1 a 7 hasta que haya creado una tabla de cada hoja de cálculo del libro.

Cambiar el nombre de los campos de clave principal

Nota: Cuando importó las hojas de cálculo, Access agregó automáticamente una columna de clave principal a cada tabla y, de manera predeterminada, Access denominó esa columna "Id." y la estableció con el tipo de datos Autonumeración. Los pasos de esta sección explican cómo cambiar el nombre de cada campo de clave principal. Esto ayuda a identificar claramente todos los campos de una consulta.

  1. En el panel de navegación, haga clic con el botón derecho en cada una de las tablas que creó en los pasos anteriores y haga clic en Vista Diseño.

  2. En cada tabla, busque el campo de clave principal. De manera predeterminada, Access denomina cada campo Id..

  3. Agregue el nombre de la tabla en la columna Nombre de campo para cada campo de clave principal.

    Por ejemplo, puede cambiar el nombre del campo Id. de la tabla Categorías a "Id. de categoría" y el campo de la tabla Pedidos a "Id. de pedido" Para la tabla Detalles de pedidos, cambie el nombre del campo a "Id. de detalles" Para la tabla Productos, cambie el nombre del campo a "Id. de producto"

  4. Guarde los cambios.

Cada vez que aparecen las tablas de ejemplo en este artículo, incluyen el campo de clave principal y se cambia el nombre del campo según se describe con los pasos anteriores.

Principio de página

Sumar datos con una fila de total

Puede agregar una fila de total a una consulta al abrir la consulta en la vista Hoja de datos, agregar la fila y, después, seleccionar la función de agregado que quiera usar, como Suma, Mín, Máx o Promedio. Los pasos de esta sección explican cómo crear una consulta de selección básica y agregar una fila de total. No es necesario usar las tablas de ejemplo que se describen en la sección anterior.

Crear una consulta de selección básica

  1. En la ficha Crear, en el grupo Otros, haga clic en Diseño de la consulta.

  2. En el cuadro de diálogo Mostrar tablas, haga doble clic en las tablas que quiera usar en la consulta y, después, haga clic en Cerrar.

    Las tablas seleccionadas aparecen como ventanas en la sección superior del diseñador de consultas.

  3. Haga doble clic en los campos de tabla que quiera usar en la consulta.

    Puede incluir campos que contienen datos descriptivos, como nombres y descripciones, pero es necesario incluir un campo que contenga datos numéricos o de moneda.

    Cada campo aparece en una celda de la cuadrícula de diseño.

  4. Haga clic en Ejecutar Imagen del botón para ejecutar la consulta.

    El conjunto de resultados de consulta aparece en la vista Hoja de datos.

  5. Si quiere, puede cambiar a la vista Diseño y ajustar la consulta. Para ello, haga clic con el botón derecho en la pestaña del documento de la consulta y haga clic en la Vista Diseño. Después, puede agregar o quitar campos de tabla para ajustar la consulta (si es necesario). Para quitar un campo, seleccione la columna de la cuadrícula de diseño y presione Suprimir.

  6. Guarde la consulta.

Agregar una fila de total

  1. Asegúrese de que la consulta está abierta en la vista Hoja de datos. Para ello, haga clic con el botón derecho en la pestaña del documento de la consulta y haga clic en la Vista Hoja de datos.

    -o-

    En el panel de navegación, haga doble clic en la consulta. Esto ejecuta la consulta y carga los resultados en una hoja de datos.

  2. En el grupo Registros de la pestaña Inicio, haga clic en Totales.

    Aparece una nueva fila de Total en la hoja de datos.

  3. En la fila de Total, haga clic en la celda del campo que quiera sumar y luego seleccione Suma en la lista.

Ocultar una fila de total

  • En el grupo Registros de la pestaña Inicio, haga clic en Totales.

Para más información sobre cómo usar una fila de total, vea el artículo Mostrar totales de columna en una hoja de datos.

Principio de página

Calcular los totales generales con una consulta

Un total general es la suma de todos los valores de una columna. Puede calcular varios tipos de totales generales, incluidos:

  • Un total general sencillo que suma los valores de una columna. Por ejemplo, puede calcular el total de costes de envío.

  • Un total general calculado que suma los valores de más de una columna. Por ejemplo, puede calcular el total de ventas si multiplica el coste de varios elementos por el número de elemento pedido y, después, suma los valores resultantes.

  • Un total general que excluye algunos registros. Por ejemplo, puede calcular el total de ventas solo para el último viernes.

En los pasos de las secciones siguientes se explica cómo crear cada tipo de total general. En los pasos se usan las tablas Pedidos y Detalles de pedidos.

La tabla Pedidos

Id. de pedido

Fecha del pedido

Fecha de envío

Ciudad de envío

Gastos de envío

1

14/11/2005

15/11/2005

Yakarta

55,00 $

2

14/11/2005

15/11/2005

Sídney

76,00 $

3

16/11/2005

17/11/2005

Sídney

87,00 $

4

17/11/2005

18/11/2005

Yakarta

43,00 $

5

17/11/2005

18/11/2005

París

105,00 $

6

17/11/2005

18/11/2005

Stuttgart

112,00 $

7

18/11/2005

19/11/2005

Viena

215,00 $

8

19/11/2005

20/11/2005

Miami

525,00 $

9

20/11/2005

21/11/2005

Viena

198,00 $

10

20/11/2005

21/11/2005

París

187,00 $

11

21/11/2005

22/11/2005

Sídney

$8.100

12

23/11/2005

24/11/2005

Yakarta

92,00 $

La tabla Detalles de pedidos

Id. de detalle

Id. de pedido

Nombre del producto

Id. de producto

Precio unitario

Cantidad

Descuento

1

1

Cree su propio teclado

12

77,95 $

9

0,05

2

1

Figura Burócrata

2

78,88 $

4

0,075

3

2

Ejercicio para apasionados de la informática, el DVD

7

14,88 $

6

0,04

4

2

El chip mágico

4

32,65 $

8

0,00

5

2

Apasionados de la informática y criaturas mitológicas

6

78,50 $

4

0,00

6

3

Access, el juego

5

22,95 $

5

0,15

7

4

Figura de acción Programador

1

12,95 $

2

0,06

8

4

Pizza voladora definitiva

8

36,75 $

8

0,04

9

5

Unidad de disquete de 5,25 pulgadas externa (escala de 1:4)

9

65,00 $

4

0,10

10

6

Diagrama de base de datos relacional

3

22,50 $

12

0,065

11

7

Tristeza

11

53,33 $

6

0,08

1,2

7

Diagrama de base de datos relacional

3

22,50 $

4

0,09

Calcular un total general simple

  1. En la ficha Crear, en el grupo Otros, haga clic en Diseño de la consulta.

  2. En el cuadro de diálogo Mostrar tabla, haga doble clic en la tabla que quiera usar en la consulta y, después, haga clic en Cerrar.

    Si usa los datos de ejemplo, haga doble clic en la tabla Pedidos.

    La tabla aparece en una ventana en la sección superior del diseñador de consultas.

  3. Haga doble clic en el campo que quiera sumar. Asegúrese de que el campo está establecido en el tipo de datos Número o Moneda. Si intenta sumar los valores de los campos no numéricos, como un campo de texto, Access muestra el mensaje de error No coinciden los tipos de datos en la expresión de criterios al intentar ejecutar la consulta.

    Si usa los datos de ejemplo, haga doble clic en la columna Gastos de envío.

    Puede agregar más campos numéricos a la cuadrícula si quiere calcular los totales generales de esos campos. Una consulta de totales puede calcular los totales generales de más de una columna.

  4. En la pestaña Diseño, en el grupo Mostrar u ocultar, haga clic en Totales. Imagen del botón

    Aparece la fila Total en la cuadrícula de diseño y aparece Agrupar por en la celda de la columna Gastos de envío.

  5. Cambie el valor de la celda de la fila Total a Suma.

  6. Haga clic en Ejecutar Imagen del botón para ejecutar la consulta y mostrar los resultados en la vista Hoja de datos.

    Sugerencia: Tenga en cuenta que Access agrega "SumaDe" al principio del nombre del campo que va a sumar. Para cambiar el encabezado de columna a algo que tenga más sentido, como Total de envíos, vuelva a la vista Diseño y haga clic en la fila Campo de la columna Gastos de envío en la cuadrícula de diseño. Coloque el cursor junto a Gastos de envío y escriba las palabras Total de envíos, seguidas por dos puntos, así: Total de envíos: Gastos de envío.

  7. De manera opcional, guarde la consulta y ciérrela.

Calcular un total general que excluye algunos registros

  1. En la ficha Crear, en el grupo Otros, haga clic en Diseño de la consulta.

  2. En el cuadro de diálogo Mostrar tabla, haga doble clic en la tabla Pedidos y en la tabla Detalles de pedidos y, después, haga clic en Cerrar para cerrar el cuadro de diálogo.

  3. Agregue el campo Fecha de pedido de la tabla Pedidos a la primera columna en la cuadrícula de diseño de consulta.

  4. En la fila Criterios de la primera columna, escriba Fecha() -1. Esta expresión excluye los registros del día actual del total calculado.

  5. Después, cree la columna que calcula el importe de ventas para cada transacción. Escriba la siguiente expresión en la fila Campo de la segunda columna en la cuadrícula:

    Valor total de ventas: (1-[Detalles de pedidos].[Descuento]/100)*([Detalles de pedidos].[Precio unitario]*[Detalles de pedidos].[Cantidad])

    Asegúrese de que la expresión hace referencia a campos establecidos en los tipos de datos Número o Moneda. Si la expresión hace referencia a campos establecidos en otros tipos de datos, Access muestra el mensaje No coinciden los tipos de datos en la expresión de criterios cuando intenta ejecutar la consulta.

  6. En la pestaña Diseño, en el grupo Mostrar u ocultar, haga clic en Totales.

    Aparece la fila Total en la cuadrícula de diseño y aparece Agrupar por en la primera y en la segunda columna.

  7. En la segunda columna, cambie el valor de la celda de la fila Total a Suma. La función Suma suma las cifras de ventas individuales.

  8. Haga clic en Ejecutar Imagen del botón para ejecutar la consulta y mostrar los resultados en la vista Hoja de datos.

  9. Guarde la consulta como Ventas diarias.

    Nota: La próxima vez que abra la consulta en la vista Diseño, puede que note un pequeño cambio en los valores especificados en las filas Campo y Total de la columna de Valor total de ventas. La expresión aparece dentro de la función Suma y en la fila Total se muestra Expresión en lugar de Suma.

    Por ejemplo, si usa los datos de ejemplo y crea la consulta (como se muestra en los pasos anteriores), verá:

    Valor total de ventas: Suma((1-[Detalles de pedidos].Descuento/100)*([Detalles de pedidos].PrecioUnitario*[Detalles de pedidos].Cantidad))

Principio de página

Calcular los totales de grupo con una consulta de totales

En los pasos de esta sección se explica cómo crear una consulta de totales que calcule subtotales de grupos de datos. Durante el proceso, recuerde que, de manera predeterminada, una consulta de totales solo puede incluir los campos que contienen los datos de grupo (como un campo de "categorías") y el campo que contiene los datos que quiera sumar (como un campo de "ventas"). Las consultas de totales no pueden incluir otros campos que describan los elementos de una categoría. Si quiere ver esos datos descriptivos, puede crear una segunda consulta de selección que combine los campos de la consulta de totales con los campos de datos adicionales.

En los pasos de esta sección se explica cómo crear las consultas de totales y de selección que necesita para identificar el total de ventas de cada producto. En los pasos se usan estas tablas de ejemplo:

La tabla Productos

Id. de producto

Nombre del producto

Precio

Categoría

1

Figura de acción Programador

12,95 $

Muñecos

2

Diversión con C# (un juego de mesa para toda la familia)

15,85 $

Juegos y puzles

3

Diagrama de base de datos relacional

22,50 $

Imágenes y marcos

4

El chip mágico (500 piezas)

32,65 $

Imágenes y marcos

5

Access, el juego

22,95 $

Juegos y puzles

6

Apasionados de la informática y criaturas mitológicas

78,50 $

Videojuegos

7

Ejercicio para apasionados de la informática, el DVD

14,88 $

DVD y películas

8

Pizza voladora definitiva

36,75 $

Deportes

9

Unidad de disquete de 5,25 pulgadas externa (escala de 1:4)

65,00 $

Modelos y aficiones

10

Figura Burócrata

78,88 $

Muñecos

11

Tristeza

53,33 $

Videojuegos

12

Cree su propio teclado

77,95 $

Modelos y aficiones

La tabla Detalles de pedidos

Id. de detalle

Id. de pedido

Nombre del producto

Id. de producto

Precio unitario

Cantidad

Descuento

1

1

Cree su propio teclado

12

77,95 $

9

5 %

2

1

Figura Burócrata

2

78,88 $

4

7,5 %

3

2

Ejercicio para apasionados de la informática, el DVD

7

14,88 $

6

4 %

4

2

El chip mágico

4

32,65 $

8

0

5

2

Apasionados de la informática y criaturas mitológicas

6

78,50 $

4

0 %

6

3

Access, el juego

5

22,95 $

5

15 %

7

4

Figura de acción Programador

1

12,95 $

2

6 %

8

4

Pizza voladora definitiva

8

36,75 $

8

4 %

9

5

Unidad de disquete de 5,25 pulgadas externa (escala de 1:4)

9

65,00 $

4

10 %

10

6

Diagrama de base de datos relacional

3

22,50 $

1,2

6,5 %

11

7

Tristeza

11

53,33 $

6

8 %

1,2

7

Diagrama de base de datos relacional

3

22,50 $

4

9 %

En los pasos siguientes se asume que existe una relación uno a varios entre los campos Id. de producto en la tabla Pedidos y la tabla Detalles de pedidos, con la tabla Pedidos en el lado "uno" de la relación.

Crear la consulta de totales

  1. En la ficha Crear, en el grupo Otros, haga clic en Diseño de la consulta.

  2. En el cuadro de diálogo Mostrar tabla, seleccione las tablas con las que quiera trabajar, haga clic en Agregar y, después, haga clic en Cerrar cuando haya terminado de agregar las tablas.

    -o-

    Haga doble clic en las tablas que quiera usar y luego haga clic en Cerrar. Cada tabla aparece como una ventana en la sección superior del diseñador de consultas.

    Si usa las tablas de ejemplo mostradas anteriormente, agregue las tablas Productos y Detalles de pedidos.

  3. Haga doble clic en los campos de tabla que quiera usar en la consulta.

    Como norma general, agregue únicamente el campo de grupo y el campo de valor a la consulta. Pero puede usar un cálculo en lugar de un campo de valor (en los pasos siguientes se explica cómo hacerlo).

    1. Agregue el campo Categoría de la tabla Productos a la cuadrícula de diseño.

    2. Cree la columna que calcula el importe de ventas para cada transacción al escribir la siguiente expresión en la segunda columna en la cuadrícula:

      Valor total de ventas: (1-[Detalles de pedidos].[Descuento]/100)*([Detalles de pedidos].[Precio unitario]*[Detalles de pedidos].[Cantidad])

      Asegúrese de que los campos a los que se hace referencia en la expresión son de los tipos de datos Número o Moneda. Si hace referencia a campos de otros tipos de datos, Access muestra el mensaje de error No coinciden los tipos de datos en la expresión de criterios cuando intenta cambiar a la vista Hoja de datos.

    3. En la pestaña Diseño, en el grupo Mostrar u ocultar, haga clic en Totales.

      Aparece la fila Total en la cuadrícula de diseño y, en esa fila, aparece Agrupar por en la primera y en la segunda columna.

    4. En la segunda columna, cambie el valor de la fila Total a Suma. La función Suma suma las cifras de ventas individuales.

    5. Haga clic en Ejecutar Imagen del botón para ejecutar la consulta y mostrar los resultados en la vista Hoja de datos.

    6. Mantenga la consulta abierta para usar en la siguiente sección.

      Usar criterios con una consulta de totales

      La consulta que creó en la sección anterior incluye todos los registros en las tablas subyacentes. No excluye ningún pedido al calcular los totales y muestra los totales de todas las categorías.

      Si necesita excluir algunos registros, puede agregar criterios a la consulta. Por ejemplo, puede ignorar las transacciones inferiores a 100 $ o calcular totales solo de algunas de las categorías de productos. En los pasos de esta sección se explica cómo usar tres tipos de criterios:

    7. Criterios que omiten determinados grupos al calcular los totales.    Por ejemplo, solo calculará los totales de las categorías Videojuegos, Imágenes y marcos, y Deportes.

    8. Criterios que ocultan determinados totales después de calcularlos.    Por ejemplo, puede mostrar solo los totales superiores a 150 000 $.

    9. Criterios que excluyen los registros individuales del total.    Por ejemplo, puede excluir transacciones de ventas individuales cuando el valor (precio unitario * cantidad) sea menor que 100 $.

      En los pasos siguientes se explica cómo agregar los criterios uno por uno y ver el impacto en el resultado de la consulta.

      Agregar criterios a la consulta

    10. Abra la consulta de la sección anterior en la vista Diseño. Para ello, haga clic con el botón derecho en la pestaña del documento de la consulta y haga clic en la Vista Diseño.

      -o-

      En el panel de navegación, haga clic con el botón derecho en la consulta y después haga clic en Vista Diseño.

    11. En la fila Criterios de la columna Id. de categoría, escriba = Muñecos O Deportes O Imágenes y marcos.

    12. Haga clic en Ejecutar Imagen del botón para ejecutar la consulta y mostrar los resultados en la vista Hoja de datos.

    13. Vuelva a cambiar a la vista Diseño y, en la fila Criterios de la columna de Valor total de ventas, escriba >100.

    14. Ejecute la consulta para ver los resultados y luego vuelva a la vista Diseño.

    15. Agregue los criterios para excluir las transacciones de ventas individuales que sean inferiores a 100 $. Para ello, tiene que agregar otra columna.

      Nota: No puede especificar el tercer criterio en la columna Valor total de ventas. Cualquier criterio que especifique en esta columna se aplica al valor total, no a los valores individuales.

    16. Copie la expresión de la segunda columna en la tercera columna.

    17. En la fila Total de la nueva columna, seleccione Dónde y, en la fila Criterios, escriba >20.

    18. Ejecute la consulta para ver los resultados y luego guarde la consulta.

      Nota: La próxima vez que abra la consulta en la vista Diseño, puede que note pequeños cambios en la cuadrícula de diseño. En la segunda columna, la expresión en la fila Campo aparecerá dentro de la función Suma y el valor de la fila Total mostrará Expresión en lugar de Suma.

      Valor total de ventas: Suma((1-[Detalles de pedidos].Descuento/100)*([Detalles de pedidos].PrecioUnitario*[Detalles de pedidos].Cantidad))

      También verá una cuarta columna. Esta columna es una copia de la segunda columna, pero los criterios que ha especificado en la segunda columna aparecen como parte de la nueva columna.

Principio de página

Sumar datos de varios grupos con una consulta de tabla de referencias cruzadas

Una consulta de tabla de referencias cruzadas es un tipo de consulta especial que muestra los resultados en una cuadrícula similar a una hoja de cálculo de Excel. Las consultas de tablas de referencias cruzadas resumen los valores y, después, vuelven a agruparlos por dos conjuntos de datos: un conjunto en el lateral (un conjunto de encabezados de fila) y el otro en la parte superior (un conjunto de encabezados de columna). En esta ilustración se muestra una parte del conjunto de resultados de la consulta de tabla de referencias cruzadas de ejemplo:

Una consulta de tabla de referencias cruzadas de ejemplo

Durante el proceso, recuerde que una consulta de tabla de referencias cruzadas no siempre rellena todos los campos en el conjunto de resultados, ya que las tablas que usa en la consulta no siempre contienen valores para cada punto de datos posible.

Al crear una consulta de tabla de referencias cruzadas, normalmente se incluyen datos de más de una tabla y siempre se incluyen tres tipos de datos: los datos que se usan como encabezados de fila, los datos que se usan como encabezados de columna y los valores que quiera sumar o calcular.

En los pasos de esta sección se usan las tablas siguientes:

La tabla Pedidos

Fecha del pedido

Fecha de envío

Ciudad de envío

Gastos de envío

14/11/2005

15/11/2005

Yakarta

55,00 $

14/11/2005

15/11/2005

Sídney

76,00 $

16/11/2005

17/11/2005

Sídney

87,00 $

17/11/2005

18/11/2005

Yakarta

43,00 $

17/11/2005

18/11/2005

París

105,00 $

17/11/2005

18/11/2005

Stuttgart

112,00 $

18/11/2005

19/11/2005

Viena

215,00 $

19/11/2005

20/11/2005

Miami

525,00 $

20/11/2005

21/11/2005

Viena

198,00 $

20/11/2005

21/11/2005

París

187,00 $

21/11/2005

22/11/2005

Sídney

81,00 $

23/11/2005

24/11/2005

Yakarta

92,00 $

La tabla Detalles de pedidos

Id. de pedido

Nombre del producto

Id. de producto

Precio unitario

Cantidad

Descuento

1

Cree su propio teclado

12

77,95 $

9

5 %

1

Figura Burócrata

2

78,88 $

4

7,5 %

2

Ejercicio para apasionados de la informática, el DVD

7

14,88 $

6

4 %

2

El chip mágico

4

32,65 $

8

0

2

Apasionados de la informática y criaturas mitológicas

6

78,50 $

4

0

3

Access, el juego

5

22,95 $

5

15 %

4

Figura de acción Programador

1

12,95 $

2

6 %

4

Pizza voladora definitiva

8

36,75 $

8

4 %

5

Unidad de disquete de 5,25 pulgadas externa (escala de 1:4)

9

65,00 $

4

10 %

6

Diagrama de base de datos relacional

3

22,50 $

1,2

6,5 %

7

Tristeza

11

53,33 $

6

8 %

7

Diagrama de base de datos relacional

3

22,50 $

4

9 %

En los pasos siguientes se explica cómo crear una consulta de tabla de referencias cruzadas que agrupe el total de ventas por ciudad. La consulta usa dos expresiones para devolver una fecha con formato y un total de ventas.

Crear una consulta de tabla de referencias cruzadas

  1. En la ficha Crear, en el grupo Otros, haga clic en Diseño de la consulta.

  2. En el cuadro de diálogo Mostrar tablas, haga doble clic en las tablas que quiera usar en la consulta y, después, haga clic en Cerrar.

    Cada tabla aparece como una ventana en la sección superior del diseñador de consultas.

    Si usa las tablas de ejemplo, haga doble clic en la tabla Pedidos y en la tabla Detalles de pedidos.

  3. Haga doble clic en los campos que quiera usar en la consulta.

    Cada nombre de campo aparece en una celda en blanco de la fila Campo de la cuadrícula de diseño.

    Si usa las tablas de ejemplo, agregue los campos Ciudad de envío y Fecha de envío de la tabla Pedidos.

  4. En la siguiente celda en blanco en la fila Campo, copie y pegue o escriba la siguiente expresión: Total de ventas: Suma (CCur([Detalles de pedidos].[Precio Unitario]*[Cantidad]*(1-[Descuento])/100)*100)

  5. En la pestaña Diseño, en el grupo Tipo de consulta, haga clic en Tabla de referencias cruzadas.

    Las filas Total y Tabla de referencias cruzadas aparecen en la cuadrícula de diseño.

  6. Haga clic en la celda de la fila Total del campo Ciudad y seleccione Agrupar por. Haga lo mismo en el campo Fecha de envío. Cambie el valor de la celda Total del campo Total de ventas a Expresión.

  7. En la fila Tabla de referencias cruzadas, establezca la celda del campo Ciudad en Encabezado de fila, establezca el campo Fecha de envío en Encabezado de columna y establezca el campo Total de ventas en Valor.

  8. En la pestaña Diseño, en el grupo Resultados, haga clic en Ejecutar.

    Los resultados de la consulta aparecen en la vista Hoja de datos.

Principio de página

Referencia de la función de agregado

Esta tabla enumera y describe las funciones de agregado que proporciona Access en la fila de Total y en las consultas. Recuerde que Access proporciona más funciones de agregado para consultas que para la fila de total. Además, si trabaja con un proyecto de Access (un front-end de Access conectado a una base de datos de Microsoft SQL Server), puede usar el conjunto mayor de funciones de agregado que ofrece SQL Server. Para más información sobre ese conjunto de funciones, vea los Libros en pantalla de Microsoft SQL Server.

Función

Descripción

Se usa con los tipos de datos

Promedio

Calcula el valor promedio de una columna. La columna tiene que contener datos numéricos, de moneda o de fecha y hora. La función omite los valores nulos.

Número, moneda, fecha y hora

Cuenta

Cuenta el número de elementos en una columna.

Todos los tipos de datos excepto datos escalares de repetición complejos, como una columna de listas multivalor.

Para más información sobre las listas multivalor, vea los artículos Guía de campos multivalor y Agregar o cambiar una columna de búsqueda que permita almacenar varios valores.

Máximo

Devuelve el elemento con el valor más alto. Para datos de texto, el valor más alto es el último valor alfabético (Access no distingue mayúsculas de minúsculas). La función omite los valores nulos.

Número, moneda, fecha y hora

Mínimo

Devuelve el elemento con el valor más bajo. Para datos de texto, el valor más bajo es el primer valor alfabético (Access no distingue mayúsculas de minúsculas). La función omite los valores nulos.

Número, moneda, fecha y hora

Desviación estándar

Mide cómo se distribuyen los valores respecto a un valor promedio (una media).

Para más información sobre cómo usar esta función, vea el artículo Mostrar totales de columna en una hoja de datos.

Número, moneda

Suma

Agrega los elementos de una columna. Funciona solo en datos numéricos y de moneda.

Número, moneda

Varianza

Mide la varianza estadística de todos los valores de la columna. Esta función solo se puede usar en datos numéricos y de moneda. Si la tabla contiene menos de dos filas, Access devuelve un valor nulo.

Para más información sobre las funciones de varianza, vea el artículo Mostrar totales de columna en una hoja de datos.

Número, moneda

Principio de página

Notas: 

  • Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

  • Para su referencia, puede encontrar la versión en inglés de este artículo aquí. Todos los miembros de la comunidad de Microsoft pueden mejorar este artículo mediante el marco de colaboración en traducciones (CTF). Simplemente, mueva el puntero sobre cualquier frase del artículo y, a continuación, haga clic en "MEJORAR TRADUCCIÓN" en el widget CTF. Haga clic aquí para obtener más información acerca de CTF. Con el uso de CTF, el usuario acepta nuestras Condiciones del servicio.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×