Seleccionar y usar las plantillas de Access 2007

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

En este artículo

Información general

Paso 1: Seleccione una plantilla

Paso 2: Personalizar una plantilla

Paso 3: Agregar datos a la base de datos nueva

Paso 4: Buscar registros


Información general

Para que resulte más sencillo comenzar a usar una base de datos eficiente, Microsoft Office Access ofrece varias plantillas de bases de datos diseñadas de manera profesional. Cada plantilla crea una solución completa descentralizada que puede usar sin modificaciones o personalizar para adaptarla a sus necesidades. Cada plantilla contiene tablas, formularios, informes, consultas, macros y relaciones predefinidos que pueden proporcionarle ideas para personalizar su propia base de datos.

Además, puede descargar fácilmente otras plantillas de bases de datos de Access del sitio web de Microsoft Office Online haciendo clic en los vínculos dentro de Access. Después de seleccionar una plantilla y de personalizarla para adaptarla a sus necesidades, puede agregar datos y comenzar la navegación por los registros.

Paso 1: Seleccionar una plantilla

Puede seleccionar una de las plantillas que se instala con Access, o buscar una plantilla en línea.

Seleccionar una plantilla instalada

  1. En la ventana Introducción a Microsoft Access, en Categorías de plantillas, haga clic en Plantillas locales.

    Lista de plantillas disponibles   

Plantilla

Se usa para

Activos

Hacer un seguimiento de los activos, incluidos los detalles y los propietarios de los activos. Puede colocar activos en categorías y registrar su condición, fecha de adquisición, ubicación y propietario.

Contactos

Administrar información sobre personas con las que trabaja su equipo, por ejemplo, clientes y socios. Puede realizar un seguimiento de la información de nombre y dirección, números de teléfono, direcciones de correo electrónico e incluso adjuntar una imagen.

Eventos

Realizar un seguimiento de las próximas reuniones, plazos y otros eventos importantes. Registrar un título, una ubicación, una fecha de inicio, una fecha de finalización, una descripción y además adjuntar una imagen.

Profesores

Administrar información importante acerca de los miembros del profesorado, como los números de teléfono, las direcciones, la información de los contactos para emergencias y datos sobre el empleo.

Problemas

Administrar y realizar un seguimiento de un conjunto de problemas. Puede asignar, establecer la prioridad y seguir el progreso de los problemas desde el principio hasta el final.

Proyectos de marketing

Administrar los detalles de un proyecto de marketing y programar y supervisar las entregas del proyecto.

Proyectos

Administrar las tareas y realizar un seguimiento del presupuesto de uno o más proyectos.

Canalización de ventas

Supervisar el progreso de la prospección de ventas en un pequeño grupo de profesionales de ventas.

Alumnos

Administrar información relativa a los alumnos, incluidos los contactos para emergencias, información médica e información acerca de sus tutores.

Tareas

Realice un seguimiento de un grupo de elementos de trabajo que usted o su grupo deban realizar.

Northwind 2007

Crear un sistema de seguimiento de pedidos. Debe eliminar los datos incluidos como ejemplo.

  1. Haga clic en la plantilla que desea usar como modelo para la base de datos.

  2. En el cuadro Nombre de archivo, escriba un nombre para la base de datos.

  3. Para seleccionar una ubicación específica para la nueva base de datos, haga clic en el icono de archivo situado junto al cuadro Nombre de archivo.

    Sugerencia: Para vincular la base de datos a un sitio de Windows SharePoint Services, active la casilla Crear y vincular la base de datos a un sitio de Windows SharePoint Services.

  4. Haga clic en Crear.

La nueva base de datos ya puede usarse y se puede personalizar según sus preferencias.

Seleccionar una plantilla en línea

  1. En la ventana Introducción a Microsoft Access, siga uno de estos procedimientos:

    • Para examinar todas las plantillas ofrecidas en línea, en Categorías de plantillas, haga clic en Destacado y, a continuación, seleccione la plantilla que desea.

    • Para seleccionar una plantilla en línea según un tema, haga clic en un tema en Microsoft en línea, a continuación, seleccione la plantilla que desea.

  2. En el cuadro Nombre de archivo, escriba un nombre nuevo para la plantilla y luego haga clic en el icono de archivo situado junto al cuadro de texto para seleccionar una ubicación específica para la nueva base de datos.

  3. Haga clic en Descargar.

Sugerencia: Para vincular la base de datos a un sitio de Microsoft Windows SharePoint Services, active la casilla Crear y vincular la base de datos a un sitio de Windows SharePoint Services.

La nueva base de datos ya puede usarse y se puede personalizar según sus preferencias.

Volver al principio

Paso 2: Personalizar una plantilla

Después de seleccionar la plantilla de base de datos, puede personalizarla para adaptarla a sus necesidades. Una base de datos creada a partir de una plantilla contiene una serie de tablas, formularios e informes prediseñados e integrados con los que puede trabajar inmediatamente. Cuando crea una base de datos a partir de una plantilla, Access crea las tablas y otros objetos necesarios para respaldar el objetivo para el cual se diseñó la plantilla. En algunos casos, la estructura de la base de datos de la plantilla es compleja y podría ser necesario personalizar algunas de sus partes. Si realiza cambios en el diseño de las tablas proporcionadas, debe tener cuidado de no invalidar las relaciones existentes. Si observa que debe hacer muchos cambios en la estructura de una plantilla, puede resultar más sencillo comenzar con una base de datos en blanco.

Al personalizar una plantilla, intente evitar cambiar el nombre de los campos o las tablas. Es posible que estos campos y tablas se usen en otros objetos de base de datos, como formularios e informes, y si les cambia el nombre, es posible que otros objetos de base de datos a los que hacen referencia o de los que dependen esos nombres de campos y tablas no funcionen adecuadamente. Antes de cambiar el nombre de una tabla en el panel de navegación o de cambiar el nombre de un campo en la vista Hoja de datos o en la vista Diseño, debe asegurarse de que la característica Autocorrección de nombres esté activada. La característica Autocorrección de nombres propaga automáticamente los cambios de nombre de los campos, formularios o informes a otros objetos en toda la base de datos. Generalmente, la configuración Autocorrección de nombres está activada de forma predeterminada para todas las bases de datos nuevas.

Personalizar un formulario o un informe

Puede personalizar una plantilla de formulario o un informe de varias maneras. Por ejemplo, para cambiar el formato de un formulario, ábralo en la vista Diseño y, a continuación, elija un nuevo formato desde el grupo Formato automático (en la ficha Formato). También puede personalizar un formulario o informe si agrega campos. Al agregar un campo a un formulario o informe, crea un control en ese formulario o informe. Si desea personalizar los controles existentes en una plantilla, puede cambiar las propiedades de esos controles.

Agregar un nuevo control a un formulario o informe

  1. En el panel de navegación, haga clic con el botón secundario en el formulario o informe al cual desea agregar el control y, a continuación, haga clic en Vista Diseño.

  2. Haga clic en la ficha Diseño.

  3. En el grupo Controles, haga clic en el control que desea agregar y, a continuación, haga clic en Utilizar Asistentes para controles.

    Comando Utilizar Asistentes para controles del grupo Controles

  4. Siga los pasos del asistente para crear y personalizar el nuevo control.

Para obtener más información sobre cómo crear formularios e informes, vea los vínculos de la sección Vea también.

Cambiar un control

Puede personalizar la manera en que se muestra un control ya existente en un formulario o informe. Para cambiar un formato de presentación, cambie la propiedad Formato de un campo. Los controles basados en este campo heredan automáticamente la propiedad Formato en los nuevos formularios e informes que cree.

Definir el formato de presentación en la vista Hoja de datos

  1. Haga clic en el botón de Microsoft Office Imagen del botón de Office y, a continuación, en Abrir.

  2. En el cuadro de diálogo Abrir, abra la base de datos que contiene el control que desea cambiar.

  3. En el panel de navegación, haga doble clic en la tabla que contiene el campo cuyo formato desea establecer.

    La tabla se abre en la vista Hoja de datos.

  4. Haga clic en el campo cuyo formato de presentación desea establecer.

  5. En la ficha hoja de datos, en el grupo formato y tipo de datos, haga clic en la flecha en la lista desplegable situada junto a formato y, a continuación, seleccione un formato. Imagen de la cinta de opciones de Access del grupo Formato y tipo de datos

    El campo se muestra con el nuevo formato de presentación aplicado.

Definir el formato de presentación en la vista Diseño

  1. Haga clic en el botón de Microsoft Office Imagen del botón de Office y, a continuación, en Abrir.

  2. En el cuadro de diálogo Abrir, abra la base de datos que contiene el control que desea cambiar.

  3. En el panel de navegación, haga clic con el botón secundario en la tabla que contiene el campo cuyo formato de presentación desea cambiar y, a continuación, haga clic en Vista Diseño.

    La tabla se abre en la vista Diseño.

  4. Haga clic en el campo cuyo formato de presentación desea establecer.

  5. En Propiedades del campo, en la ficha General, seleccione un formato de presentación en la lista Formato.

  6. Para guardar los cambios, haga clic en Guardar en la Barra de herramientas de acceso rápido.

Volver al principio

Paso 3: Agregar datos a la nueva base de datos

Después de seleccionar una plantilla y realizar la personalización necesaria, puede agregar los datos a la base de datos importándolos o vinculándolos a datos externos.

Importar datos

Puede importar datos en varios formatos, entre otros, libros de Excel, listas de Windows SharePoint Services 3.0, libretas de direcciones de Outlook u otras bases de datos de Access.

  • Para importar datos, en la ficha Datos externos, en el grupo Importar, haga clic en el comando correspondiente al tipo de archivo que va a importar.

    Botones de comando en el grupo Importar

    Notas: 

    • Si no ve un icono para el tipo de datos que desea importar, haga clic en Más y, a continuación, siga las instrucciones del cuadro de diálogo Obtener datos externos.

    • Si no puede encontrar un comando para importar los datos externos, es posible que tenga que iniciar el programa en el que creó los datos originalmente (esto se haría fuera de Access) y, a continuación, usar ese programa para guardar los datos en un formato de archivo común (como un archivo de texto delimitado). A continuación, vuelva a Access y use uno de los comandos de datos externos para importar esos datos.

  • En la última página del asistente, es posible que se le pida que guarde los detalles de estos pasos del proceso de importación. Guardar los detalles puede ser útil si importa datos desde ese mismo origen de datos en el futuro. Active la casilla Guardar pasos de importación, escriba los detalles y, a continuación, haga clic en Guardar importación. Ahora puede repetir la misma importación en cualquier momento haciendo clic en Importaciones guardadas en el grupo Importar de la ficha Datos externos. Si no desea guardar los detalles de esta operación de importación, haga clic en Cerrar.

Vincular a datos

Cuando se vincula a datos, éstos permanecen almacenados en el formato original y aparecen como una tabla vinculada en la nueva base de datos. Para la mayoría de los formatos de archivo, los datos se pueden ver y modificar con Access o el programa original en el que se crearon porque ambos usan los mismos datos físicos. Sin embargo, si los datos están almacenados en un libro de Excel, sólo puede ver los datos vinculados en Access; no puede modificarlos. Para modificar los datos de un libro vinculado, debe usar Excel.

    1. Haga clic en el botón de Microsoft Office Imagen del botón de Office y, a continuación, en Abrir.

    2. En el cuadro de diálogo Abrir, seleccione y abra la base de datos.

    3. En la ficha Datos externos, en el grupo Importar, haga clic en el comando correspondiente al tipo de archivo al que desee vincular. Por ejemplo, si desea vincular a los datos de un libro de Excel, haga clic en Excel. Si no ve un icono para el tipo de datos que desea vincular, haga clic en Más.

      Aparece el cuadro de diálogo Obtener datos externos.

      Nota: Si no puede encontrar un comando para vincular a los datos externos, es posible que tenga que iniciar el programa (esto se haría fuera de Access) en el que creó los datos originalmente y, a continuación, usar ese programa para guardar los datos en un formato de archivo común (como un archivo de texto delimitado). A continuación, vuelva a Access y use uno de los comandos de datos externos para vincular a esos datos.

    4. En el cuadro de diálogo Obtener datos externos, haga clic en Examinar para buscar el archivo de datos de origen o escriba la ruta de acceso completa del archivo de datos de origen en el cuadro Nombre de archivo.

    5. Haga clic en la opción que desee en Especifique cómo y dónde desea almacenar los datos en la base de datos actual.

      Para la mayoría de los formatos de archivo, se inicia un asistente. No obstante, si está vinculando a datos de una base de datos de Access, aparece el cuadro de diálogo Importar objeto. Seleccione las opciones en el cuadro de diálogo Vincular tablas y, a continuación, prosiga con el paso 7. En caso contrario, continúe con el paso 6.

    6. Complete los pasos del asistente. El proceso exacto que debe seguir depende de las opciones que elija.

Volver al principio

Paso 4: Ubicar registros

Después de importar los datos a la base de datos, necesitará una forma eficiente de ubicar registros específicos. Puede usar la barra de herramientas de la parte inferior de la base de datos para ubicar los registros.

Botones de desplazamiento

Use los botones de navegación para buscar registros en una tabla o vista.:

Botón de navegación

Usar para ir a

1.

Primer registro

2.

Registro anterior

3.

Registro específico: haga clic en el cuadro de texto, escriba el número de registro y, a continuación, presione ENTRAR para mostrar ese registro. Los números de registro se cuentan secuencialmente desde el comienzo del formulario u hoja de datos.

4.

Registro siguiente

5.

Último registro

6.

Nuevo registro (vacío)

7.

Filtro:  este indicador muestra si se aplicó un filtro. Si no hay ningún filtro aplicado o se han borrado todos los filtros, se muestra el indicador Sin filtro.

8.

Cuadro Buscar: escriba texto en el cuadro Buscar y el primer valor coincidente se resalta en tiempo real a medida que escribe cada carácter. Use esta característica para buscar rápidamente un registro.

Opciones adicionales para ubicar registros

Además puede ubicar registros con uno de los siguientes métodos.

Ir a un registro específico

Buscar un registro específico

Aplicar un filtro para mostrar solo un conjunto concreto de registros

Realizar una búsqueda personalizada mediante una consulta

Ir a un registro específico

Algunas plantillas contienen formularios que cuentan con la opción para ver un registro concreto con una lista desplegable Ir a. Por ejemplo, el formulario Detalles de contactos de la plantilla Contactos y el formulario Proyectos y tareas de la plantilla Proyectos de marketing cuentan con esta opción. Puede usar esta opción para ver un registro específico desde una lista desplegable. Si está disponible, el cuadro Ir a está ubicado en la parte superior izquierda del formulario.

  1. Haga clic en la flecha que hay junto a la lista Ir a.

    El cuadro Ir a

  2. Haga clic en el registro que desea ver.

Buscar un registro específico

Use la ficha Buscar del cuadro de diálogo Buscar y reemplazar para buscar registros específicos. Puede buscar en un campo concreto o en una tabla o vista completa.

Nota: Puede usar el cuadro de diálogo Buscar y reemplazar sólo si la tabla o vista muestran datos actualmente.

  1. Abra la tabla en la que desea realizar la búsqueda y, a continuación, haga clic en el campo que contiene el registro que desea buscar.

  2. En la ficha Inicio, en el grupo Buscar, haga clic en Buscar.

    Botón de comando Buscar

  3. En el cuadro de diálogo Buscar y reemplazar, escriba el criterio de búsqueda en el cuadro Buscar.

  4. En la lista Buscar, seleccione Todo y, a continuación, haga clic en Buscar siguiente.

Para obtener más información sobre cómo usar el cuadro de diálogo Buscar y reemplazar, vea los vínculos de la sección Vea también.

Filtrar para mostrar sólo un conjunto específico de registros

Puede activar o desactivar un filtro para cambiar con facilidad entre las vistas filtradas y sin filtro de los mismos datos.

Puede aplicar un filtro para limitar los registros mostrados a los que cumplen los criterios. Al aplicar un filtro, será más sencillo buscar los registros que desee. Por ejemplo, para limitar rápidamente los registros mostrados, haga clic con el botón secundario en un campo cuyo valor desee hacer coincidir y, a continuación, seleccione una de las opciones del menú de selección: Igual a, No es igual a, Contiene o No contiene.

  • Abra la tabla o el formulario al que desee agregar un filtro.

  • Para asegurarse de que la tabla o el formulario aún no están filtrados, en la ficha Inicio, en el grupo Ordenar y filtrar, haga clic en Opciones avanzadas y, a continuación, en Borrar todos los filtros. Si este comando no está disponible (atenuado), no se aplicó ningún filtro.

    Grupo Ordenar y filtrar

  • Para aplicar un filtro, haga clic en el campo que desee filtrar y, a continuación, en la ficha Inicio, en el grupo Ordenar y filtrar, haga clic en Filtrar y seleccione una opción de filtrado.

  • Para aplicar un filtro que se basa en una selección, abra una tabla o formulario y navegue hasta el registro que contiene el valor que desea usar como parte del filtro. A continuación, haga clic en el campo. En la ficha Inicio, en el grupo Ordenar y filtrar, haga clic en selección y, a continuación, haga clic en el filtro que desea aplicar.

  • Para aplicar un filtro que basa una selección parcial, seleccione solo los caracteres que desee. En la ficha Inicio, en el grupo Ordenar y filtrar, haga clic en selección y, a continuación, haga clic en el filtro que desea aplicar.

Para obtener más información sobre la aplicación de un filtro, vea los vínculos de la sección Vea también.

Realizar una búsqueda personalizada con una consulta

Puede usar las consultas para realizar búsquedas personalizadas, aplicar filtros personalizados y ordenar registros. Las consultas se pueden guardar y reutilizar y pueden utilizarse para crear formularios e informes. También puede usar una consulta para buscar solo los registros de la tabla que le interesa. El tipo de consulta que cree depende de los registros que desee incluir y si desea que Access hacer nada con los resultados.

  1. En la ficha Crear, en el grupo Otros, haga clic en Asistente para consultas.

    Comando Asistente para consultas en el grupo Otros

  2. Siga los pasos del Asistente para consultas.

Para obtener más información sobre cómo crear consultas, vea los vínculos de la sección Vea también.

Volver al principio

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×