SUMAR.SI.CONJUNTO (función SUMAR.SI.CONJUNTO)

En este artículo se describe la sintaxis de la fórmula y el uso de la funciónSUMAR.SI.CONJUNTO de Microsoft Excel.

Descripción

Agrega las celdas de un intervalo que cumpla con varios criterios. Por ejemplo, si desea sumar los números del rango A1:A20 solo si los números de B1:B20 correspondientes son mayores que cero (0) y los números de C1:C20 correspondientes son menores que 10, puede usar la siguiente fórmula:

=SUMAR.SI.CONJUNTO(A1:A20, B1:B20, ">0", C1:C20, "<10")

Importante   El orden de los argumentos es diferente entre las funciones SUMAR.SI.CONJUNTO y SUMAR.SI. Concretamente, el argumento rango_suma es el primer argumento de SUMAR.SI.CONJUNTO, pero es el tercero de SUMAR.SI. Si copia o modifica estas funciones similares, asegúrese de poner los argumentos en el orden correcto.

Sintaxis

SUMAR.SI.CONJUNTO( rango_suma , rango_criterios1, criterios1, [rango_criterios2, criterios2], ...)

La sintaxis de la función SUMAR.SI.CONJUNTO tiene los siguientes argumento:

  • Rango_suma    Obligatorio. Una o más celdas para sumar, incluidos números o nombres, rangos o referencia de celda que contengan números. Se omiten los valores en blanco o de texto.

  • Rango_criterios1    Obligatorio. El primer rango en el que se evalúan los criterios asociados.

  • Criterios1    Obligatorio. Los criterios en forma de número, expresión, referencia de celda o texto que define qué celdas del argumento rango_criterios1 se agregarán. Por ejemplo, los criterios se pueden expresar como 32, ">32", B4, "manzanas" o "32".

  • rango_criterios2; criterios2; …    Opcional. Rangos adicionales y sus criterios asociados. Se permiten hasta 127 pares de rangos/criterios.

Observaciones

  • Las celdas del argumento rango_suma se suman solo si se cumplen los criterios correspondientes especificados para esa celda. Por ejemplo, supongamos que una fórmula contiene dos argumentos rango_criterios. Si la primera celda de rango_criterios1 cumple con criterios1 y la primera celda de rango_criterios2 cumple con criterios2, se agrega la primera celda de rango_suma a la suma y así sucesivamente para todas las celdas restantes de los rangos especificados.

  • Las celdas del argumento rango_suma que contienen VERDADERO se evalúan como 1; las celdas de rango_suma que contienen FALSO se evalúan como 0 (cero).

  • A diferencia de los argumentos rango y criterios de la función SUMAR.SI, en la función SUMAR.SI.CONJUNTO, cada argumento rango_criterios debe contener el mismo número de filas y columnas que el argumento rango_suma.

  • Puede usar caracteres comodín como el signo de interrogación : el signo de interrogación (?) y el asterisco (*) , en los criterios. El signo de interrogación corresponde a solo carácter cualquiera y el asterisco equivale a cualquier secuencia de caracteres. Si desea buscar un signo de interrogación o un asterisco reales, escriba una tilde (~) delante del caracter.

Ejemplos

El libro siguiente muestra ejemplos de esta función. Inspecciónelos, cambie las fórmulas existentes o escriba sus propias fórmulas para conocer el funcionamiento de la función.

Copie los datos del ejemplo en la siguiente tabla y péguelos en la celda A1 de una nueva hoja de cálculo de Excel. Para las fórmulas que muestren resultados, selecciónelas, presione F2 y, a continuación, presione Entrar. Si lo necesita, puede ajustar los anchos de la columna para ver todos los datos.

Cantidad vendida

Producto

Vendedor

5

Manzanas

1

4

Manzanas

2

15

Alcachofas

1

3

Alcachofas

2

22

Plátanos

1

12

Plátanos

2

10

Zanahorias

1

33

Zanahorias

2

Fórmula

Descripción

Resultado

=SUMAR.SI.CONJUNTO(A2:A9; B2:B9; "=A*"; C2:C9; 1)

Agrega el número total de productos vendidos que empiezan por "A" y que vendió el vendedor 1.

20

=SUMAR.SI.CONJUNTO(A2:A9; B2:B9; "<>Plátanos"; C2:C9; 1)

Agrega la cantidad total de productos (sin incluir los plátanos) vendidos por el vendedor 1.

30

Para trabajar en profundidad con los datos de ejemplo en Excel, descargue el libro incrustado en su equipo y, a continuación, ábralo en Excel.

Ejemplo 2

Totales

Cuenta 1

Cuenta 2

Cuenta 3

Cuenta 4

Cantidad en dólares

100,00 $

390,00 $

8321,00 $

500,00 $

Tasa de interés (2000)

1%

0,5%

3%

4%

Tasa de interés (2001)

1%

1,3%

2,1%

2%

Tasa de interés (2002)

0,5%

3%

1%

4%

Fórmula

Descripción

Resultado

=SUMAR.SI.CONJUNTO(B2:E2; B3:E3; ">3%"; B4:E4; ">=2%")

Importes totales de cada una de las cuentas bancarias en las que el interés era mayor que 3% para el año 2000 y mayor o igual que 2% para el año 2001. Solo la cuenta 4 satisface ambas condiciones.

500,00 $

=SUMAR.SI.CONJUNTO(B2:E2; B5:E5; ">=1%"; B5:E5; "<=3%"; B4:E4; ">1%")

Importes totales de cada una de las cuentas bancarias en las que el interés era entre 1% y 3% para el año 2002 y mayor que 1% para el año 2001. Las cuentas 2 y 3 satisfacen ambas condiciones.

8711,00 $

Ejemplo 3

Medidas diarias

Día 1

Día 2

Día 3

Día 4

Lluvia (pulgadas totales)

3,3

0,8

5,5

5,5

Temperatura media (grados)

55

39

39

58

Velocidad media del viento (millas por hora)

6,5

19,5

6

6,5

Fórmula

Descripción

Resultado

=SUMAR.SI.CONJUNTO(B2:E2; B3:E3; ">=40"; B4:E4; "<10")

Agrega la cantidad total de lluvia de los días en que la temperatura promedio era de al menos 40° Fahrenheit y la velocidad promedio del viento era menor de 10 millas por hora.

8,8

Nota

Solo se suman las celdas B2 y E2 porque, para cada columna (de B a E), los valores de las filas 3 y 4 deben cumplir con los criterios1 y los criterios2 respectivamente. Las celdas B3 y B4 cumplen con ambos criterios, al igual que E3 y E4. Sin embargo, C3 y C4 no cumplen con ninguno de los criterios. Por último, aunque D4 cumple con los criterios2, D3 no cumple con los criterios1.

Ejemplo 4

Medidas de mañana y tarde

Día 1

Día 2

Día 3

Día 4

a.m.: lluvia (pulgadas totales)

1,3

0

1,5

3

p.m.: lluvia (pulgadas totales)

2

0,8

4

2,5

a.m.: temperatura media (grados)

56

44

40

38

p.m.: temperatura media (grados)

54

34

38

77

a.m.: velocidad media del viento (millas por hora)

13

6

9

1

p.m.: velocidad media del viento (millas por hora)

0

33

4

12

Fórmula

Descripción

Resultado

=SUMAR.SI.CONJUNTO(B2:E3; B4:E5; ">=40"; B6:E7; "<10")

Agrega la cantidad total de lluvias para los períodos de 12 horas en los que la temperatura promedio era de al menos 40° Fahrenheit y la velocidad promedio del viento era menor de 10 millas por hora.

3,5

Notas

Solo se suman las celdas B3, C2, y D2, ya que sus celdas correspondientes cumplen con ambos criterios. Las celdas correspondientes de B3 son B5 y B7, las celdas correspondientes de C2 son C4 y C6, y las celdas correspondientes de D2 son D4 y D6.

Como ejemplo de los datos excluidos de la operación, las celdas correspondientes de B2 (B4 y B6) no cumplen con ambos criterios; concretamente, la celda B6 se excluye porque su valor (13) es mayor que el valor del argumento criterios2 (10).

Ejemplo 5

Casas

Metros cuadrados

Dormitorios

Baños

Garaje

Año de construcción

Precio

Casa1

1200

2

1

1940

125.000 $

Casa2

1580

3

1,5

no

1965

217.000 $

Casa3

2200

4

3

2003

376.000 $

Casa4

2000

3

2,5

2001

249.000 $

Casa5

2140

4

3

1998

199.000 $

>2

y*

Fórmula

Descripción

Resultado

=SUMAR.SI.CONJUNTO(G2:G6;C2:C6;A7;E2:E6;B7;F2:F6;">1999";F2:F6;"<2004")

Suma el precio de las casas que tengan al menos 3 dormitorios, un garaje y que tengan entre 5 y 10 años en el año 2009.

625.000 $

=PROMEDIO.SI.CONJUNTO(G2:G6;C2:C6;">2";E2:E6;C7;F2:F6;">1999";F2:F6;"<2004")

Devuelve el precio promedio de las casas que tengan al menos 3 dormitorios, un garaje y que tengan entre 5 y 10 años de antigüedad en el año 2009. Además de "2" y "1999," la fórmula usa C7 (y*) como criterio de carácter comodín.

312.500 $

Principio de página

Se aplica a: Excel 2013, Excel Online



¿Le ha sido útil esta información?

No

¿Cómo podemos mejorarlo?

255 caracteres restantes

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!

Recursos de soporte técnico

Cambiar idioma