SUMAPRODUCTO (función SUMAPRODUCTO)

En este artículo se describen la sintaxis de la fórmula y el uso de la función SUMAPRODUCTO en Microsoft Excel.

Descripción

Multiplica los componentes correspondientes de las matrices suministradas y devuelve la suma de esos productos.

Sintaxis

SUMAPRODUCTO(matriz1, [matriz2], [matriz3], ...)

La sintaxis de la función SUMAPRODUCTO tiene los siguientes argumentos:

  • Matriz1     Obligatorio. Es el primer argumento de matriz cuyos componentes desea multiplicar y después sumar.

  • Matriz2, matriz3,...     Opcional. De 2 a 255 matrices cuyos componentes desea multiplicar y después sumar.

Observaciones

  • Los argumentos de matriz deben tener las mismas dimensiones. De lo contrario, SUMAPRODUCTO devuelve el valor de error #¡VALOR!.

  • SUMAPRODUCTO considera las entradas de matriz no numéricas como 0.

Ejemplo

Copie los datos de ejemplo en la tabla siguiente y péguelos en la celda A1 de una hoja de cálculo nueva de Excel. Para que las fórmulas muestren los resultados, selecciónelas, presione F2 y luego ENTRAR. Si lo necesita, puede ajustar el ancho de las columnas para ver todos los datos.

Matriz 1

Matriz 2 

3

4

2

7

8

6

6

7

1

9

5

3

Fórmula

Descripción

Resultado

=SUMAPRODUCTO(A2:B4; D2:E4)

Multiplica todos los componentes de las dos matrices y, a continuación, agrega los productos , es decir, 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156).

156

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×