SI (función SI)

Este artículo describe la sintaxis de la fórmula y el uso de la funciónSI en Microsoft Excel.

Descripción

La función SI devuelve un valor si una condición especificada se evalúa como VERDADERO y otro valor si se evalúa como FALSO. Por ejemplo, la fórmula =SI(A1>10,"Más de 10","10 o menos") devuelve "Más de 10" si A1 es mayor que 10 y "10 o menos" si A1 es menor o igual que 10.

Sintaxis

SI(prueba_lógica, [valor_si_verdadero], [valor_si_falso])

La sintaxis de la función SI tiene los siguientes argumento:

  • Prueba_lógica    Obligatorio. Es cualquier valor o expresión que pueda evaluarse como VERDADERO o FALSO. Por ejemplo, A10=100 es una expresión lógica; si el valor de la celda A10 es igual a 100, la expresión se evalúa como VERDADERO. De lo contrario, se evaluará como FALSO. Este argumento puede usar cualquier operador de comparación.

  • Valor_si_verdadero    Opcional. Es el valor que desea que se devuelva si el argumento prueba_lógica se evalúa como VERDADERO. Por ejemplo, si el valor de este argumento es la cadena de texto "Dentro de presupuesto" y el argumento prueba_lógica se evalúa como VERDADERO, la función SI muestra el texto "Dentro de presupuesto". Si el argumento prueba_lógica se evalúa como VERDADERO y omite el argumento valor_si_verdadero (es decir, después de prueba_lógica solamente hay una coma), la función SI devuelve 0 (cero). Para mostrar la palabra VERDADERO, use el valor lógico VERDADERO para el argumento valor_si_verdadero.

  • Valor_si_falso    Opcional. Es el valor que desea que se devuelva si el argumento prueba_lógica se evalúa como FALSO. Por ejemplo, si el valor de este argumento es la cadena de texto "Presupuesto excedido" y el argumento prueba_lógica se evalúa como FALSO, la función SI devuelve el texto "Presupuesto excedido". Si prueba_lógica se evalúa como FALSO y omite el argumento valor_si_falso (es decir, después del argumento valor_si_verdadero no hay una coma), la función SI devuelve el valor lógico FALSO. Si prueba_lógica se evalúa como FALSO y el valor del argumento valor_si_falso está en blanco (es decir, solo hay una coma después del argumento valor_si_verdadero), la función SI devuelve el valor 0 (cero).

Observaciones

  • Puede anidar hasta 64 funciones SI como argumentos valor_si_verdadero y valor_si_falso para crear pruebas más complicadas (vea en el ejemplo 3 una muestra de funciones SI anidadas). Para comprobar muchas condiciones también puede usar las funciones BUSCAR, BUSCARV, BUSCARH o ELEGIR (vea el ejemplo 4 para obtener una muestra de la función BUSCAR).

  • Si cualquiera de los argumentos de la función SI es una matriz, cada elemento de la matriz se evaluará cuando se ejecute la instrucción SI.

  • Excel proporciona funciones adicionales que puede usar para analizar los datos en función de una condición. Por ejemplo, para contar el número de veces que una cadena de texto o un número aparecen dentro de un rango de celdas, use las funciones de hoja de cálculo CONTAR.SI o CONTAR.SI.CONJUNTO. Para calcular una suma basándose en una cadena de texto o un número de un rango, use las funciones de hoja de cálculo SUMAR.SI o SUMAR.SI.CONJUNTO.

Ejemplos

Los libros de abajo muestran ejemplos de esta función. Inspecciónelos, cambie las fórmulas existentes o especifique sus propias fórmulas para saber cómo funciona la función.

Copie los datos de ejemplo en la tabla siguiente y cópielos en la celda A1 de una nueva hoja de cálculo de Excel. Para que las fórmulas muestren resultados, selecciónelas, presione F2 y después presione Entrar. Si lo necesita, puede ajustar los anchos de columna para ver todos los datos.

Datos

50

23

33175

Fórmula

Descripción

Resultado

=SI(A2<=100;"Dentro de presupuesto";"Presupuesto excedido")

Si el número en la celda A2 es igual o menor que 100, la fórmula devuelve "Dentro de presupuesto". De lo contrario, la función devuelve "Presupuesto excedido".

Dentro de presupuesto

=SI(A2=100;A2+B2;"")

Si el número en la celda A2 es igual a 100, se calcula y devuelve la suma A2 + B2. En caso contrario, se devuelve texto vacío ("").

0

=SI(3<1,"ACEPTAR")

Si el resultado es Falso y no se proporciona ningún argumento valor_si_falso para el resultado Falso, se devuelve FALSO.

FALSO

Si el resultado es Falso y se proporciona un argumento valor_si_falso en blanco para el resultado Falso (una coma sigue al argumento valor_si_verdadero), se devuelve 0.

0

Para trabajar más en profundidad con los datos de ejemplo en Excel, descargue el libro incrustado en el equipo y ábralo en Excel.

Ejemplo 2

Gastos reales

Gastos previstos

1.500 $

900 $

500 $

900 $

500 $

925 $

Fórmula

Descripción

Resultado

=SI(A2>B2;"Presupuesto excedido";"Aceptar")

Comprueba si los gastos reales de la fila 2 son mayores que los gastos previstos. Devuelve "Presupuesto excedido" porque el resultado de la prueba es Verdadero.

Presupuesto excedido

=SI(A3>B3;"Presupuesto excedido";"Aceptar")

Comprueba si los gastos reales de la fila 3 son mayores que los gastos previstos. Devuelve "Aceptar" porque el resultado de la prueba es Falso.

Aceptar)

Ejemplo 3

Puntuación

45

90

78

Fórmula

Descripción

Resultado

=SI(A2>89,"A",SI(A2>79;"B";SI(A2>69;"C";SI(A2>59;"D";"F"))))

Usa condiciones SI anidadas para asignar una letra de calificación a la puntuación de la celda A2.

F

=SI(A3>89;"A";SI(A3>79;"B";SI(A3>69;"C";SI(A3>59;"D";"F"))))

Usa condiciones SI anidadas para asignar una letra de calificación a la puntuación de la celda A3.

A

=SI(A4>89;"A";SI(A4>79;"B";SI(A4>69;"C";SI(A4>59;"D";"F"))))

Usa condiciones SI anidadas para asignar una letra de calificación a la puntuación de la celda A4.

C

Ejemplo 4

Puntuación

45

90

78

Fórmula

Descripción

Resultado

=BUSCAR(A2;{0;60;63;67;70;73;77;80;83;87;90;93;97};{"F";"D-";"D";"D+";"C-";"C";"C+";"B-";"B";"B+";"A-";"A";"A+"})

En lugar de usar varias funciones SI anidadas, la fórmula usa la función BUSCAR para buscar una letra de calificación que corresponde a una puntuación numérica almacenada en una serie en la fórmula.

F

=BUSCAR(A3;{0;60;63;67;70;73;77;80;83;87;90;93;97};{"F";"D-";"D";"D+";"C-";"C";"C+";"B-";"B";"B+";"A-";"A";"A+"})

En lugar de usar varias funciones SI anidadas, la fórmula usa la función BUSCAR para buscar una letra de calificación que corresponde a una puntuación numérica almacenada en una serie en la fórmula.

A-

=BUSCAR(A4;{0;60;63;67;70;73;77;80;83;87;90;93;97};{"F";"D-";"D";"D+";"C-";"C";"C+";"B-";"B";"B+";"A-";"A";"A+"})

En lugar de usar varias funciones SI anidadas, la fórmula usa la función BUSCAR para buscar una letra de calificación que corresponde a una puntuación numérica almacenada en una serie en la fórmula.

C+

Se aplica a: Excel 2013, Excel Online



¿Le ha sido útil esta información?

No

¿Cómo podemos mejorarlo?

255 caracteres restantes

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!

Recursos de soporte técnico

Cambiar idioma