Publicar un libro en una biblioteca de SharePoint

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

En Microsoft Excel 2013, puede publicar un libro en una biblioteca de Microsoft SharePoint de modo que los usuarios puedan verlo o editarlo en un explorador web sin tener Excel instalado en sus equipos. Publicar es básicamente lo mismo que guardar, pero con algunas opciones integradas que permiten controlar lo que los usuarios pueden ver cuando abren el libro en un explorador.

Adoptar en toda la organización la práctica de guardar o publicar un libro en un sitio de SharePoint central, le ayuda a garantizar que no empiecen a surgir versiones ligeramente diferentes del mismo libro por toda la organización cuando se envía por correo electrónico.

Estableciendo algunas opciones de publicación, se puede poner el énfasis en partes específicas del libro, como los gráficos, o bien excluir otras partes para que no se visualicen en el explorador. Por ejemplo, puede mostrar un gráfico pero no mostrar los datos subyacentes. O bien, puede mostrar solo determinadas hojas de cálculo a aquellas personas que necesitan verlas y ocultar el resto de hojas de cálculo.

En este artículo se muestra cómo publicar un libro desde el programa de escritorio de Excel 2013 y no abarca temas sobre la conexión a un libro o a datos de un libro en un elemento web de Excel Web Access en una página de SharePoint. Para obtener más información sobre los elementos web de Excel Web Access, vea el artículo Conectar un elemento web de Excel Web Part con un libro de Excel.

Al publicar un libro en un sitio de SharePoint, todo el libro se guarda en SharePoint. Un usuario con los permisos de SharePoint necesarios puede visualizar y trabajar con todo el libro en el explorador o en el programa de escritorio Excel.

Si se implementa Office Online en SharePoint, ver y trabajar con los datos en el explorador puede ser muy similar a trabajar con los datos en el programa de escritorio de Excel. De hecho, a diferencia del programa de escritorio Excel, varios usuarios pueden editar simultáneamente un libro en la cuadrícula del explorador. Al mostrar un libro en el explorador, si el botón Editar en Excel Online está visible, significa que Office Online se encuentra disponible.

Editar en Excel Online en el menú Editar libro

Para obtener más información, vea el artículo Diferencias entre utilizar un libro en Excel y en Excel Services.

Preparar el libro

Antes de publicar el libro, puede seleccionar solo las hojas de cálculo o elementos que desea que estén visibles en el explorador. Simplemente recuerde que aunque puede limitar qué estará visible en este modo, igualmente se guarda todo el contenido del libro en el servidor de SharePoint.

Si desea incluir todas las hojas de cálculo como un elemento además de otros elementos, como gráficos o tablas dinámicas, defina toda la hoja de cálculo como un rango con nombre. Seleccione toda la hoja de cálculo y, a continuación, defina un rango con nombre. De este modo, el rango con nombre aparecerá como un elemento disponible en el cuadro de diálogo Opciones de publicación cuando esté listo para la publicación.

Para permitir que los usuarios escriban un valor en una celda para trabajar con una fórmula en otra celda, establezca esa celda como un nombre definido en Excel antes de publicar el libro. Después puede agregar ese nombre definido como un parámetro en la pestaña Parámetros, en el cuadro de diálogo Opciones de vista de explorador.

Por ejemplo, a continuación se muestra una la celda D2 que tiene el nombre definido "Tasa". En el explorador, un usuario escribe un valor, 5,625, en el cuadro del panel Parámetros y, a continuación, hace clic en Aplicar. De ese modo, el valor aparece en la celda D2 y la fórmula de A2 usa el valor de D2. El resultado de la fórmula vuelve a calcular y se muestra en A2: 1.151,31 $.

Para obtener información acerca de cómo definir rangos, vea la Ayuda de Excel.

Al escribir un parámetro en el panel se usa en la celda D2

Nota: Si crea segmentaciones para una tabla de Excel y define un nombre para el intervalo de celdas que contienen la tabla y las segmentaciones, no podrá usar las segmentaciones para filtrar la tabla en el explorador si publica el intervalo definido. Si publica la tabla o toda la hoja de cálculo o su libro, las segmentaciones funcionarán según lo previsto en el explorador.

Publicar el libro

  1. Haga clic en Archivo > Guardar como >SharePoint.

  2. Si ve la carpeta de SharePoint encarpeta actual o carpetas recientes, haga clic en la carpeta que desee. En caso contrario, haga clic en Examinar y escriba la dirección web del sitio de SharePoint. A continuación, vaya a la carpeta donde desea publicar el libro. Aparece el cuadro de diálogo Guardar como.

  3. Para seleccionar hojas de cálculo o elementos individuales para publicarlos en el libro, haga clic en el botón Opciones de vista de explorador. Verá las pestañas Mostrar y Parámetros. Si solo desea publicar todo el libro, haga clic en Guardar. De lo contrario, realice uno de los pasos siguientes:

  • Para mostrar el libro entero en el explorador, seleccione Todo el libro en el cuadro de lista de la pestaña Mostrar.

  • Para mostrar solo hojas de cálculo específicas en el explorador, en la pestaña Mostrar, seleccione Hojas y, a continuación, desactive las casillas de las hojas que no desea ocultar en el explorador.

    De forma predeterminada, todas las hojas están seleccionadas. Para hacer que todas las hojas vuelvan a estar visibles rápidamente después de desactivar algunas de las casillas de verificación, active la casilla de verificación Todas las hojas.

  • Para mostrar únicamente ciertos elementos en el explorador (como intervalos, gráficos, tablas o tablas dinámicas específicos), en la pestaña Mostrar, seleccione Elementos en el libro en el cuadro de lista y, a continuación, active las casillas de los elementos que desea mostrar.

  • En la pestaña Parámetros, agregue todos los nombres definidos que desee usar para especificar celdas que sean editables cuando los usuarios ven el libro en el explorador. A continuación, haga clic en Aceptar para cerrar el cuadro de diálogo.

  1. Guarde el libro.

Notas: 

  • Si selecciona elementos que tienen el mismo nombre (como un gráfico y su tabla de datos subyacente), únicamente uno de esos elementos estará disponible en el explorador. Para mostrar todos los elementos, debe asegurarse de que cada elemento del libro tenga un nombre exclusivo.

  • Si selecciona elementos que tienen el mismo nombre (como un gráfico y su tabla de datos subyacente), únicamente uno de esos elementos estará disponible en el explorador. Para mostrar todos los elementos, debe asegurarse de que cada elemento del libro tenga un nombre exclusivo.

  • Puede cambiar el nombre de las tablas en la pestaña Diseño del grupo Propiedades, el nombre de las tablas dinámicas en la pestaña Opciones del grupo Tabla dinámica, y el nombre de los gráficos o gráficos dinámicos en la pestaña Diseño del grupo Propiedades. Puede cambiar el nombre de otros elementos duplicados, como rangos de nombres, en la pestaña Fórmulas del grupo Nombres definidos.

  • Puede cambiar el nombre de las tablas en la pestaña Diseño del grupo Propiedades, el nombre de las tablas dinámicas en la pestaña Opciones del grupo Tabla dinámica, y el nombre de los gráficos o gráficos dinámicos en la pestaña Diseño del grupo Propiedades. Puede cambiar el nombre de otros elementos duplicados, como rangos de nombres, en la pestaña Fórmulas del grupo Nombres definidos.

Obtener información sobre los Servicios de Excel y sobre el trabajo con datos en el explorador

Capacidades de inteligencia empresarial en Servicios de Excel

Trabajar con datos externos en Servicios de Excel

Actualización de datos en un libro en la ventana de un explorador

Volver al principio

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×