Publicar un libro en un sitio de SharePoint en Excel para Windows

Puede publicar un libro en una biblioteca de Microsoft SharePoint de modo que los usuarios puedan verlo o editarlo en un explorador web sin tener Excel instalado en sus equipos. Publicar es básicamente lo mismo que guardar, pero con algunas opciones integradas que permiten controlar lo que los usuarios pueden ver cuando abren el libro en un explorador.

Adoptar en toda la organización la práctica de guardar o publicar un libro en un sitio de SharePoint central, le ayuda a garantizar que no empiecen a surgir versiones ligeramente diferentes del mismo libro por toda la organización cuando se envía por correo electrónico.

Estableciendo algunas opciones de publicación, se puede poner el énfasis en partes específicas del libro, como los gráficos, o bien excluir otras partes para que no se visualicen en el explorador. Por ejemplo, puede mostrar un gráfico pero no mostrar los datos subyacentes. O bien, puede mostrar solo determinadas hojas de cálculo a aquellas personas que necesitan verlas y ocultar el resto de hojas de cálculo.

Este artículo muestra cómo publicar un libro desde Excel para Windows y no cubre la conexión de un libro o de datos de un libro a un elemento Web de Excel Web Access en una página de SharePoint.

Al publicar un libro en un sitio de SharePoint, todo el libro se guarda en SharePoint. Un usuario con los permisos de SharePoint necesarios puede visualizar y trabajar con todo el libro en el explorador o en el programa de escritorio Excel.

Si se implementa Office para la Web en SharePoint, ver y trabajar con los datos en el explorador puede ser muy similar a trabajar con los datos en el programa de escritorio de Excel. De hecho, a diferencia del programa de escritorio Excel, varios usuarios pueden editar simultáneamente un libro en la cuadrícula del explorador. Al mostrar un libro en el explorador, si el botón Editar en Excel Online está visible, significa que Office para la Web se encuentra disponible.

Editar en Excel Online en el menú Editar libro

Preparar el libro

Antes de publicar el libro, puede seleccionar solo las hojas de cálculo o elementos que desea que estén visibles en el explorador. Simplemente recuerde que aunque puede limitar qué estará visible en este modo, igualmente se guarda todo el contenido del libro en el servidor de SharePoint.

Si desea incluir todas las hojas de cálculo como un elemento además de otros elementos, como gráficos o tablas dinámicas, defina toda la hoja de cálculo como un rango con nombre. Seleccione toda la hoja de cálculo y, a continuación, defina un rango con nombre. De este modo, el rango con nombre aparecerá como un elemento disponible en el cuadro de diálogo Opciones de publicación cuando esté listo para la publicación.

Para permitir que los usuarios escriban un valor en una celda para trabajar con una fórmula en otra celda, establezca esa celda como un nombre definido en Excel antes de publicar el libro. Después puede agregar ese nombre definido como un parámetro en la pestaña Parámetros, en el cuadro de diálogo Opciones de vista de explorador.

Por ejemplo, a continuación se muestra una celda D2 que tiene el nombre definido "Tasa". En el explorador, un usuario escribe un valor, 5,625, en el cuadro Tasa del panel Parámetros y luego hace clic en Aplicar. El valor aparece entonces en la celda D2 y la fórmula de A2 usa el valor de D2. El resultado de la fórmula se recalcula y se muestra en A2: 1151,31 $.

Al escribir un parámetro en el panel se usa en la celda D2

Nota: Si crea segmentaciones para una tabla de Excel y define un nombre para el intervalo de celdas que contienen la tabla y las segmentaciones, no podrá usar las segmentaciones para filtrar la tabla en el explorador si publica el intervalo definido. Si publica la tabla o toda la hoja de cálculo o su libro, las segmentaciones funcionarán según lo previsto en el explorador.

Publicar el libro

  1. Haga clic en la pestaña Archivo, elija Guardar como y luego haga clic en SharePoint.

  2. Si ve la carpeta de SharePoint en Actuales, Recientes o Antiguas, haga clic en la carpeta que desee.

    Aparecerá el cuadro de diálogo Guardar como.


    En caso contrario, haga clic en Examinar, escriba la dirección web del sitio de SharePoint y, a continuación, vaya a la carpeta donde desea publicar el libro.

    Haga clic en una carpeta de SharePoint o en Examinar
  3. Para seleccionar hojas de cálculo o elementos individuales para publicarlos en el libro, haga clic en Opciones de vista de explorador.

    En el cuadro de diálogo Guardar como, haga clic en Opciones de vista de explorador

    Verá las pestañas Mostrar y Parámetros.

  4. Si solo quiere publicar todo el libro, haga clic en Guardar. De lo contrario, realice uno de los pasos siguientes:

    • Para mostrar el libro entero en el explorador, seleccione Todo el libro en el cuadro de lista de la pestaña Mostrar.

    • Para mostrar solo hojas de cálculo específicas en el explorador, seleccione Hojas en la pestaña Mostrar y desmarque las casillas de verificación de aquellas que no quiera ocultar en el explorador.

      De forma predeterminada, todas las hojas están seleccionadas. Para hacer que todas las hojas vuelvan a estar visibles rápidamente después de desmarcar algunas de las casillas de verificación, marque la casilla de verificación Todas las hojas.

    • Para mostrar únicamente elementos específicos en el explorador (como intervalos con nombre, gráficos, tablas o tablas dinámicas), en la pestaña Mostrar, elija Elementos en el libro en el cuadro de lista y, después, marque las casillas de los elementos que quiere mostrar.

    • En la pestaña Parámetros, agregue todos los nombres definidos que quiera usar para especificar celdas que son editables cuando los usuarios ven el libro en el explorador. A continuación, haga clic en Aceptar.

  5. Guarde el libro.

Notas: 

  • Si selecciona elementos que tienen el mismo nombre (como un gráfico y su tabla de datos subyacente), únicamente uno de esos elementos estará disponible en el explorador. Para mostrar todos los elementos, debe asegurarse de que cada elemento del libro tenga un nombre exclusivo.

  • Puede cambiar el nombre de las tablas en la pestaña Diseño del grupo Propiedades, el nombre de las tablas dinámicas en la pestaña Opciones del grupo Tabla dinámica, y el nombre de los gráficos o gráficos dinámicos en la pestaña Diseño del grupo Propiedades. Puede cambiar el nombre de otros elementos duplicados, como rangos de nombres, en la pestaña Fórmulas del grupo Nombres definidos.

Si se implementa Office para la Web en SharePoint, ver y trabajar con los datos en el explorador puede ser muy similar a trabajar con los datos en el programa de escritorio de Excel. De hecho, a diferencia del programa de escritorio Excel, varios usuarios pueden editar simultáneamente un libro en la cuadrícula del explorador. Al mostrar un libro en el explorador, si el botón Editar en Excel Online está visible, significa que Office para la Web se encuentra disponible.

Editar en Excel Online en el menú Editar libro

Para obtener más información, vea el artículo diferencias entre usar un libro en Excel y servicios de Excel.

Preparar el libro

Antes de publicar el libro, puede seleccionar solo las hojas de cálculo o elementos que desea que estén visibles en el explorador. Simplemente recuerde que aunque puede limitar qué estará visible en este modo, igualmente se guarda todo el contenido del libro en el servidor de SharePoint.

Si desea incluir todas las hojas de cálculo como un elemento además de otros elementos, como gráficos o tablas dinámicas, defina toda la hoja de cálculo como un rango con nombre. Seleccione toda la hoja de cálculo y, a continuación, defina un rango con nombre. De este modo, el rango con nombre aparecerá como un elemento disponible en el cuadro de diálogo Opciones de publicación cuando esté listo para la publicación.

Para permitir que los usuarios escriban un valor en una celda para trabajar con una fórmula en otra celda, establezca esa celda como un nombre definido en Excel antes de publicar el libro. Después puede agregar ese nombre definido como un parámetro en la pestaña Parámetros, en el cuadro de diálogo Opciones de vista de explorador.

Por ejemplo, a continuación se muestra una celda D2 que tiene el nombre definido "Tasa". En el explorador, un usuario escribe un valor, 5,625, en el cuadro del panel parámetros y hace clic en aplicar. El valor aparece entonces en la celda D2 y la fórmula de A2 usa el valor de D2. El resultado de la fórmula se recalcula y se muestra en A2: 1151,31 $.

Para obtener más información sobre cómo definir intervalos, consulte la ayuda de Excel.

Al escribir un parámetro en el panel se usa en la celda D2

Nota: Si crea segmentaciones para una tabla de Excel y define un nombre para el intervalo de celdas que contienen la tabla y las segmentaciones, no podrá usar las segmentaciones para filtrar la tabla en el explorador si publica el intervalo definido. Si publica la tabla o toda la hoja de cálculo o su libro, las segmentaciones funcionarán según lo previsto en el explorador.

Publicar el libro

  1. Haga clic en archivo > Guardar como >SharePoint.

  2. Si ve su carpeta de SharePoint encarpeta actual o carpetas recientes, haga clic en la carpeta que desee. En caso contrario, haga clic en examinar y escriba la dirección web del sitio de SharePoint. A continuación, vaya a la carpeta donde desea publicar el libro. Aparecerá el cuadro de diálogo Guardar como.

  3. Para seleccionar hojas de cálculo o elementos individuales para publicarlos en el libro, haga clic en Opciones de vista de explorador. Verá la pestaña Mostrar y la ficha parámetros . Si solo quiere publicar todo el libro, haga clic en Guardar. De lo contrario, realice uno de los pasos siguientes:

    • Para mostrar el libro entero en el explorador, seleccione Todo el libro en el cuadro de lista de la pestaña Mostrar.

    • Para mostrar solo algunas hojas de cálculo específicas en el explorador, en la pestaña Mostrar , seleccione hojas en el cuadro de lista y, a continuación, desactive las casillas de las hojas que no desea que estén ocultas en el explorador.

      De forma predeterminada, todas las hojas están seleccionadas. Para hacer que todas las hojas se vean rápidamente de nuevo después de desactivar algunos de los cuadros, active la casilla todas las hojas .

    • Para mostrar solo elementos específicos en el explorador (como rangos con nombre, gráficos, tablas o tablas dinámicas), en la pestaña Mostrar , seleccione elementos en el libro en el cuadro de lista y, a continuación, active las casillas de los elementos que desea mostrar.

    • En la pestaña parámetros , agregue los nombres definidos que desee usar para especificar las celdas que se pueden editar cuando los usuarios ven el libro en el explorador. A continuación, haga clic en Aceptar para cerrar el cuadro de diálogo.

  4. Guarde el libro.

Notas: 

  • Si selecciona elementos que tienen el mismo nombre (como un gráfico y su tabla de datos subyacente), únicamente uno de esos elementos estará disponible en el explorador. Para mostrar todos los elementos, debe asegurarse de que cada elemento del libro tenga un nombre exclusivo.

  • Si selecciona elementos que tienen el mismo nombre (como un gráfico y su tabla de datos subyacente), únicamente uno de esos elementos estará disponible en el explorador. Para mostrar todos los elementos, debe asegurarse de que cada elemento del libro tenga un nombre exclusivo.

  • Puede cambiar el nombre de las tablas en la pestaña Diseño del grupo Propiedades, el nombre de las tablas dinámicas en la pestaña Opciones del grupo Tabla dinámica, y el nombre de los gráficos o gráficos dinámicos en la pestaña Diseño del grupo Propiedades. Puede cambiar el nombre de otros elementos duplicados, como rangos de nombres, en la pestaña Fórmulas del grupo Nombres definidos.

  • Puede cambiar el nombre de las tablas en la pestaña Diseño del grupo Propiedades, el nombre de las tablas dinámicas en la pestaña Opciones del grupo Tabla dinámica, y el nombre de los gráficos o gráficos dinámicos en la pestaña Diseño del grupo Propiedades. Puede cambiar el nombre de otros elementos duplicados, como rangos de nombres, en la pestaña Fórmulas del grupo Nombres definidos.

Para obtener más información sobre los elementos Web de Excel Web Access, vea el artículo Mostrar un libro en un elemento Web de Excel Web Access.

Al publicar un libro en un servidor de SharePoint, todo el contenido del libro se guarda en el servidor y se puede ver y trabajar con si se abre el libro en el programa de escritorio de Excel. Si Office Web Apps se implementa en el servidor de SharePoint, ver y trabajar con los datos en el explorador Web puede ser muy parecido a trabajar con los datos en el programa de escritorio de Excel. De hecho, la edición simultánea de un libro es posible en la cuadrícula del explorador cuando se implementan las aplicaciones Web de Office. Cuando ve un libro en el explorador, si el botón Editar en el explorador está visible, significa que Office Web Apps está disponible.

Botón Editar en el explorador

Para obtener más información, vea el artículo diferencias entre usar un libro en Excel y servicios de Excel.

Preparar el libro

Antes de publicar el libro, tiene la oportunidad (en el cuadro de diálogo Opciones de publicación ) para seleccionar las hojas de cálculo o los elementos que desea que estén visibles en el explorador cuando la edición no se ha habilitado haciendo clic en el botón Editar en el explorador . Recuerde que aunque puede seleccionar lo que se puede ver en este modo, todo el contenido del libro se guarda en el servidor de SharePoint.

Si desea incluir todas las hojas de cálculo como un elemento además de otros elementos, como gráficos o tablas dinámicas, defina toda la hoja de cálculo como un rango con nombre. Seleccione toda la hoja de cálculo y, a continuación, defina un rango con nombre. De este modo, el rango con nombre aparecerá como un elemento disponible en el cuadro de diálogo Opciones de publicación cuando esté listo para la publicación.

Si desea permitir que los usuarios proporcionen un parámetro a una fórmula al ver una hoja de cálculo en un explorador, establezca una celda como un nombre definido. Después, puede agregar ese nombre definido como parámetro en la pestaña parámetros del cuadro de diálogo Opciones de publicación .

Por ejemplo, en el siguiente gráfico que muestra una hoja de cálculo en el explorador, la celda D2 tiene la tasa de nombres definida. En el explorador, un usuario ha introducido un valor, 5,625, en el cuadro del panel parámetros y después hizo clic en aplicar. El valor aparece entonces en la celda D2 y la fórmula de A2 usa el valor de D2. El resultado de la fórmula se recalcula y se muestra en A2: 1151,31 $.

Usar un parámetro en el explorador

Para obtener más información sobre cómo definir intervalos, consulte la ayuda de Excel.

Publicar el libro

  1. Haga clic en la pestaña Archivo y luego en Guardar y enviar.

  2. Haga clic en Guardar en SharePoint.
    Nota:    si el comando Guardar en SharePoint no está disponible, aún puede guardar el libro en un sitio de SharePoint con el comando Guardar como . El cuadro de diálogo Opciones de publicación no estará disponible. También puede cargar directamente el libro desde una biblioteca de SharePoint. Los usuarios pueden ver y modificar el contenido del libro en el explorador yendo directamente al sitio en el que se guarda el libro.

    Comando Guardar como

  3. Si desea seleccionar hojas de cálculo o elementos individuales para publicarlos en el libro, haga clic en el botón Opciones de publicación . En caso contrario, si desea publicar todo el libro, vaya directamente al paso 4.
    En la pestaña Mostrar , haga lo siguiente:

    • Para mostrar todo el libro en el explorador, seleccione todo el libro en el cuadro de lista.

    • Para mostrar solo algunas hojas de cálculo específicas en el explorador, seleccione hojas en el cuadro de lista y, a continuación, desactive las casillas de las hojas que no desea que estén visibles.
      Nota    de forma predeterminada, se seleccionan todas las hojas. Para hacer que todas las hojas se vean rápidamente de nuevo después de desactivar algunas de las casillas de verificación, puede activar la casilla todas las hojas .

    • Para mostrar solo elementos específicos en el explorador (como rangos con nombre, gráficos, tablas o tablas dinámicas), seleccione los elementos del libro en el cuadro de lista y, a continuación, active las casillas de los elementos que desee mostrar.
      Nota si selecciona elementos que tienen el mismo nombre (como un gráfico y su tabla de datos subyacente), solo uno de estos elementos estará disponible en el explorador. Para mostrar todos los elementos, debe asegurarse de que cada elemento del libro tiene un nombre único. Puede cambiar el nombre de las tablas en la pestaña Diseño del grupo Propiedades, el nombre de las tablas dinámicas en la pestaña Opciones del grupo Tabla dinámica, y el nombre de los gráficos o gráficos dinámicos en la pestaña Diseño del grupo Propiedades. Se puede cambiar el nombre de los elementos duplicados, como los rangos con nombre, en la pestaña fórmulas del grupo nombres definidos .
      Seleccionar hojas de cálculo o elementos

    • En la pestaña parámetros , agregue los nombres definidos que desee usar para especificar las celdas que se pueden editar cuando los usuarios ven el libro en el explorador. A continuación, haga clic en Aceptar para cerrar el cuadro de diálogo.
      Establecer parámetros

  4. Elija una ubicación en la que publicar el libro.
    Es posible que ya haya ubicaciones de servidor guardadas en ubicación actual, ubicaciones recienteso ubicaciones de las que puede elegir. Si no existen dichas ubicaciones o quiere guardar en una nueva ubicación, en ubicaciones, haga doble clic en examinar en busca de una ubicación.

  5. En el cuadro de diálogo Guardar como , escriba la dirección web del sitio de SharePoint y, a continuación, vaya al sitio o biblioteca en el que desea guardar el libro.

  6. Si aún no ha seleccionado hojas de cálculo o elementos individuales o ha establecido parámetros, haga clic en el botón Opciones de publicación .

  7. En el cuadro nombre de archivo , acepte el nombre sugerido para el libro o escriba un nombre nuevo, si lo desea.

  8. Para mostrar el contenido del libro en una ventana del explorador inmediatamente después de que la operación de publicación haya finalizado, asegúrese de que la casilla abrir con Excel en el explorador está activada.

  9. Haga clic en Guardar.

Nota:  Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido le resulte útil. ¿Podría decirnos si la información le resultó útil? Aquí puede consultar el artículo en inglés.

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×