Preparar, publicar y mantener su sitio Web de Publisher

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Nota: Publicaciones Web solo están disponibles en Publisher 2007 y versiones anteriores. Para obtener información sobre cómo actualizar las publicaciones existentes de Web en Publisher 2010, vea funcionalidad de Web.

Después de planear y crear una publicación Web en Microsoft Office Publisher 2007, puede publicar en la web, un servidor de red o una carpeta compartida en su PC. Cualquier el destino, Publisher crea archivos HTML filtrados de la publicación Web. Puede abrir y leer estos archivos HTML en cualquier explorador Web, como Windows Internet Explorer.

Publicación Web con barra de exploración, texto y gráficos

En este artículo

En este artículo se trata los procedimientos para crear y publicar su publicación Web como archivos HTML y para actualizar su sitio Web modificando la publicación Web y publicarla.

Preparar el sitio Web

Publicar su sitio Web

Mantener su sitio Web

Preparar el sitio Web

Su sitio Web es una extensión de su empresa y marca de su empresa. Antes de crear el sitio Web, plan de ella. Para obtener ayuda con este modo, vea el artículo Planear el sitio Web.

¿Qué es la mejor herramienta?

Cuando diseñe su sitio y la información que se proporcionará, considere la posibilidad de herramienta de creación que es la adecuada para sus necesidades. Office Publisher 2007 es una excelente herramienta de creación usar cuando desee crear rápidamente, publicar y administrar sitios Web sencillo y estático que coincidan con la marca de su empresa y que requieren revisiones de solo texto y gráficos. Office Publisher 2007 no es la herramienta adecuada en los siguientes casos:

  • Si su sitio Web necesita interactividad o contenido basado en base de datos, para que los visitantes pueden responder en un sitio Web inicie (blog) o comprar artículos en el carro de la compra

  • Si su sitio Web requiere validación de datos, como la comprobación de crédito números de tarjetas

  • Si prevé que más adelante modificar el código HTML sin formato en un editor HTML después de crear el sitio Web en Office Publisher 2007, que combina código HTML, XML y VML para generar sitios Web

Crear el sitio Web

Puede crear una nueva publicación Web en Office Publisher 2007. Si desea trabajar en un sitio Web existente que no tenga publicación Web, puede copiar y pegar contenido de las páginas Web publicadas en una nueva publicación Web, que se vuelve a crear el sitio Web como una publicación Web, o puede usar una herramienta de edición HTML.

  1. En el menú Archivo, haga clic en Nueva.

  2. En la lista de Tipos de publicaciones, haga clic en sitios Web.

  3. Siga uno de estos procedimientos:

    • Para crear un sitio Web personalizado que se basa en los objetivos del sitio, asegúrese de que está seleccionada Asistente Web fácil de usar, en el panel de tareas de Opciones y, a continuación, haga clic en el diseño que desee.

    • Para crear un sitio Web desde cero, en sitios Web, haga clic en Tamaños en blanco y, a continuación, haga clic en el tamaño que desee.

  4. Haga clic en Crear.

  5. Si elige usar el Asistente para la Web fácil, seleccione las opciones que desee en el cuadro de diálogo Generador de sitios Web fáciles y, a continuación, haga clic en Aceptar.

  6. Agregar contenido a la publicación y realice los cambios que desee.

    Sugerencia: Evite colocar objetos en páginas principales de la publicación Web. Objetos que se colocan en las páginas maestras de Office Publisher 2007 no se muestran correctamente cuando se ve en algunos exploradores Web.

Comprobar la publicación de Web

Antes de publicar su sitio Web, compruebe que el sitio funcione como se esperaba y que se han resuelto todos los posibles problemas que pueden surgir.

Puede buscar problemas mediante el Verificador de diseño y vista previa de su sitio.

Usar el Verificador de diseño para buscar y corregir problemas

El Verificador de diseño es una eficaz herramienta para encontrar posibles problemas. Muchos de sus comprobaciones son para problemas básicos de formato. Sin embargo, algunas de ellas son específicas para problemas que pueden afectar a las publicaciones de Web. Para ejecutar el Verificador de diseño, haga lo siguiente:

  1. En el menú Herramientas, haga clic en Verificador de diseño.

  2. En el panel de tareas Verificador de diseño, seleccione las casillas de verificación Ejecutar comprobaciones de diseño generales y Ejecutar comprobaciones de sitio web.

    Nota: Asegúrese de que no está seleccionada la casilla de verificación Ejecutar comprobaciones de impresión comercial.

  3. En el panel de tareas Verificador de diseño, en Seleccione un elemento para corregirlo, haga clic en la flecha situada junto al elemento que desee corregir y, a continuación, siga uno de estos procedimientos:

    • Haga clic en corrección automática para corregir el problema con el elemento automáticamente.

      La corrección automática variará dependiendo del problema. En la mayoría de los casos, ninguna corrección automática está disponible.

    • Haga clic en Ir a este elemento para ir a la página donde se encuentra el elemento de problema seleccionado.

      A continuación, puede realizar los cambios necesarios para corregir el problema.

    • Haga clic en Explicar para abrir el tema de Ayuda donde se explica el problema con mayor detalle, además de ofrecer sugerencias sobre cómo corregirlo.

    • Haga clic en nunca este volver a ejecutar comprobación para desactivar la casilla de verificación.

      Haga clic en esta opción afecta a todas las instancias del problema.

Obtener una vista previa de su sitio Web

  • En el menú Archivo, haga clic en Vista previa de la página Web.

El sitio Web se vista previa en el explorador predeterminado. Comprobar la versión preliminar para lo siguiente:

  • Se abre el sitio y todas las páginas sean accesibles.

  • Todos los hipervínculos funcionan como se esperaba.

  • Controles de navegación funcionan según lo previsto.

  • No faltan elementos.

  • Los sonidos de fondo se reproducen según lo esperado.

Buscar un servicio de hospedaje Web

Antes de publicar su sitio Web en la web, debe suscribirse a un servicio que proporciona un proveedor de servicios de Internet (ISP) de hospedaje. Este servicio le proporcionará acceso a Internet, espacio de almacenamiento en un servidor web y un localizador uniforme de recursos (URL) para que los usuarios pueden tener acceso a su sitio Web. Antes de publicar su sitio Web, póngase en contacto con el ISP o el administrador del sistema para obtener la información que necesita y la dirección URL del sitio Web o la dirección del sitio FTP donde puede guardar los archivos.

Varios ISP está probablemente disponibles en su área. Asegúrese de que el ISP que se suscribe ofrece el tipo de soporte que desee. Si tiene poca experiencia en la publicación en la web, puede ser conveniente un ISP que puede ayudarle a través de posibles problemas.

Volver al principio

Publicación Web con barra de exploración, texto y gráficos

Después de comprobar y obtener una vista previa de la publicación Web y suscribirse a un servicio de hospedaje, ya está listo para publicar el sitio Web.

Puede publicar un sitio Web en un servidor web, un servidor de red, un servidor de protocolo de transferencia de archivos (FTP) o una carpeta en su PC.

El sitio de publicación en una ubicación de su equipo puede servir varios propósitos:

  • Puede usar los archivos publicados para probar su sitio Web antes de realizar los archivos disponibles en la web.

  • Puede usar una utilidad FTP para publicar los archivos en la web cargándolos desde la ubicación del archivo en el equipo.

  • Mantener una copia local de los archivos HTML, así como la publicación Web.

El ISP puede proporcionarle la información que le ayudará a decidir el método de publicación que es mejor para usted.

Si publica en la web o en el equipo, Office Publisher 2007 reúne todos los archivos relacionados que crea en una sola carpeta. Los archivos que Office Publisher 2007 crea incluyen otras páginas HTML que componen el sitio, los gráficos GIF y JPEG que usar en las páginas y los archivos de sonidos incrustados.

Puede configurar Office Publisher 2007 para organizar estos archivos en la carpeta en la que publicar su sitio Web en una de estas dos maneras. De forma predeterminada, Office Publisher 2007 crea una única página de inicio y una subcarpeta que contiene todos los archivos auxiliares son necesarias para su sitio Web. O bien, puede organizar la página de inicio con todos los archivos auxiliares para el sitio Web en una única carpeta.

¿Cómo controlar dónde Office Publisher 2007 organiza el sitio Web se publica de archivos?

En el menú Herramientas, haga clic en Opciones, haga clic en la pestaña de Web y, a continuación, siga uno de estos procedimientos:

  • Para separar la página de inicio de los archivos auxiliares, seleccione la casilla de verificación Organizar archivos auxiliares en una carpeta.

  • Para agrupar la página principal y todos los archivos auxiliares en la misma carpeta, desactive la casilla de verificación Organizar archivos auxiliares en una carpeta.

Al publicar una publicación en la web, Office Publisher 2007 crea archivos HTML filtrados, que propagarán a la web más rápidamente que los archivos HTML sin filtrar. Dado que el HTML filtrado archivos que Office Publisher 2007 crea no contienen etiquetas específicas de Microsoft Office, no puede abrir los archivos HTML en Office Publisher 2007 y editarlos. Debe realizar cambios en el sitio Web en la publicación Web y, a continuación, volver a publicar el sitio Web.

Publicar un sitio Web en una ubicación de Internet o a una red

Antes de realizar este procedimiento, póngase en contacto con el ISP o el administrador del sistema para obtener la información que necesita para publicar y la dirección URL del sitio Web donde puede guardar los archivos.

  1. En el menú Archivo, haga clic en Publicar en el Web.

  2. En el cuadro de diálogo publicar en Web, en el cuadro nombre de archivo, escriba la dirección URL del servidor web o de red donde desea guardar el sitio Web. Por ejemplo, escriba http://www.northwindtraders.com.

  3. Haga clic en Guardar.

  4. Si se le pide, escriba su nombre de usuario y contraseña, y haga clic en Aceptar.

    El directorio asociado a la dirección URL aparecerá en el cuadro de diálogo publicar en Web.

  5. Haga doble clic en la carpeta donde desea guardar el sitio Web.

  6. En el cuadro Nombre de archivo, seleccione Índice como el nombre predeterminado de la página principal y, a continuación, haga clic en Guardar.

    Index.htm es la selección predeterminada. Seleccionar índice como el nombre de la página principal facilita el acceso e impide que los usuarios ver una lista de los archivos que componen el sitio Web.

  7. Cuando se le pida, haga clic en Aceptar.

Publicar un sitio Web mediante FTP

Antes de realizar este procedimiento, póngase en contacto con el administrador del sistema o ISP para obtener la información que necesita para publicar en un sitio de FTP. También debe crear un sitio FTP en Ubicaciones FTP.

Antes de agregar un sitio FTP a la lista de Ubicaciones FTP, debe tener acceso a Internet o en una intranet.

  1. En el menú Archivo, haga clic en Publicar en el Web.

  2. En el cuadro de diálogo publicar en Web, haga clic en Herramientas y, a continuación, haga clic en Asignar unidad de red.

  3. En el cuadro de diálogo Asignar unidad de red, haga lo siguiente:

    • En la lista unidad, haga clic en una letra de unidad. Puede seleccionar cualquier letra disponible.

    • Para conectar cada vez que inicie sesión el equipo, seleccione la casilla de verificación Conectar de nuevo al iniciar sesión.

    • Haga clic en conectarse a un sitio Web que puede usar para almacenar sus documentos e imágenes.

  4. En el Asistente para agregar ubicación de red, haga clic en siguiente, haga clic en Elegir una ubicación de red personalizada y, a continuación, haga clic en siguiente.

  5. En el cuadro Dirección de Internet o red, escriba la dirección del sitio FTP (por ejemplo, tipo ftp://ftp.microsoft.com) y, a continuación, haga clic en siguiente.

    Nota: Si no puede conectarse a una unidad de red o una carpeta, el equipo puede estar desactivado o que no tenga los permisos correctos. Si no puede conectarse, póngase en contacto con el Administrador de red o ISP.

  6. Si no desea iniciar la sesión de forma anónima, desactive la casilla iniciar sesión de forma anónima, escriba un nombre de usuario en el cuadro nombre de usuario y, a continuación, haga clic en siguiente.

  7. Escriba un nombre para esta ubicación de red y, a continuación, haga clic en siguiente.

  8. Haga clic en Finalizar.

  9. En el menú Archivo, haga clic en Publicar en el Web.

  10. En la lista Guardar en, haga clic en Ubicaciones FTP.

  11. En la lista de sitios FTP, haga doble clic en el sitio que desee y, a continuación, haga doble clic en la carpeta donde desea publicar su sitio Web.

    Nota: Si su ISP, debe usar un programa específico para cargar el sitio Web, o si va a publicar su sitio Web en una intranet corporativa, debe guardar una versión del sitio Web en un formato de archivo específico HTML y seguir un procedimiento distinto para publicar el sitio Web. Pida a su ISP o el administrador del sistema para obtener información sobre cómo guardar y publicar su sitio Web.

Publicar un sitio Web en una carpeta en el equipo

  1. En el menú Archivo, haga clic en Publicar en el Web.

  2. En la barra de direcciones, haga clic en la unidad o la carpeta donde desea publicar el sitio Web, como la carpeta documentos.

    Si desea agregar el sitio Web a una nueva carpeta, haga clic en Nueva carpeta en la barra de herramientas para crear una nueva carpeta, escriba un nombre para la nueva carpeta y, a continuación, presione ENTRAR.

  3. En el cuadro Nombre de archivo, seleccione Índice como el nombre predeterminado de la página principal y, a continuación, haga clic en Guardar.

    Index.htm es la selección predeterminada. Seleccionar índice como el nombre de la página principal facilita el acceso e impide que los usuarios ver una lista de los archivos que componen el sitio Web.

Mantener su sitio Web

Después de publicar su sitio Web, puede actualizar según sea necesario para reflejar la nueva información. Sin embargo, no puede abrir los archivos HTML filtrados en Publisher. Debe abrir la publicación Web original, realice los cambios que desee y, a continuación, volver a publicar su sitio Web.

Nota: No debe intentar actualizar los archivos HTML filtrados mediante un editor de texto, como Microsoft Notepad o Microsoft WordPad. Aunque es posible hacerlo, HTML que genera Publisher es muy complejo y probablemente resultará difícil modificarlos a mano. Para obtener los mejores resultados, actualice siempre el sitio Web de Publisher utilizando la publicación Web y, a continuación, volver a publicar en la web.

Publicar solo lo que ha cambiado

En Office Publisher 2007, puede publicar actualizaciones de un sitio Web publicada anteriormente rápidamente mediante el uso de incremental publicación en la web, que se publica únicamente las páginas que ha actualizado. Si va a actualizar su sitio Web a menudo o si su sitio Web es grande y complejo, incremental publicar en la web puede acelerar la tarea de actualizar su sitio Web.

Si realiza cambios en el sitio Web directamente en un servidor web fuera Office Publisher 2007, sin embargo, activar incremental publicar en la web puede impedir publicar actualizaciones posteriores a su sitio Web mediante el comando publicar en Web. Si piensa administrar sus archivos de sitio Web directamente en el servidor web (como a través de un programa independiente FTP ), debe desactivar incremental publicar en la web.

Nota: Carga incremental en la web está activada de forma predeterminada en Publisher.

Activar incremental publicar en la web o desactivar

  1. En el menú Herramientas, haga clic en Opciones y, a continuación, haga clic en la pestaña de la Web.

  2. En Guardar, siga uno de estos procedimientos:

    • Para desactivar incremental publicar en la web, desactive la casilla de verificación Habilitar carga incremental en la Web.

    • Activar incremental publicar en la web, active la casilla de verificación Habilitar carga incremental en la Web.

Publicar los cambios en su sitio Web

Publicar actualizaciones a un sitio Web es ligeramente diferente a publicar un sitio Web por primera vez. Después de publicar un sitio Web a una ubicación en la web o en una red, aparecerá un acceso directo en el servidor web o un servidor de red en Mis sitios de red.

  1. En el menú Archivo, haga clic en Publicar en el Web.

  2. En el cuadro de diálogo publicar en Web, en el panel de navegación, haga clic en Este equipo.

  3. En la lista de archivos, haga doble clic en el acceso directo a la carpeta en el servidor web o un servidor de red donde publicó su sitio Web.

  4. Haga doble clic en la carpeta donde desea guardar el archivo.

  5. En el cuadro nombre de archivo, escriba el nombre del archivo que desea actualizar y, a continuación, haga clic en Guardar.

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×