Personalizar vistas de datos y formularios con SharePoint Designer

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Una vista de datos es una vista dinámica y personalizable de un origen de datos desde un sitio de SharePoint. SharePoint Designer 2010 recupera datos de un origen de datos en el formulario del lenguaje de marcado Extensible (XML) y muestra o proporciona una entrada de datos con transformaciones Extensible Stylesheet Language (XSL). La vista de datos puede mostrar datos de una amplia variedad de orígenes, incluidas las listas de SharePoint y bibliotecas, las consultas de base de datos, documentos XML, servicios Web y las secuencias de comandos del servidor. Agregar y personalizar vistas de datos mediante SharePoint Designer 2010.

SharePoint Designer 2010 incluye un amplio conjunto de herramientas que puede usar para personalizar lista y vistas de datos, como se muestra aquí.

Abrir sitio en SharePoint Designer 2010

Las herramientas WYSIWYG en SharePoint Designer 2010 insertar lenguaje Extensible (XSL) directamente en la página para que no tiene que saber XSL para crear vistas personalizadas de datos eficaces. Si necesita personalizar el código, siempre puede editar el XSL directamente en la vista código en SharePoint Designer 2010.

Hay varias maneras de que crear vistas y formularios en SharePoint Designer 2010. Puede crear una vista de lista asociada a una lista de SharePoint o la biblioteca. puede crear una vista de datos y asociarla con la misma lista u otro origen de datos; puede crear un formulario mediante la adición de una vista de datos a la página, a continuación, insertar cada campo como un formulario; y así sucesivamente. Más información sobre la creación de vistas y formularios en la sección Vea también.

Estos resultado de una combinación de vistas de lista (elemento de Web de vista de lista XSLT) y vistas de datos (elemento Web de formulario de datos) en las páginas y, si bien hay diferencias entre los dos, personalizarlos de manera similar. Agrega y quita columnas, aplica filtros, ordena y agrupar campos, aplica formato condicional y mucho más con las herramientas disponibles en SharePoint Designer 2010.

En este artículo se describe las personalizaciones más comunes que deberá realizar en lista o vistas de datos mediante SharePoint Designer 2010.

En este artículo

Abriendo lista y vistas de datos

Agregar, quitar y reorganizar las columnas

Ordenar y agrupar

Filtro

Formato condicional

Paginación

Habilitar la edición directa

Habilitar la actualización asincrónica

Agregar opciones de la barra de herramientas

Aplicar estilos de vista

Más opciones de personalización

Abrir vistas de datos y de lista

Vistas de lista y vistas de datos pueden crear y abiertas en un número de formas en SharePoint Designer 2010 (como se explica en el principio de este artículo). Por ejemplo, puede abrir una vista de lista desde la lista o biblioteca que está actualmente asociado, o puede abrir una vista de datos desde la página del sitio donde se encuentra. Ambas opciones están en el menú de navegación. (Asociado a una lista o biblioteca o cualquier número de orígenes de datos. Use uno de los siguientes métodos para abrir una vista de lista o la vista de datos en SharePoint Designer 2010.)

Abrir sitio en SharePoint Designer 2010

Para abrir una vista de lista asociada a una lista

  1. Abrir el sitio en SharePoint Designer 2010.

  2. En el panel Navegación, haga clic en Listas y bibliotecas.

  3. Abra la lista que contiene su vista de lista.

  4. Haga clic en la pestaña Opciones y use las opciones de edición de vista para personalizar la vista de lista.

    Nota: Puede que necesite primer clic dentro de la vista para mostrar la vista de opciones de edición en SharePoint Designer 2010

Para abrir una vista de datos o una vista de lista desde una página de un sitio

  1. Abrir el sitio en SharePoint Designer 2010.

  2. En el panel de navegación, haga clic en Páginas del sitio.

  3. Abra la página que contiene su vista de datos o vista de lista.

  4. Haga clic en la pestaña Opciones y use las opciones de edición de vista para personalizar la vista de lista o vista de datos.

    Nota: Tendrá que hacer clic primero en la vista para mostrar la vista de opciones de edición en SharePoint Designer 2010.

En el resto de este artículo, se supone que ha realizado estos pasos o unos similares para abrir su vista para editarla.

Volver al principio

Agregar, quitar y reorganizar columnas

Por lo general, una de las primeras tareas que se realizan con una vista de datos es agregar y quitar columnas. Al cambiar las columnas en una vista de datos, está agregando, quitando u organizando los campos tal como aparecen en la vista de datos. El cuadro de diálogo Editar columnas se usa para agregar, quitar y reorganizar columnas, tanto si muestran filas como columnas. También es posible modificar columnas mediante los comandos de edición de tabla de la ficha Tabla. Más adelante en este artículo se habla del diseño de la tabla.

Nota: El comando Editar columnas está disponible únicamente cuando la vista de datos muestra los datos en una tabla HTML.

Realice los pasos siguientes para agregar, quitar o reorganizar columnas en una vista de lista o de datos.

  1. Con la vista abierto en SharePoint Designer 2010, haga clic en la pestaña Opciones y, a continuación, haga clic en Agregar o quitar columnas Abrir sitio en SharePoint Designer 2010 .

    Nota: El comando Editar columnas no está disponible si la vista de datos está en una tabla HTML que usa atributos rowspan o colspan con un valor mayor que 1.

  2. Se abre el cuadro de diálogo Editar columnas.
    Abrir sitio en SharePoint Designer 2010

  3. Siga uno de los procedimientos siguientes:

    • Para agregar una columna, seleccione el campo de columna en campos disponibles y, a continuación, haga clic en Agregar.

    • Para seleccionar varios campos a la vez, presione y mantenga presionado CTRL mientras hace clic en los campos.

    • Para quitar una columna existente, seleccione la columna en Columnas mostradas y, a continuación, haga clic en Quitar.

    • Para seleccionar varios campos a la vez, mantenga presionado CTRL mientras hace clic en los campos.

    • Para reorganizar columnas, seleccione la columna en Columnas mostradas y, a continuación, haga clic en Subir o Bajar

  4. Haga clic en Aceptar para aplicar los cambios a la vista.

Nota: El cuadro de diálogo Editar columnas mostrará únicamente los campos que se incluyen en la consulta de origen de datos de la vista de datos. El origen de datos reales puede contener campos adicionales. Para incluir esos campos, deberá actualizar la consulta de origen de datos.

Para obtener más información acerca de las vistas de datos, vea la sección Vea también.

Volver al principio

Ordenar y agrupar

Al ordenar datos en una vista de datos, modifique el orden en que aparecen para que sea más fácil para usted y los visitantes del sitio a comprender los datos. Criterio de ordenación ejemplos de orden alfabético y numéricos. Ordenar adicional puede crear pedidos mediante el cuadro de diálogo Orden avanzado en SharePoint Designer 2010.

Además de ordenar datos, también puede agruparlos. Al agrupar datos, puede mostrar un encabezado o pie de página para un grupo de campos en el criterio de ordenación y elegir si el grupo aparecerá expandido o contraído de forma predeterminada. También puede elegir mantener sus grupos juntos al paginar la vista y mostrar los nombres de columna o los totales para cada grupo.

Para ordenar columnas en una vista de lista o de datos

Con la vista abierto en SharePoint Designer 2010, haga clic en la pestaña Opciones y, a continuación, haga clic en Ordenar y agrupar Abrir sitio en SharePoint Designer 2010 .

Se abre el cuadro de diálogo Ordenar y agrupar.
Abrir sitio en SharePoint Designer 2010

  1. En campos disponibles, haga clic en el campo que desee ordenar y, a continuación, haga clic en Agregar.

  2. En Ordenar propiedades, elija cómo desea ordenar los campos seleccionando Ascendente (valor más bajo a valor más alto) o Descendente (valor más alto a valor más bajo).

    También puede cambiar el orden ascendente o descendente ordenar haciendo doble clic en el campo en la lista criterio de ordenación.

  3. Para usar la ordenación más avanzadas de orden ascendente o descendente, haga clic en Editar expresión de ordenación. Se abrirá el cuadro de diálogo Orden avanzado, donde puede personalizar el criterio de ordenación mediante expresiones XPath. Más información en la lista avanzada y personalización de la vista de datos mediante expresiones XPath.

  4. Para ordenar por varios campos, elija más campos en Campos disponibles y, a continuación, agréguelos al criterio de ordenación.

    Si agrega varios campos al criterio de ordenación y desea cambiar el campo que se ordena en primer lugar, seleccione el campo en la lista Criterio de ordenación y haga clic en Subir o Bajar.

    Haga clic en Aceptar para aplicar los cambios a la vista.

Para agrupar en una vista de lista o de datos

Con la vista abierto en SharePoint Designer 2010, haga clic en la pestaña Opciones y, a continuación, haga clic en Ordenar y agrupar Ordenar y agrupar .

  1. Se abre el cuadro de diálogo Ordenar y agrupar.
    Abrir sitio en SharePoint Designer 2010

  2. En la lista Criterio de ordenación, haga clic en el campo por el que desee agrupar.
    Tenga en cuenta que cada campo del criterio de ordenación puede tener aplicadas propiedades de grupo individuales. Asegúrese de que selecciona el campo que desea antes de aplicar las propiedades del grupo.

  3. En Propiedades del grupo, para mostrar un encabezado al principio de cada grupo, active la casilla de verificación Mostrar encabezado de grupo y, a continuación, haga lo siguiente:

    1. Para que los grupos en la vista aparezcan expandidos de forma predeterminada, haga clic en Expandir grupo de manera predeterminada.

    2. Para que los grupos en la vista de datos aparezcan contraídos de forma predeterminada, haga clic en Contraer grupo de manera predeterminada.

  4. Las opciones restantes solo se aplican a vistas de datos y no a vistas de lista (para obtener más información sobre las diferencias entre vistas de lista y vistas de datos, visite la sección Vea también).

  5. Para que aparezca un pie de página al final de cada grupo que muestra cuántos registros hay en este grupo, active la casilla de verificación Mostrar pie de grupo.

  6. Después de activar la casilla de verificación Mostrar encabezado de grupo o Mostrar pie de grupo, el botón Agrupación avanzada aparece disponible.

  7. Haga clic en Agrupación avanzada (esta opción se habilita al activar las opciones Mostrar encabezado de grupo o Mostrar pie de grupo).

  8. Siga uno de estos procedimientos:

    • Para ocultar los registros individuales de la lista, active la casilla de verificación Ocultar siempre detalles de grupo.

    • Para mostrar todos los elementos de un grupo en una única página, incluso si el total excede del número especificado de elementos para mostrar en una lista, active la casilla de verificación Mantener los grupos al paginar.

    • Para insertar una fila en cada grupo que muestra los nombres de columna, active la casilla de verificación Mostrar nombres de columna por grupo.

    • Para insertar una fila en cada grupo que muestra el número total de registros dentro de cada grupo, active la casilla de verificación Mostrar totales de columna por grupo.

Para permitir a los usuarios del sitio ordenar y agrupar datos mediante el explorador, puede agregar una barra de herramientas a la vista, tal y como se describe más adelante en este artículo.

Volver al principio

Filtro

Es posible aplicar un filtro a una vista para que solo se muestren en la vista de lista o de datos aquellos datos que cumplan ciertos criterios. Esto resulta útil cuando tiene una vista que contiene cientos o miles de registros y desea leer los datos con más facilidad. Al crear un filtro, se generan una o varias expresiones que se aplican a los datos. Hay tres partes básicas: el nombre del campo (nombre del campo por el que desea filtrar), el operador (la regla que desea aplicar al valor) y el valor (los datos que busca).

Realice los pasos siguientes para filtrar una vista de lista o de datos.

  1. Con la vista abierto en SharePoint Designer 2010, haga clic en la pestaña Opciones y, a continuación, haga clic en filtro Abrir sitio en SharePoint Designer 2010 .

  2. Se abre el cuadro de diálogo Criterios de filtro.
    Abrir sitio en SharePoint Designer 2010

  3. En Nombre de campo, haga clic en el campo que contenga los valores que desee.

  4. Haga clic en el cuadro Comparación y, a continuación, en el operador que desea.

  5. Haga clic en el cuadro Valor y, a continuación, seleccione o escriba los criterios que desee.

  6. Para agregar otra cláusula al filtro, haga clic en el cuadro Y/O al final de la cláusula existente y, a continuación:

    1. Haga clic en Y para crear un filtro en el que los datos deben coincidir con los criterios de ambas cláusulas.

    2. Haga clic en O para crear un filtro en el que los datos deben coincidir con los criterios de una sola cláusula.

  7. Haga clic en el mensaje Haga clic aquí para agregar una nueva cláusula.

  8. Repita los pasos del 3 al 6 para crear una cláusula adicional para este filtro.

  9. Si trabaja con vistas de datos y desea utilizar condiciones más avanzadas, active la casilla Agregar filtros XSLT y, a continuación, haga clic en Editar.
    Se abre el cuadro de diálogo Condición avanzada, donde puede personalizar el criterio de ordenación mediante expresiones XPath.

  10. Haga clic en Aceptar.

Para permitir a los visitantes del sitio ordenar y agrupar datos mediante el explorador, puede agregar una barra de herramientas a la vista, tal y como se describe más adelante en este artículo. Recuerde simplemente que filtrar en el explorador solo afecta a la presentación de los datos, no limita la cantidad de datos disponible en la vista.

Nota: Filtrar una vista de datos puede afectar al rendimiento. Es importante filtrar un conjunto de datos manejable. Al aplicar filtrado básico mediante el cuadro de diálogo criterios de filtro, se aplica el filtro antes de que los datos se devuelven. Si sin embargo, utiliza la opción avanzada de filtrado (disponible para las vistas de datos); el filtrado se aplica a la presentación de XSLT, después de que los datos se devuelven

Volver al principio

Formato condicional

Con el formato condicional, puede aplicar texto con formato, colores de fondo, iconos personalizados y otras opciones a un valor de datos o etiqueta HTML que seleccione cuando los datos cumplen ciertos criterios. También puede establecer condiciones que determinen si se debe mostrar u ocultar la etiqueta HTML o el valor de datos. El formato condicional es una manera eficaz de resaltar elementos en una vista de datos para los que el usuario debe realizar alguna acción. Por ejemplo, puede resaltar tareas atrasadas, proyectos que superan su presupuesto o suministros de la empresa que escasean.

Realice los pasos siguientes para aplicar formato condicional a una vista de lista o de datos.

Con la vista abierta en SharePoint Designer 2010, haga clic en la fila o columna en la que desea aplicar formato condicional.

  1. Haga clic en la pestaña Opciones, haga clic en filtro Abrir sitio en SharePoint Designer 2010 y elija uno de estos procedimientos:

  2. Mostrar contenido para mostrar datos en la vista que cumplan los criterios especificados.

  3. Ocultar contenido para ocultar datos en la vista que cumplan los criterios especificados.

  4. Aplicar formato a fila para aplicar formato a una fila que cumpla los criterios especificados.

  5. Aplicar formato a columna para aplicar formato a una columna que cumpla los criterios especificados.

  6. Aplicar formato a selección para aplicar formato a una selección que cumpla los criterios especificados (antes de usar esta opción, debe resaltar primero una parte de la vista de datos).

    La presentación y ocultar opciones de contenido cambiarán la visibilidad del seleccionan valores de datos o etiquetas HTML. Las opciones de formato aplicarán un estilo a etiquetas HTML seleccionadas o valores de datos.

  7. Se abre el cuadro de diálogo Criterios de condición.
    Abrir sitio en SharePoint Designer 2010

  8. En Nombre de campo, haga clic en el campo que contenga los valores que desee.

  9. Haga clic en el cuadro Comparación y, a continuación, en el operador que desea.

  10. Haga clic en el cuadro Valor y, a continuación, seleccione o escriba los criterios que desee.

  11. Para utilizar condiciones más avanzadas en la vista, haga clic en Avanzadas.
    Se abre el cuadro de diálogo Condición avanzada, donde puede personalizar el criterio de ordenación mediante expresiones XPath.

  12. Para agregar otra cláusula a los criterios para formato condicional, haga clic en el cuadro Y/O al final de la cláusula existente y, a continuación:

    • Haga clic en Y para crear un criterio para formato condicional en el que los datos deban coincidir con los criterios de ambas cláusulas.

    • Haga clic en O para crear un criterio para formato condicional en el que los datos deban coincidir con los criterios de una sola cláusula.

  13. Bajo la cláusula existente, haga clic en el mensaje Haga clic aquí para agregar una nueva cláusula.

  14. Repita los pasos del 4 al 7 para crear una cláusula adicional para el criterio para formato condicional.

  15. Si muestra u oculta datos con la condición, haga clic en Aceptar para cerrar el cuadro de diálogo. Para aplicar un formato especial a la condición, haga clic en Establecer estilo.

  16. Se abre el cuadro de diálogo Modificar estilo.
    Abrir sitio en SharePoint Designer 2010

  17. Elija las opciones de formato que desee aplicar a la vista de datos.
    Por ejemplo, para que el texto se muestre en negrita con un fondo en amarillo, debe elegir Negrita en el menú Espesor de la fuente. A continuación, haga clic en la categoría Fondo y, en el menú Color de fondo, escriba Amarillo o elija una variante de amarillo.

  18. Haga clic en Aceptar.

Dado que las vistas de lista y de datos muestran datos en directo, verá que el formato condicional se aplica inmediatamente en la vista Diseño.

Volver al principio

Paginación

Con la paginación, puede cambiar la cantidad de registros que se muestran en cada página de una vista de lista o de datos. Es posible configurar la vista para que muestre elementos en grupos de 5, 10 o de cualquier otro valor que se indique. Por lo tanto, los visitantes del sitio verán vínculos para ir al grupo anterior o siguiente de la vista. También se puede especificar un límite máximo de elementos que se muestran en la vista que, nuevamente, puede ser de 5, 10 o de cualquier valor que se indique.

Realice los pasos siguientes para agregar un valor de paginación a una vista de lista o de datos.

Con la vista abierto en SharePoint Designer 2010, haga clic en la pestaña Opciones y, a continuación, haga clic en paginación Abrir sitio en SharePoint Designer 2010 .

  1. Elija una de las opciones de paginación:

    1. Mostrar grupos de elementos: elija si mostrar elementos en grupos de 1, 5, 10 o 30.

      Si selecciona esta opción, muestra vínculos de navegación en la vista cuando el número total de registros supera el número especificado en esta opción.

    2. Limitar a elementos: elija una cantidad máxima de elementos que desee mostrar en la vista: 1, 5, 10 o 30.

  2. Elija Más opciones de paginación para especificar un valor personalizado para la paginación de la vista de datos.

  3. Se abre el cuadro de diálogo Propiedades de la vista de datos.
    Abrir sitio en SharePoint Designer 2010

  4. En la ficha Paginación, seleccione una de las siguientes opciones:

    • Elija Mostrar elementos en grupos de este tamaño y, a continuación, especifique un número en el cuadro proporcionado.
      El valor predeterminado en esta opción es de 10 si hay más de 25 registros en la vista, y de 6 si la vista contiene menos de 25 registros.

    • Elija Limitar el número de elementos mostrados a y, a continuación, especifique un número en el cuadro proporcionado.
      El valor predeterminado de este campo está establecido en 100.

  5. Haga clic en Aceptar.

Además de cambiar el número de registros que se muestran para la vista en una página web, puede cambiar el número de registros que aparecen en la vista Diseño de SharePoint Designer 2010. Puede hacerlo con la que desea ver cómo se representará una vista con un determinado número de registros. Para cambiar el número de registros en la vista Diseño, haga clic en la pestaña Diseño y en el grupo vista previa, elija una de las opciones de vista previa de vista de datos disponibles.

Volver al principio

Habilitar la edición incluida

Cuando se habilita la edición incluida, los visitantes del sitio pueden editar fácilmente los registros en el contexto de la vista sin necesidad de salir de la página ni abrir una nueva ventana. Solo tienen que hacer clic en un botón de edición situado junto a la columna o fila de la vista de datos para que el campo se pueda editar. Para cada registro hay cuadros de texto, menús y controles de campo disponibles, al igual que lo están en los formularios de editar elementos y de nuevo elemento. La edición incluida combina lo mejor de una vista y de un formulario en una sola ubicación.

Realice los pasos siguientes para habilitar la edición incluida en una vista de lista o de datos.

Con la vista abierto en SharePoint Designer 2010, haga clic en la pestaña Opciones y, a continuación, haga clic en Edición directa Abrir sitio en SharePoint Designer 2010 .
Para vistas de lista, este permite nuevos y los vínculos de edición, que los visitantes del sitio que se usan para crear y editar los registros.

  1. En las vistas de datos, elija una o todas las opciones siguientes de edición incluida:

    1. Mostrar vínculos de edición de elementos: habilita un vínculo de edición en el que hacen clic los usuarios para editar el registro incluido.

    2. Mostrar vínculos de inserción de elementos: habilita un vínculo de inserción en el que hacen clic los usuarios para crear nuevos registros incluidos.

    3. Mostrar vínculos de eliminación de elementos: habilita un vínculo de eliminación en el que hacen clic los usuarios para eliminar registros incluidos.

  2. Guarde los cambios de su vista de lista o de datos.

Vistas de lista, la próxima vez que abra la vista en un explorador y desplace el puntero sobre una fila o columna, verá un botón de Abrir sitio en SharePoint Designer 2010 Editar. Vistas de datos, vea Editar vínculo junto a cada fila o columna.

Haga clic en el vínculo para comenzar a editar la fila o columna de registros incluidos, tal y como se muestra a continuación.

Abrir sitio en SharePoint Designer 2010

Volver al principio

Habilitar actualizaciones asincrónicas

Las actualizaciones asincrónicas son un componente esencial de la plataforma ASP.NET AJAX que se pueden habilitar para vistas de lista y de datos en su sitio. Al habilitarlas, la vista de lista o de datos recupera datos del servidor en tiempo real y los presenta en un explorador sin necesidad de que el usuario actualice la página. Las vistas de lista y de datos con actualizaciones asincrónicas son idóneas para paneles y páginas web dinámicas con gran cantidad de datos.

Nota: Actualizaciones asincrónicas puede deshabilitarse en Administración Central, así que si esta opción no está disponible, póngase en contacto con el administrador del servidor

.

Realice los pasos siguientes para habilitar las actualizaciones asincrónicas en una vista de lista o de datos.

Con la vista abierto en SharePoint Designer 2010, haga clic en la pestaña Opciones y, a continuación, active la casilla de Actualización asincrónica.
Abrir sitio en SharePoint Designer 2010

  1. Para agregar un botón de actualización a la página, active la casilla del Botón Actualizar.
    Permite a los visitantes del sitio haga clic en un botón de actualización Abrir sitio en SharePoint Designer 2010 para actualizar la página manualmente.

  2. Elija un intervalo de actualización: 15 segundos, 30 segundos, o 60 segundos.

  3. Guarde los cambios de su vista de lista o de datos.

Volver al principio

Agregar opciones de barra de herramientas

Si la vista usa una lista o biblioteca como origen de datos, puede agregar la barra de herramientas de lista de SharePoint a la vista para poder trabajar de forma más eficaz con la lista o la biblioteca subyacentes. La barra de herramientas de lista de SharePoint es la barra de menús ubicada en la parte superior de una lista o una biblioteca que proporciona varias opciones para trabajar con esa lista o biblioteca. Se pueden agregar dos tipos de barras de herramientas:

  • Barra de herramientas de SharePoint: ofrece opciones de edición de listas, como la adición de nuevos elementos, la creación de vistas y columnas, y la edición de las propiedades de la lista.

  • Barra de herramientas Agrupar: ofrece opciones de visualización de listas, como cambiar el filtro, la ordenación y la agrupación.

Realice los pasos siguientes para agregar la barra de herramientas a una vista de lista o de datos.

Con la vista abierto en SharePoint Designer 2010, haga clic en la ficha Diseño y, a continuación, haga clic en Opciones de Abrir sitio en SharePoint Designer 2010 .

  1. Para agregar una barra de herramientas completa con opciones de edición de listas, haga clic en Barra de herramientas de SharePoint.

  2. Para agregar una barra de herramientas con opciones de visualización de listas, haga clic en Barra de herramientas Agrupar.

    Nota: La barra de herramientas aplica el filtrado de la presentación de la vista y no en el nivel de consulta. Por lo tanto, debe confiar en esto como está principal medio de filtrado de la vista. Para ello, debe usar el filtrado, como se describe más adelante en este artículo.

  3. Para quitar la barra de herramientas, haga clic en Ninguna.

  4. Guarde los cambios de su vista de lista o de datos.

Al abrir la vista en el explorador, verá la barra de herramientas en la parte superior de la página. Si habilita tanto la Barra de herramientas de SharePoint como la Barra de herramientas Agrupar, verá estas opciones en la parte superior de la vista.

Abrir sitio en SharePoint Designer 2010

Volver al principio

Aplicar estilos de vista

De forma predeterminada, al crear una vista de datos o de lista, los datos suelen aparecer en un diseño de tabla básica. Es posible cambiar el diseño de la vista rápida y fácilmente aplicando un estilo de vista distinto. Por ejemplo, puede cambiar el diseño de tabla básica de su vista por uno que presente la vista con bordes, columnas o listas con viñetas.

Antes de aplicar un estilo de vista a una vista de lista o de datos, es importante tener en cuenta que todas las conexiones de elementos web y personalizaciones anteriores se quitarán.

Realice los pasos siguientes para aplicar un estilo de vista a una vista de lista o de datos.

Con la vista abierta en SharePoint Designer 2010, haga clic en la ficha Diseño y, a continuación, haga clic en uno de los estilos de vista en función de la descripción de texto de vista previa y mantener el mouse.

Abrir sitio en SharePoint Designer 2010

Nota: Verá los estilos de vista diferentes disponibles dependiendo de si está aplicando una vista de lista o una vista de datos. Además, el número de estilos depende de lo que se ha cargado a la Galería de estilos de la colección de sitios.

  1. Para ver más estilos, haga clic en más Abrir sitio en SharePoint Designer 2010 en la esquina inferior derecha del grupo Estilos de vista.

  2. Un mensaje de advertencia le informará de que todas las conexiones de elementos web y cambios de formato personalizados se quitarán al cambiar el estilo de vista. Haga clic en para continuar.

    Nota: Si elige un estilo que muestra menos campos que la vista original, dichos campos se quitan de la vista.

  3. Guarde los cambios de su vista de lista o de datos.

Volver al principio

Opciones de personalización adicionales

Además de las personalizaciones anteriores, una vista de lista o de datos se puede personalizar de las siguientes maneras:

  • Crear una columna de fórmula     que muestra el resultado de un cálculo de otras columnas en la vista. Esto es similar a la manera de que usar fórmulas en una hoja de cálculo. Por ejemplo, podría, multiplique el precio unitario de un producto por el número de unidades en existencias para mostrar el valor total de elementos en una columna independiente.

  • Mostrar datos de varios orígenes     en una sola vista. Esto es eficaz a combinar orígenes de datos en un único lugar. Por ejemplo, es posible, mostrar las categorías de producto de una información de producto y lista de otra lista en la misma vista.

  • Agregar parámetros     a una lista o vista de datos. Por ejemplo, puede pasar un parámetro desde otro menú a la vista de datos y filtrar datos por ese valor de parámetro.

  • Agregar controles de servidor     a la lista o la vista de datos. Puede enlazar controles de SharePoint, los controles ASP.NET y más a un origen de datos y agregarlos a una vista para crear interfaces de datos completas, interactivas para los usuarios.

  • Cambiar la fuente y el formato     de la lista o la vista de datos. Puede cambiar el tamaño de fuente, color de fuente, familia de fuentes y más de los campos y los encabezados de columna. Puede hacer esto manualmente con las herramientas WYSIWYG de SharePoint Designer 2010 o aplicar estilos CSS a estos elementos en la página.

  • Personalizar el diseño de tabla     de la lista o la vista de datos. Puede agregar y quitar las celdas de tabla, cambiar el ancho o alto de una fila o columna, mostrar u ocultar los bordes o sombreado y mucho más con las opciones de edición de tabla de SharePoint Designer 2010.

Volver al principio

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×