Ocultar valores e indicadores de error en las celdas

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Supongamos que las fórmulas de hoja de cálculo tienen errores que puede prever no es necesario corregir, pero desea mejorar la presentación de los resultados. Hay varias maneras de ocultar valores e indicadores de error en las celdas.

Hay muchas razones por qué fórmulas pueden devolver errores. Por ejemplo, no se permite la división por 0 y si escribe la fórmula = 1/0 devuelve #DIV/0. Incluyen de valores de error # ¡ DIV/0!, # n/a, #NAME?, #NULL!, #NUM!, #REF! y #VALUE!.

¿Qué desea hacer?

Dar formato al texto de las celdas que contienen errores para que éstos no se muestren

Mostrar un guión, #N/A o NOD en lugar del valor de error

Detalles de la función

Ocultar los valores de error en un informe de tabla dinámica

Ocultar indicadores de error en las celdas

Dar formato al texto de las celdas que contienen errores para que éstos no se muestren

  1. Seleccione el rango de celdas que contenga el valor de error.

  2. En la pestaña Inicio, en el grupo Estilos, haga clic en la flecha junto a Formato condicional y, después, haga clic en Administrar reglas.

    Se mostrará el cuadro de diálogo Administrador de reglas de formato condicionales.

  3. Haga clic en Nueva regla.

    Aparecerá el cuadro de diálogo Nueva regla de formato.

  4. En Seleccionar un tipo de regla, haga clic en Utilizar una fórmula que determine las celdas para aplicar formato.

  5. En Editar una descripción de regla, en el cuadro de lista Dar formato a los valores donde esta fórmula sea verdadera, escriba la siguiente fórmula:

    = ESERROR (referencia)

    Donde referencia es una referencia relativa a la celda que contiene el valor de error.

  6. Haga clic en Formato y, a continuación, en la ficha Fuente.

  7. En el cuadro Color, seleccione blanco.

Principio de página

Mostrar un guión, #N/A o NOD en lugar del valor de error

Para realizar esta tarea, utilice las funciones SI.ERROR y NOD.

Example

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

Cómo copiar un ejemplo

  1. Cree una hoja de cálculo o un libro en blanco.

  2. Seleccione el ejemplo en el tema de Ayuda.

    Nota: No seleccione los encabezados de fila ni de columna.

    Seleccionar un ejemplo de la Ayuda

    Seleccionar un ejemplo de la Ayuda

  3. Presione CTRL+C.

  4. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

  5. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

1

".2"

3%

A

Datos

10%

0

Fórmula

Descripción (resultado)

=A2/A3

Da un error (#¡DIV/0!)

=SI.ERROR(A2/A3;"NOD")

Devuelve NOD cuando el valor es un error

=SI.ERROR(A2/A3;"-")

Devuelve un guión cuando el valor es un error

=SI.ERRORA2/A3,NOD())

Devuelve #N/A cuando el valor es un error

Detalles de la función

SI.ERROR

NOD

Principio de página

Ocultar los valores de error en un informe de tabla dinámica

  1. Haga clic en el informe de tabla dinámica.

  2. En la pestaña Opciones, en el grupo Opciones de tabla dinámica, haga clic en la flecha junto a Opciones y, a continuación, en Opciones.

  3. Haga clic en la ficha Diseño y formato y siga uno o varios de los procedimientos siguientes:

    Cambiar el modo en que se muestran los errores     Active la casilla de verificación Para valores erróneos, mostrar situada bajo Formato. En el cuadro, escriba el valor que desee mostrar en lugar de los errores. Para mostrar los errores como celdas en blanco, elimine los caracteres del cuadro.

    Cambiar el modo en que se muestran las celdas vacías     Active la casilla de verificación Para celdas vacías, mostrar. En el cuadro, escriba el valor que desee mostrar en las celdas vacías. Para mostrar celdas en blanco, elimine los caracteres del cuadro. Para mostrar ceros, desactive la casilla de verificación.

Principio de página

Ocultar indicadores de error en las celdas

Si una celda contiene una fórmula que incumple alguna regla, aparece un triángulo en la esquina superior izquierda de la celda. Puede evitar que se muestren estos indicadores.

Celda con un problema de fórmula

Celda con un problema de fórmula

  1. Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office , haga clic en Opciones de Excel y, después, haga clic en la categoría Fórmulas.

  2. En Comprobación de errores, desactive la casilla de verificación Habilitar comprobación de errores en segundo plano.

Principio de página

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

¿Le ha sido útil esta información?

De acuerdo. ¿Algún comentario más?

¿Cómo podemos mejorarlo?

¡Gracias por sus comentarios!

×