No se puede guardar la base de datos replicada en formato de Access 2007

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Síntomas

En Microsoft Office Access 2007, replicar bases de datos que se crearon en versiones anteriores de Access (. Formato MDB) no se puede guardar en el nuevo. Formato de archivo ACCDB. La opción aparece atenuada (no disponible) cuando intenta utilizar el comando Guardar base de datos como (haga clic en el Botón de Microsoft Office Imagen del botón de Office y, a continuación, haga clic en la flecha situada junto a Guardar como ).

Causa

El formato de archivo .ACCDB no admite réplicas.

Resolución

Usar la base de datos replicada con el formato de archivo .MDB

Puede seguir usando la base de datos replicada con el formato de archivo .MDB. La funcionalidad de réplica sigue siendo compatible con el formato de archivo .MDB.

Volver a crear manualmente la base de datos con el formato de archivo de Office Access 2007

Si decide que el nuevo formato de archivo ofrece ventajas que pesan más que las ventanas que ofrecen las réplicas, podrá crear una nueva base de datos con el formato de Office Access 2007 y volver a crear manualmente la base de datos replicada.

Nota: Este método funciona con cualquier base de datos replicada pero, a menos que se use una réplica completa que se ha sincronizado con todas las demás réplicas del conjunto de réplicas, los datos y proyectos que no estén incluidos en la réplica no se incluirán en la nueva base de datos.

Antes de comenzar a volver a crear las bases de datos, debe asegurarse de que todos los objetos ocultos y de sistema de la réplica estén visibles. El objetivo es garantizar que pueda obtener acceso a los campos específicos de la réplica cuando vuelva a crearla.

  1. Seleccione el campo que desea convertir. Debe abrir la réplica usando la misma versión de Access que se usó originalmente para crear la réplica para mostrar los campos ocultos y de sistema.

  2. En el menú Herramientas, haga clic en Opciones. Se abre el cuadro de diálogo Opciones.

  3. En la ficha Vista, en la sección Mostrar, seleccione Objetos ocultos y Objetos del sistema. Haga clic en Aceptar para aplicar la nueva configuración y cerrar el cuadro de diálogo Opciones.

Volver a crear manualmente la base de datos

  1. Cree una base de datos en blanco y ábrala.

    Nota: Access crea una tabla nueva vacía llamada Tabla1. Debe eliminar esta tabla: puede hacerlo cerrándola inmediatamente antes de realizar cambios en ella. Haga clic con el botón secundario en la ficha de objetos y, a continuación, elija Cerrar en el menú contextual.

  2. En la pestaña Datos externos, en el grupo Importar, haga clic en Access.

    Aparece el cuadro de diálogo Obtener datos externos - Base de datos de Access.

  3. Haga clic en Examinar para buscar la base de datos replicada.

  4. Haga clic en la base de datos replicada que contiene los objetos de base de datos que desee volver a crear en la nueva base de datos y, a continuación, haga clic en Abrir.

  5. En el cuadro de diálogo Obtener datos externos - Base de datos de Access, haga clic en Importar tablas, consultas, formularios, informes, macros y módulos en la base de datos actual y, a continuación, haga clic en Aceptar.

  6. Haga clic en los objetos de base de datos que desee importar a la nueva base de datos. Si desea importar todos los objetos, haga clic en Seleccionar todo en cada ficha.

    Importante    No seleccione ninguna tabla. Va a volver a crear las tablas más adelante.

  7. Tras seleccionar los objetos, haga clic en Aceptar para importarlos.

    En la última página del asistente, tiene la opción de guardar los pasos del proceso de importación para usarlos en el futuro. Para ello, active la casilla de verificación Guardar los pasos de la importación, escriba la información adecuada y haga clic en Guardar importación.

  8. Abra la base de datos replicada en Office Access 2007. Por cada tabla de la base de datos replicada, cree una consulta de creación de tabla que tome todos los datos de la antigua tabla y cree una tabla en la nueva base de datos con los mismos datos.

    Nota: Si s_GUID es una clave principal (y las claves externas de otras tablas que hacen referencia a él), debe incluir el campo s_GUID en la nueva tabla. Si el campo s_GUID no se usa como clave principal, no hay ninguna razón para conservar en la nueva tabla. No copie los campos s_Lineage y generar a la nueva tabla.

    De forma predeterminada, los campos s_GUID, s_Lineage y s_Generation están ocultos. Para que se muestren, siga este procedimiento:

    1. En la base de datos replicada deben estar cerradas todas las tablas.

    2. Haga clic con el botón secundario en la parte superior del panel de exploración y, después, haga clic en Opciones de exploración. Se abre el cuadro de diálogo Opciones.

    3. En la sección Opciones de presentación, seleccione Mostrar objetos del sistema y después haga clic en Aceptar.

      ¿Cómo?

      1. Cree una consulta, seleccionando las tablas que contienen los registros que desea incluir en la nueva tabla.

        ¿Cómo?

        1. En la ficha Crear, en el grupo Otros, haga clic en Diseño de la consulta.

        2. En el cuadro de diálogo Mostrar tabla, haga clic en la ficha que recoja las tablas con cuyos datos desea trabajar.

        3. Haga doble clic en el nombre de cada objeto que desee agregar a la consulta y, después, haga clic en Cerrar.

        4. Agregue campos a la fila Campo en la cuadrícula de diseño.

        5. Para ver los resultados de la consulta, haga clic en el menú Ver y, a continuación, haga clic en Vista Hoja de datos.

      2. En la vista Diseño de la consulta, en la ficha Diseño, en el grupo Tipo de consulta, haga clic en Crear tabla. Aparece el cuadro de diálogo Crear tabla.

      3. En el cuadro Nombre de tabla, escriba el nombre de la tabla que desee crear o reemplazar.

      4. Haga clic en Otra base de datos y, a continuación, escriba la ruta de acceso a la base de datos en la que desee incluir la nueva tabla o haga clic en Examinar para buscar la base de datos.

      5. Haga clic en Aceptar.

      6. En la ficha Diseño, en el grupo resultados, haga clic en Ejecutar. Esto hará que la nueva tabla.

        Nota: La nueva tabla que acaba de crear no hereda las propiedades de los campos ni la configuración de clave principal de la tabla original.

  9. Por cada tabla de la nueva base de datos, cree el mismo índice que se utilizó en la tabla de la réplica.

    ¿Cómo?

    1. Abra una tabla en la vista Diseño.

    2. En la parte superior de la ventana, haga clic en el campo para el que desee crear un índice.

    3. En la parte inferior de la ventana, haga clic en el cuadro de la propiedad Indizado y, a continuación, haga clic en Sí (Con duplicados) o Sí (Sin duplicados).

    4. Seleccione el campo o los campos que forman la clave principal.

    5. En el grupo Herramientas de la ficha Diseño, haga clic en Clave principal.

  10. Para cada tabla en la nueva base de datos, crear las relaciones existentes en la tabla de la réplica.

    ¿Cómo?

    Cuando se crea una relación entre tablas, los campos relacionados no tienen los mismos nombres. Sin embargo, los campos relacionados deben tener el mismo tipo de datos a menos que el campo de clave principal es un campo Autonumeración. Hacer coincidir un campo Autonumeración con un campo numérico sólo si la propiedad tamaño del campo de ambos de los campos coincidentes es el mismo. Por ejemplo, se pueden hacer coincidir un campo Autonumeración y un campo numérico si la propiedad tamaño del campo de ambos campos es Entero largo. Aunque ambos campos coincidentes son campos numéricos, deben tener el mismo valor de la propiedad tamaño del campo.

    Definir uno a varios o una relación uno a uno

    1. Cierre todas las tablas abiertas. No es posible crear ni modificar las relaciones entre tablas abiertas.

    2. En el grupo Mostrar u ocultar de la ficha Herramientas de base de datos, haga clic en Relaciones.

    3. Si no se han definido relaciones en la base de datos, aparecerá automáticamente el cuadro de diálogo Mostrar tabla.

      Si necesita agregar las tablas que va a relacionar y no aparece el cuadro de diálogo Mostrar tabla, invóquelo: en la ficha Diseño, en el grupo Mostrar u ocultar, haga clic en el botón Mostrar tabla.

    4. Haga doble clic en el nombre de las tablas que desee relacionar y, a continuación, cierre el cuadro de diálogo Mostrar tabla. Para crear una relación entre una tabla y ella misma, agregue dos veces dicha tabla.

    5. Arrastre el campo que desee relacionar de una tabla al campo relacionado en la otra tabla.

      Para arrastrar varios campos, presione la tecla CTRL, haga clic en cada campo y después arrástrelos.

      En la mayoría de los casos, se arrastra el campo de clave principal (con texto en negrita) de una tabla a un campo similar (a menudo con el mismo nombre) denominado clave externa en la otra tabla.

    6. Aparecerá el cuadro de diálogo Modificar relaciones. Compruebe los nombres de los campos mostrados en las dos columnas para asegurarse de que son correctos. Puede cambiarlos si es necesario.

      Si es preciso, establezca las opciones de relación.

    7. Haga clic en el botón Crear para crear la relación.

    8. Repita los pasos 4 a 7 por cada par de tablas que desee relacionar.

      Al cerrarse la ventana Relaciones, Microsoft Access pregunta si desea guardar el diseño. Independientemente de si lo guarda o no, las relaciones creadas se guardan en la base de datos.

    Definir una relación varios a varios

    1. Cree las dos tablas que tendrán una relación de varios a varios.

    2. Cree una tercera tabla, denominada tabla de unión, y agregue a ésta nuevos campos con las mismas definiciones que los campos de clave principal de cada una de las otras dos tablas. En la tabla de unión, los campos de clave principal funcionan como claves externas. Puede agregar otros campos a la tabla de unión, tal como lo haría con cualquier otra tabla.

    3. En la tabla de unión, establezca la clave principal para que incluya los campos de clave principal de las otras dos tablas. Por ejemplo, en una tabla de unión Detalles de pedidos, la clave principal estará formada por los campos IdPedido e IdProducto.

      ¿Cómo?

      1. Abra la tabla en la vista Diseño.

      2. Seleccione los campos que desee definir como clave principal.

        Para seleccionar un campo, haga clic en el selector de fila del campo que desee.

        Para seleccionar varios campos, mantenga presionada la tecla CTRL y, a continuación, haga clic en el selector de filas de cada campo.

      3. En el grupo Herramientas de la ficha Diseño, haga clic en Clave principal.

        Nota: Si desea que el orden de los campos de una clave principal de varios campos sea diferente del orden de esos campos en la tabla, haga clic en el botón Índices en el grupo Mostrar/Ocultar para que se muestre la ventana Índices y, a continuación, cambie el orden de los nombres de campo para el índice denominado PrimaryKey.

    4. Definir una relación de uno a varios entre cada una de las dos tablas principales y la tabla de unión.

  11. Guarde la nueva base de datos.

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×