NO (función NO)

Use la función NO, una de las funciones lógicas, cuando desee asegurarse de que un valor no es igual a otro.

Ejemplo

Ejemplos de la función NO para invertir argumentos.  Por ejemplo, =NO(1+1=2)

La función NO invierte el valor del argumento.

Un uso común para la función NO es expandir la utilidad de otras funciones que realicen pruebas lógicas. Por ejemplo, la función SI realiza una prueba lógica y, después, devuelve un valor si la prueba se evalúa en VERDADERO y otro valor si la prueba se evalúa en FALSO. Mediante el uso de la función NO como la prueba lógica de la función SI puede probar distintas condiciones en vez de solo una.

Sintaxis

NO(lógica)

La sintaxis de la función NO tiene los siguientes argumentos:

  • Valor_lógico    Obligatorio. Un valor o una expresión que puede evaluarse como VERDADERO o FALSO.

Observaciones

Si el valor lógico es FALSO, NO devuelve VERDADERO; si el valor lógico es VERDADERO, NO devuelve FALSO.

Ejemplos

Aquí se muestran algunos ejemplos generales del uso de NO por sí mismo y junto a las funciones SI, Y y O.

Ejemplos de NO con funciones SO, Y y O


Fórmula

Descripción

=NO(A2>100)

A2 NO es mayor de 100

=SI(Y(NO(A2>1),NO(A2<100)),A2,"El valor está fuera del rango")

50 es mayor que 1 (VERDADERO), Y 50 es menor que 100 (VERDADERO), así que NO invierte ambos argumentos a FALSO. Y requiere que ambos argumentos sean verdaderos, por lo que devuelve el resultado si es FALSO.

=SI(O(NO(A3<0),NO(A3>50)),A3,"El valor está fuera del rango")

100 no es menor que 0 (FALSO) y 100 es mayor que 50 (VERDADERO), por lo que NO invierte los argumentos VERDADERO/FALSO. O solo requiere que uno de los argumentos sea VERDADERO, por lo que devuelve el resultado si es VERDADERO.

Cálculo de la comisión de ventas

Aquí se muestra un escenario bastante común donde necesitamos calcular si el personal de ventas está cualificado para recibir un bonus mediante NO con SI e Y.

Ejemplo de calcular una bonificación de ventas con las funciones SI, Y y NO.  La fórmula de la celda E14 es =SI(Y(NO(B14<$B$7),NO(C14<$B$5)),B14*$B$8,0)
  • =SI(Y(NO(B14<$B$7),NO(C14<$B$5)),B14*$B$8,0- SI las ventas totales NO son menores que el objetivo de ventas, Y las cuentas tienen NO son menores que el objetivo de cuentas, entonces se multiplican las ventas totales por el % de la comisión, en caso contrario, devuelve 0.

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Vea también

Ver un vídeo sobre cómo usar la función SI

Obtener información sobre cómo usar funciones anidadas en una fórmula

Función SI

Función Y

Función O

Información general de fórmulas en Excel

Cómo evitar las fórmulas rotas

Usar la comprobación de errores para detectar errores en las fórmulas

Métodos abreviados de teclado en Excel 2016 para Windows

Métodos abreviados de teclado en Excel 2016 para Mac

Funciones lógicas (referencia)

Funciones de Excel (orden alfabético)

Funciones de Excel (por categoría)

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×