Modificar, editar o cambiar un informe

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Este tema describe las técnicas que puede usar para modificar un informe existente de Access. Access proporciona dos vistas que puede usar para realizar cambios en el informe: la vista Diseño y la vista Diseño. La opción de vista para usar depende de la tarea específica está intentando llevar a cabo. Es posible que acabe utilizar ambas vistas para realizar los cambios.

¿Qué quiere hacer?

Comprender la vista Diseño

Comprender la vista Diseño

Alternar entre las vistas

Modificar el informe en la vista Diseño

Modificar el informe en la vista Diseño

Comprender la vista Diseño

Vista presentación es la vista más intuitiva para modificación de informes y se puede usar para casi todos los cambios que desee realizar en un informe en Access. En la vista Diseño, el informe se está ejecutando, para que pueda ver los datos como aparecerá al imprimirlo. Sin embargo, también puede realizar cambios en el diseño del informe en esta vista. Dado que puede ver los datos mientras está modificando el informe, es una vista muy útil para establecer el ancho de columna, agregar niveles de agrupamiento, o realizar casi cualquier otra tarea que afecta a la apariencia y legibilidad del informe. La siguiente ilustración muestra un informe de libreta de teléfonos del cliente en la vista Diseño.

Informe en la vista Presentación

El informe que ve en la vista presentación no es exactamente el mismo que el informe impreso. Por ejemplo, no hay ningún saltos de página en la vista Diseño. Además, si ha usado Configurar página para formato el informe con columnas, las columnas no se muestran en la vista Diseño. Sin embargo, la vista Diseño le ofrece una aproximación muy del informe impreso. Si desea ver el aspecto que tendrá el informe impreso, use la vista previa de impresión.

Determinadas tareas no se puede realizar en la vista Diseño y requieren que se va a cambiar a la vista Diseño. En algunos casos, Access muestra un mensaje que le indica que debe cambiar a la vista Diseño para realizar un cambio determinado.

Comprender la vista Diseño

Vista Diseño ofrece una vista más detallada de la estructura del informe. Puede ver las bandas de encabezado y pie de página para el informe, página y grupos. El informe no se está ejecutando en la vista Diseño, por lo que no puede ver los datos subyacentes mientras se trabaja; Sin embargo, hay algunas tareas que puede realizar más fácilmente en la vista de diseño que en la vista Diseño. Puedes:

  • Agregar una mayor variedad de controles al informe, como etiquetas, imágenes, líneas y rectángulos.

  • Editar orígenes de control de cuadro de texto en los propios cuadros de texto, sin usar la hoja de propiedades.

  • Cambiar algunas propiedades que no están disponibles en la vista Diseño.

La siguiente ilustración muestra un informe de libreta de teléfonos del cliente en la vista Diseño.

Informe en la vista Diseño

Alternar vistas

Access proporciona una gran variedad de métodos para cambiar entre vistas. Si el informe está ya abierto, puede cambiar a otra vista siguiendo uno de estos procedimientos:

  • Haga clic en el informe en el panel de navegación y, a continuación, haga clic en la vista que desee en el menú contextual.

  • Haga clic en la ficha de documentos o la barra de título y, a continuación, haga clic en la vista que desee en el menú contextual.

  • En la ficha Inicio, en el grupo Ver, haga clic en el botón Ver para alternar entre las vistas disponibles. Como alternativa, puede haga clic en la flecha situada debajo de vista y, a continuación, seleccione una de las vistas disponibles en el menú.

  • Secundario en un área en blanco del informe y, a continuación, haga clic en la vista que desee. Si el informe está abierto en la vista Diseño, debe secundario fuera de la cuadrícula de diseño.

  • Haga clic en uno de los iconos de vista pequeño en la barra de estado de Access.

Si el informe no está abierto, haga doble clic en el informe en el panel de navegación para abrirlo en la vista informe. Para abrir el informe en otra vista, haga clic en el informe en el panel de navegación y, a continuación, haga clic en la vista que desee en el menú contextual.

Nota: Si va a modificar un informe en el que ha usado Configurar página para crear varias columnas (por ejemplo, un informe de etiquetas postales), solo puede ver las columnas en la vista previa de impresión. Cuando ve el informe en la vista informe o presentación, Access muestra los datos en una sola columna.

Modificar el informe en la vista Diseño

Esta sección describen algunas de las modificaciones de informe comunes que puede realizar en la vista Diseño.

Cambiar el ancho de columna o un campo en la vista Diseño

  1. Haga clic en un elemento de la columna que desea ajustar.

    Se dibuja un borde alrededor del elemento para indicar que el campo está seleccionado.

  2. Arrastre el borde derecho o izquierdo del borde hasta que la columna tenga el ancho que desee.

Cambiar el alto de fila o campo en la vista Diseño

  1. Haga clic en un elemento de la fila que desea ajustar.

    Se dibuja un borde alrededor del elemento para indicar que el campo está seleccionado.

  2. Arrastre el borde superior o inferior del borde hasta que la fila tenga el alto que desee.

Agregar un campo en la vista Diseño

  • En la pestaña Diseño, en el grupo Herramientas, haga clic en Agregar campos existentes.

    Se muestra la lista de campos disponibles. Si hay campos disponibles en otras tablas, éstos se mostrarán en campos disponibles en otras tablas:.

  • Arrastre un campo desde la Lista de campos hasta el informe. Al mover el campo, un área resaltada indicará dónde se colocará el campo cuando suelte el botón del mouse.

    Nota: Para agregar varios campos a la vez, mantenga presionada la tecla CTRL y haga clic en cada campo en la Lista de campos que desee. A continuación, suelte la tecla CTRL y arrastre los campos al informe. Los campos se colocarán adyacentes.

Volver al principio

Comprender los diseños de controles

Diseños de controles son guías de alineación horizontal y vertical de los controles para dar a su informe una apariencia uniforme. Cree un diseño de controles como una tabla, donde cada celda de la tabla contiene un control. Los procedimientos siguientes muestran cómo agregar, quitar o reorganizar los controles en los diseños de control.

Diseños de control vienen en dos tipos: tabulares y apilados.

  • En los diseños de control tabular, los controles se organizan en filas y columnas como una hoja de cálculo, con etiquetas en la parte superior. Diseños de controles tabulares siempre expanden en dos secciones de un informe. cualquier sección los controles, las etiquetas estarán en la sección sobre ellos. La siguiente ilustración muestra un diseño de control tabular básico.

    Diseño básico de controles en tabla

  • En los diseños apilados, los controles se organizan verticalmente como es posible que vea en un formulario de papel, con una etiqueta a la izquierda de cada control. Diseños apilados siempre están incluidos en una única sección del informe. La siguiente ilustración muestra un diseño de control apilado básico.

    Diseño de control apilado básico

Puede tener varios diseños de controles de cualquier tipo en un informe. Por ejemplo, es posible que tenga un diseño tabular para crear una fila de datos de cada registro y, a continuación, uno o varios diseños apilados debajo, que contiene más datos del mismo registro.

Crear un nuevo diseño de control

Access crea automáticamente diseños de control en columnas en las circunstancias siguientes:

  • Crear un nuevo informe haciendo clic en informe Imagen del botón en el grupo de informes en la ficha crear.

  • Crear un nuevo informe haciendo clic en Informe en blanco Imagen del botón en el grupo de informes en la ficha crear y, a continuación, arrastrar un campo desde el panel Lista de campos al informe.

En un informe existente, puede crear un nuevo diseño de control haciendo lo siguiente:

  1. Seleccione un control que desee agregar al diseño.

  2. Si desea agregar otros controles al mismo diseño, mantenga presionada la tecla MAYÚS y seleccione también esos controles.

  3. Siga uno de estos procedimientos:

    • En la ficha Organizar, en el grupo tabla, haga clic en Tabular o apilado.

    • Haga clic en el control o controles seleccionados, elija Diseño y, a continuación, haga clic en Tabular o apilado.

Access crea el diseño de control y al que agregan los controles seleccionados.

Cambiar un diseño de control de tabular apiladas o de apilada a tabular

Para cambiar un diseño completo de un tipo de diseño a la otra:

  • Seleccione el diseño de control haciendo clic en el selector de diseño naranja en la esquina superior izquierda del diseño.

    Se seleccionan todas las celdas del diseño.

  • Siga uno de estos procedimientos:

    • En la ficha Organizar, en el grupo tabla, haga clic en el tipo de diseño que desee (Tabular o apilado ).

    • Haga clic en el diseño de control, elija Diseño y, a continuación, haga clic en el tipo de diseño que desee.

Access reorganiza los controles en el tipo de diseño que ha seleccionado.

Dividir un diseño de control en dos diseños

Puede dividir un diseño de control en dos diseños mediante el procedimiento siguiente:

  1. Mantenga presionada la tecla MAYÚS y haga clic en los controles que desee mover al nuevo diseño de control.

  2. Siga uno de estos procedimientos:

    • En la ficha Organizar, en el grupo tabla, haga clic en el tipo de diseño que desee para el nuevo diseño (Tabular o apilado ).

    • Haga clic en los controles seleccionados, elija Diseño y, a continuación, haga clic en el tipo de diseño que desee para el nuevo diseño.

Access crea un nuevo diseño de control y al que agregan los controles seleccionados.

Reorganizar los controles en un diseño de control

  • Puede mover un control dentro de un diseño de control, arrástrelo a la ubicación que desee. Mientras arrastra el campo, una barra horizontal o vertical indica dónde se colocará cuando suelte el botón del mouse.

  • Puede mover un control de un diseño de control a otro diseño de control del mismo tipo. Por ejemplo, puede arrastrar un control desde un diseño apilado a otro formato apilado, pero no a un diseño tabular.

Agregar controles a un diseño de control

Para agregar un nuevo campo desde el panel Lista de campos a un diseño de control existente   

  • Simplemente arrastre el campo desde el panel Lista de campos en el diseño. Una barra horizontal o vertical indica dónde se colocará el campo cuando suelte el botón del mouse.

Agregar controles existentes a un diseño de control existente   

  1. Seleccione el primer control que desee agregar al diseño de control.

  2. Si desea agregar otros controles al mismo diseño, mantenga presionada la tecla MAYÚS y seleccione también esos controles. Puede seleccionar controles en otros diseños de control.

  3. Siga uno de estos procedimientos:

    • Si el informe está abierto en la vista Diseño, arrastre los campos seleccionados en el diseño. Una barra horizontal o vertical indica dónde se colocará los campos cuando suelte el botón del mouse.

    • Si el informe está abierto en la vista presentación:

      1. En la ficha Organizar, en el grupo tabla, haga clic en el tipo de diseño que va a agregar. Si va a agregar a un diseño tabular, haga clic enTabular. Si va a agregar a un diseño apilado, haga clic enapilado.

        Access crea un nuevo diseño y agrega los controles seleccionados.

      2. Arrastre el nuevo diseño en el diseño existente. Una barra horizontal o vertical indica dónde se colocará los campos cuando suelte el botón del mouse.

Quitar los controles de un diseño de control

Eliminar un control de un diseño de controles permite colocarlo en cualquier parte del informe sin que ello afecte la posición de los otros controles.

  1. Seleccione el control que desee quitar de la distribución. Para seleccionar varios controles, mantenga presionada la tecla MAYÚS y, a continuación, haga clic en los controles que desea quitar. Para seleccionar todos los controles en el diseño, haga clic en el cuadro de selector de diseño en la esquina superior izquierda del diseño.

  2. Haga clic en uno de los controles seleccionados, elija Diseño y, a continuación, haga clic en Quitar diseño.

    Access elimina los controles seleccionados del diseño.

Sugerencia: Para evitar que un control que se inserta en un diseño de control al moverlo, mantenga presionada la tecla CTRL y, a continuación, arrastre el control hasta donde desee.

Volver al principio

Eliminar un campo o columna

  1. Haga clic en el campo o la columna que desea eliminar, o haga clic en la etiqueta o encabezado de columna.

    Access dibuja un borde alrededor del elemento para indicar que está seleccionado.

  2. Pulse SUPRIMIR.

Cambiar configuración de página

Usar los grupos de Tamaño de página y Diseño de página en la ficha Configurar página para cambiar el tamaño, orientación, márgenes y así sucesivamente.

  1. Haga clic en la pestaña Configuración de página.

  2. En el grupo Tamaño de página, haga clic en tamaño para seleccionar otro tamaño de papel.

  3. En el grupo Tamaño de página, haga clic en márgenes para realizar ajustes en los márgenes del informe.

  4. En el grupo Diseño de página, haga clic en vertical u horizontal para cambiar la orientación del papel.

Cambiar el formato de un campo

  1. Seleccione el campo al que desea aplicar formato.

  2. En la ficha formato, use las herramientas del grupo fuente para aplicar el formato que desee.

Enlazar un cuadro de texto a un campo diferente (cambiar el origen de un control)

  1. Haga clic dentro de la columna o el campo que desea cambiar el origen del control.

    Se dibuja un borde alrededor del elemento para indicar que el campo está seleccionado.

  2. Si actualmente no se muestra la hoja de propiedades, presione F4 para mostrarla.

  3. En la pestaña datos de la hoja de propiedades, establezca la propiedad ControlSource en el nuevo campo. Puede seleccionar un campo de la lista desplegable, o puede escribir una expresión en el cuadro.

Cambiar el origen de registros del informe

  1. Si no se muestra la hoja de propiedades, presione F4 para mostrarla.

  2. En la lista desplegable en la parte superior de la hoja de propiedades, haga clic en informe.

  3. En la hoja de propiedades, haga clic en la pestaña Datos.

  4. En la lista desplegable Origen del registro, seleccione la tabla o consulta que desea usar para un origen de registros o haga clic en Botón Generador para mostrar el generador de consultas.

    Nota: Si el informe está basado actualmente en una tabla, Access le preguntará si desea crear una consulta basada en la tabla. Haga clic en para mostrar el generador de consultas y crear la consulta o haga clic en No para cancelar la operación. Si elige crear una consulta, la nueva consulta se convertirá en el origen de registros del informe. Se creará como una consulta "incrustada", es decir, una consulta que se almacena en la propiedad RecordSource del informe, en lugar de como un objeto de consulta independiente.

Ajustar el texto en un campo

  1. Si no se muestra la hoja de propiedades, haga clic en el campo en el que desea ajustar el texto y haga clic en Propiedades. En caso contrario, simplemente haga clic en el campo para seleccionarlo.

  2. En la ficha formato de la hoja de propiedades, establezca la propiedad Autoextensible en.

Agregar líneas de división

Si los controles están incluidos en un diseño de control, puede agregar líneas de división para proporcionar separación más visual entre los controles.

  1. Haga clic en cualquier campo en un diseño de control.

    Se dibuja un borde alrededor del campo para indicar que está seleccionado.

  2. En la ficha Organizar, en el grupo tabla, haga clic en cuadrícula.

  3. Seleccione el estilo de cuadrícula que desee de la lista desplegable.

Nota: También puede agregar líneas de división haciendo doble clic en cualquier campo en un diseño de controles, apuntando a presentación, apuntando a las líneas de división y seleccionando el tipo de cuadrícula que desee.

Volver al principio

Agregar o modificar un logotipo u otra imagen

Los procedimientos siguientes muestran cómo agregar un logotipo a un informe mediante la herramienta logotipo y cómo cambiar el tamaño de un control de imagen o una imagen dentro de un control de imagen.

Agregar un logotipo

  • En la ficha Diseño, en el grupo Encabezado y pie de página, haga clic en logotipo.

    Se muestra el cuadro de diálogo Insertar imagen.

  • Vaya a la carpeta donde se encuentra almacenado el archivo de logotipo y haga doble clic en el archivo.

    Access agrega el logotipo a la esquina superior izquierda del informe.

Cambiar el tamaño de un control que contiene un logotipo u otra imagen

  1. Haga clic en el control que contiene la imagen.

    Se dibuja un borde alrededor del control para indicar que está seleccionado.

  2. Coloque el puntero en el borde. Cuando el puntero se convierta en una flecha de dos puntas, puede arrastrarlo en las direcciones indicadas por las flechas para hacer que el control de imagen mayor o menor.

Nota que el valor predeterminado de la propiedad de Modo de tamaño de una imagen es Recortar, lo que significa que la imagen tendrá el mismo tamaño independientemente del tamaño del control de imagen. Si desea que la imagen para obtener mayor o menor, mientras que el tamaño del control, haga lo siguiente:

Cambiar el logotipo o la imagen dentro del control

  1. Seleccione la imagen.

  2. Si no se muestra la Hoja de propiedades, presione F4 para mostrarla.

  3. En la ficha formato de la hoja de propiedades, establezca la propiedad de Modo de tamaño en la opción que desee:

Configuración

Descripción

Imagen prediseñada

La imagen sea el mismo tamaño, independientemente del tamaño pequeño realizar el control de imagen. Si hace más pequeño que la imagen del control de imagen, se recorta la imagen.

Estirar

La imagen se expande vertical y horizontalmente para que coincida con el tamaño del control de imagen. No se conserva la relación de aspecto original de la imagen, por lo que esta configuración puede dar lugar a una imagen distorsionada a menos que establezca con precisión el alto y ancho del control de imagen.

Zoom

Como se cambia el tamaño del control de imagen, la imagen se ajusta para ser tan grande como sea posible sin que ello afecte la relación de aspecto original de la imagen.

Volver al principio

Agregar o editar el título de un informe

Los procedimientos siguientes muestran cómo agregar o modificar una etiqueta que contiene el título del informe.

Agregar un título a un informe

  • En la ficha Diseño, en el grupo Encabezado y pie de página, haga clic en título.

    Se agrega una nueva etiqueta en el encabezado del informe y, a continuación, el nombre del informe se introduce automáticamente como el título del informe.

  • Cuando se crea la etiqueta, el texto de la etiqueta se selecciona para que si desea cambiar el texto, comience a escribir el título que desee.

  • Cuando haya terminado, presione ENTRAR.

Editar el título del informe

  1. Haga doble clic en la etiqueta que contiene el título del informe para colocar el cursor en la etiqueta.

  2. Escriba el texto que desea usar como el título del informe y presione ENTRAR cuando haya terminado.

Agregar números de página, la fecha actual o la hora actual

Los procedimientos siguientes muestran cómo agregar números de página a un informe y cómo agregar la fecha actual o la hora actual.

Agregar números de página

  • En la ficha Diseño, en el grupo Encabezado y pie de página, haga clic en Números de página.

    Se muestra el cuadro de diálogo Números de página.

  • Elija el formato, la posición y la alineación que desee para los números de página.

  • Si no desea un número en la primera página, desactive la casilla de verificación Mostrar el número de la primera página.

  • Haga clic en Aceptar.

    Los números de página se agregan al informe. Cambiar a vista preliminar para ver el aspecto que tendrán los números al imprimir el informe.

Agregar la fecha u hora

  • En la ficha Diseño, en el grupo Encabezado y pie de página, haga clic en fecha y hora.

    Se muestra el cuadro de diálogo fecha y hora.

  • Desactive la casilla de verificación Incluir fecha si no desea incluir la fecha.

  • Si desea incluir la fecha, haga clic en el formato de fecha que desee.

  • Desactive la casilla de verificación Incluir hora si no desea incluir la hora.

  • Si desea incluir la hora, haga clic en el formato que desee.

    Se muestra un ejemplo de la fecha y hora en los formatos que haya elegido, en el área ejemplo del cuadro de diálogo.

  • Haga clic en Aceptar.

Modificar el informe en la vista Diseño

En algunos casos, no se puede realizar modificaciones en el informe en la vista Diseño y debe utilizar la vista Diseño.

Agregar números de línea

  1. En el grupo Controles de la pestaña Diseño, haga clic en Cuadro de texto.

  2. Haga clic en un área abierta de la sección donde desea que aparezcan los números de línea. En la mayoría de los casos, se trata de la sección de detalles. El cuadro de texto se moverá a su ubicación final más adelante.

    Al hacer clic en el informe, Access crea un cuadro de texto independiente nuevo.

  3. Haga clic en la etiqueta (justo a la izquierda del cuadro de texto nuevo) y presione SUPRIMIR.

  4. Haga clic una vez en el nuevo cuadro de texto para seleccionarlo y, a continuación, haga clic en para colocar el cursor en el cuadro de texto.

  5. Escriba = 1 y, a continuación, presione ENTRAR.

  6. Si no se muestra la Hoja de propiedades, presione F4 para mostrarla.

  7. En la pestaña datos de la hoja de propiedades, establezca la propiedad Suma continua en Sobre todo.

    Nota: Si se trata de un informe agrupado y si desea que la numeración comience en 1 para cada grupo, establezca la propiedad en Sobre grupo.

  8. Cambiar el tamaño del cuadro de texto a un ancho menor, colocando el puntero sobre el controlador de tamaño en el borde derecho del cuadro de texto y arrástrelo a la izquierda. Deje suficiente espacio para el número de línea mayor que espera ver en este informe.

  9. Si es necesario, liberar espacio para el cuadro de texto en el extremo izquierdo de la sección detalle arrastrando los controles existentes de esa sección a la derecha o cambiando el tamaño del control izquierda en esa sección.

  10. Arrastre el nuevo cuadro de texto a la ubicación que desee en el informe.

  11. Cambiar a la vista informe, vista preliminar o vista Diseño para ver los números de línea.

Hacer que un encabezado de grupo aparezca en la parte superior de cada página

Para los grupos que abarcan varias páginas, resulta útil tener el encabezado de grupo aparece en la parte superior de cada página para que pueda ver fácilmente qué grupo están los datos. Puede seleccionar un encabezado de grupo en la vista presentación, pero es más fácil hacerlo en la vista Diseño.

  1. Haga doble clic en el selector de sección de encabezado de grupo (la barra horizontal encima de la sección de encabezado de grupo).

  2. En la ficha formato de la hoja de propiedades, establezca la propiedad Repetir sección en .

Abrir un subinforme en su propia ventana de vista de diseño

Cuando abre un informe en la vista Diseño, cualquier subinforme incluido en el informe se abre también en la vista Diseño. Sin embargo, cada subinforme se muestra dentro de su control de subinforme, no como una ventana independiente. Dado que el control de subinforme a menudo es demasiado pequeño para trabajar con facilidad, es suele ser más cómodo abrir el subinforme en su propia ventana y, a continuación, editarlo. Para abrir un subinforme en una ventana nueva, siga uno de estos procedimientos:

  • Seleccione el subinforme y, a continuación, en la ficha Diseño, en el grupo Herramientas, haga clic en subinforme en nueva ventana.

  • Haga clic una vez fuera del control del subinforme para asegurarse de está desactivada y, a continuación, haga clic con botón dentro del control de subinforme y, a continuación, haga clic en subinforme en nueva ventana.

Volver al principio

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×