Introducción a las consultas

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Cuando desee revisar, agregar, cambiar o eliminar datos de la base de datos, considere la posibilidad de usar una consulta.

Al utilizar una consulta, puede responder a preguntas muy específicas acerca de sus datos que serían difíciles de responder mirando directamente la tabla de datos. Puede usar las consultas para filtrar los datos, realizar cálculos con ellos y resumirlos. También puede usar consultas para automatizar muchas tareas de administración de datos y revisar los cambios realizados en los datos antes de confirmarlos.

Nota: Funciones de consulta de agregado, como suma o contar, no están disponibles en las consultas Web.

El uso de consultas facilita muchas de las tareas con bases de datos

En este artículo

Información general

Mirar un subconjunto de los datos de una tabla

Revisar los datos de más de una tabla a la vez

Pida a variaciones de una pregunta con parámetros

Realizar cálculos basados en sus datos

Mirar datos resumidos o agregados

Crear una nueva tabla utilizando datos de otras tablas

Agregar datos a una tabla utilizando datos de otras tablas

Cambiar datos de forma automatizada

Eliminar datos de forma automatizada

Información general

En este artículo se proporciona información básica sobre las consultas y se proporciona ejemplos de los diferentes tipos de consultas.

Una consulta es una solicitud de los resultados de los datos, de las acciones de los datos o de ambos. Puede usar una consulta para responder a una pregunta sencilla, realizar cálculos, combinar datos de diferentes tablas o incluso para agregar, cambiar o eliminar datos de una tabla. Las consultas que se utilizan para recuperar datos de una tabla o realizar cálculos se denominan consultas de selección. Las consultas que agregan, cambian o eliminan datos se denominan consultas de acción.

También puede utilizar una consulta para proporcionar datos para un formulario o informe. En una base de datos debidamente diseñada, los datos que desea presentar mediante un formulario o informe se encuentran a menudo en varias tablas. Al utilizar una consulta, puede reunir los datos que desee usar antes de diseñar su formulario o informe.

Para obtener más información sobre cómo usar una consulta para proporcionar datos para formularios e informes, vea los vínculos que aparecen en la sección Vea también o busque en la Ayuda.

Abrir una consulta existente

Si no está familiarizado con el panel de navegación, es posible que no sepa cómo abrir una consulta que ya existe. El panel de navegación es una característica que reemplaza la ventana Base de datos de versiones anteriores a Access 2007. Verá el panel de navegación en el lado izquierdo de la pantalla.

Para abrir cualquier objeto de la base de datos, como una consulta, puede hacer doble clic en el objeto en el panel de navegación.

Usar la base de datos Northwind para practicar con ejemplos

Nota: En los ejemplos de este artículo se usa una base de datos creada mediante la plantilla de base de datos Northwind 2010.

  1. Haga clic en la pestaña Archivo y, a continuación, haga clic en Nuevo.

  2. En la mitad del panel, bajo Plantillas disponibles, haga clic en Plantillas de ejemplo y, a continuación, en Northwind.

  3. En el panel derecho, revise el nombre del archivo de base de datos del cuadro Nombre de archivo y haga cambios en caso necesario. También puede buscar otra ubicación si hace clic en el icono de carpeta.

  4. Haga clic en Crear.

  5. Siga las instrucciones que aparecen en la página Northwind Traders (en la ficha de objeto Pantalla de inicio) para abrir la base de datos y, a continuación, cierre la ventana Cuadro de diálogo de inicio de sesión.

Parte superior de la página

Mirar un subconjunto de los datos de una tabla

Puede que en ocasiones desee revisar todos los datos de una tabla, pero otras veces quizá desee revisar sólo los datos de determinados campos o revisar los datos sólo si ciertos campos cumplen determinados criterios. Para revisar algunos de los datos de una tabla, use una consulta de selección.

Suponga que desea comprobar una lista de productos y sus precios. Puede crear una consulta que devuelva la información de productos y precios siguiendo este procedimiento:

  1. Abra la base de datos Northwind que creó previamente mediante estos pasos.

  2. En la ficha Crear, en el grupo Consulta, haga clic en Diseño de la consulta.

  3. En el cuadro de diálogo Mostrar tabla, en la ficha Tablas, haga doble clic en Productos.

  4. Cierre el cuadro de diálogo Mostrar tabla.

  5. En la tabla Productos, haga doble clic en Nombre de producto y en Precio listado para agregar estos campos a la cuadrícula de diseño de la consulta.

  6. En la ficha Diseño, en el grupo Resultados, haga clic en Ejecutar.

    La consulta se ejecuta y se muestra una lista de productos y precios.

Parte superior de la página

Revisar los datos de más de una tabla a la vez

Tablas en una base de datos bien diseñada guardan relaciones lógicas entre sí. Estas relaciones existen basándose en los campos de las tablas tienen en común. Cuando desee revisar los datos de tablas relacionadas, utilice una consulta de selección.

Suponga que desea comprobar los pedidos de los clientes que viven en una determinada ciudad. Los datos sobre los pedidos y los clientes están almacenados en dos tablas de la misma base de datos. Cada tabla tiene un campo Id. de cliente, que forma la base de una relación de uno a varios entre las dos tablas. Puede crear una consulta que devuelva los pedidos de los clientes de una determinada ciudad, como Las Vegas, siguiendo este procedimiento:

  1. Abra la base de datos Northwind que creó previamente mediante estos pasos.

  2. En la ficha Crear, en el grupo Consulta, haga clic en Diseño de la consulta.

  3. En el cuadro de diálogo Mostrar tabla, en la ficha Tablas, haga doble clic en Clientes y en Pedidos.

  4. Cierre el cuadro de diálogo Mostrar tabla.

    Fíjese en la línea, denominada combinación, que conecta el campo Id. de la tabla Clientes con el campo Id. de cliente de la tabla Pedidos. Esta línea muestra la relación entre las dos tablas.

  5. En la tabla Clientes, haga doble clic en Compañía y en Ciudad para agregar estos campos a la cuadrícula de diseño de la consulta.

  6. En la cuadrícula de diseño de consulta, en la columna Ciudad, desactive la casilla de verificación la fila Mostrar.

  7. En la fila Criterios de la columna Ciudad, escriba Las Vegas.

    Desactivando la casilla de verificación Mostrar impide que se muestre la ciudad en los resultados de la consulta y, a continuación, escribir Las Vegas en la fila criterios especifica que desea ver solo los registros donde el valor del campo Ciudad es Las Vegas. En este caso, la consulta devuelve únicamente a los clientes que se encuentran en Las Vegas, L y empresa AA.

    Tenga en cuenta que no tiene que mostrar un campo para usarlo con un criterio.

  8. En la tabla Pedidos, haga doble clic en Id. de pedido y en Fecha de pedido para agregar estos campos a las siguientes dos columnas de la cuadrícula de diseño de la consulta.

  9. En la ficha Diseño, en el grupo Resultados, haga clic en Ejecutar.

    La consulta se ejecuta y muestra una lista con los pedidos de los clientes de Las Vegas.

  10. Presione CTRL+G para guardar la consulta.

    Aparecerá el cuadro de diálogo Guardar como.

  11. En el cuadro Nombre de la consulta, escriba Pedidos por ciudad y, a continuación, haga clic en Aceptar.

Parte superior de la página

Pida a variaciones de una pregunta con parámetros

Puede que en ocasiones desee ejecutar una consulta que sólo se diferencie ligeramente de otra existente. Puede cambiar la consulta original para usar su nuevo criterio, pero si desea ejecutar con frecuencia variaciones de una consulta concreta, considere la posibilidad de usar una consulta de parámetros. Cuando ejecuta una consulta de parámetros, la consulta solicita los valores de los campos y, a continuación, usa los valores especificados para crear los criterios de la consulta.

En el ejemplo anterior, creó una consulta que devuelve los pedidos de los clientes de Las Vegas. Puede modificar la consulta de modo que le pida la ciudad cada vez que la ejecute siguiendo este procedimiento:

  1. Abra la base de datos Northwind que creó previamente mediante estos pasos.

  2. Presione F11 para mostrar el panel de navegación.

    Nota: Este paso no es necesario si ya se muestra el panel de exploración.

  3. En el panel de exploración, haga clic con el botón secundario del mouse (ratón) en la consulta denominada Pedidos por ciudad (que creó en la sección anterior) y, a continuación, haga clic en Vista Diseño en el menú contextual.

  4. En la cuadrícula de diseño de consulta, en la fila criterios de la columna ciudad, elimine Las Vegasy, a continuación, escriba [¿qué city?].

    La cadena [¿qué city?] es el indicador de parámetro. Los corchetes indica que desea que la consulta para solicitar entrada y el texto (en este caso, para ¿Qué ciudad?) es la pregunta que muestra el indicador de parámetro.

    Nota: No se puede usar ni un punto (.) ni un signo de exclamación (!) como texto en el mensaje de solicitud de parámetros.

  5. Active la casilla de verificación en la fila Mostrar de la columna Ciudad de manera que se muestre la ciudad en los resultados de la consulta.

  6. En la ficha Diseño, en el grupo Resultados, haga clic en Ejecutar.

    La consulta solicita que indique un valor para Ciudad.

  7. Escriba Nueva York y, a continuación, presione ENTRAR.

    La consulta se ejecuta y muestra los pedidos de los clientes de Nueva York.

    ¿Pero qué sucede si no sabe qué valores puede especificar? Para que los parámetros sean más flexibles, use caracteres comodín como parte del mensaje:

  8. En la ficha Inicio, en el grupo Vistas, haga clic en Ver y, a continuación, haga clic en Vista Diseño.

  9. En la cuadrícula de diseño de la consulta, en la fila Criterios de la columna Ciudad, escriba Como [¿Para qué ciudad?]&"*".

    En este parámetro preguntar, la palabra clave Like , la y comercial (&), y el asterisco (*) entre comillas permitir que el usuario escriba una combinación de caracteres, incluidos los caracteres comodín, para devolver una gran variedad de resultados. Por ejemplo, si el usuario escribe *, la consulta devuelve todas las ciudades; Si el usuario escribe L, la consulta devuelve todas las ciudades que empiecen por la letra "L"; y si el usuario escribe * s *, la consulta devuelve todas las ciudades que contienen la letra "s".

  10. En la ficha Diseño, en el grupo Resultados, haga clic en Ejecutar.

    En la solicitud de consulta, escriba Nueva y, a continuación, presione ENTRAR.

  11. La consulta se ejecuta y muestra los pedidos de los clientes de Nueva York.

Especificar los tipos de datos de los parámetros

También puede especificar qué tipo de datos debe aceptar un parámetro. Puede establecer el tipo de datos para cualquier parámetro, pero es especialmente importante establecer el tipo de datos para los datos numéricos, de moneda o de fecha y hora. Cuando se especifica el tipo de datos que debe aceptar un parámetro, los usuarios ven un mensaje de error más útil si especifican el tipo de datos equivocado, por ejemplo, texto cuando se espera moneda.

Nota: Si se establece un parámetro para que acepte datos de texto, cualquier entrada se interpretará como texto y no se mostrará ningún mensaje de error.

Para especificar el tipo de datos de los parámetros de una consulta, siga este procedimiento:

  1. Con la consulta abierta en la vista Diseño, en la ficha Diseño, en el grupo Mostrar u ocultar, haga clic en Parámetros.

  2. En el cuadro de diálogo Parámetros de la consulta, en la columna Parámetro, escriba la solicitud de cada parámetro para el que desee especificar el tipo de datos. Asegúrese de que cada parámetro coincida con la solicitud que utiliza en la fila Criterios de la cuadrícula de diseño de la consulta.

  3. En la columna Tipo de datos, seleccione el tipo de datos para cada parámetro.

Parte superior de la página

Realizar cálculos basados en sus datos

La mayor parte del tiempo, no se usan las tablas para calcular valores basados en datos de la misma base de datos. Por ejemplo, la tabla Detalles de pedido de Northwind 2007 no almacena los subtotales de los productos porque el subtotal correspondiente a un producto dado se calcula utilizando los datos almacenados en los campos Cantidad, Precio y Descuento de la tabla Detalles de pedido.

En algunos casos, los valores calculados ya no están actualizados porque cambian los valores en los que se basan. Por ejemplo, no debe almacenar la edad de una persona en una tabla porque cada año tendrá que actualizar el valor; en su lugar, almacene la fecha de nacimiento de la persona y, a continuación, use una expresión en una consulta para calcular su edad.

Siga el procedimiento que se detalla a continuación para crear una consulta que calcule los subtotales de los productos basándose en los datos de la tabla Detalles de pedido.

  1. Abra la base de datos Northwind que configuró previamente con estos pasos.

  2. En la ficha Crear, en el grupo Consulta, haga clic en Diseño de la consulta.

  3. En el cuadro de diálogo Mostrar tabla, en la ficha Tablas, haga doble clic en Detalles de pedido.

  4. Cierre el cuadro de diálogo Mostrar tabla.

  5. En la tabla Detalles de pedido, haga doble clic en Id. de producto para agregar este campo a la primera columna de la cuadrícula de diseño de la consulta.

  6. En la segunda columna de la cuadrícula, haga clic con el botón secundario del mouse en la fila Campo y, a continuación, haga clic en Zoom en el menú contextual.

  7. En el cuadro Zoom, escriba o pegue lo siguiente:

    Subtotal: ([Cantidad]*[Precio])-([Cantidad]*[Precio]*[Descuento])

    Haga clic en Aceptar.

    Este es el campo calculado. El campo calculado multiplica la cantidad de cada uno producto por el precio unitario de ese producto, multiplica la cantidad de cada producto por el precio de venta y descuento de ese producto y, a continuación, resta el descuento total del precio unitario total.

  8. En la ficha Diseño, en el grupo Resultados, haga clic en Ejecutar.

    Se ejecuta la consulta y, a continuación, se muestra una lista de productos y subtotales, por pedido.

  9. Presione CTRL+S para guardar la consulta y, a continuación, asigne un nombre a la consulta Subtotales de productos.

Parte superior de la página

Mirar datos resumidos o agregados

Cuando utiliza tablas para registrar las transacciones o almacenar datos numéricos que se usan periódicamente, resulta útil poder comprobar los datos agregados, como las sumas o los promedios.

Access le permite revisar los datos agregados simples en cualquier hoja de datos agregando una fila de totales. Una fila de totales es una fila en la parte inferior de la hoja de datos que puede mostrar un total u otro valor agregado.

Nota: No se puede agregar una fila Total a la hoja de datos de una consulta web.

Puede agregar una fila Total a la consulta Subtotales de productos que creó en el ejemplo anterior siguiendo este procedimiento:

  1. Ejecute la consulta Subtotales de productos y deje los resultados abiertos en la Vista de hoja de datos.

  2. En la ficha Inicio, en el grupo Registros, haga clic en Totales.

    Aparecerá una nueva fila en la parte inferior de la hoja de datos con la palabra Total en la primera columna.

  3. Haga clic en la celda de la última fila de la hoja de datos denominada Total.

    Observe que aparecerá una flecha en la celda.

  4. Haga clic en la flecha para ver las funciones de agregado disponibles.

    Dado que la columna contiene datos de texto, hay sólo dos opciones: Ninguno y Cuenta.

  5. Seleccione Cuenta.

    El contenido de la celda cambia de Total a una cuenta de los valores de la columna.

  6. Haga clic en la celda adyacente (la segunda columna).

    Observe que aparecerá una flecha en la celda.

  7. Haga clic en la flecha y, a continuación, en Suma.

    El campo muestra una suma de los valores de la columna.

  8. Deje la consulta abierta en la vista Hoja de datos.

Crear una consulta de totales para obtener resúmenes más complejos

La fila Total de una hoja de datos es muy útil, pero para preguntas más complejas, se utiliza una consulta de totales. Una consulta de totales es una consulta de selección que permite agrupar y resumir los datos. Por ejemplo, suponga que desea ver las ventas totales por producto. En una consulta de totales, puede usar Suma, una función de agregado, para ver las ventas totales por producto.

Nota: No se pueden usar funciones de agregado en una consulta web.

Siga el procedimiento que se detalla a continuación para modificar la consulta Subtotales de productos para obtener subtotales resumidos por producto.

  1. En la ficha Inicio, en el grupo Vistas, haga clic en Ver y, a continuación, haga clic en Vista Diseño.

    Se abre la consulta Subtotales de productos en la vista Diseño.

  2. En la ficha Diseño, en el grupo Mostrar u ocultar, haga clic en Totales.

    Aparece la fila Totales en la cuadrícula de diseño de la consulta.

    Nota: Si bien tienen nombres similares, la fila Totales de la cuadrícula de diseño y la fila Total de una hoja de datos no son lo mismo:

    • Puede agrupar por valores de campo mediante la fila Totales en la cuadrícula de diseño.

    • Puede agregar una fila Total de hoja de datos a los resultados de una consulta de totales.

    • Cuando utiliza la fila Totales en la cuadrícula de diseño, debe elegir una función de agregado para cada campo. Si no desea realizar un cálculo en un campo, puede agrupar por ese campo.

  3. En la segunda columna de la cuadrícula de diseño, en la fila Total, seleccione Suma en la lista desplegable.

  4. En la ficha Diseño, en el grupo Resultados, haga clic en Ejecutar.

    La consulta se ejecuta y, a continuación, muestra una lista de productos con subtotales.

  5. Presione CTRL+G para guardar la consulta. Deje la consulta abierta.

Crear una consulta de tabla de referencias cruzadas para agregar otro nivel de agrupamiento

Ahora, suponga que desea comprobar los subtotales de los productos, pero también desea agregar por mes, de modo que cada fila muestre los subtotales de un producto y cada columna muestre los subtotales de producto de un mes. Para mostrar los subtotales de un producto y los subtotales de producto de un mes, use una consulta de tabla de referencias cruzadas.

Nota: Una consulta de tabla de referencias cruzadas no se puede mostrar en un explorador web.

Puede modificar nuevamente la consulta Subtotales de productos de manera que la consulta devuelva filas con los subtotales de producto y columnas con los subtotales mensuales.

  1. En la ficha Inicio, en el grupo Vistas, haga clic en Ver y, a continuación, haga clic en Vista Diseño.

  2. En el grupo Configuración de consultas, haga clic en Mostrar tabla.

  3. En el cuadro de diálogo Mostrar tabla, haga doble clic en Pedidos y, a continuación, haga clic en Cerrar.

  4. En la ficha Diseño, en el grupo Tipo de consulta, haga clic en Tabla de referencias cruzadas.

    En la cuadrícula de diseño, la fila Mostrar está oculta y se muestra la fila Tabla de referencias cruzadas.

  5. En la tercera columna de la cuadrícula de diseño, haga clic con el botón secundario del mouse en la fila Campo y, a continuación, haga clic en Zoom en el menú contextual. Se abrirá el cuadro Zoom

  6. En el cuadro Zoom, escriba o pegue lo siguiente:

    Mes: "Mes " & ParcFecha("m", [Fecha de pedido])

  7. Haga clic en Aceptar.

  8. En la fila Tabla de referencias cruzadas, seleccione los valores siguientes en la lista desplegable: Encabezado de fila para la primera columna, Valor para la segunda columna y Encabezado de columna para la tercera columna.

  9. En la ficha Diseño, en el grupo Resultados, haga clic en Ejecutar.

    Se ejecuta la consulta y se muestran los subtotales de producto, agregados por mes.

  10. Presione CTRL+G para guardar la consulta.

Parte superior de la página

Crear una nueva tabla utilizando datos de otras tablas

Puede usar una consulta de creación de tabla para crear una nueva tabla a partir de datos almacenados en otras tablas.

Nota: No se puede ejecutar una consulta de creación de tabla en un explorador web.

Por ejemplo, suponga que desea enviar datos referentes a los pedidos de Chicago a un socio empresarial de Chicago que use Access para preparar informes. En lugar de enviar todos los datos de los pedidos, conviene restringirlos a los datos específicos de los pedidos de Chicago.

Puede crear una consulta de selección que contenga los datos de los pedidos de Chicago y, a continuación, usar la consulta de selección para crear la nueva tabla siguiendo este procedimiento:

  1. Abra la base de datos Northwind que creó previamente mediante estos pasos.

  2. Para ejecutar una consulta de creación de tabla, quizá necesite habilitar el contenido de la base de datos por medio de la barra de mensajes, que aparece debajo de la cinta de opciones si la base de datos no es de confianza al abrirla.

    Cómo habilitar la base de datos

    • En la barra de mensajes, haga clic en Habilitar contenido.

    Si la base de datos está en una ubicación de confianza, la barra de mensajes no aparecerá y no será necesario habilitar el contenido.

  3. Cierre el formulario del cuadro de diálogo de inicio de sesión.

  4. En la ficha Crear, en el grupo Consulta, haga clic en Diseño de la consulta.

  5. En el cuadro de diálogo Mostrar tabla, haga doble clic en Detalles de pedido y en Pedidos.

  6. Cierre el cuadro de diálogo Mostrar tabla.

  7. En la tabla Pedidos, haga doble clic en Id. de cliente y en Ciudad dest para agregar estos campos a la cuadrícula de diseño.

  8. En la tabla Detalles de pedido, haga doble clic en Id. de pedido, Id. de producto, Cantidad, Precio y Descuento para agregar estos campos a la cuadrícula de diseño.

  9. En la columna Ciudad dest de la cuadrícula de diseño, active la casilla situada en la fila Mostrar. En la fila Criterios, escriba 'Chicago' (incluidas las comillas simples).

    Compruebe los resultados de la consulta antes de usarlos para crear la tabla.

  10. En la ficha Diseño, en el grupo Resultados, haga clic en Ejecutar.

  11. Presione CTRL+G para guardar la consulta.

    Aparecerá el cuadro de diálogo Guardar como.

  12. En el cuadro Nombre de la consulta, escriba Consulta de pedidos de Chicago y, a continuación, haga clic en Aceptar.

  13. En la ficha Inicio, en el grupo Vistas, haga clic en Ver y, a continuación, en Vista Diseño.

  14. En la ficha Diseño, en el grupo Tipo de consulta, haga clic en Crear tabla.

    Aparecerá el cuadro de diálogo Crear tabla.

  15. En el cuadro de diálogo Crear tabla, en el cuadro Nombre de tabla, escriba Pedidos de Chicago y, a continuación, haga clic en Aceptar.

  16. En la ficha Diseño, en el grupo Resultados, haga clic en Ejecutar.

  17. En el cuadro de diálogo de confirmación, haga clic en para confirmar.

    Se crea la nueva tabla, que aparece en el panel de exploración.

    Nota: Si ya hay una tabla con el nombre especificado, ésta se borra antes de que se ejecute la consulta.

  18. En la ficha Diseño, en el grupo Resultados, haga clic en Ejecutar.

    Como ya existe la tabla Pedidos de Chicago, aparecerá un cuadro de diálogo de advertencia.

  19. Haga clic en No para cancelar la acción y cerrar el cuadro de diálogo.

Parte superior de la página

Agregar datos a una tabla utilizando datos de otras tablas

Puede utilizar una consulta de datos anexados para recuperar datos de una o varias tablas y agregar dichos datos a otra tabla.

Nota: No se puede ejecutar una consulta de datos anexados en un explorador web.

Suponga que creó una tabla para compartirla con un socio empresarial de Chicago, pero se da cuenta de que el socio también trabaja con clientes del área de Milwaukee. Ahora desea agregar a la tabla filas con datos del área de Milwaukee antes de compartir la tabla con su socio.

Puede agregar datos del área de Milwaukee a la tabla Pedidos de Chicago creada en el ejemplo anterior siguiendo este procedimiento:

  1. Abra la consulta denominada "Consulta de pedidos de Chicago" en la vista Diseño.

  2. En la pestaña Diseño, en el grupo Tipo de consulta, haga clic en Anexar. Se abre el cuadro de diálogo Anexar.

  3. En el cuadro de diálogo Anexar, haga clic en la flecha del cuadro Nombre de tabla y, a continuación, seleccione Pedidos de Chicago en la lista desplegable.

  4. Haga clic en Aceptar.

    Se cierra el cuadro de diálogo Anexar. En la cuadrícula de diseño, desaparece la fila Mostrar y aparece la fila Anexar a.

  5. En la cuadrícula de diseño, en la fila Criterios de la columna Ciudad dest, elimine 'Chicago' y, a continuación, escriba 'Milwaukee'.

  6. En la fila Anexar a, seleccione el campo adecuado para cada columna.

    En este ejemplo, los valores de la fila Anexar a deben coincidir con los de la fila Campo, pero no es obligatorio para que funcionen las consultas de datos anexados.

  7. En la ficha Diseño, en el grupo Resultados, haga clic en Ejecutar.

Nota: Al iniciar una consulta que devuelve una gran cantidad de datos, puede aparecer un mensaje de error que indica que la consulta no se puede deshacer. Pruebe a aumentar el límite del segmento de memoria a 3 MB para que la consulta se procese correctamente.

Parte superior de la página

Cambiar datos de forma automatizada

Puede usar una consulta de actualización para cambiar los datos de las tablas y para escribir los criterios con los que especificar las filas que deben actualizarse. Una consulta de actualización permite revisar los datos actualizados antes de realizar la actualización.

Importante: Una consulta de acción no se puede deshacer. Conviene que haga una copia de seguridad de las tablas que vaya a actualizar mediante una consulta de actualización.

Nota: No se puede ejecutar una consulta de actualización en un explorador web.

En el ejemplo anterior, anexó filas a la tabla Pedidos de Chicago. En esta tabla, el campo Id. de producto muestra el identificador de producto numérico. Para que los datos resulten más útiles para los informes, quizá prefiera reemplazar los identificadores de producto con los nombres de producto. Para ello, primero debe cambiar de Número a Texto el tipo de datos del campo Id. de producto de la tabla Pedidos de Chicago de manera que ese campo acepte nombres de producto.

Puede actualizar los valores de la tabla Pedidos de Chicago siguiendo este procedimiento:

  1. Abra la tabla Pedidos de Chicago en la vista Diseño.

  2. En la fila Id. de producto, cambie el tipo de datos de Número a Texto.

  3. Guarde y cierre la tabla Pedidos de Chicago.

  4. En la ficha Crear, en el grupo Consulta, haga clic en Diseño de la consulta.

  5. En el cuadro de diálogo Mostrar tabla, haga doble clic en Pedidos de Chicago y en Productos.

  6. Cierre el cuadro de diálogo Mostrar tabla.

  7. En la ficha Diseño, en el grupo Tipo de consulta, haga clic en Actualizar.

    En la cuadrícula de diseño, desaparecen las filas Ordenar y Mostrar y aparece la fila Actualizar a.

  8. En la tabla Pedidos de Chicago, haga doble clic en Id. de producto para agregar este campo a la cuadrícula de diseño.

  9. En la cuadrícula de diseño, en la fila Actualizar a de la columna de Identificador de producto, escriba o pegue la siguiente:

    [Productos].[Nombre de producto]

    Sugerencia: Puede usar una consulta de actualización para eliminar los valores de campo si utiliza una cadena vacía ("") o un valor NULL en la fila Actualizar a.

  10. En la fila Criterios, escriba o pegue lo siguiente:

    [Id. de producto] Como ([Productos].[Id])

    La palabra clave Like es necesaria porque los campos que se va a comparar contienen diferentes tipos de datos (identificador de producto es datos de texto, ID es datos numéricos).

  11. Puede comprobar qué valores van a cambiar debido a una consulta de actualización viendo la consulta en la vista Hoja de datos.

    En la ficha Diseño, en el grupo Resultados, haga clic en Ver y después en Vista Hoja de datos.

    La consulta devuelve una lista con los identificadores de producto que se van a actualizar.

  12. En la ficha Diseño, en el grupo Resultados, haga clic en Ejecutar.

    Cuando abra la tabla Pedidos de Chicago, verá que los valores numéricos del campo Id. de producto se han reemplazado por los nombres de producto de la tabla Productos.

Parte superior de la página

Eliminar datos de forma automatizada

Puede usar una consulta de eliminación para eliminar datos de las tablas o para escribir los criterios que especifiquen las filas que se deben eliminar. Una consulta de eliminación permite revisar las filas que se eliminarán antes de realizar la eliminación.

Nota: No se puede ejecutar una consulta de eliminación en un explorador web.

Suponga que va a enviar la tabla Pedidos de Chicago (actualizada en el ejemplo anterior) a su socio empresarial de Chicago y se da cuenta de que algunas de las filas contienen diversos campos vacíos. Desea eliminar estas filas vacías antes de enviar la tabla. Podrá abrir la tabla y eliminar las filas manualmente, pero quizá le resulte más útil usar una consulta de eliminación si hay que eliminar bastantes filas y tiene claros los criterios para especificar las filas que deben eliminarse.

Puede usar una consulta para eliminar de la tabla Pedidos de Chicago las filas que no tengan un valor para Id. de pedido siguiendo este procedimiento:

  1. En la ficha Crear, en el grupo Consulta, haga clic en Diseño de la consulta.

  2. En el cuadro de diálogo Mostrar tabla, haga doble clic en Pedidos de Chicago.

  3. Cierre el cuadro de diálogo Mostrar tabla.

  4. En la ficha Diseño, en el grupoTipo de consulta, haga clic en Eliminar.

    En la cuadrícula de diseño, desaparecen las filas Ordenar y Mostrar y aparece la fila Eliminar.

  5. En la tabla Pedidos de Chicago, haga doble clic en Id. de pedido para agregarlo a la cuadrícula.

  6. En la cuadrícula de diseño, en la fila Criterios de la columna Id. de pedido, escriba Es Nulo.

  7. En la ficha Diseño, en el grupo Resultados, haga clic en Ejecutar.

Principio de página

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

¿Le ha sido útil esta información?

De acuerdo. ¿Algún comentario más?

¿Cómo podemos mejorarlo?

¡Gracias por sus comentarios!

×