Introducción a Access 2007

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Hay varias formas de comenzar a trabajar con Microsoft Office Access 2007, dependiendo de si se usa Access por primera vez, mover datos desde otro programa de hoja de cálculo o de base de datos en Access o actualizar desde una versión anterior de Access. En este artículo se aborda los problemas que puedan surgir en cada una de estas situaciones.

¿Qué desea hacer?

Empezar a usar Access por primera vez

Importar datos desde una hoja de cálculo u otro programa

Usar una base de datos de una versión anterior en varias versiones de Access

Empezar a usar Access por primera vez

características de Office Access 2007 un número de mejoras que hacen que el proceso de creación de una base de datos sea más fácil que nunca. Los usuarios que hayan creado bases de datos en Access antes apreciarán cómo estas características nuevas y mejoradas aceleran el proceso de creación.

Cuando empiece a Office Access 2007, la primera pantalla que aparece es la página Introducción a Microsoft Office Access (a menos que inicie Access haciendo doble clic en un archivo de base de datos específico de Access, en cuyo caso que se abre la base de datos en su lugar). La página Introducción a Microsoft Office Access es el punto de partida desde el que puede crear una nueva base de datos, abra una base de datos existente o ver contenido destacado de Microsoft Office Online.

Crear una base de datos mediante una plantilla

Descargar una plantilla de Microsoft Office Online

Crear una base de datos desde cero

Crear una base de datos en blanco

Agregar una tabla

Pegar datos de otro origen en una tabla de Access

Importar datos de otro origen

Abrir una base de datos existente de Access

Sugerencia: Access 2010 tiene herramientas eficaces que resulte más fácil realizar un seguimiento, informe y compartir los datos.

Crear una base de datos mediante una plantilla

Access incluye una gran variedad de plantillas que se pueden usar para acelerar el proceso de creación de bases de datos. Una plantilla es una base de datos lista para usar que contiene todas las tablas, consultas, formularios e informes necesarios para llevar a cabo una tarea específica. Por ejemplo, hay plantillas que se pueden usar para realizar un seguimiento de problemas, administrar contactos o gastos. Algunas plantillas contienen varios registros de ejemplo que ayudan a mostrar su uso. Las plantillas de base de datos pueden usarse tal cual o pueden personalizarse de modo que se ajusten a las necesidades específicas del usuario.

  1. Inicie Access, si no está ya en ejecución.

    Si ya está abierta una base de datos, haga lo siguiente para mostrar la página Introducción a Microsoft Office Access:

    • Haga clic en el Botón de Microsoft Office Imagen de botón

      Página Introducción a Microsoft Office Access

  2. Aparecen varias plantillas bajo Plantillas destacadas en línea en la página Introducción a Microsoft Office Access, y mucho más no estarán disponibles si hace clic en una de las categorías debajo de Categorías de plantillas en el lado izquierdo de la ventana de Access. Aún más pueden descargarse desde el sitio Web de Microsoft Office (consulte la siguiente sección, descargar una plantilla de Microsoft Office Online, para obtener información detallada).

  3. Haga clic en la plantilla que desee utilizar.

  4. En el panel en el lado derecho de la ventana de Access, Access sugiere un nombre de archivo para la base de datos en el cuadro Nombre de archivo. Puede editar el nombre de archivo y especifique una carpeta diferente. Si lo desea, puede crear la base de datos y vincular a un sitio de Windows SharePoint Services 3.0.

  5. Haga clic en crear (o haga clic en Descargar, para una plantilla de Office Online).

    Access crea y, a continuación, abre la base de datos. Se abrirá un formulario, en el que puede comenzar a escribir datos.

    Nota: Si la plantilla contiene datos de ejemplo, puede eliminar cada registro como sigue:

    • Haga clic en el encabezado de fila para el registro que desea eliminar. (El encabezado de fila es el cuadro o la barra que aparece a la izquierda del registro).

    • En la ficha Inicio, en el grupo registros, haga clic en Eliminar. Imagen de botón

  6. Para empezar a introducir datos, haga clic en la primera celda vacía del formulario y empiece a escribir. Después de escribir algunos registros, puede usar el panel de navegación para ver si hay otros formularios o informes que desee usar.

Descargar una plantilla de Microsoft Office Online

Si no encuentra una plantilla que se adapte a sus necesidades en la página Introducción a Microsoft Office Access, puede explorar el sitio Web de Office Online para una selección más grande.

  1. Inicie Access, si no está ya en ejecución.

    Si ya está abierta una base de datos, haga lo siguiente para mostrar la página Introducción a Microsoft Office Access:

    • Haga clic en el Botón de Microsoft Office Imagen de botón

  2. En la parte inferior de la página Introducción a Microsoft Office Access, en más en Office Online, haga clic en plantillas.

    El sitio Web de Office Online aparece en una nueva ventana del explorador.

  3. Use las herramientas de búsqueda en el sitio de Office Online para buscar y descargar la plantilla que desee.

  4. Después de descargar una plantilla, la nueva base de datos se almacena en una de las siguientes carpetas:

    • Windows Vista    c:\Users\user usuario\Documents

    • Microsoft Windows Server 2003 o Microsoft Windows XP    c:\Documents and Settings\nombre de usuario\Mis documentos

      La próxima vez que desee trabajar con la base de datos, use Access o el Explorador de Windows para abrirla desde esa ubicación.

Principio de la sección

Crear una base de datos desde cero

Si ninguna de las plantillas se ajusta a sus necesidades, o si tiene datos en otro programa que desea importar a Access, quizás decida que es mejor crear una base de datos desde cero. Para la mayoría de las aplicaciones, este proceso implica uno o ambos de los procedimientos siguientes:

  • Crear nuevas tablas y, a continuación, escribir, pegar o importar datos a esas tablas.

  • Importar datos desde otros orígenes, que crea nuevas tablas en el proceso.

Para más información sobre cómo planear y diseñar una base de datos, o sobre cómo crear relaciones, formularios, informes o consultas, siguen los vínculos de la sección Vea también de este artículo.

Crear una base de datos en blanco

  1. Inicie Access.

  2. En la página Introducción a Microsoft Office Access, haga clic en Base de datos en blanco.

    Botón Base de datos en blanco

  3. En el panel de la Base de datos en blanco, escriba un nombre de archivo en el cuadro Nombre de archivo. Si no proporciona una extensión de nombre de archivo, Access agrega automáticamente. La ubicación predeterminada del archivo es uno de estos procedimientos:

    • Windows Vista    c:\Users\user usuario\Documents

    • Microsoft Windows Server 2003 o Microsoft Windows XP    c:\Documents and Settings\nombre de usuario\Mis documentos

      Para cambiar la ubicación del archivo, haga clic en Examinar Imagen de botón junto al cuadro Nombre de archivo, busque y seleccione la nueva ubicación y, a continuación, haga clic en Aceptar.

  4. Haga clic en Crear.

    Access crea la base de datos y, a continuación, abre una tabla vacía (denominada Tabla1) en la Vista de hoja de datos.

  5. Access coloca el cursor en la primera celda vacía de la columna Agregar nuevo campo.

    Tabla nueva vacía en una nueva base de datos

    Para agregar datos, comience a escribir, o bien, pegue datos de otro origen tal y como se describe en la sección Pegar datos de otro origen en una tabla de Access, más adelante en este artículo.

    Notas: 

    • Escribir datos en la vista Hoja de datos es muy similar a escribir datos en una hoja de cálculo de Excel. La principal restricción es que los datos deben escribirse en filas y columnas contiguas, empezando en la esquina superior izquierda de la hoja de datos. No intente aplicar formato a los datos incluyendo filas o columnas en blanco tal y como haría en una hoja de Excel, ya que de este modo desperdiciaría espacio en la tabla. La tabla contiene únicamente sus datos. Toda la presentación visual de esos datos la hará en los formularios e informes que diseñe más adelante.

    • Mientras escribe datos, se crea la estructura de tabla. Cada vez que agregue una columna nueva a la tabla, se define un nuevo campo. Access establece la tipo de datos del campo en función del tipo de datos que especifique. Por ejemplo, si tiene una columna en la que ha escrito únicamente valores de fecha, Access establecerá el tipo de datos de ese campo en fecha y hora. Si más adelante intenta escribir un valor de fecha no (como un nombre o un número de teléfono) de ese campo, Access muestra un mensaje que le informa de que el valor no coincide con el tipo de datos de la columna. Cuando sea posible, deberá planear la tabla para que cada columna contiene el mismo tipo de datos, ya sea texto, fechas, números o algún otro tipo. Esto facilita mucho más fácil crear consultas, formularios e informes que seleccionen solo los datos que desee.

    • Para obtener más información sobre cómo trabajar con hojas de datos, vea el artículo Abrir una hoja de datos en blanco.

Si no desea escribir datos en este momento, haga clic en Cerrar Imagen de botón.

Agregar una tabla

Puede agregar una nueva tabla a una base de datos existente mediante las herramientas del grupo Tablas de la ficha Crear.

Imagen de la cinta de Access

Haga clic en tabla para crear una tabla en blanco en la vista Hoja de datos. Puede usar la vista Hoja de datos para empezar a escribir datos inmediatamente y que Access cree la estructura de tabla para usted, o puede usar vista Diseño para crear primero la estructura de tabla y, a continuación, cambie a la vista Hoja de datos para escribir los datos. Independientemente de la vista iniciar en, siempre puede cambiar a la otra vista mediante los botones de vista en la barra de estado de la ventana de Access.

Insertar una tabla, empezando en la vista Hoja de datos    En la vista Hoja de datos, puede escribir datos inmediatamente y dejar que Access cree la estructura de tabla en segundo plano. Nombres de campo se asignan por números (campo1, campo2 etc.) y Access define el tipo de datos, en función del tipo de datos que especifique.

  1. En la ficha crear, en el grupo tablas, haga clic en tabla. Imagen de botón

  2. Access crea la tabla y, a continuación, coloca el cursor en la primera celda vacía de la columna Agregar nuevo campo.

    Nota: Si no ve una columna denominada Agregar nuevo campo, es posible que en la vista Diseño en lugar de la vista Hoja de datos. Para cambiar a la vista Hoja de datos, haga doble clic en la tabla en el panel de navegación. Access le pedirá que asigne un nombre para la nueva tabla y, a continuación, se cambia a la vista Hoja de datos.

  3. En la ficha hoja de datos, en el grupo campos y columnas, haga clic en Nuevo campo. Imagen de botón

    Access muestra el panel Plantillas de campos, que contiene una lista de tipos de campo utilizados con frecuencia. Si arrastra uno de estos campos a la hoja de datos, Access agregará un campo con ese nombre y establezca sus propiedades en un valor apropiado para ese tipo de campo. Puede cambiar las propiedades más adelante. Debe arrastrar el campo al área de la hoja de datos que contiene datos. Aparece una barra de inserción vertical, que muestra el campo donde se encuentran.

  4. Para agregar datos, comience a escribir en la primera celda vacía, o bien, pegue datos de otro origen tal y como se describe más adelante en este artículo.

    • Para cambiar el nombre de una columna (campo), haga doble clic en el encabezado de columna y, a continuación, escriba el nuevo nombre. Es recomendable asignar un nombre significativo a cada campo, por lo que puede saber qué contiene cuando lo vea en el panel Lista de campos.

    • Para mover una columna, selecciónela haciendo clic en su encabezado y, a continuación, arrástrela hasta la ubicación que desee. También puede seleccionar varias columnas contiguas y arrastrarlas juntas hasta una nueva ubicación.

Insertar una tabla, empezando en la vista Diseño    En la vista Diseño, cree primero estructura de la nueva tabla. A continuación, cambie a la vista Hoja de datos para escribir datos o escribir los datos mediante otro método, como pegar o anexar.

  1. En la ficha Crear, en el grupo Tablas, haga clic en Diseño de tabla. Imagen de botón

  2. Para cada campo de la tabla, escriba un nombre en la columna Nombre de campo y, a continuación, seleccione un tipo de datos en la lista Tipo de datos.

    Nota: Si no ve las columnas Nombre de campo y Tipo de datos, es posible que en la vista Hoja de datos en lugar de la vista Diseño. Para cambiar a la vista Diseño, haga clic en el botón de la vista Diseño en la barra de estado de la ventana de Access. Access le pedirá que asigne un nombre para la nueva tabla y, a continuación, cambia a la vista Diseño.

  3. Si lo desea, puede escribir una descripción para cada campo en la columna Descripción. La descripción se muestra en la barra de estado cuando el punto de inserción se encuentra en ese campo y se usa como texto de la barra de estado para los controles que cree arrastrando el campo desde el panel Lista de campos a un formulario o informe y para los controles que se crean para ese campo por el Asistente para formularios o el Asistente para informes.

  4. Tras agregar todos los campos, guarde la tabla :

    • Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y luego en Guardar o presione CTRL+G.

  5. Puede comenzar a escribir datos en la tabla en cualquier momento. Para ello, cambie a la vista Hoja de datos, haga clic en la primera celda vacía y comience a escribir. Asimismo, puede pegar datos de otro origen tal y como se describe en la siguiente sección.

Si, tras escribir algunos datos, desea agregar uno o más campos a la tabla, comience a escribir en la columna Agregar nuevo campo en la vista Hoja de datos, o puede agregar nuevos campos mediante los comandos en el grupo campos y columnas en la ficha hoja de datos.

Para obtener más información sobre la creación de tablas, incluido el uso de plantillas de tabla, vea el artículo crear tablas en una base de datos.

Principio de la sección

Pegar datos de otro origen en una tabla de Access

Si los datos están almacenados en otro programa, como Office Excel 2007, puede copiarlos y pegarlos en una tabla de Access. En general, este proceso funciona mejor si los datos ya están separados en columnas, como ocurre en las hojas de cálculo de Excel. Si los datos están en un programa de procesamiento de texto, es conveniente separar las columnas de datos con tabulaciones o convertir los datos en una tabla en el programa de procesamiento de texto antes de copiar los datos. Si los datos requieren modificación o algún tipo de manipulación (por ejemplo, separar los nombres completos en nombres y apellidos), quizás prefiera realizar esta operación antes de copiar los datos, especialmente si no está familiarizado con Access.

Cuando pegue los datos en una tabla vacía, Access definirá el tipo de datos de cada campo de acuerdo con la clase de datos que encuentre. Por ejemplo, si un campo pegado no contiene más que valores de fecha, Access aplica el tipo de datos Fecha/Hora a ese campo. Si el campo pegado sólo contiene las palabras "sí" y "no", Access aplica el tipo de datos Sí/No al campo.

Access asigna nombres a los campos dependiendo de lo que encuentre en la primera fila de datos pegados. Si la primera fila de datos pegados es del mismo tipo que las filas siguientes, Access determina que la primera fila forma parte de los datos y asigna nombres de campo genéricos (F1, F2, etc.). Si la primera fila de datos pegados no es similar a las siguientes filas, Access determina que la primera fila consiste en nombres de campos. Access asigna nombres a los campos en consecuencia y no se incluye la primera fila en los datos.

Si Access asigna nombres de campo genéricos, deberá cambiar los nombres de los campos lo antes posible para evitar confusiones.Siga este procedimiento:

  1. Guarde la tabla.

    • Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y luego en Guardar o presione CTRL+G.

  2. En la vista Hoja de datos, haga doble clic en cada encabezado de columna y, a continuación, escriba un nombre de campo válido para cada columna. Puede parecer que está escribiendo datos, pero la fila de encabezado de columna contiene nombres de campo y no contiene datos.

  3. Guarde la tabla de nuevo.

Nota: Puede cambiar también el nombre de los campos editándolos en la vista Diseño. Para cambiar a la vista Diseño, haga clic con el botón secundario en la tabla en el panel de navegación y, a continuación, haga clic en Vista Diseño. Para cambiar a la vista Hoja de datos, haga doble clic en la tabla en el panel de navegación.

Principio de la sección

Importar datos de otro origen

Puede que tenga datos que haya recopilado en otro programa y desea importar en Access. O puede trabajar con personas que almacenan sus datos en otros programas y desea trabajar con sus datos en Access. En ambos casos, Access facilita importar datos de otros programas. Puede importar datos desde una hoja de cálculo de Excel, de una tabla en otra base de datos de Access, de una lista de SharePoint o de una variedad de otros orígenes. El proceso varía ligeramente en función de su origen, pero estas instrucciones le ayudarán a empezar:

  1. En la pestaña Datos externos, en el grupo Importar, haga clic en el comando para el tipo de archivo que va a importar.

    Imagen de la cinta de Access

    Por ejemplo, si va a importar datos de una hoja de cálculo de Excel, haga clic en Excel. Si no aparece el tipo de programa correcto, haga clic en Más.

    Nota: Si no encuentra el tipo de formato correcto en el grupo Importar, debe iniciar el programa en el que creó originalmente los datos y, a continuación, usar ese programa para guardar los datos en un archivo común de formato (por ejemplo, un archivo de texto delimitado ) antes de importar los datos en Access.

  2. En el cuadro de diálogo Obtener datos externos, haga clic en Examinar para ir al archivo de datos de origen, o bien, escriba la ruta de acceso completa al archivo de datos de origen en el cuadro Nombre de archivo.

  3. Haga clic en la opción que desee en Especifique cómo y dónde desea almacenar los datos de la base de datos actual. Puede crear una nueva tabla con los datos importados, agregar los datos a una tabla existente o crear una tabla vinculada que mantenga un vínculo al origen de datos.

  4. Haga clic en Aceptar.

    Access inicia al Asistente para importar.

  5. Siga las instrucciones del Asistente para importar. El procedimiento exacto depende de la opción Importar o vincular que seleccionó.

  6. En la última página del asistente, haga clic en Finalizar.

    Access le preguntará si desea guardar los detalles de la operación de importación que acaba de completarse.

    • Si cree que va a realizar de nuevo la misma operación de importación, haga clic en Guardar los pasos de la importación y escriba los detalles.

      A continuación, podrá reproducir fácilmente la operación de importación; para ello, haga clic en Importaciones guardadas en el grupo Importar de la ficha Datos externos, seleccione la especificación de importación y haga clic en Ejecutar.

    • Si no desea guardar los detalles de la operación, haga clic en Cerrar.

Access importa los datos a una nueva tabla y, a continuación, muestra la tabla en Tablas en el panel de navegación.

Para obtener más información sobre cómo importar datos a Access, use los vínculos de la sección Vea también en este artículo.

Principio de la sección

Abrir una base de datos existente de Access

  1. Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y, después, haga clic en Abrir.

  2. Haga clic en un acceso directo del cuadro de diálogo Abrir, o bien, en el cuadro Buscar en, haga clic en la unidad o carpeta que contenga la base de datos que desee.

  3. En la lista de carpetas, haga doble clic en las carpetas hasta que se abra la carpeta que contiene la base de datos.

  4. Cuando encuentre la base de datos, siga uno de estos procedimientos:

    • Para abrir la base de datos en modo predeterminado de apertura, haga doble clic en ella.

    • Si desea abrir la base de datos para el acceso compartido en un entorno multiusuario, de modo que usted y otros usuarios puedan leer y escribir en la base de datos al mismo tiempo, haga clic en Abrir.

    • Si desea abrir la base de datos para el acceso de sólo lectura, de modo que se pueda ver pero no modificar la base de datos, haga clic en la flecha situada junto al botón Abrir y, a continuación, haga clic en Abrir como de sólo lectura.

    • Si desea abrir la base de datos para el acceso exclusivo, de modo que ningún otro usuario pueda abrirla mientras usted la tenga abierta, haga clic en la flecha situada junto al botón Abrir y, a continuación, haga clic en Abrir en modo exclusivo.

    • Para abrir la base de datos como sólo lectura, haga clic en la flecha que aparece junto al botón Abrir y elija Abrir en modo exclusivo. Los demás usuarios podrán abrir la base de datos, pero tendrán acceso de sólo lectura.

Si no encuentra la base de datos que desea abrir   

  1. En el cuadro de diálogo Abrir, haga clic en el acceso directo Mi PC, o bien, en el cuadro Buscar en, haga clic en Mi PC.

  2. En la lista de unidades, haga clic con el botón secundario del mouse (ratón) en la unidad en la que cree que podría estar la base de datos y, a continuación, haga clic en Buscar.

  3. Especifique los criterios de búsqueda y, a continuación, presione ENTRAR para buscar la base de datos.

  4. Si encuentra la base de datos, ábrala haciendo doble clic en ella en el cuadro de diálogo Resultados de la búsqueda.

  5. Como la búsqueda se inició desde el cuadro de diálogo Abrir, deberá hacer clic en Cancelar en ese cuadro de diálogo antes de abrir la base de datos.

Nota: Puede abrir directamente un archivo de datos en un formato de archivo externo, como dBASE, Paradox, Microsoft Exchange o Excel. Puede abrir también directamente cualquier origen de datos ODBC, como Microsoft SQL Server o Microsoft FoxPro. Access crea automáticamente una nueva base de datos de Access en la misma carpeta que el archivo de datos y agrega vínculos a cada tabla de la base de datos externa.

Sugerencias

  • Para abrir una de las últimas bases de datos que se hayan abierto, haga clic en el nombre de archivo en la lista Abrir base de datos reciente en la página Introducción a Microsoft Office Access. Access abre la base de datos, aplicar las mismas opciones que la última vez que lo abrió la base de datos. Si no se muestra la lista de archivos usados recientemente, haga clic en el Botón de Microsoft Office Imagen del botón de Microsoft Office y, a continuación, haga clic en Opciones de Access. Aparece el cuadro de diálogo Opciones de Access. Haga clic en la categoría Avanzadas y, a continuación, en la sección Mostrar, active la casilla de verificación archivos usados recientemente. (También puede especificar el número de archivos usados recientemente que desea mostrar en la lista, hasta un máximo de nueve.)

  • Si va a abrir una base de datos haciendo clic en el Botón de Microsoft Office Imagen del botón de Microsoft Office y utilizando el comando Abrir, puede ver una lista de accesos directos a bases de datos que ha abierto anteriormente haciendo clic en Documentos recientes en el cuadro de diálogo Abrir.

Principio de la sección

Principio de página

Importar datos desde una hoja de cálculo u otro programa

Si está familiarizado con otros programas de base de datos o la hoja de cálculo, probablemente conoce los conceptos básicos de cómo funcionan estas aplicaciones y las bases de datos se usan para. Access difiere muchas otras aplicaciones de base de datos que le permite crear bases de datos relacionales. Access también ofrece muchas opciones para trabajar con otros programas de base de datos, como SQL Server.

En esta sección

Importar una hoja de cálculo de Excel a Access

Importar una hoja de cálculo de Excel como una tabla en una nueva base de datos de Office Access 2007

Usar el Asistente para analizar tablas para organizar los datos

Trabajar con datos de otros programas

Importar una hoja de cálculo de Excel a Access

Muchos usuarios comienzan a explorar Access después de crear primero una lista en Excel, que es una excelente aplicación para iniciar una lista. Sin embargo, a medida que crece la lista, se vuelve más difícil de organizar y actualizar. Mover la lista a Access suele ser el siguiente paso lógico.

La estructura de una tabla de base de datos es similar a la de una hoja de cálculo, ya que los datos se almacenan en filas y columnas. Como consecuencia, suele ser fácil importar una hoja de cálculo a una tabla de una base de datos. La principal diferencia entre almacenar datos en una hoja de cálculo y almacenarlos en una base de datos reside en la forma en que los datos están organizados. Si simplemente se importa una hoja de cálculo completa como una nueva tabla en una base de datos, no se resolverán los problemas asociados a la organización y la actualización de los datos, sobre todo si la hoja de cálculo contiene datos redundantes. Para solucionar esos problemas, es preciso dividir los datos de la hoja de cálculo en tablas independientes. Cada una de esas tablas contiene datos relacionados. Para obtener más información sobre la organización de datos en las tablas, vea el artículo Conceptos básicos del diseño de una base de datos.

Access ofrece el Asistente para analizar tablas, que puede ayudar a completar este proceso. Después de importar los datos en una tabla, el asistente ayuda a dividir la tabla en tablas separadas, cada una con datos que no están duplicados en ninguna otra. Además, el asistente crea las relaciones necesarias entre las tablas.

Importar una hoja de cálculo de Excel como una tabla en una base de datos Office Access 2007

  1. Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y, después, haga clic en Nuevo.

  2. Escriba un nombre para la nueva base de datos en el cuadro Nombre de archivo y, a continuación, haga clic en Crear.

  3. Cierre Tabla1.

    Cuando se le pregunte si desea guardar los cambios realizados en el diseño de Tabla1, haga clic en No.

  4. En la pestaña Datos externos, en el grupo Importar, haga clic en Excel. Imagen del botón

  5. En el cuadro de diálogo Obtener datos externos, haga clic en Examinar.

  6. Use el cuadro de diálogo Abrir archivo para buscar el archivo.

  7. Seleccione el archivo y haga clic en Abrir.

  8. En el cuadro de diálogo Obtener datos externos, asegúrese de que está seleccionada la opción Importar el origen de datos en una nueva tabla de la base de datos actual.

  9. Haga clic en Aceptar.

    Se inicia el Asistente para importación de hojas de cálculo, que hace algunas preguntas sobre los datos.

  10. Siga las instrucciones haciendo clic en Siguiente o Atrás para moverse entre las páginas. En la última página del asistente, haga clic en Finalizar.

    Nota: Access preguntará si desea guardar los detalles de la operación de importación que acaba de finalizar. Si cree que va a realizar de nuevo la misma operación de importación, haga clic en y escriba los detalles. De este modo, podrá reproducir fácilmente la operación haciendo clic en Importaciones guardadas en el grupo Importar de la ficha Datos externos. Si no desea guardar los detalles de la operación, haga clic en Cerrar.

Access importa los datos a una nueva tabla y, a continuación, la muestra en Todas las tablas en el panel de navegación.

Usar el Asistente para analizar tablas para organizar los datos

Después de importar los datos en una tabla de Access, puede usar al Asistente para analizar tablas para identificar rápidamente los datos de repetición. El asistente proporciona una forma sencilla de organizar los datos duplicados en tablas separadas, para que sea almacenarse en la forma más eficiente. Access conserva la tabla original como copia de seguridad y, a continuación, crea tablas nuevas que puede usar como base para la aplicación de la base de datos.

  1. Abra la base de datos Access que contiene la tabla que desee analizar.

  2. En la ficha Herramientas de base de datos, en el grupo Analizar, haga clic en Analizar tabla.

    Se inicia el Asistente para analizar tablas.

    En caso de está familiarizado con el concepto de normalización, dos páginas de introducción del asistente contienen un breve tutorial, con botones que puede hacer clic para ver ejemplos. Si no ve esas páginas, pero en su lugar una casilla denominada Mostrar páginas de introducción?, seleccione la casilla de verificación y, a continuación, haga clic en Atrás dos veces para ver la introducción. Si no desea ver las páginas de introducción después de la introducción de lectura, puede desactivar la casilla de verificación.

  3. En la página que comienza con la frase qué tabla contiene campos con valores que se repiten en muchos registros?, seleccione la tabla que desee analizar y, a continuación, haga clic en siguiente.

  4. Puede dejar que el asistente decida qué campos se incluyen en qué tablas, o bien, puede decidirlo usted mismo. Si sigue las instrucciones del asistente, podrá cambiar el diseño de la tabla en la siguiente página del asistente.

    Nota: Si deja que el asistente decida qué campos se incluyen en qué tablas, puede que sus decisiones no siempre sean las más apropiadas para los datos, sobre todo si se trata de una cantidad reducida de datos. Se recomienda comprobar cuidadosamente los resultados del asistente. En cambio, puede que el asistente sugiera una organización más eficaz, por lo que es una buena idea probar al menos una vez las decisiones del asistente. Si no le gustan las sugerencias, siempre puede reorganizar manualmente los campos y hacer clic en Atrás para organizar usted mismo todos los campos.

  5. Haga clic en Siguiente. En esta página debe especificar qué tablas contienen qué campos. Si dejó que el asistente tomara las decisiones, debería ver varias tablas conectadas mediante líneas de relación. En caso contrario, Access crea una sola tabla con todos los campos. En ambos casos, se pueden realizar cambios en esta página.

    • Puede arrastrar campos de una tabla hasta un área en blanco de la página para crear una nueva tabla que contenga esos campos. Access pedirá un nombre de tabla.

    • Puede arrastrar campos de una tabla a otra si cree que se van a almacenar más eficazmente en esa otra tabla.

    • A la mayoría de las tablas se les asigna un campo Id. o Id. único generado. Para obtener más información sobre los campos Id., haga clic en Sugerencias en la esquina superior derecha del asistente.

    • Para deshacer un cambio, haga clic en el botón Deshacer.

    • Para cambiar el nombre de una tabla, haga doble clic en su barra de título, escriba el nuevo nombre y, a continuación, haga clic en Aceptar.

  6. Tras organizar los campos a su manera, haga clic en Siguiente.

  7. Si el asistente encuentra registros con valores muy similares, los identificará como posibles errores tipográficos y presentará una pantalla en la que se puede confirmar lo que se va a hacer con ellos. Desplácese por la lista para buscar los que tengan valores en la columna Corrección y, a continuación, haga clic en el elemento apropiado de la lista desplegable. Seleccione Dejar tal y como está para que el asistente no cambie el valor. Cuando termine, haga clic en Siguiente.

  8. El asistente le pregunta si desea crear una consulta que se parezca a la tabla original. Si ya ha creado formularios e informes basados en la tabla original, se recomienda crear esa consulta. Si elige Sí, crear la consulta, el asistente cambia el nombre de la tabla original anexando "_ANTERIOR" al nombre de la tabla. A continuación, asigna un nombre a la nueva consulta usando el nombre de la tabla original. Los formularios e informes basados en la tabla usan ahora la consulta para sus datos y siguen funcionando como antes.

  9. Haga clic en Finalizar.

    El asistente crea las nuevas tablas según lo especificado y, a continuación, las abre. Ciérrelas cuando termine de comprobar los resultados.

Principio de la sección

Trabajar con datos de otros programas

Office Access 2007 ofrece características para trabajar con datos almacenados en otros programas.

  • Crear una nueva base de datos de Access que se vincule a datos con otro formato de archivo    Puede usar Access para abrir un archivo con otro formato como un archivo de texto, dBASE o una hoja de cálculo. Access crea automáticamente una base de datos de Access y vincula el archivo.

    1. Inicie Access.

    2. Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y, después, haga clic en Abrir.

    3. En el cuadro de diálogo Abrir, haga clic en el tipo de archivo que desee abrir en la lista. Si no está seguro del tipo de archivo, haga clic en Todos los archivos (*.*).

    4. Si es preciso, vaya a la carpeta que contenga el archivo que desee abrir. Cuando encuentre el archivo, haga doble clic en él para abrirlo.

    5. Siga las instrucciones del asistente. En la última página del asistente, haga clic en Finalizar.

  • Importar o vincular datos a una base de datos existente de Access    Puede importar datos de otros orígenes y programas a tablas de Access de modo que los datos se encuentren en el archivo de Access, o bien, puede vincular a los datos desde Access de modo que los datos permanecen en el archivo original (fuera del archivo de Access).

    Importar o vincular datos

    1. En la pestaña Datos externos, en el grupo Importar, haga clic en el formato en el que se almacenan los datos.

      Puede importar o vincular datos de los siguientes formatos:

      • Microsoft Office Access

      • Microsoft Office Excel

      • Microsoft Windows SharePoint Services

      • Archivos de texto

      • Archivos XML

      • Bases de datos ODBC

      • Documentos HTML

      • Microsoft Office Outlook

      • dBase

      • Paradox

      • Lotus 1-2-3

        Aparece el cuadro de diálogo Obtener datos externos.

    2. Siga las instrucciones que aparecen en el cuadro de diálogo.

      Access importará o vinculará los datos a la base de datos. Para la mayoría de los formatos, es preciso especificar la ubicación de los datos y elegir cómo se desea almacenar los datos en la base de datos.

Principio de la sección

Principio de página

Usar una base de datos de una versión anterior en varias versiones de Access

Si su base de datos de Access o proyecto de Access se creó en Access 2000 o versiones posteriores, puede usar la base de datos o el proyecto en la versión de Access en que se creó o en cualquier versión posterior, incluso si el archivo está habilitada la seguridad. Por ejemplo, archivos de Access 2000 se pueden usar en Access 2000 hasta Office Access 2007 y archivos de Access 2002-2003 se pueden usar en Access 2002-2003 hasta Office Access 2007.

Puede haber situaciones en las que desee conservar los datos en una versión anterior de Access, pero puede que haya usuarios con una versión posterior de Access que quieran establecer vínculos a dichos datos y, además, beneficiarse de algunas de las funciones de la versión posterior. La solución es crear una nueva base de datos "front-end" en la versión posterior (que incluya formularios, informes, consultas y macros, pero no tablas) y vincularla a las tablas del archivo de la versión anterior. Siga uno de los siguientes procedimientos en función de si la base de datos está incluida en un archivo o si está dividida en una aplicación front-end/back-end.

Usar una base de datos de Access de un archivo en varias versiones de Access

Usar una aplicación front-end/back-end en varias versiones de Access

Usar una base de datos de Access de un archivo en varias versiones de Access

Si todas las tablas, formularios y otros objetos de la base de datos de Access se encuentran en un archivo .mdb y desea usar la base de datos en varias versiones de Access, puede crear una nueva base de datos front-end en una versión posterior y vincular al archivo original. Los usuarios que tienen la versión anterior de Access están todavía puede usar la base de datos original. Los usuarios que tienen la versión más reciente pueden usar la nueva base de datos front-end para establecer un vínculo a los mismos datos.

  1. Use el siguiente procedimiento para convertir la base de datos a cualquiera de los tres formatos más recientes: Access 2000, Access 2002-2003 o Access 2007. Este comando conserva la base de datos original en su formato original y crea una copia en el formato que especifique.

    • Cierre el archivo de Access. Si el archivo es una base de datos de Access multiusuario ubicada en un servidor o una carpeta compartida, asegúrese de que ningún otro usuario lo tenga abierto.

    • Inicie Access 2007.

    • Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y, después, haga clic en Abrir.

    • Busque la ubicación del archivo que desea convertir y, a continuación, haga doble clic en él para abrirlo.

      Nota: Si se muestra el cuadro de diálogo Mejoras de base de datos donde se le pregunta si desea mejorar la base de datos, elija No.

    • Si se abre un formulario cuando inicie la base de datos, ciérrelo.

    • Haga clic en el Botón de Microsoft Office Imagen del botón de Microsoft Office, elija Guardar como y, a continuación, en Guardar la base de datos en otro formato, haga clic en el formato de archivo al que desea convertir.

    • En el cuadro de diálogo Guardar como, escriba un nombre para la nueva base de datos.

      Nota: A menos que se va a guardar la base de datos en otra ubicación, su nombre debe ser diferente de la base de datos original. En cualquier caso, es preferible utilizar un nombre diferente, poder distinguir fácilmente entre las bases de datos front-end y back-end. Sin embargo, si va a convertir al formato de Access 2007, la extensión de nombre de archivo cambia de .mdb a .accdb, por lo que puede usar el mismo nombre de archivo.

    • Haga clic en Guardar.

  2. Dividir la base de datos convertida en una aplicación de cliente/servidor mediante el procedimiento siguiente:

    • En la ficha Herramientas de base de datos, en el grupo Mover datos, haga clic en Base de datos de Access. Imagen del botón

    • En el cuadro de diálogo Divisor de base de datos, haga clic en Dividir base de datos.

    • Escriba un nombre para la base de datos back-end y haga clic en Dividir.

  3. Elimine la base de datos back-end creada por la herramienta Divisor de base de datos . Tenga cuidado para no eliminar la base de datos original.

  4. Vincular la nueva base de datos front-end a las tablas de la base de datos original: en la ficha Herramientas de base de datos, en el grupo Herramientas de base de datos, haga clic en Administrador de tablas vinculadas. Imagen del botón

  5. Haga clic en Seleccionar todo y, a continuación, active la casilla de verificación Preguntar siempre por la nueva ubicación.

  6. Haga clic en Aceptar, vaya a la base de datos de la versión anterior y, a continuación, haga doble clic en ella.

    Si el proceso se ha realizado correctamente, Access mostrará un mensaje en el que se indica que se han actualizado correctamente todas las tablas vinculadas seleccionadas.

    Ahora, puede mejorar la nueva base de datos front-end para admitir nuevas características para los usuarios que hayan actualizado a Access 2000, Access 2002-2003 o Access 2007. Los usuarios que tienen versiones anteriores pueden seguir usando la base de datos de la versión anterior.

    Si lo desea, también puede convertir la nueva base de datos front-end a otra versión. Por ejemplo, si la base de datos original estaba en formato Access 2000, podría crear un Access 2002-2003 front-end para los usuarios con esta versión y un Access 2007 front-end para los usuarios que tengan esta versión. Vínculo a los datos en el archivo de Access 2000 ambas versiones front-end.

Principio de la sección

Usar una aplicación front-end/back-end en varias versiones de Access

Si la base de datos de Access ya es una aplicación front-end/back-end, solo tiene que convertir el front-end al formato de archivo de Access 2000, Access 2002-2003 o Access 2007. Cambios no son necesarios para la base de datos back-end.

El procedimiento siguiente muestra cómo usar el comando Guardar base de datos como para convertir la base de datos front-end a cualquiera de los tres formatos más recientes: Access 2000, Access 2002-2003 o Access 2007. Este comando conserva la base de datos original en su formato original y crea una copia en el formato que especifique.

  1. Cierre la base de datos front-end. Si el archivo es una base de datos de Access multiusuario ubicada en un servidor o una carpeta compartida, asegúrese de que nadie más tiene abierto.

  2. Inicie Access 2007.

  3. Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y, después, haga clic en Abrir.

  4. Vaya a la ubicación de la base de datos front-end y haga doble clic en ella para abrirla.

    Nota: Si se muestra el cuadro de diálogo Mejoras de base de datos donde se le pregunta si desea mejorar la base de datos, elija No.

  5. Si aparece un formulario cuando abra la base de datos, ciérrelo.

  6. Haga clic en el Botón de Microsoft Office Imagen del botón de Microsoft Office, elija Guardar como y, a continuación, en Guardar la base de datos en otro formato, haga clic en el formato de archivo al que desea convertir.

  7. En el cuadro de diálogo Guardar como, escriba un nombre para la nueva base de datos.

  8. Haga clic en Guardar.

Ahora, puede mejorar la nueva base de datos front-end para admitir nuevas características para los usuarios que hayan actualizado a Access 2000, Access 2002-2003 o Access 2007.

Principio de la sección

Principio de página

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

¿Le ha sido útil esta información?

¿Cómo podemos mejorarlo?

¿Cómo podemos mejorarlo?

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!