Insertar una hoja de datos en un formulario

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Una hoja de datos es una sencilla vista de datos organizados en filas y columnas. Si se hace doble clic en una tabla en el panel de exploración, Microsoft Office Access 2007 la muestra como una hoja de datos. Gracias a su presentación compacta de los datos, las hojas de datos funcionan bien cuando se usan como subformularios para mostrar los datos del lado "varios" de una relación de uno a varios. En este artículo se describe cómo se pueden agregar hojas de datos a los formularios de Office Access 2007.

¿Qué desea hacer?

Ver un ejemplo de una hoja de datos en un formulario

Establecer relaciones entre tablas

Crear un formulario que contenga una hoja de datos mediante la herramienta formulario

Crear un formulario que contenga una hoja de datos mediante la vista Diseño

Insertar una hoja de datos en un formulario existente mediante la vista Diseño

Insertar una hoja de datos en un formulario existente mediante la vista Diseño

Comprender las diferencias entre un formulario dividido y un formulario que contenga una hoja de datos

Ver un ejemplo de una hoja de datos en un formulario

Supongamos que desea crear un formulario que muestre datos sobre categorías de productos y todos los productos dentro de esas categorías. Los datos de la tabla Categorías representan el lado "uno" de la relación, mientras que los datos de la tabla Productos representan el lado "varios" de la relación. Cada categoría puede contener numerosos productos.

Formulario que contiene un subformulario

1. El formulario principal muestra los datos del lado "uno" de la relación.

2. La hoja de datos muestra los datos del lado "varios" de la relación.

Volver al principio

Establecer relaciones entre tablas

Antes de diseñar un formulario con una hoja de datos, debe revisar la relación que existe entre las tablas y agregar las relaciones que falten. De este modo, Access podrá crear automáticamente los vínculos entre las hojas de datos y los formularios principales. Para ver, agregar o modificar las relaciones entre las tablas de una base de datos, en la ficha Herramientas avanzadas, en el grupo Analizar, haga clic en Relaciones. Para obtener más información sobre cómo crear relaciones, vea los vínculos que aparecen en la sección Vea también.

Volver al principio

Crear un formulario que contenga una hoja de datos mediante la herramienta Formulario

Cuando se usa la herramienta Formulario para crear un formulario basado en una tabla que está en el lado "uno" de una relación uno a varios, Access inserta automáticamente una hoja de datos que muestra los datos del lado "varios" de la relación.

Por ejemplo, si se cumplen las condiciones siguientes, Access inserta una hoja de datos que muestra todos los pedidos de cada cliente:

  • Se crea un formulario simple basado en la tabla Compradores.

  • Se ha definido una relación uno a varios con la tabla Pedidos que especifica que un registro de la tabla Compradores se puede relacionar con varios registros de la tabla Pedidos.

  • La tabla Compradores no está en el lado "uno" de ninguna otra relación uno a varios.

  • En el panel de exploración, haga clic en la tabla que está en el lado "uno" de la relación uno a varios.

  • En la ficha crear, en el grupo formularios, haga clic en formulario. Imagen de botón

Access crea el formulario con la hoja de datos en su parte inferior. Si Access no crea una hoja de datos, eso significa que la tabla usada para el formulario no forma parte de una relación uno a varios o que la tabla forma parte de más de una relación uno a varios.

Notas: 

  • Además de crear el formulario principal, este proceso no crea ningún otro objeto de formulario. La hoja de datos es una vista directa de la tabla.

  • Para ocultar una columna en una hoja de datos    Haga clic con el botón secundario del mouse (ratón) y, a continuación, haga clic en Ocultar columna. Esta configuración se guarda. Si se guarda y se cierra el formulario y, a continuación, se vuelve a abrirlo, la columna permanecerá oculta.

  • Para restaurar una columna oculta en una hoja de datos    Haga clic con el botón secundario del mouse en cualquier encabezado de columna de la hoja de datos y, a continuación, haga clic en Mostrar columnas. Active la casilla de verificación situada junto a cada columna que desee restaurar y, a continuación, haga clic en Cerrar.

Volver al principio

Crear un formulario que contiene una hoja de datos mediante la vista Presentación

Si ya se han definido las relaciones entre las tablas de la base de datos, se puede crear rápidamente un formulario que contiene una hoja de datos mediante la vista Presentación. Cuando se agrega un campo del lado "varios" de una relación a un formulario basado en el lado "uno" de la relación, Access crea automáticamente una hoja de datos para mostrar los registros relacionados.

  1. En la ficha crear, en el grupo formularios, haga clic en Formulario en blanco. Imagen de botón

    Access abre un formulario en blanco en la vista Presentación y muestra el panel Lista de campos.

    Nota: Si cierra el panel Lista de campos de manera fortuita, puede volver a abrirlo siguiendo uno de estos procedimientos:

    • Presione ALT+F8.

      O bien,

      En la ficha formato, en el grupo controles, haga clic en Agregar campos existentes. Imagen de botón

  2. Haga clic en el signo más situado junto a la tabla que está en el lado "uno" de la relación uno a varios y, a continuación, arrastre el primer campo que desee incluir hasta el formulario.

    Observe que el panel Lista de campos divide las tablas en secciones: Campos disponibles para esta vista y, más abajo, Campos disponibles en tablas relacionadas. En la parte inferior del panel Lista de campos, las tablas que no están directamente relacionadas con la tabla principal se encuentran bajo Campos disponibles en otras tablas.

  3. Desde la sección Campos disponibles para esta vista, arrastre todos los campos que desee hasta el formulario principal.

  4. Desde la sección Campos disponibles en tablas relacionadas, arrastre hasta el formulario el primer campo que desee incluir en la hoja de datos. Access crea una hoja de datos y le agrega el campo.

  5. Para agregar campos adicionales a la nueva hoja de datos, primero debe hacer clic en la hoja para seleccionarla. Observe que Access reorganiza el panel Lista de campos para que los campos disponibles para la hoja de datos estén en la parte superior. Desde la sección Campos disponibles para esta vista, arrastre los otros campos que desee incluir en la hoja de datos. Cuando arrastra cada uno de los campos hasta la hoja de datos, Access dibuja una barra de inserción para mostrar dónde se va a insertar el campo cuando suelte el botón del mouse.

  6. Siga agregando campos al formulario principal o a la hoja de datos haciendo clic primero en el formulario principal o en la hoja de datos para seleccionarlo y arrastrando, luego, el campo desde el panel Lista de campos.

La sección campos disponibles en otras tablas del panel Lista de campos contiene tablas que no están directamente relacionadas con la tabla o consulta que se basa el formulario seleccionado o una hoja de datos. Si ha definido todas las relaciones de tabla válida en la ventana Relaciones, los campos en la sección campos disponibles en otras tablas no están probable que sean válidos para el formulario que está creando. Si arrastra un campo de esta sección al formulario, Access muestra el cuadro de diálogo Especificar relación. Debe escribir el campo o campos que se relacionan las dos tablas entre sí antes de continuar. Si hace esto, el panel Lista de campos ya no estará ordenará en secciones de acuerdo con las relaciones predefinidas. Puede ser mejor haga clic en Cancelar en este cuadro de diálogo y volver a examinar las relaciones de tabla en su lugar. Para obtener más información acerca de las relaciones, vea el artículo crear, modificar o eliminar una relación.

Volver al principio

Insertar una hoja de datos en un formulario existente mediante la vista Presentación

Si ya se han definido las relaciones entre las tablas de la base de datos, se puede agregar rápidamente una hoja de datos a un formulario existente mediante la vista Presentación. Cuando se agrega un campo del lado "varios" de una relación a un formulario basado en el lado "uno" de la relación, Access crea automáticamente una hoja de datos para mostrar los registros relacionados.

  1. Abra el formulario existente en la vista Presentación haciendo clic con el botón secundario del mouse en el formulario en el panel de exploración y, a continuación, haciendo clic en Vista Presentación en el menú contextual.

    Si no ve el panel Lista de campos:

    • Presione ALT+F8.

      O bien,

      En la ficha formato, en el grupo controles, haga clic en Agregar campos existentes. Imagen de botón

      Observe que el panel Lista de campos divide las tablas en secciones: Campos disponibles para esta vista y, más abajo, Campos disponibles en tablas relacionadas. En la parte inferior del panel Lista de campos, las tablas que no están directamente relacionadas con la tabla principal se encuentran bajo Campos disponibles en otras tablas.

  2. En la sección Campos disponibles en tablas relacionadas, expanda la tabla que contiene el primer campo que desee incluir en la hoja de datos y arrastre el campo hasta el formulario. Access crea una hoja de datos y le agrega el campo.

  3. Para agregar campos adicionales a la nueva hoja de datos, primero debe hacer clic en la hoja para seleccionarla. Observe que Access reorganiza el panel Lista de campos para que los campos disponibles para la hoja de datos estén en la parte superior. Desde la sección Campos disponibles para esta vista, arrastre los otros campos que desee incluir en la hoja de datos. Cuando arrastra cada uno de los campos hasta la hoja de datos, Access dibuja una barra de inserción para mostrar dónde se va a insertar el campo cuando suelte el botón del mouse.

  4. Siga agregando campos al formulario principal o a la hoja de datos haciendo clic primero en el formulario principal o en la hoja de datos para seleccionarlo y arrastrando, luego, el campo desde el panel Lista de campos.

La sección campos disponibles en otras tablas del panel Lista de campos contiene tablas que no están directamente relacionadas con la tabla o consulta que se basa el formulario seleccionado. Si ha definido todas las relaciones de tabla válida en la ventana Relaciones, los campos en la sección campos disponibles en otras tablas no están probable que sean válidos para el formulario que está creando. Si arrastra un campo de esta sección en el formulario, Access muestra el cuadro de diálogo Especificar relación. Debe escribir el campo o campos que se relacionan las dos tablas entre sí antes de continuar. Si hace esto, el panel Lista de campos ya no se ordenará en secciones de acuerdo con las relaciones predefinidas. Puede ser mejor haga clic en Cancelar en este cuadro de diálogo y volver a examinar las relaciones de tabla en su lugar. Para obtener más información acerca de las relaciones, vea el artículo crear, modificar o eliminar una relación.

Volver al principio

Insertar una hoja de datos en un formulario existente mediante la vista Diseño

Use este procedimiento para agregar una hoja de datos directamente basada en una tabla o consulta a un formulario existente en la vista Diseño.

  1. Abra el formulario en la vista Diseño haciendo clic con el botón secundario del mouse en el formulario en el panel de exploración y, a continuación, haciendo clic en Vista Diseño.

  2. En la ficha Diseño, en el grupo Controles, si está seleccionada la herramienta Utilizar Asistentes para controles, haga clic en ella de modo que no esté seleccionada.

    Imagen de botón

    ¿Por qué?

    Si se usa, el Asistente para controles de subformulario genera un objeto de formulario independiente y basa el control de subformulario en ese objeto de formulario. En cambio, este procedimiento crea una hoja de datos directamente basada en una tabla o consulta en vez de un formulario.

  3. En la ficha Diseño, en el grupo controles, haga clic en el botón de Imagen de botón Subformulario/subinforme. Imagen de botón

  4. En la cuadrícula de diseño del formulario, haga clic en el lugar donde desee insertar la hoja de datos.

  5. Para cambiar la posición y el tamaño del control de subformulario, arrastre los controladores situados en los bordes y esquinas del control.

  6. Para editar la etiqueta asociada del control de subformulario, haga clic en ella y, a continuación, haga doble clic en ella para seleccionar su texto y luego escriba una nueva etiqueta. Si prefiere eliminar la etiqueta, haga clic en ella y, a continuación, presione SUPRIMIR.

  7. Si no se muestra la hoja de propiedades, presione F4.

  8. Si no está seleccionado el control de subformulario, haga clic en él para seleccionarlo.

  9. En la ficha Datos de la hoja de propiedades, haga clic en la lista desplegable Objeto origen y, a continuación, haga clic en la tabla o consulta que desee mostrar en la hoja de datos. Por ejemplo, si desea mostrar los datos de la tabla denominada Pedidos, haga clic en Tabla.Pedidos.

  10. Si ha definido correctamente las relaciones antes de iniciar este procedimiento, Access configurará automáticamente las propiedades Vincular campos secundarios y Vincular campos principales con los valores correctos que vinculen el formulario principal a la hoja de datos.

    Las propiedades Vincular campos secundarios y vincular campos principales están en blanco

    Si Access no puede determinar cómo debe vincular el control de subformulario al formulario principal, deja las propiedades Vincular campos secundarios y Vincular campos principales del control de subformulario en blanco. Estas propiedades deben configurarse manualmente de la siguiente manera:

    1. Abra el formulario principal en la vista Diseño.

    2. Haga clic en el control de subformulario para seleccionarlo.

    3. Si no ve la hoja de propiedades, presione F4.

    4. En la ficha Datos de la hoja de propiedades, haga clic en (...) junto al cuadro de la propiedad Vincular campos secundarios.

      Aparece el cuadro de diálogo Vinculador de campos de subformulario.

    5. En las listas desplegables Campos principales y Campos secundarios, seleccione los campos a los que desee vincular los formularios. Si no está seguro de los campos, haga clic en Sugerir para que Access determine los campos de vinculación. Cuando termine, haga clic en Aceptar.

      Si no ve el campo que desee usar para vincular los formularios, puede que tenga que editar el origen de registros del formulario principal o secundario para asegurarse de que contiene el campo. Por ejemplo, si el formulario está basado en una consulta, asegúrese de que el campo de vinculación está en los resultados de la consulta.

    6. Guarde el formulario principal y cambie a la vista Formulario para comprobar que el formulario funciona según previsto.

  11. Guarde el formulario haciendo clic en Guardar Imagen de botón en la Barra de herramientas de acceso rápido o presione CTRL+G.

  12. Cambie a la vista Formulario y compruebe que la hoja de datos funciona según previsto.

Volver al principio

Obtener información sobre las diferencias entre un formulario dividido y un formulario que contiene una hoja de datos

Un formulario que contiene una hoja de datos muestra datos de orígenes de datos diferentes (si bien suelen estar relacionados). Por ejemplo, un formulario puede mostrar empleados y puede tener una hoja de datos que muestra todas las tareas asignadas a cada empleado. La hoja de datos tiene otro origen de datos que el formulario que lo contiene. En cambio, un formulario dividido tiene dos secciones (un formulario y una hoja de datos), pero en ambas secciones se muestran los mismos datos. Las dos secciones están conectadas y ofrecen a la vez dos vistas distintas de los datos.

Para obtener más información sobre cómo crear y trabajar con un formulario dividido, vea el artículo crear un formulario dividido.

Volver al principio

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×