Insertar un objeto en la hoja de cálculo de Excel

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Puede usar vinculación e incrustación de objetos (OLE) para incluir contenido de otros programas, como Word o Excel.

OLE es compatible con muchos programas y se utiliza para que el contenido que se ha creado en un programa pueda estar disponible en otro programa. Por ejemplo, se puede insertar un documento de Office Word en un libro de Office Excel. Para ver qué tipos de contenido se pueden insertar, haga clic en Objeto en el grupo Texto de la ficha Insertar. En el cuadro Tipo de objeto sólo aparecerán los programas instalados en su equipo que admitan objetos OLE.

Si copia información entre Excel o cualquier programa que admita OLE, como Word, puede copiar la información como objeto vinculado u objeto incrustado. Las diferencias principales entre objetos vinculados y objetos incrustados radican en dónde se almacenan los datos y cómo se actualiza el objeto una vez que lo ha colocado en el archivo de destino. Los objetos incrustados se almacenan en el libro en el que se han insertado y no se actualizan. Los objetos vinculados permanecen en archivos independientes y pueden actualizarse.

Objetos vinculados e incrustados de un documento

Objetos vinculados e incrustados en un documento de Office para Windows

1. El objeto incrustado no tiene conexión con el archivo de origen.

2. Un objeto vinculado se vincula al archivo de origen.

3. El archivo de origen actualiza el objeto vinculado.

Cuándo usar objetos vinculados

Si desea que la información del archivo de destino se actualice cuando los datos del archivo de origen cambien, use objetos vinculados.

Con un objeto vinculado, la información original queda almacenada en el archivo de origen. El archivo de destino muestra una representación de la información vinculada pero únicamente almacena la ubicación de los datos originales (y el tamaño si el objeto es un gráfico de Excel). El archivo de origen debe permanecer disponible en el equipo o la red para mantener el vínculo a los datos originales.

La información vinculada se puede actualizar de forma automática si cambia los datos originales en el archivo de origen. Por ejemplo, si selecciona un párrafo en un documento de Word y luego lo pega como objeto vinculado en un libro de Excel, la información puede ser actualizada en Excel si cambia la información de su documento de Word.

Cuándo usar objetos incrustados

Si no desea actualizar los datos copiados cuando cambien en el archivo de origen, utilice un objeto incrustado. La versión del origen se incrusta por completo en el libro. Si copia información como un objeto incrustado, el archivo de destino requiere más espacio de disco que si vincula la información.

Cuando un usuario abre el archivo en otro equipo, puede ver el objeto incrustado sin tener acceso a los datos originales. Como los objetos incrustados no tienen vínculos al archivo de origen, el objeto no se actualiza si se cambian los datos originales. Para cambiar un objeto incrustado, haga doble clic en el objeto para abrirlo y modificarlo en el programa de origen. El programa de origen (u otro programa que pueda modificar el objeto) debe estar instalado en su equipo.

Cambiar la forma en que se muestra un objeto OLE

Se puede mostrar un objeto vinculado o un objeto incrustado en un libro exactamente como aparece en el programa origen o como un icono. Si el libro se va a ver en línea y no piensa imprimirlo, puede mostrar el objeto como un icono. De ese modo se reduce al mínimo la cantidad de espacio de visualización que ocupa el objeto. Los usuarios que quieran visualizar la información pueden hacer doble clic en el icono.

Insertar un objeto en una hoja de cálculo

  1. Haga clic en la celda de la hoja de cálculo donde quiere insertar el objeto.

  2. En la ficha Insertar, en el grupo texto, haga clic en objeto Icono de objeto en la cinta de opciones .
    Insertar objeto

  3. En el cuadro de diálogo objeto , haga clic en la ficha crear desde archivo.

  4. Haga clic en Examinar y seleccione el archivo que quiere insertar.

  5. Si desea insertar un icono en la hoja de cálculo en lugar de mostrar el contenido del archivo, active la casilla de verificación Mostrar como icono . Si no selecciona las casillas de verificación, Excel muestra la primera página del archivo. En ambos casos, se abre el archivo completo hacer doble clic. Haga clic en Aceptar.

    Nota: Después de agregar el icono o el archivo, puede arrastrar y colóquela en cualquier lugar de la hoja de cálculo. También puede cambiar el icono o el archivo mediante el uso de los controladores de tamaño. Para buscar los controladores, haga clic en el archivo o el icono de una vez.

Insertar un vínculo a un archivo

Desea simplemente agregar un vínculo al objeto de totalmente la incrustación. Puede hacerlo si el libro y el objeto que desea agregar se almacenan en un sitio de SharePoint, una unidad de red compartida o una ubicación similar y la ubicación de los archivos permanecerán igual. Esto es útil si el objeto vinculado realiza cambios porque el vínculo siempre abre el documento más actualizado.

Nota: Si mueve el archivo vinculado a otra ubicación, el vínculo deja de funcionar.

  1. Haga clic en la celda de la hoja de cálculo donde quiere insertar el objeto.

  2. En la ficha Insertar, en el grupo texto, haga clic en objeto Icono de objeto en la cinta de opciones .
    Insertar objeto

  3. Haga clic en la ficha crear desde archivo .

  4. Haga clic en Examinar y, a continuación, seleccione el archivo que desea vincular.

  5. Active la casilla Vincular a archivo y haga clic en Aceptar.

Crear un nuevo objeto desde dentro de Excel

Puede crear un objeto completamente nuevo basado en otro programa sin salir del libro. Por ejemplo, si desea agregar una explicación más detallada al gráfico o tabla, puede crear un documento incrustado, como un archivo Word o PowerPoint, en Excel. Puede establecer el objeto que se muestren directamente en una hoja de cálculo o agregar un icono que abre el archivo.

Este objeto incrustado es un documento de Word.
  1. Haga clic en la celda de la hoja de cálculo donde quiere insertar el objeto.

  2. En la ficha Insertar, en el grupo texto, haga clic en objeto Icono de objeto en la cinta de opciones .
    Insertar objeto

  3. En la pestaña Crear nuevo, seleccione el tipo de objeto que quiere insertar de la lista. Si quiere insertar un icono en la hoja de cálculo en lugar del objeto en sí, active la casilla Mostrar como icono.

  4. Haga clic en Aceptar. Según el tipo de archivo que se va a insertar, se abre una nueva ventana de programa o bien aparece una ventana de edición dentro de Excel.

  5. Cree el nuevo objeto que quiere insertar.

    Cuando haya terminado, si Excel abrió una nueva ventana del programa en el que se creó el objeto, puede trabajar directamente en ella.

    Puede editar el documento de Word incrustado directamente en Excel.

    Cuando haya finalizado su trabajo en la ventana, puede realizar otras tareas sin guardar el objeto incrustado. Cuando se cierra el libro se guardará automáticamente los nuevos objetos.

    Nota: Después de agregar el objeto, puede arrastrarlo y colocarlo en cualquier lugar de la hoja de cálculo de Excel. También puede cambiar el tamaño del objeto mediante los controladores de tamaño. Para buscar los controladores, haga clic una vez en el objeto.

Insertar un objeto en una hoja de cálculo

  1. Haga clic en la celda de la hoja de cálculo donde quiere insertar el objeto.

  2. En la pestaña Insertar, en el grupo Texto, haga clic en Objeto.

    La opción Objeto está en la pestaña Insertar.
  3. Haga clic en la ficha Crear desde archivo.

    La pestaña "Crear de un archivo" en el cuadro de diálogo Objeto.
  4. Haga clic en Examinar y seleccione el archivo que quiere insertar.

  5. Si desea insertar un icono en la hoja de cálculo en lugar de mostrar el contenido del archivo, active la casilla de verificación Mostrar como icono . Si no selecciona las casillas de verificación, Excel muestra la primera página del archivo. En ambos casos, se abre el archivo completo hacer doble clic. Haga clic en Aceptar.

    Nota: Después de agregar el icono o el archivo, puede arrastrar y colóquela en cualquier lugar de la hoja de cálculo. También puede cambiar el icono o el archivo mediante el uso de los controladores de tamaño. Para buscar los controladores, haga clic en el archivo o el icono de una vez.

Insertar un vínculo a un archivo

Desea simplemente agregar un vínculo al objeto de totalmente la incrustación. Puede hacerlo si el libro y el objeto que desea agregar se almacenan en un sitio de SharePoint, una unidad de red compartida o una ubicación similar y la ubicación de los archivos permanecerán igual. Esto es útil si el objeto vinculado realiza cambios porque el vínculo siempre abre el documento más actualizado.

Nota: Si mueve el archivo vinculado a otra ubicación, el vínculo deja de funcionar.

  1. Haga clic en la celda de la hoja de cálculo donde quiere insertar el objeto.

  2. En la pestaña Insertar, en el grupo Texto, haga clic en Objeto.

    La opción Objeto está en la pestaña Insertar.
  3. Haga clic en la ficha crear desde archivo .

  4. Haga clic en Examinar y, a continuación, seleccione el archivo que desea vincular.

  5. Active la casilla Vincular a archivo y haga clic en Aceptar.

    En la pestaña "Crear de un archivo", seleccione "Vincular al archivo".

Crear un nuevo objeto desde dentro de Excel

Puede crear un objeto completamente nuevo basado en otro programa sin salir del libro. Por ejemplo, si desea agregar una explicación más detallada al gráfico o tabla, puede crear un documento incrustado, como un archivo Word o PowerPoint, en Excel. Puede establecer el objeto que se muestren directamente en una hoja de cálculo o agregar un icono que abre el archivo.

Este objeto incrustado es un documento de Word.
  1. Haga clic en la celda de la hoja de cálculo donde quiere insertar el objeto.

  2. En la pestaña Insertar, en el grupo Texto, haga clic en Objeto.

    La opción Objeto está en la pestaña Insertar.
  3. En la pestaña Crear nuevo, seleccione el tipo de objeto que quiere insertar de la lista. Si quiere insertar un icono en la hoja de cálculo en lugar del objeto en sí, active la casilla Mostrar como icono.

    La pestaña Crear nuevo en el cuadro de diálogo Objeto.
  4. Haga clic en Aceptar. Según el tipo de archivo que se va a insertar, se abre una nueva ventana de programa o bien aparece una ventana de edición dentro de Excel.

  5. Cree el nuevo objeto que quiere insertar.

    Cuando haya terminado, si Excel abrió una nueva ventana del programa en el que se creó el objeto, puede trabajar directamente en ella.

    Puede editar el documento de Word incrustado directamente en Excel.

    Cuando haya finalizado su trabajo en la ventana, puede realizar otras tareas sin guardar el objeto incrustado. Cuando se cierra el libro se guardará automáticamente los nuevos objetos.

    Nota: Después de agregar el objeto, puede arrastrarlo y colocarlo en cualquier lugar de la hoja de cálculo de Excel. También puede cambiar el tamaño del objeto mediante los controladores de tamaño. Para buscar los controladores, haga clic una vez en el objeto.

Vincular o incrustar contenido de otro programa con OLE

Puede vincular o incrustar todo o parte del contenido de otro programa.

Crear un vínculo al contenido de otro programa

  1. Haga clic en la hoja de cálculo donde desee colocar el objeto vinculado.

  2. En la pestaña Insertar, en el grupo Texto, haga clic en Objeto.

    Imagen de la cinta de Excel

  3. Haga clic en la ficha Crear desde archivo.

  4. En el cuadro Nombre de archivo, escriba el nombre del archivo o haga clic en Examinar para seleccionar desde la lista.

  5. Active la casilla de verificación Vincular.

  6. Siga uno de estos procedimientos:

    • Para mostrar el contenido, desactive la casilla de verificación Mostrar como icono.

    • Para mostrar un icono, active la casilla de verificación Mostrar como icono. Opcionalmente, para cambiar la imagen de icono predeterminada o la etiqueta, haga clic en Cambiar icono y, a continuación, haga clic en el icono que desee en la lista de icono o escriba una etiqueta en el cuadro título.

    Nota: No se puede utilizar el comando Objeto para insertar gráficos y ciertos tipos de archivos. Para insertar un gráfico o archivo, en la ficha Insertar, en el grupo Ilustraciones, haga clic en Imagen.

Insertar contenido desde otro programa

  1. Haga clic en la hoja de cálculo donde desee colocar el objeto incrustado.

  2. En la pestaña Insertar, en el grupo Texto, haga clic en Objeto.

    Imagen de la cinta de Excel

  3. Si el documento ya no existe, haga clic en la ficha Crear nuevo. En el cuadro Tipo de objeto, haga clic en el tipo de objeto que desee crear.

    Si el documento ya existe, haga clic en la ficha Crear desde archivo. En el cuadro Nombre de archivo, escriba el nombre del archivo o haga clic en Examinar para seleccionarlo en una lista.

  4. Desactive la casilla de verificación Vincular a archivo.

  5. Siga uno de estos procedimientos:

    • Para mostrar el contenido, desactive la casilla de verificación Mostrar como icono.

    • Para mostrar un icono, active la casilla de verificación Mostrar como icono. Para cambiar la imagen de icono predeterminada o la etiqueta, haga clic en Cambiar icono y, a continuación, haga clic en el icono que desee en la lista icono o escriba una etiqueta en el cuadro título.

Vincular o incrustar contenido parcial desde otro programa

  1. Desde un programa que no sea Excel, seleccione la información que desea copiar como vinculado o objeto incrustado.

  2. En la pestaña Inicio, en el grupo Portapapeles, haga clic en Copiar.

    Imagen de la cinta de Excel

  3. Cambie a la hoja de cálculo en la que desee colocar la información y, a continuación, haga clic donde desee que aparezca la información.

  4. En la ficha Inicio, en el grupo Portapapeles, haga clic en la flecha que aparece debajo de Pegar y, a continuación, haga clic en Pegado especial.

  5. Siga uno de estos procedimientos:

    • Para pegar la información como un objeto vinculado, haga clic en Pegar vínculo.

    • Para pegar la información como un objeto incrustado, haga clic en Pegar. En el cuadro Como, haga clic en la entrada con la palabra "objeto" en su nombre. Por ejemplo, si ha copiado la información de un documento de Word, haga clic en Objeto de documento de Microsoft Word.

Cambiar la forma en que se muestra un objeto OLE

  1. Haga clic con el botón secundario, elija tipo de objetoObjeto (por ejemplo, Objeto de documento) y, a continuación, haga clic en Convertir.

  2. Siga uno de estos procedimientos:

    • Para mostrar el contenido, desactive la casilla de verificación Mostrar como icono.

    • Para mostrar un icono, active la casilla de verificación Mostrar como icono. Si lo desea, puede cambiar la imagen de icono predeterminada o la etiqueta. Para ello, haga clic en Cambiar icono y, a continuación, haga clic en el icono que desee en la lista de icono o escriba una etiqueta en el cuadro título.

Controlar las actualizaciones a los objetos vinculados

Puede actualizar vínculos a otros programas para que se actualicen de los siguientes modos: automáticamente, al abrir el archivo de destino; manualmente, cuando desee ver los datos anteriores antes de actualizarlos con los datos nuevos desde el archivo de origen; o al solicitar específicamente la actualización, independientemente de que esté activada la actualización automática o manual.

Establecer un vínculo a otro programa para que se actualice de forma manual

  1. En la pestaña Datos, en el grupo Conexiones, haga clic en Modificar vínculos.

    Imagen de la cinta de Excel

    Nota: El comando Modificar vínculos no está disponible si el archivo no contiene vínculos a otros archivos.

  2. En la lista Origen, haga clic en el objeto vinculado que desee actualizar. Una A en la columna Actualizar significa que el vínculo es automático y una M en la columna Actualizar que el vínculo está establecido en la actualización Manual.

    Sugerencia: Para seleccionar varios objetos vinculados, mantenga presionada la tecla CTRL y haga clic en cada objeto vinculado. Para seleccionar todos los objetos vinculados, presione CTRL+A.

  3. Para actualizar un objeto vinculado sólo cuando haga clic en Actualizar valores, haga clic en Manual.

Establecer un vínculo a otro programa para que se actualice de forma automática

  1. En la pestaña Datos, en el grupo Conexiones, haga clic en Modificar vínculos.

    Imagen de la cinta de Excel

    Nota: El comando Modificar vínculos no está disponible si el archivo no contiene vínculos a otros archivos.

  2. En la lista Origen, haga clic en el objeto vinculado que desee actualizar. Una A en la columna Actualizar significa que el vínculo se actualizará de forma automática y una M en la columna Actualizar significa que el vínculo debe ser actualizado de forma manual.

    Sugerencia: Para seleccionar varios objetos vinculados, mantenga presionada la tecla CTRL y haga clic en cada objeto vinculado. Para seleccionar todos los objetos vinculados, presione CTRL+A.

  3. Haga clic en Aceptar.

Problema: no puedo actualizar los vínculos automáticos en mi hoja de cálculo

La opción Automático se puede sobrescribir mediante la opción de Excel Actualizar vínculos a otros documentos.

Para asegurarse de que los vínculos automáticos a los objetos OLE se pueden actualizar automáticamente:

  1. Haga clic en el Botón de Microsoft Office Imagen del botón de Office , haga clic en Opciones de Excel y, a continuación, haga clic en la categoría Avanzadas.

  2. Asegúrese de que en Al calcular este libro, esté activada la casilla de verificación Actualizar vínculos a otros documentos.

Actualizar un vínculo a otro programa ahora

  1. En la pestaña Datos, en el grupo Conexiones, haga clic en Modificar vínculos.

    Imagen de la cinta de Excel

    Nota: El comando Modificar vínculos no está disponible si el archivo no contiene vínculos a otros archivos.

  2. En la lista Origen, haga clic en el objeto vinculado que desee actualizar.

    Sugerencia: Para seleccionar varios objetos vinculados, mantenga presionada la tecla CTRL y haga clic en cada objeto vinculado. Para seleccionar todos los objetos vinculados, presione CTRL+A.

  3. Haga clic en Actualizar valores.

Modificar el contenido de un programa OLE

Cuando está en Excel, puede cambiar el contenido vinculado o incrustado de otro programa.

Modificar un objeto vinculado en el programa de origen

  1. En la pestaña Datos, en el grupo Conexiones, haga clic en Modificar vínculos.

    Imagen de la cinta de Excel

    Nota: El comando Modificar vínculos no está disponible si el archivo no contiene vínculos a otros archivos.

  2. En la lista Archivo de origen, haga clic en el origen de un objeto vinculado y, a continuación, haga clic en Abrir origen.

  3. Haga los cambios que desee en el objeto vinculado.

  4. Salga del programa origen para volver al archivo de destino.

Modificar un objeto incrustado en el programa de origen

  1. Haga doble clic en la tabla objeto incrustado para abrirla.

  2. Haga los cambios que desee en el objeto.

  3. Si va a modificar el objeto dentro del programa abierto, haga clic en cualquier lugar fuera del objeto para volver al archivo de destino.

    Si va a modificar el objeto incrustado en el programa de origen en una ventana independiente, cierre el programa de origen para volver al archivo de destino.

Nota: Al hacer doble clic en ciertos objetos incrustados, como vídeos y clips de sonido, en vez de abrirse un programa, se reproduce el objeto. Para modificar uno de esos objetos incrustados haga clic con el botón secundario en el icono u objeto, elija tipo de objetoObjeto (por ejemplo, Objeto de clip multimedia) y, a continuación haga clic en Modificar.

Modificar un objeto incrustado en un programa que no sea el programa de origen

  1. Seleccione el objeto incrustado que desee modificar.

  2. Haga clic con el botón secundario del mouse en el icono o el proyecto, seleccione Objetotipo de objeto (por ejemplo, Objeto Documento) y haga clic en Convertir.

  3. Siga uno de estos procedimientos:

    • Para convertir el objeto incrustado al tipo que especifique en la lista, haga clic en Convertir en.

    • Para abrir el objeto incrustado como el tipo de objeto que haya especificado en la lista sin cambiar el tipo de objeto incrustado, haga clic en Activar.

Seleccionar un objeto OLE mediante el teclado

  1. Presione CTRL+G para mostrar el cuadro de diálogo Ir a.

  2. Haga clic en Especial, seleccione Objetos y, a continuación, haga clic en Aceptar.

  3. Presione la tecla TAB hasta que se seleccione el objeto que desee.

  4. Presione MAYÚS+F10.

  5. Elija Objeto u Objeto Gráfico y, a continuación, haga clic en Modificar.

Problema: Al hace doble clic en un objeto vinculado o incrustado, aparece el mensaje "no se puede modificar"

Este mensaje aparece cuando el archivo de origen o el programa origen no se puede abrir.

Asegúrese de que el programa de origen está disponible.     Si el programa de origen no está instalado en el equipo, convierta el objeto al formato de archivo de un programa que tenga instalado.

Asegúrese de que la memoria es la adecuada.     Asegúrese de que tiene suficiente memoria para ejecutar el programa de origen. Cierre otros programas para liberar la memoria si es necesario.

Cierre todos los cuadros de diálogo     Si el programa de origen está ejecutándose, asegúrese de que no tiene abierto ningún cuadro de diálogo. Cambie al programa de origen y cierre los cuadros de diálogo que estén abiertos.

Cierre el archivo de origen.     Si el archivo de origen es un objeto vinculado, asegúrese de que no lo tenga abierto ningún otro usuario.

Asegúrese de que no se ha cambiado el nombre del archivo de origen     Si el archivo de origen que desea modificar es un objeto vinculado, asegúrese de que tiene el mismo nombre que tenía cuando creó el vínculo y que no se ha movido. Seleccione el objeto vinculado y, a continuación, haga clic en el comando Modificar vínculos en el grupo Conexiones de la ficha Datos para ver el nombre del archivo de origen. Si el archivo de origen se ha cambiado de nombre o se ha movido, utilice el botón Cambiar origen del cuadro de diálogo Modificar vínculos para ubicar el archivo de origen y volver a conectar el vínculo.

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×