Información general sobre la conexión (importación) a datos

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Este artículo de referencia explica cómo importar y conectar los datos. Obtendrá información acerca de las tareas como importar, actualizar, proteger y administrar datos.

En este artículo

Trabajar con conexiones de datos externos

Actualización de datos

Importar datos de orígenes de datos

Mejorar la seguridad de acceso a datos

Problemas acerca de cómo conectarse a datos

Trabajo con conexiones de datos externos

En las siguientes secciones se describe cómo funcionan las conexiones de datos externos y cómo se busca, edita, administra y comparte la información de conexión con otros programas y usuarios.

Volver al principio

Descripción de los conceptos básicos de las conexiones de datos

Los datos de un libro de Excel pueden proceder de dos ubicaciones diferentes. Pueden estar almacenados directamente en el libro o en un origen de datos externo, como un archivo de texto, una base de datos o un cubo de procesamiento analítico en línea (OLAP). Este origen de datos externos se conecta al libro a través de una conexión de datos, que es un conjunto de información que describe cómo localizar, iniciar una sesión y tener acceso al origen de datos externo.

La ventaja principal de conectarse a datos externos consiste en que puede analizar periódicamente estos datos sin tener que copiar repetidamente los datos en su libro, una operación que puede ser larga y provocar errores. Tras conectarse a los datos externos, también puede actualizar automáticamente los libros de Excel desde el origen de datos original siempre que el origen de datos se actualice con información nueva.

La información de conexión se almacena en el libro y también se puede almacenar en un archivo de conexión, como un archivo de conexión de datos de Office (.odc) o un archivo de nombre de origen de datos (.dsn).

Para introducir datos externos en Excel, debe tener acceso a los datos. Si el origen de datos externo que desea tener acceso no está en el equipo local, debe ponerse en contacto con el Administrador de la base de datos para una contraseña, permisos de usuario u otra información de conexión. Si el origen de datos es una base de datos, asegúrese de que la base de datos no se abre en modo exclusivo. Si el origen de datos es un archivo de texto o una hoja de cálculo, asegúrese de que otro usuario no tiene abrir para acceso exclusivo.

Una gran cantidad de orígenes de datos también requiere un controlador ODBC o un proveedor OLE DB para coordinar el flujo de datos entre Excel, el archivo de conexión y el origen de datos.

En el diagrama siguiente se resumen los principales puntos referentes a las conexiones de datos.

Conexión a orígenes de datos externos

1. hay una gran variedad de orígenes de datos que puede conectarse a: Analysis Services, SQL Server, Microsoft Access, otros OLAP y bases de datos relacionales, hojas de cálculo y archivos de texto.

2. numerosos orígenes de datos tienen un controlador ODBC asociado o el proveedor OLE DB.

3. un archivo de conexión define toda la información necesaria para obtener acceso y recuperar datos de un origen de datos.

4. información de conexión se copia desde un archivo de conexión en un libro y fácilmente se puede modificar la información de conexión.

5. los datos se copian en un libro de modo que puede usar igual que usa datos almacenados directamente en el libro.

Volver al principio

Búsqueda de conexiones

Para buscar archivos de conexión, use el cuadro de diálogo Conexiones existentes. (En el grupo Obtener datos externos de la ficha Datos, haga clic en Conexiones existentes). Al usar este cuadro de diálogo, podrá ver los siguientes tipos de conexiones:

  • Conexiones del libro   

    Esta lista muestra todas las conexiones actuales del libro. La lista se crea a partir de conexiones que el usuario ya ha definido y creado en el cuadro de diálogo Seleccionar origen de datos del Asistente para la conexión de datos o de las conexiones que ha seleccionado previamente como conexión desde este cuadro de diálogo.

  • Archivos de conexión en el equipo   

    Esta lista se crea a partir de la carpeta Mis archivos de origen de datos, generalmente almacenada en la carpeta Mis documentos (Windows XP) o Documentos (Windows Vista).

  • Archivos de conexión en la red   

    Esta lista puede crearse a partir de lo siguiente:

    • Un conjunto de carpetas de la red local, cuya ubicación se pueda implementar en la red como parte de la implementación de directivas de grupo de Microsoft Office.

    • Un Excel Services biblioteca de conexiones de datos (DCL) en un sitio de SharePoint Foundation. Para obtener más información acerca de DCL, vea la sección publicar en servicios de Excel de forma segura.

Volver al principio

Edición de las propiedades de conexión

También puede usar Excel como editor de archivos de conexión para crear y editar conexiones a orígenes de datos externos almacenados en un libro o en un archivo de conexión. Si no encuentra la conexión que desea, puede crear una haciendo clic en Examinar en busca de más para mostrar el cuadro de diálogo Seleccionar origen de datos y, a continuación, en Nuevo origen para iniciar el Asistente para la conexión de datos.

Después de crear la conexión, puede usar el cuadro de diálogo Propiedades de conexión (en la pestaña datos, en el grupo Obtener datos externos, haga clic en Propiedades ) para controlar varias configuraciones de conexiones a orígenes de datos externos y usar, volver a utilizar o modificar archivos de conexión.

Si usa un archivo de conexión para conectarse a un origen de datos, Excel copia la información de conexión del archivo de conexión en el libro de Excel. Cada vez que realice alguna modificación en el cuadro de diálogo Propiedades de conexión, estará editando la información de la conexión de datos almacenada en el libro actual de Excel, y no la del archivo de conexión original que se puede haber usado para crear la conexión (que aparece en el nombre de archivo de la propiedad Archivo de conexión de la ficha Definición). Después de editar la información de conexión (a excepción de las propiedades Nombre de conexión y Descripción de conexión), se quita el vínculo al archivo de conexión y se borra la propiedad Archivo de conexión.

Para asegurarse de que el archivo de conexión se use siempre cuando se actualice un origen de datos, haga clic en Intentar utilizar siempre este archivo para actualizar los datos en la ficha Definición. Al activar esta casilla de verificación, se garantiza que las actualizaciones del archivo de conexión siempre se usarán en todos los libros que usen ese archivo de conexión, que también debe tener esta propiedad establecida.

Volver al principio

Administración de conexiones

En el cuadro de diálogo Conexiones del libro, puede administrar fácilmente estas conexiones, incluida su creación, modificación y eliminación. (En el grupo Obtener datos externos de la ficha Datos, haga clic en Conexiones). Puede usar este cuadro de diálogo para hacer lo siguiente:

  • Crear, editar, actualizar y eliminar las conexiones utilizadas en el libro.

  • Comprobar el origen de datos externos. Es posible que desee realizar esto si la conexión fue definida por otro usuario.

  • Mostrar dónde se utiliza cada conexión en el libro actual.

  • Diagnosticar un mensaje de error sobre las conexiones a datos externos.

  • Redirigir una conexión a un servidor u origen de datos distinto, o reemplazar el archivo de conexión por una conexión existente.

  • Simplificar la creación y el uso compartido de archivos de conexión con otros usuarios.

Volver al principio

Uso compartido de conexiones

Los archivos de conexión son especialmente útiles para compartir conexiones de forma coherente, resaltar las conexiones, ayudar a mejorar la seguridad de las conexiones y facilitar la administración de los orígenes de datos. La mejor manera de compartir los archivos de conexión es colocarlos en una ubicación segura y de confianza, como una carpeta de red o una biblioteca de SharePoint, donde los usuarios pueden leer el archivo pero solo usuarios designados pueden modificarlo.

Uso de archivos ODC

Puede crear archivos de conexión de datos de Office (.odc) conectándose a datos externos mediante el cuadro de diálogo Seleccionar origen de datos o mediante el Asistente para la conexión de datos para conectarse a orígenes de datos nuevos. Un archivo .odc usa etiquetas HTML y XML personalizadas para almacenar la información de conexión. Puede ver o modificar fácilmente el contenido del archivo en Excel.

Puede compartir los archivos de conexión con otras personas para que puedan tener el mismo acceso a un origen de datos externo. Los otros usuarios no tienen que configurar un origen de datos para abrir el archivo de conexión, pero es posible que tengan que instalar el controlador ODBC o proveedor OLE DB necesario para obtener acceso a los datos externos en sus equipos.

Los archivos ODC son el método recomendado para conectarse a datos y para compartir los datos. Para convertir fácilmente otros archivos de conexión tradicionales (archivos de consulta, DSN y UDL) a un archivo ODC, abra el archivo de conexión y haga clic en el botón Exportar archivo de conexión en la ficha Definición del cuadro de diálogo Propiedades de conexión.

Uso de archivos de consulta

Los archivos de consulta son archivos de texto que contienen información del origen de datos, incluso el nombre del servidor donde están ubicados los datos y la información de conexión que proporciona al crear un origen de datos. Los archivos de consulta son una forma tradicional de compartir consultas con otros usuarios de Excel.

Usar archivos de consulta .dqy    Puede utilizar Microsoft Query para guardar archivos .dqy que contengan consultas de bases de datos relacionales o archivos de texto. Al abrir estos archivos en Microsoft Query, puede ver los datos devueltos por la consulta y modificar la consulta para recuperar resultados diferentes. Puede guardar un archivo .dqy para cualquier consulta que cree mediante el Asistente para consultas o directamente en Microsoft Query.

Usar archivos de consulta .oqy    Puede guardar archivos .oqy para conectarse a datos en una base de datos OLAP en un servidor o en un archivo de cubo sin conexión (.cub). Al utilizar el Asistente para conexiones multidimensionales en Microsoft Query para crear un origen de datos para una base de datos OLAP o un cubo, se crea automáticamente un archivo .oqy. Dado que las bases de datos OLAP no están organizadas por registros o tablas, no puede crear consultas ni archivos .dqy para obtener acceso a estas bases de datos.

Usar archivos de consulta .rqy    Excel puede abrir archivos de consulta en formato .rqy para controladores de origen de datos de OLE DB que use este formato. Para obtener más información, consulte la documentación del controlador.

Usar archivos de consulta .qry    Microsoft Query puede abrir y guardar archivos de consulta en formato .qry para usarlos con versiones anteriores de Microsoft Query que no puede abrir archivos .dqy. Si tiene un archivo de consulta en formato .qry que desea utilizar en Excel, abra el archivo en Microsoft Query y, a continuación, guárdelo como un archivo .dqy. Para obtener información sobre cómo guardar archivos .dqy, consulte la Ayuda de Microsoft Query.

Usar archivos de consulta Web .iqy    Excel puede abrir archivos de consulta Web .iqy para recuperar datos desde la Web.

Volver al principio

Uso de propiedades y rangos de datos externos

Un rango de datos externos (también llamado una tabla de consulta) es un nombre definido o un nombre de tabla que define la ubicación de los datos que se traen a una hoja de cálculo. Cuando se conecta a datos externos, Excel crea un rango de datos externos automáticamente, excepto en el caso de un informe de tabla dinámica que está conectado a un origen de datos, en el que no se crea un rango de datos externos. En Excel, puede aplicar formato y disponer un rango de datos externos o usarlo en cálculos al igual que con los demás datos.

Excel asigna automáticamente los nombres de los rangos de datos externos de la siguiente manera:

  • Los rangos de datos externos de archivos de conexión de datos de Office (ODC) reciben el mismo nombre que el nombre de archivo.

  • Rangos de datos externos de bases de datos se denominan con el nombre de la consulta. De forma predeterminada Consulta_de_origen es el nombre del origen de datos que usó para crear la consulta.

  • Los rangos de datos externos de archivos de texto reciben el nombre del archivo de texto.

  • Rangos de datos externos de consultas Web se denominan con el nombre de la página Web de la cual se recuperan los datos.

Si su hoja de cálculo tiene más de un rango de datos externos del mismo origen, los rangos se numeran. Por ejemplo, MiTexto, MiTexto_1, MiTexto_2, y así sucesivamente.

Un rango de datos externos tiene otras propiedades (que no se deben confundir con las propiedades de conexión) que se pueden usar para controlar los datos; por ejemplo, la conservación del formato de celda y el ancho de columna. Estas propiedades de rango de datos externos pueden ser modificadas. Para ello, haga clic en Propiedades en el grupo Conexiones de la ficha Datos y, a continuación, realice los cambios en los cuadros de diálogo Propiedades del rango de datos externos o Propiedades de los datos externos.

Nota: Si desea compartir un resumen o un informe que se basa en datos externos, puede dar a otros usuarios un libro que contenga un rango de datos externos o puede crear una plantilla de informe. Un plantilla de informe le permite guardar el resumen o informe sin guardar los datos externos para que el archivo es más pequeño. Cuando un usuario abre la plantilla de informe, se recuperan los datos externos.

Volver al principio

Descripción de la compatibilidad con orígenes de datos en Excel y Servicios de Excel

Hay varios objetos de datos (como un rango de datos externos y un informe de tabla dinámica) que se pueden usar para conectarse a diferentes orígenes de datos. Sin embargo, el tipo de origen de datos al que puede conectarse es diferente entre cada objeto de datos. También puede usar y actualizar datos conectados en Servicios de Excel, pero hay otras limitaciones y soluciones que debe tener en cuenta.

Compatibilidad con orígenes de datos y objetos de datos de Excel

En la siguiente tabla, se resumen los orígenes de datos que se admiten en cada uno de los objetos de datos de Excel.

Origen de datos compatibles

Excel
datos
objeto

¿Crea
externos
datos
rango?

OLE
DB

ODBC

Texto
archivo

HTML
archivo

XML
archivo

Compartir -
punto
lista

Asistente para importación de texto

No

No

No

No

No

Informe de tabla dinámica
(que no sea OLAP)

No

No

No

Informe de tabla dinámica
(OLAP)

No

No

No

No

No

No

Tabla de Excel

No

No

Asignación XML

No

No

No

No

No

Consulta web

No

No

No

No

Asistente para la conexión de datos

Microsoft Query

No

No

No

No

Nota: Estos archivos, un archivo de texto importado mediante el Asistente para importación de texto, un archivo XML importado mediante una asignación XML y un archivo HTML o XML importado mediante una consulta web no usan un controlador ODBC o proveedor OLE DB para establecer la conexión con el origen de datos.

Compatibilidad con orígenes de datos de Servicios de Excel

Si desea mostrar un libro de Excel en Servicios de Excel (Excel en un explorador web), puede conectarse y actualizar los datos, pero debe usar un informe de tabla dinámica. Servicios de Excel no es compatible con rangos de datos externos, lo que significa que no admite una tabla de Excel conectada a un origen de datos, una consulta web, una asignación XML o Microsoft Query.

Sin embargo, puede resolver esta limitación mediante el uso de una tabla dinámica para conectarse al origen de datos y, a continuación, diseñar y presentar la tabla dinámica como tabla bidimensional sin niveles, grupos ni subtotales, de modo que se muestren todos los valores de fila y columna deseados. Para obtener más información, vea los vínculos de la sección Vea también.

Volver al principio

Descripción de Data Access Components

Microsoft Data Access Components (MDAC) 2,8 se incluye con Microsoft Windows Server 2003 y Windows XP Service Pack 2. Con MDAC, puede conectarse a y utilizar los datos de una amplia variedad de orígenes de datos relacionales y. Puede conectarse a varios orígenes de datos diferentes con controladores de conectividad abierta de base de datos (ODBC) o proveedores de OLE DB, que se genera y enviados por Microsoft o desarrollados por terceros distintos. Al instalar Microsoft Office, se agregan controladores ODBC adicionales y proveedores de OLE DB con el equipo.

Windows Vista y Windows 7 usan Windows Data Access Components (Windows DAC).

Para ver una lista completa de los proveedores OLE DB instalados en el equipo, abra el cuadro de diálogo Propiedades de vínculo de datos de un archivo de vínculo de datos y, a continuación, haga clic en la pestaña Proveedor.

Para ver una lista completa de los controladores ODBC instalados en el equipo, abra el cuadro de diálogo Administrador de orígenes de datos ODBC y, a continuación, haga clic en la ficha Controladores.

Asimismo, puede utilizar controladores ODBC y proveedores OLE DB de otros fabricantes para obtener información de orígenes que no sean orígenes de datos de Microsoft, incluidos otros tipos de bases de datos ODBC y OLE DB. Para obtener información sobre la instalación de estos controladores ODBC o proveedores OLE DB, consulte la documentación de la base de datos o póngase en contacto con el proveedor de la base de datos.

Volver al principio

Usar ODBC para conectarse a orígenes de datos

En las siguientes secciones se describe más detalladamente la conectividad abierta de bases de datos (ODBC).

Arquitectura ODBC

En la arquitectura ODBC, una aplicación (como Excel) se conecta al Administrador de controladores ODBC, que a su vez usa un controlador ODBC específico (como el controlador ODBC de Microsoft SQL) para conectarse a un origen de datos (como una base de datos de Microsoft SQL Server).

Definir la información de conexión

Para conectarse a orígenes de datos ODBC, siga este procedimiento:

  1. Asegúrese de que el controlador ODBC adecuado esté instalado en el equipo que contiene el origen de datos.

  2. Defina un nombre de origen de datos (DSN) mediante el Administrador de origen de datos ODBC para almacenar la información de conexión en el Registro o en un archivo DNS, o bien, mediante una cadena de conexión en código de Microsoft Visual Basic para pasar la información de conexión directamente al Administrador de controladores ODBC.

    Para definir un origen de datos, en Windows Vista, haga clic en el botón Inicio y, a continuación, en Panel de control. Haga clic en Sistema y mantenimiento y, a continuación, haga clic en Herramientas administrativas. En Windows XP y en Windows Server, haga clic en Inicio y, a continuación, haga clic en Panel de control. Haga clic en Rendimiento y mantenimiento, haga clic en Herramientas administrativas y, a continuación, haga clic en Orígenes de datos (ODBC). Para obtener más información sobre las diferentes opciones, haga clic en el botón Ayuda en cada cuadro de diálogo.

Orígenes de datos de equipo

Orígenes de datos de máquina almacenan la información de conexión en el registro, en un equipo específico, con un nombre definido por el usuario. Puede usar orígenes de datos de equipos sólo en el equipo se definen en. Existen dos tipos de orígenes de datos de equipo, usuario y del sistema. Orígenes de datos de usuario pueden ser usados sólo por el usuario actual y sólo son visibles para ese usuario. Orígenes de datos de sistema pueden ser usados por todos los usuarios en un equipo y son visibles para todos los usuarios en el equipo.

Los orígenes de datos de equipo son especialmente útiles cuando se desea mejorar la seguridad porque ayudan a asegurar que solo los usuarios que han iniciado sesión pueden verlos y porque los usuarios remotos no los pueden copiar a otro equipo.

Orígenes de datos de archivo

Los orígenes de datos de archivo (que también se denominan archivos DSN) almacenan información de conexión en un archivo de texto en vez del Registro y suelen ser más flexibles que los orígenes de datos de equipo. Por ejemplo, los orígenes de datos de archivo se pueden copiar a cualquier equipo con el controlador ODBC adecuado, de modo que la aplicación puede contar con información de conexión coherente y exacta en todos los equipos donde se usa. O bien, se puede ubicar el origen de datos de archivo en un solo servidor, compartirlo entre diversos equipos de la red y mantener fácilmente la información de conexión en una sola ubicación.

Un origen de datos de archivo también puede ser susceptible de no ser compartido. En ese caso, reside en un solo equipo y apunta a un origen de datos de equipo. Este tipo de origen de datos de archivo puede usarse para obtener acceso a los orígenes de datos de equipo existentes desde los orígenes de datos de archivo.

Volver al principio

Utilizar OLE DB para conectarse a orígenes de datos

En las siguientes secciones se describe más detalladamente la base de datos de vinculación e incrustación de objetos (OLE DB).

Arquitectura OLE DB

En la arquitectura OLE DB, la aplicación que obtiene acceso a los datos se denomina consumidor de datos (como Excel) y el programa que permite el acceso nativo a los datos se denomina proveedor de base de datos (como el proveedor OLE DB de Microsoft para SQL Server).

Definir la información de conexión

Un archivo Universal Data Link (.udl) contiene la información de conexión que un consumidor de datos utiliza para obtener acceso a un origen de datos a través del proveedor OLE DB de ese origen de datos. Puede crear la información de conexión siguiendo uno de estos procedimientos:

  • En el Asistente para la conexión de datos, use el cuadro de diálogo Propiedades de vínculo de datos para definir un vínculo de datos para un proveedor de OLE DB. Para obtener más información, vea la sección Importar datos mediante el Asistente para la conexión de datos.

  • Cree un archivo de texto en blanco con una extensión de nombre de archivo .udl y, a continuación, modifique el archivo. De este modo, se muestra el cuadro de diálogo Propiedades de vínculo de datos.

Volver al principio

Actualización de datos

Cuando se conecta a un origen de datos externos, también puede realizar una operación de actualización para recuperar los datos actualizados. Cada vez que actualice los datos, verá la versión más reciente de los datos, incluidos los cambios realizados desde la última actualización.

En la siguiente ilustración, se explica el proceso básico que tiene lugar cuando se actualizan datos conectados a un origen de datos externo.

Proceso básico de actualización de datos externos

1. Una operación de actualización obtiene datos actualizados.

2. el archivo de conexión define toda la información necesaria para obtener acceso y recuperar datos de origen de datos externo.

3. hay una gran variedad de orígenes de datos que puede actualizar: OLAP, SQL Server, Access, OLE DB, ODBC, hojas de cálculo y archivos de texto.

4. Los datos actualizados se agregan al libro actual.

Excel proporciona muchas opciones para actualizar datos importados, entre los que se incluye la actualización de datos cada vez que se abra el libro y la actualización automática del mismo a intervalos de tiempo determinados. Puede continuar trabajando en Excel mientras los datos se están actualizando, y también puede comprobar el estado de la actualización mientras se actualizan los datos.

Si el origen de datos externos requiere un contraseña para tener acceso a los datos, puede requerir que se escriba la contraseña cada vez que se actualiza el rango de datos externos.

Volver al principio

Importación de datos desde orígenes de datos

Windows XP, Windows Vista y Microsoft Office ofrecen los controladores ODBC y proveedores OLE DB que puede usar para recuperar datos de los siguientes orígenes de datos comunes: Microsoft Access, archivos HTML de Internet, archivos de texto, Microsoft SQL Server, SQL Server Analysis Services y archivos XML. Al usar el Asistente para la conexión de datos y Microsoft Query, también puede tener acceso a muchos otros orígenes de datos que tienen los controladores ODBC y proveedores OLE DB adecuados, incluso otros libros de Excel, Microsoft FoxPro, dBASE, Paradox, Oracle y DB2.

Volver al principio

Importación de datos desde una base de datos de Access

Existen diversas maneras de intercambiar datos entre Microsoft Access y Microsoft Excel.

  • Para traer datos de Access a Excel, puede copiarlos de una hoja de datos de Access y pegarlos en una hoja de cálculo de Excel, conectar con una base de datos de Access desde una hoja de cálculo de Excel o exportar datos de Access a una hoja de cálculo de Excel.

  • Para traer datos de Excel a Access, puede copiarlos de una hoja de cálculo de Excel y pegarlos en una hoja de datos de Access, importar una hoja de cálculo de Excel en una tabla de Access o crear un vínculo con una hoja de cálculo de Excel desde una tabla de Access.

Nota: La palabra Importar tiene dos significados diferentes entre Excel y Access. En Excel importar significa crear una conexión permanente con datos que se pueden actualizar. En Access importar significa reunir datos en Access una vez, pero sin una conexión de datos.

Trabajar con datos de Access en Excel

Es posible que desee trabajar con datos de Access en un libro de Excel para aprovechar las características de análisis de datos y creación de gráficos, la flexibilidad en la presentación y diseño de los datos o las funciones de Excel que no están disponibles en Access.

Conectar con datos de Access desde Excel

Para llevar datos actualizables de Access a Excel, puede crear una conexión a la base de datos de Access y recuperar todos los datos de una tabla o consulta. Por ejemplo, tal vez desee actualizar un informe presupuestario de Excel que distribuye cada mes para que contenga los datos del mes en curso.

Exportar datos de Access a Excel

Mediante el Asistente para exportación de Access, puede exportar un objeto de base de datos de Access (como una tabla, una consulta o un formulario) o registros seleccionados en una vista, a una hoja de cálculo de Excel. Cuando lleve a cabo una operación de exportación en Access, puede guardar el diseño de la operación para usarlo más adelante e incluso puede programar la operación de exportación para que se ejecute automáticamente en intervalos especificados.

A continuación se describen algunos escenarios comunes de exportación de datos de Access a Excel:

  • Su departamento o grupo utiliza Access y Excel para trabajar con los datos. Éstos están almacenados en bases de datos de Access, pero utiliza Excel para analizarlos y distribuir los resultados del análisis. Su equipo exporta los datos a Excel cuando es necesario, pero desearía que el proceso fuera más eficaz.

  • Utiliza Access con mucha frecuencia, pero su jefe prefiere ver los informes en Excel. Periódicamente, tiene que copiar los datos a Excel, pero le gustaría automatizar este proceso para ahorrar tiempo.

Para obtener más información sobre cómo exportar datos de Access a Excel, vea el sistema de Ayuda de Access.

Trabajar con datos de Excel en Access

Tal vez desee trabajar con los datos de Excel en una base de datos de Access para aprovechar las características de administración de datos, seguridad o multiusuario de Access. Aunque Access contiene muchas características útiles, hay dos de ellas que son especialmente adecuadas para los datos de Excel:

  • Informes    Si está familiarizado con el diseño de informes de Access y desea resumir u organizar los datos de Excel en este tipo de informe, puede crear un informe de Access. Por ejemplo, puede crear informes más flexibles, como informes de grupo y resumen, etiquetas impresas e informes gráficos.

  • Formularios    Si desea usar un formulario para buscar o mostrar datos en Excel, puede crear un formulario de Access. Por ejemplo, puede crear un formulario de Access para mostrar campos en un orden diferente del orden de columnas en la hoja de cálculo, o puede ver más fácilmente una fila larga de datos en una pantalla.

Para obtener más información sobre cómo trabajar con formularios e informes de Access, vea el sistema de Ayuda de Access.

Establecer un vínculo a datos de Excel desde Access

Puede vincular un rango de datos de Excel en una base de datos de Access como una tabla. Use este sistema si tiene previsto mantener el rango de datos en Excel, pero desea también que los datos estén disponibles en Access. Este tipo de vínculo se crea desde la base de datos de Access, no desde Excel.

Cuando se establece un vínculo a una hoja de cálculo o un rango con nombre de Excel, Access crea una nueva tabla que está vinculada a las celdas de origen. Todos los cambios que se realicen en las celdas de origen en Excel se reflejan en la tabla vinculada. Sin embargo, no puede modificar el contenido de la tabla correspondiente en Access. Si desea agregar, modificar o eliminar datos, debe realizar los cambios en el archivo de Excel de origen.

A continuación, se incluyen algunos escenarios comunes de vinculación a una hoja de cálculo de Excel desde Access:

  • Desea seguir manteniendo los datos en hojas de cálculo de Excel, pero desea poder usar las eficaces características de consulta y generación de informes de Access.

  • Su departamento o grupo de trabajo usa Access pero los datos de orígenes externos con los que trabaja están en hojas de cálculo de Excel. No desea mantener copias de datos externos sino que desea poder trabajar con ellos en Access.

Para obtener más información sobre cómo vincular datos de Access a Excel, vea el sistema de Ayuda de Access.

Importar datos de Excel a Access

Para almacenar datos de Excel en una base de datos de Access y utilizar y mantener estos datos en Access de ahora en adelante, puede importar los datos a Access. Cuando se importan datos, Access los almacena en una tabla nueva o existente sin modificarlos. Solo puede importar una hoja de cálculo cada vez durante una operación de importación. Para importar datos de varias hojas de cálculo, repita la operación de importación para cada hoja de cálculo.

A continuación se incluyen algunos escenarios comunes de importación de datos de Excel en Access:

  • Utiliza Excel con mucha frecuencia, pero a partir de ahora desea utilizar Access para trabajar con estos datos. Desea mover los datos de las hojas de cálculo de Excel a una o varias bases de datos de Access.

  • Su departamento o grupo de trabajo utiliza Access, pero de vez en cuando recibe datos en formato de Excel que debe combinar con bases de datos de Access. Desea importar estas hojas de cálculo de Excel a la base de datos cuando las recibe.

  • Utiliza Access para administrar los datos, pero los informes semanales que recibe del resto de los integrantes de su equipo son libros de Excel. Desea agilizar el proceso de importación para asegurarse de que los datos se importan cada semana a una hora específica a la base de datos.

Para obtener más información sobre cómo importar datos de Excel a Access, vea el sistema de Ayuda de Access.

Volver al principio

Importación de datos desde Internet

Las páginas web suelen contener información que es perfecta para el análisis en Excel. Por ejemplo, puede analizar cotizaciones en Excel mediante el uso de información que viene directamente de una página web. Según sus necesidades, puede recuperar datos actualizables (es decir, puede actualizar los datos en Excel con los datos más recientes de la página web) o puede obtener datos de una página web y mantenerlos estáticos en la hoja de cálculo.

Puede usar una consulta web para recuperar datos almacenados en una intranet o en Internet, como una sola tabla, varias tablas o todo el texto de una página web, y analizar los datos mediante las herramientas y características de Excel. Con un solo clic, puede actualizar fácilmente los datos con la información más actualizada de la página web. Por ejemplo, puede recuperar y actualizar índices de cotizaciones desde una página web pública o recuperar y actualizar una tabla de información de ventas de una página web de la empresa.

Puede importar datos que proceden de una página Web mediante el cuadro de diálogo Nueva consulta Web. (En la pestaña datos, en el grupo Obtener datos externos, haga clic en Desde la Web ). Necesita acceso a World Wide Web a través de la intranet de su organización o un módem en su equipo o la red, o puede realizar una consulta de archivos HTML o XML que se almacenan en el equipo.

Volver al principio

Importación de archivos de texto

Puede utilizar Excel para importar datos de un archivo de texto a una hoja de cálculo. (En la fichaDatos, en el grupo Obtener datos externos, haga clic en Desde texto). El Asistente para importar texto examina el archivo de texto que se va a importar y ayuda a garantizar que los datos se importen del modo deseado.

Existen dos formas de importar datos de un archivo de texto usando Excel: puede abrir el archivo de texto en Excel (lo cual no establece una conexión con el archivo de texto) o puede importar el archivo de texto como un rango de datos externos (lo cual sí establece una conexión con el archivo de texto).

Son dos los formatos de archivo de texto que se usan habitualmente:

  • Archivos de texto delimitados (.txt), en los que el carácter de tabulación (el código de carácter ASCII 009) separa normalmente cada campo de texto.

  • Archivos de texto de valores separados por comas (.csv), en los que el carácter de coma (,) suele separar cada campo de texto.

También puede cambiar el carácter separador que se usa tanto en los archivos de texto delimitados como en los .csv. Esto puede ser necesario para asegurarse de que la operación de importación o de exportación se realizará de la manera deseada.

Volver al principio

Importación de datos desde Microsoft SQL Server

Microsoft SQL Server es una base de datos relacional completa diseñada para las soluciones de datos profesionales que requieren un óptimo rendimiento, disponibilidad, escalabilidad y seguridad. En Excel, puede conectarse fácilmente a una base de datos de Microsoft SQL Server. (En el grupo Obtener datos externos de la ficha Datos, haga clic en Desde otros orígenes y, a continuación, en Desde SQL Server).

Al conectarse a una base de datos de Microsoft SQL Server, el Asistente para la conexión de datos muestra tres páginas:

  • Página 1: conectarse al servidor de base de datos    Use esta página para especificar el servidor de base de datos y la forma en que iniciar sesión en el servidor.

  • Página 2: Seleccionar base de datos y tabla    Use esta página para especificar la base de datos y la tabla o consulta que contenga los datos que desea.

  • Página 3: guardar datos de conexión y archivos    Use esta página para especificar y describir las frases de búsqueda y el archivo de conexión para localizar el archivo.

Volver al principio

Importación de datos desde Microsoft SQL Server Analysis Services

Analysis Services (un componente de Microsoft SQL Server) que admite la inteligencia empresarial y es una base para sistemas de análisis de procesamiento analítico en línea (OLAP), cuadros de mandos de indicador clave de rendimiento (KPI), minería de datos y sistemas de reporting de paneles. En Excel, puede conectarse fácilmente a un una base de datos OLAP de Analysis Services utilizando un proveedor OLAP. (En la pestaña datos, en el grupo Obtener datos externos, haga clic en Desde otros orígenes y, a continuación, haga clic en Desde Analysis Services ). Un proveedor OLAP es un conjunto de software que proporciona acceso a un determinado tipo de base de datos OLAP. Este software puede incluir un controlador de origen de datos y otro software de cliente que es necesario para conectarse a una base de datos. Debe usar un informe de tabla dinámica para conectarse a un proveedor OLAP.

También puede acceder a los datos OLAP cuando esté desconectado del origen de datos OLAP. Un archivo de cubo sin conexión es un archivo con la extensión .cub que almacena una parte de la datos de origen desde una base de datos de servidor OLAP. Usar un archivo de cubo sin conexión para continuar realizar cambios en los informes de tabla dinámica y gráfico dinámico cuando el servidor no está disponible o cuando esté desconectado de la red.

Al conectarse a Analysis Services, el Asistente para la conexión de datos muestra tres páginas:

  • Página 1: conectarse al servidor de base de datos     Use esta página para especificar el servidor y la forma en que iniciar sesión en el servidor de base de datos.

  • Página 2: Seleccionar base de datos y tabla    Use esta página para especificar la base de datos y el cubo.

  • Página 3: guardar datos de conexión y archivos    Use esta página para especificar y describir las frases de búsqueda y el archivo de conexión para localizar el archivo.

Volver al principio

Importar datos XML

Excel facilita la importar datos de lenguaje de marcado Extensible (XML) que se crean desde otras aplicaciones y bases de datos, asignar elementos XML desde un esquema XML a las celdas de la hoja de cálculo y exportar revisados datos XML para la interacción con otras aplicaciones y bases de datos. Considere estas nuevas características XML como convertir Excel en un generador de archivos de datos XML con una interfaz de usuario familiar.

Gracias a las asignaciones XML, es posible agregar, identificar y extraer partes concretas de datos comerciales de los documentos de Excel con facilidad. Por ejemplo, una factura que contenga el nombre y la dirección de un cliente o un informe que contenga los resultados financieros del último trimestre ya no son informes estáticos. Esta información se puede importar fácilmente desde bases de datos y aplicaciones, revisar y exportar a las mismas bases de datos y aplicaciones o a otras distintas.

Situaciones clave de XML

Las características de XML están diseñadas para las siguientes situaciones clave:

  • Aumentar la funcionalidad de las plantillas existentes de Excel al asignar elementos XML a celdas existentes. Eso facilita la especificación y la extracción de datos XML en las plantillas sin necesidad de volver a diseñarlas.

  • Usar datos XML como entrada para los modelos de cálculo existentes al asignar elementos XML a las hojas de cálculo existentes.

  • Importar archivos de datos XML a un nuevo libro.

  • Importar datos XML de un servicio Web a la hoja de cálculo de Excel.

  • Exportar datos de las celdas de asignación a archivos de datos XML independientes de otros datos del libro.

Proceso básico para el uso de datos XML en Excel

El siguiente diagrama muestra cómo los diferentes archivos y operaciones trabajan conjuntamente cuando se utiliza XML con Excel. Básicamente, el proceso se compone de cinco fases.

Información general sobre cómo Excel trabaja con datos XML

Llamada 1 Agregar un archivo de esquema XML (.xsd) a un libro.

Imagen del botón Asignación de elementos del esquema XML a celdas individuales o listas XML.

Globo 3 Importar un archivo de datos XML (.xml) y enlazar los elementos XML a celdas asignadas.

Paso 4 Introducir datos, mover celdas asignadas y aprovechar la funcionalidad de Excel sin perder la estructura XML y las definiciones.

Globo 5 Exportar datos revisados de celdas asignadas a un archivo de datos XML.

Uso de datos XML

Cuando importa el contenido de un archivo de datos XML a una asignación XML existente en el libro, los datos del archivo se enlazan con una asignación XML almacenada en el libro. Eso significa que cada elemento de datos del archivo de datos XML tiene un elemento correspondiente en el esquema XML que se ha asignado desde un archivo de esquema XML o un esquema deducido. Cada asignación XML solo puede tener un enlace de datos XML, y un enlace de datos XML está enlazado con todas las asignaciones creadas desde una única asignación XML.

Puede abrir el cuadro de diálogo Propiedades de la asignación XML, (en el grupo XML de la ficha Programador, haga clic en Propiedades de la asignación), donde encontrará tres opciones (todas activadas de manera predeterminada) que puede establecer o desactivar para controlar el comportamiento de un enlace de datos XML:

  • Validar datos con el esquema para importar y exportar    Especifica si Excel valida datos con la asignación XML al importar datos. Establecer esta opción si desea asegurarse de que los datos XML que importar se ajustan al esquema XML.

  • Sobrescribir los datos existentes con los nuevos datos    Especifica si se sobrescriben al importar datos. Establecer esta opción si desea reemplazar los datos actuales con los nuevos datos, por ejemplo, cuando los datos actualizados se encuentran en el nuevo archivo de datos XML.

  • Listas de anexar los nuevos datos a XML existente    Especifica si el contenido del origen de datos se anexa a los datos existentes en la hoja de cálculo. Establecer esta opción, por ejemplo, cuando se consolidar datos de varios archivos de datos XML similar en una lista XML, o no desea sobrescribir el contenido de una celda que contiene una función.

Volver al principio

Importación de datos mediante el Asistente para la conexión de datos

Puede usar el Asistente para la conexión de datos para conectarse a un origen de datos externos OLE DB u ODBC que ya haya sido definido. Para abrir el Asistente para la conexión de datos, en el grupo Obtener datos externos de la ficha Datos, haga clic en De otras fuentes y luego en Desde el Asistente para la conexión de datos.

Si elige la opción de origen de datos Otro o avanzado en el Asistente para la conexión de datos, puede ver una lista de proveedores OLE DB disponibles en el cuadro de diálogo Propiedades de vínculo de datos. Además, el proveedor OLE DB de Microsoft para controladores ODBC también permite el acceso a orígenes de datos ODBC. Para obtener más información acerca de cómo usar cada ficha de este cuadro de diálogo, haga clic en Ayuda en el cuadro de diálogo Propiedades de vínculo de datos.

En general, para definir la información de conexión en el cuadro de diálogo Propiedades de vínculo de datos, siga este procedimiento:

  • Haga clic en la pestaña Proveedor, seleccione el proveedor OLE DB y, a continuación, haga clic en Siguiente. Se mostrará la ficha Conexión, en la cual podrá escribir información de conexión específica para el proveedor OLE DB.

    Cada proveedor OLE DB define información de conexión específica. Por ejemplo, el proveedor OLE DB de Microsoft para SQL Server requiere un nombre de servidor, una ubicación del servidor y un nombre de usuario. Es posible que también desee definir información adicional, como una contraseña, o si desea usar la seguridad integrada de Microsoft Windows.

  • Para proporcionar información adicional, como la configuración de red y los permisos de acceso, haga clic en la pestaña Avanzadas.

  • Para definir las propiedades de inicialización del proveedor OLE DB, haga clic en la pestaña Todo.

Nota: No se puede filtrar ni unir datos en el Asistente para la conexión de datos.

Volver al principio

Importación de datos mediante Microsoft Query

También puede utilizar Microsoft Query para importar datos. (En la pestaña datos, en el grupo Obtener datos externos, haga clic en Desde otros orígenes y, a continuación, haga clic en Desde Microsoft Query ). Utilizar Microsoft Query para configurar orígenes de datos ODBC para recuperar datos. En Microsoft Query, puede usar al Asistente para consultas para crear una sencilla consulta, o bien, puede usar criterios avanzados en Query para crear una consulta más compleja y haga lo siguiente:

  • Filtrar filas o columnas de datos antes de llevarlos a Excel.

  • Crear un consulta de parámetros.

  • Ordenar datos antes de llevarlos a Excel.

  • Unir varias tablas.

Microsoft Query proporciona un front-end simple, fácilmente accesible desde Excel, para realizar estas tareas de consultas especializadas.

Volver al principio

Importación de datos mediante programación y mediante el uso de funciones

Si es programador, existen varios enfoques dentro de Excel que puede tomar para importar datos:

  • Puede usar Visual Basic para aplicaciones para obtener acceso a un origen de datos externo. Dependiendo del origen de datos, puede usar los objetos de datos ActiveX o los objetos de acceso a datos para recuperar los datos. También puede definir una cadena de conexión en el código que especifica la información de conexión. Uso de una cadena de conexión es útil, por ejemplo, cuando desea evitar que los administradores del sistema o los usuarios para crear un archivo de conexión, o para simplificar la instalación de la aplicación.

  • Si importa datos de una base de datos de SQL Server, considere la posibilidad de usar SQL Native Client, que es una interfaz de programación de aplicaciones (API) de acceso de datos independiente que se usa para OLE DB y ODBC. Combina el proveedor OLE DB de SQL y el controlador ODBC de SQL en una misma biblioteca de vínculos dinámicos (DLL) nativa, mientras que también proporciona nuevas funciones que son independientes y distintivas de Microsoft Data Access Components (MDAC). Puede usar SQL Native Client para crear nuevas aplicaciones o para mejorar aplicaciones existentes que pueden aprovechar las características más nuevas de SQL Server, como Conjuntos de resultados activos múltiples (MARS), Tipos definidos por el usuario (UDT) y compatibilidad con el tipo de datos XML.

  • La función RDTR Recupera datos en tiempo real desde un programa compatible con automatización COM.. El complemento de automatización COM de RTD debe creado y registrado en un equipo local.

  • La instrucción SQL. Función de la solicitud se conecta con un origen de datos externo y ejecuta una consulta desde una hoja de cálculo. La instrucción SQL. Función de la solicitud, a continuación, devuelve el resultado como una matriz sin necesidad de programar una macro. Si esta función no está disponible, debe instalar el programa de complemento de ODBC de Microsoft Excel (XLODBC. XLA). Puede instalar el complemento de Office.com.

Para obtener más información acerca de cómo crear Visual Basic para Aplicaciones, vea la Ayuda de Visual Basic.

Volver al principio

Mejorar la seguridad del acceso a datos

Cuando se conecta a un origen de datos externo o actualiza los datos, es importante ser consciente de los posibles problemas de seguridad y saber qué puede hacer para resolverlos. Use las siguientes directrices y procedimientos recomendados para que le ayuden a proteger sus datos.

Volver al principio

Almacenar las conexiones de datos en una ubicación de confianza

Un archivo de conexión de datos contiene a menudo una o varias consultas que se usan para actualizar datos externos. Al reemplazar este archivo, un usuario malintencionado puede diseñar una consulta para obtener acceso a información confidencial y distribuirla a otros usuarios o realizar otras acciones dañinas. Por lo tanto, es importante asegurarse de que:

  • El archivo de conexión fue creado por una persona de confianza.

  • El archivo de conexión es seguro y procede de una ubicación de confianza.

Para ayudar a mejorar la seguridad, es posible que desee deshabilitar las conexiones a datos externos en el equipo. Para conectarse a datos al abrir un libro, debe activar las conexiones de datos utilizando la barra Centro de confianza o colocando el libro en una ubicación de confianza. Para obtener más información, vea los vínculos de la sección Vea también.

Volver al principio

Usar credenciales de forma segura

Normalmente, para obtener acceso a un origen de datos externo, se necesitan credenciales (como un nombre de usuario y una contraseña) que se utilizan para autenticar al usuario. Asegúrese de obtener estas credenciales de forma segura y de no revelarlas inadvertidamente a otros usuarios.

Importante: Use contraseñas seguras que combinen mayúsculas y minúsculas, números y símbolos. Las contraseñas no mezclan estos elementos. Contraseña segura: Y6dh! et5. Contraseñas: House27. Las contraseñas deben tener 8 o más caracteres de longitud. Es mejor una frase que utiliza 14 o más caracteres. Es importante recordar la contraseña. Si olvida su contraseña, Microsoft no podrá recuperarlo. Almacenar las contraseñas que anote en un lugar seguro fuera de la información que le ayudan a proteger.

Evite guardar la información de inicio de sesión al conectarse a los orígenes de datos. Puede que esta información se almacene como texto simple en el libro y el archivo de conexión, por lo que un usuario malintencionado puede obtener acceso a la información y poner en peligro la seguridad del origen de datos.

Siempre que sea posible, use la autenticación de Windows (también denominada conexión de confianza), que emplea una cuenta de usuario de Windows para la conexión con SQL Server. Cuando un usuario se conecta a través de una cuenta de Windows, SQL Server usa información del sistema operativo Windows para validar el nombre y la contraseña de la cuenta. Para poder usar la autenticación de Windows, un administrador de servidor deberá configurar primero SQL Server para usar este modo de autenticación. Si no estuviera disponible la autenticación de Windows, procure no almacenar la información de inicio de sesión de los usuarios en un libro o archivo de conexión: es mucho más seguro para ellos escribir sus propios datos cada vez que inician una sesión.

Volver al principio

Publicar en Servicios de Excel de forma segura

Al conectarse a un origen de datos, puede usar el cuadro de diálogo Configuración de autenticación de los Servicios de Excel para elegir un método de autenticación al acceder al origen de datos en Servicios de Excel. Puede seleccionar una de las siguientes opciones para iniciar una sesión en el origen de datos:

  • Autenticación de Windows    Seleccione esta opción para utilizar el nombre de usuario y la contraseña de Windows del usuario actual. Este es el método más seguro, pero puede influir en el rendimiento si hay muchos usuarios.

  • SSS    Seleccione esta opción para usar el servicio de almacenamiento seguro y, a continuación, escriba la cadena de identificación apropiada en el cuadro de texto ID. Un administrador del sitio puede configurar un sitio de SharePoint para usar una base de datos de servicio de almacenamiento seguro donde se pueden almacenar un nombre de usuario y contraseña. Este método puede ser más eficaz cuando hay muchos usuarios.

  • Ninguno    Seleccione esta opción para guardar el nombre de usuario y contraseña en el archivo de conexión.

Nota: La configuración de autenticación solo se usa con Servicios de Excel, con Microsoft Excel no se usa. Si desea asegurarse de que tiene acceso a los mismos datos cuando abre el libro en Excel o con Servicios de Excel, compruebe que la configuración de autenticación es la misma en Excel.

Para mejorar la seguridad de las conexiones, utilice una biblioteca de conexiones de datos (DCL). Una DCL es una biblioteca de documentos de SharePoint especial que se puede definir como una biblioteca de ubicación de confianza y que hace que sea fácil almacenar, proteger, compartir y administrar archivos ODC. Por ejemplo, un administrador necesite mover una base de datos de un servidor de prueba a un servidor de producción o actualizar una consulta que tiene acceso a los datos. Mediante un archivo ODC guardado en una DCL, la administración de esta información de conexión es mucho más fácil y acceso de los usuarios a los datos sea más adecuado, ya que todos los libros utilizan el mismo archivo de conexión y una operación de actualización (ya sea en el equipo cliente o servidor) Obtiene los cambios actualizados a ese archivo de conexión. Incluso puede configurar SharePoint Server y equipo cliente del usuario para detectar automáticamente los cambios en la conexión de archivo y, a continuación, usar la versión más actualizada de ese archivo de conexión. Para obtener más información, vea Microsoft SharePoint Foundation 2010 ayuda de Administración Central.

Volver al principio

Problemas acerca de la conexión a datos

En las siguientes secciones se describen varios problemas que puede encontrar al conectarse a datos externos

Volver al principio

Problema: Cuando intento importar datos, me quedo sin espacio en el disco.

Si cuando se conecta a datos externos se queda sin espacio en el disco, considere la posibilidad de realizar lo siguiente:

Verificación y aumente disponible espacio en disco    Para liberar espacio en el disco duro, intente vaciar la Papelera de reciclaje, la copia de seguridad de los archivos innecesarios y luego se quita de su disco duro o quitar componentes de Windows que no se usan. Para obtener más información sobre cómo liberar espacio de disco duro, consulte la Ayuda de Windows.

Estrategias que puede probar cuando el espacio es limitado    Si tiene sólo una cantidad limitada de espacio disponible en el disco duro, pruebe lo siguiente:

Microsoft Query    Siga uno o varios de estos procedimientos:

  • Simplifique la consulta    Asegúrese de que incluye únicamente las tablas y campos que son necesarios para la consulta. Si la consulta contiene tablas o campos innecesarios, elimínelos de la consulta para reducir el tamaño del archivo de consulta temporal.

  • Configurar el uso de criterios para reducir el tamaño del resultado    Usar criterios para recuperar solo los registros específicos en lugar de recuperar todos los registros de una base de datos. Para obtener más información, consulte la Ayuda de Microsoft Query.

  • Establecer un límite del número de registros devueltos por la consulta    Limitar el número de la consulta devuelve los registros. En Microsoft Query, haga clic en Opciones en el menú Edición, seleccione la casilla de verificación limitar el número de registros devueltos a en configuración de usuario y, a continuación, escriba el número máximo de registros que se devolverán en el cuadro de registros.

Asistente para la conexión de datos    Aunque no puede limitar los datos mediante el Asistente para la conexión de datos, es posible que pueda limitar los datos del origen de datos al definir una consulta en el origen de datos. Si no tiene la capacidad de o permiso para definir una consulta en el origen de datos, póngase en contacto con el Administrador de datos.

Volver al principio

Problema: ¿Dónde está el Asistente para cubos OLAP?

El Asistente para cubos OLAP de Microsoft Query, que creaba cubos OLAP a partir de una base de datos Jet, ya no está disponible en Excel.

Volver al principio

Problema: ¿Qué ha ocurrido con los servicios de recuperación de datos?

Presentados con Microsoft Office 2003, los servicios de recuperación de datos usan un archivo de conexión de datos universal (UDC) (.udcx) para obtener acceso a servicios web y consultar diferentes orígenes de datos.

En el Asistente de conexión de datos en la página del Asistente para la conexión de datos, puede seleccionar las opciones de origen de datos de Microsoft Business Solutions o Servicios de recuperación de datos. La opción de Servicios de recuperación de datos, puede elegir dos servicios de recuperación de datos: listas de Windows SharePoint Services, que recupera datos de listas y bibliotecas de documentos en un servidor que ejecuta SharePoint Foundation y Microsoft SQL Server, que recupera datos de Microsoft SQL Server 2000 o posterior.

Aunque el Asistente para la conexión de datos ya no admite la edición de archivos de conexión UDC, Excel sigue admitiendo conexiones de servicios de recuperación de datos existentes y aún puede actualizar estas conexiones.

Volver al principio

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×