Importar o vincular a datos en una base de datos de SQL Server

Importar o vincular a datos en una base de datos de SQL Server

Nota: Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Puede vincular o importar datos desde una base de datos SQL, que es una base de datos administrada de alto rendimiento usada para aplicaciones críticas. Para obtener más información, vea SQL Server 2016.

  • Al vincular a datos, Access crea una conexión bidireccional que sincroniza los cambios de los datos en Access y en la base de datos SQL.

  • Al importar datos, Access crea una copia única de los datos y, por lo tanto, los cambios de los datos (ya sea en Access o en la base de datos SQL) no se sincronizan.

Información general sobre cómo conectar Access a SQL Server

Antes de empezar

¿Quiere facilitar el proceso? Realice las preparaciones siguientes antes de vincular a datos o importar datos:

  • Busque el nombre del servidor de la base de datos de SQL Server, identifique la información de conexión necesaria y seleccione un método de autenticación (Windows o SQL Server). Para obtener más información sobre los métodos de autenticación, vea Conectar a un servidor (motor de base de datos) y Proteger la base de datos.

  • Identifique las tablas o vistas que quiera vincular o importar, así como los campos con valores únicos de las tablas vinculadas. Puede vincular o importar más de una tabla o vista en una misma operación.

  • Tenga en cuenta el número de columnas de cada tabla o vista. Access no admite más de 255 campos en una tabla, por lo que solo vinculará o importará las primeras 255 columnas. Como solución alternativa, puede crear una vista en la base de datos de SQL Server para obtener acceso a las columnas que superen este límite.

  • Determine la cantidad total de datos que se importarán. El tamaño máximo de una base de datos de Access es de 2 GB, menos el espacio necesario para los objetos del sistema. Si la base de datos de SQL Server contiene tablas de gran tamaño, es posible que no pueda importarlas todas en una única base de datos de Access. En ese caso, puede vincular los datos, en lugar de importarlos.

  • Proteja la base de datos de Access y la información de conexión que contenga con una ubicación de confianza y una contraseña de la base de datos de Access. Esto es especialmente importante si guarda la contraseña de SQL Server en Access.

  • Planee con antelación si quiere crear relaciones adicionales. Access no crea automáticamente relaciones entre tablas relacionadas al finalizar una operación de importación. Puede crear de forma manual las relaciones entre tablas nuevas y existentes con la ventana Relaciones. Para obtener más información, vea ¿Qué es la ventana Relaciones? y Crear, editar o eliminar una relación.

Fase 1: Introducción

  1. Seleccione Datos externos > Nuevo origen de datos > Desde una base de datos > Desde SQL Server.

  2. En el cuadro de diálogo Obtener datos externos: Base de datos ODBC, siga uno de estos procedimientos:

    • Para importar datos, seleccione Importar el origen de datos en una nueva tabla de la base de datos actual.

    • Para vincular a datos, seleccione Vincular el origen de datos creando una tabla vinculada.

  3. Seleccione Aceptar.

Fase 2: Crear o reutilizar un archivo DSN

Puede crear un archivo DSN o reutilizar uno existente. Use un archivo DSN si quiere usar la misma información de conexión para diferentes operaciones de vinculación e importación, o bien para compartirla con otra aplicación que también use archivos DSN. Puede crear un archivo DSN directamente con el Administrador de conexiones de datos. Para obtener más información, vea Administrar orígenes de datos ODBC.

Aunque puede seguir usando versiones anteriores del controlador ODBC de SQL, le recomendamos que use la versión 13.1, ya que contiene un gran número de mejoras y es compatible con nuevas características de SQL Server 2016. Para obtener más información, vea Microsoft ODBC Driver para SQL Server en Windows.

  1. Siga uno de estos procedimientos:

    • Si el archivo DSN que quiere usar ya existe, selecciónelo de la lista.

      Cuadro de diálogo Seleccionar origen de datos

      Según el método de autenticación que especificó en la información de conexión, puede que necesite volver a escribir una contraseña.

    • Para crear un archivo DSN:

      1. Elija Nueva.

        Cuadro de diálogo Crear origen de datos
      2. Seleccione Controlador ODBC 13 para SQL Server y, después, haga clic en Siguiente.

      3. Escriba un nombre para el archivo DSN, o bien haga clic en Examinar para crear el archivo en otra ubicación.

  2. Haga clic en Siguiente para revisar la información de resumen y, después, haga clic en Finalizar.

Fase 3: Usar el Asistente para crear un origen de datos para SQL Server

En el Asistente para crear un origen de datos para SQL Server, siga este procedimiento:

  1. En la primera página, escriba la información de identificación:

    • En el cuadro Descripción puede escribir información adicional sobre el archivo DSN.

    • En el cuadro Servidor, escriba el nombre de la base de datos de SQL Server. No haga clic en la flecha abajo.

  2. En la segunda página, seleccione uno de los siguientes métodos de autenticación:

    • Con autenticación integrada de Windows    Permite conectarse con una cuenta de usuario de Windows. De forma opcional, puede escribir un nombre de entidad de seguridad de servicio (SPN). Para obtener más información, vea Nombres de entidad de seguridad de servicio (SPN) en Conexiones de cliente (ODBC).

    • Con autenticación de SQL Server…    Permite conectarse con credenciales configuradas en la base de datos si especifica el id. de inicio de sesión y la contraseña.

  3. En las páginas 3 y 4 puede seleccionar distintas opciones para personalizar la conexión. Para obtener más información sobre estas opciones, vea Microsoft ODBC Driver para SQL Server.

  4. Se mostrará una pantalla para que confirme la configuración. Seleccione Probar origen de datos para confirmar la conexión.

  5. Puede que necesite iniciar sesión en la base de datos. En el cuadro de diálogo Inicio de sesión de SQL Server, escriba el id. de inicio de sesión y la contraseña. Para cambiar otras opciones de configuración, seleccione Opciones.

Fase 4: Seleccionar tablas para vincularlas o importarlas

  1. En el cuadro de diálogo Vincular tablas o Importar objetos, en Tablas, seleccione las tablas o vistas que quiera vincular o importar y, después, haga clic en Aceptar.

    Listas de tablas para vincular o importar
  2. En una operación de vinculación, decida si quiere seleccionar la opción Guardar contraseña.

    Seguridad    Al seleccionar esta opción, ya no tendrá que escribir las credenciales cada vez que abra Access y obtenga acceso a los datos. Pero se almacenará una contraseña no cifrada en la base de datos de Access, lo que significa que los usuarios que tengan acceso al contenido de origen podrán ver el nombre de usuario y la contraseña. Si selecciona esta opción, es muy recomendable que almacene la base de datos de Access en una ubicación de confianza y que cree una contraseña para la base de datos de Access. Para obtener más información, vea Decidir si se confía en una base de datos y Cifrar una base de datos con una contraseña de base de datos.

Fase 5: Crear especificaciones y tareas (solo importación)

Resultados

Cuando se complete una operación de vinculación o importación, las tablas aparecerán en el panel de navegación con el mismo nombre que la tabla o vista de SQL Server combinado con el nombre del propietario. Por ejemplo, si el nombre SQL es dbo.Product, el nombre de Access será dbo_Product. Si el nombre ya está en uso, Access anexará “1” al nuevo nombre de tabla (por ejemplo, dbo_Product1). Si dbo_Product1 ya está en uso, Access creará dbo_Product2, etc. Pero puede cambiar los nombres de las tablas para que sean más significativos.

En una operación de importación, Access nunca sobrescribe una tabla en la base de datos. Aunque no se pueden anexar directamente datos de SQL Server en una tabla existente, puede crear una consulta de datos anexados para anexar ratos después de importar datos desde tablas similares.

En una operación de vinculación, si las columnas son de solo lectura en una tabla de SQL Server, también serán de solo lectura en Access.

Sugerencia    Para ver la cadena de conexión, mantenga el mouse sobre la tabla en el panel de navegación de Access.

Actualizar el diseño de una tabla vinculada

No se pueden agregar, eliminar ni modificar columnas, ni tampoco se pueden cambiar los tipos de datos de una tabla vinculada. Si quiere cambiar el diseño, tendrá que hacerlo en la base de datos de SQL Server. Para ver los cambios de diseño en Access, actualice las tablas vinculadas:

  1. Seleccione Datos externos > Administrador de tablas vinculadas.

  2. Seleccione las tablas vinculadas que quiera actualizar, haga clic en Aceptar y, después, en Cerrar.

Comparar tipos de datos

Los tipos de datos de Access tienen nombres distintos de los tipos de datos de SQL Server. Por ejemplo, una columna de SQL Server del tipo de datos bit se importa o se vincula en Access con el tipo de datos Sí/No. En la tabla siguiente se comparan los tipos de datos de SQL Server y Access.

Tipos de datos de SQL Server

Tipos de datos de Access

Tamaño de campo de Access

bigint

Número grande

Vea Usar el tipo de datos Número grande.

binary (tamaño de campo)

Binario

Igual que el tamaño de campo de SQL Server.

bit

Sí/no

char (tamaño de campo), donde el tamaño de campo es menor o igual que 255.

Texto

Igual que el tamaño de campo de SQL Server.

char (tamaño de campo), donde el tamaño de campo es mayor que 255.

Memo

datetime

Fecha y hora

decimal (precision, scale)

Número

Decimal (las propiedades Precision y Scale de Access coinciden con Precision y Scale de SQL Server).

float

Número

Doble

image

Objeto OLE

int

Número

Entero largo

money

Moneda

nchar (tamaño de campo), donde el tamaño de campo es menor o igual que 255.

Texto

Igual que el tamaño de campo de SQL Server.

nchar (tamaño de campo), donde el tamaño de campo es mayor que 255.

Memo

ntext

Memo

numeric (precision, scale)

Número

Decimal (las propiedades Precision y Scale de Access coinciden con Precision y Scale de SQL Server).

nvarchar (tamaño de campo), donde el tamaño de campo es menor o igual que 255.

Texto

Igual que el tamaño de campo de SQL Server.

nvarchar (tamaño de campo), donde el tamaño de campo es mayor que 255.

Memo

nvarchar(MAX)

Memo

real

Número

Único

smalldatetime

Fecha y hora

smallint

Número

Entero

smallmoney

Moneda

sql_variant

Texto

255

text

Memo

marca de tiempo

Binario

8

tinyint

Número

Byte

uniqueidentifier

Número

Id. de replicación

varbinary

Binario

Igual que el tamaño de campo de SQL Server.

varbinary (MAX)

Objeto OLE

varchar (tamaño de campo), donde el tamaño de campo es menor o igual que 255.

Texto

Igual que el tamaño de campo de SQL Server.

varchar (tamaño de campo), donde el tamaño de campo es mayor que 255.

Memo

varchar(MAX)

Memo

xml

Memo

Puede trabajar con datos almacenados en SQL Server ya sea conectándose a SQL Server o importando los datos a una base de datos de Access. La vinculación es la mejor opción si comparte los datos con otras personas, porque los datos están almacenados en una ubicación centralizada y puede visualizar los datos más actuales, agregar o editar datos, así como ejecutar consultas o informes en Access.

Paso 1: Preparación para la vinculación

  1. Busque la base de datos de SQL Server a la que desee vincular. Si es necesario, póngase en contacto con el administrador de la base de datos para obtener información de conexión.

  2. Identifique las tablas y vistas a las que vinculará en la base de datos de SQL. Puede vincular a varios objetos al mismo tiempo.

Revise los datos de origen teniendo en cuenta lo siguiente:

  • Access admite hasta 255 campos (columnas) en una tabla, por lo que la tabla vinculada contendrá únicamente los primeros 255 campos del objeto al que vincule.

  • Las columnas que son de solo lectura en una tabla de SQL Server también lo serán en Access.

  1. Para crear la tabla vinculada en una base de datos nueva: haga clic en Archivo > Nuevo > Base de datos del escritorio en blanco. Para crear las tablas vinculadas en una base de datos de Access existente, asegúrese de que dispone de los permisos necesarios para agregar datos a la base de datos.

    Nota:  Una tabla vinculada creada en una base de datos de Access existente, recibe el mismo nombre que el objeto de origen. Así, si usted ya dispone de otra tabla con el mismo nombre, al nombre de la nueva tabla vinculada se le agrega un “1” , por ejemplo, Contactos1. (Si Contactos1 ya se está utilizando, Access creará Contactos2, y así sucesivamente.)

Paso 2: Vinculación a los datos

Al vincular a una tabla o vista de una base de datos de SQL Server, Access crea una nueva tabla (conocida como tabla vinculada) que refleja la estructura y el contenido de la tabla de origen. Puede cambiar los datos en SQL Server o en la vista Hoja de datos o Formulario de Access y los cambios se reflejarán tanto en SQL como en Access. Todos los cambios estructurales a las tablas vinculadas, como quitar o modificar columnas, se deben hacer desde SQL Server y no desde Access.

  1. Abra la base de datos de destino de Access.

  2. En la pestaña Datos externos, haga clic en Base de datos ODBC.

  3. Haga clic en Vincular al origen de datos creando una tabla vinculada > Aceptar y siga los pasos del asistente. Si el archivo .dsn que desea usar ya existe, selecciónelo en la lista del cuadro Seleccionar origen de datos.

    Para crear un nuevo archivo .dsn:

    En el cuadro Seleccionar origen de datos, haga clic en Nuevo > SQL Server > Siguiente.

    1. Escriba un nombre para el archivo .dsn, o bien haga clic en Examinar.

      Nota: Necesita permisos de escritura en la carpeta para poder guardar el archivo .dsn.

    2. Haga clic en Siguiente para revisar la información de resumen y, después, haga clic en Finalizar.

      Siga los pasos del Asistente para crear un nuevo origen de datos para SQL Server.

  4. Haga clic en Aceptar y, en Tablas, haga clic en cada tabla o vista a la que desee vincular y, a continuación, haga clic en Aceptar.

Si le aparece Seleccionar identificador de registro único, significa que Access no ha podido determinar qué campo o campos identifican de forma exclusiva cada fila de los datos de origen. En tal caso, seleccione el campo o la combinación de campos que son exclusivos para cada fila y, si no está seguro, consulte al administrador de la base de datos de SQL Server.

Cuando la operación de vinculación haya terminado, mostrará la nueva tabla o tablas vinculadas en el panel de navegación.

Aplicar la estructura más reciente del objeto de SQL Server

Cuando abra una tabla vinculada o el objeto de origen, verá que contiene los datos más recientes. No obstante, si realiza cambios estructurales en un objeto de SQL Server, tendrá que actualizar las tablas vinculadas para poder ver dichos cambios.

  1. Haga clic con el botón secundario en la tabla en el panel de navegación y, a continuación, haga clic en Administrador de tablas vinculadas en el menú contextual.

  2. Active la casilla situada junto a cada tabla vinculada que desea actualizar o bien, haga clic en Seleccionar todo para seleccionar todas las tablas vinculadas.

  3. Haga clic en Aceptar > Cerrar.

Nota: Como los tipos de datos de Access son distintos a los tipos de datos de SQL Server, Access vincula el tipo de datos más adecuados para cada columna. Usted solo puede revisar, pero no cambiar los tipos de datos asignados en Access.

Para obtener más información, consulte las formas de compartir una base de datos de escritorio de Access.

Principio de página

Si su departamento o grupo de trabajo usa Microsoft SQL Server para almacenar datos, es posible que deba trabajar con algunos datos de SQL Server en Access.

Puede reunir datos de objetos de SQL Server (tablas o vistas) en Access de dos maneras: importándolos o vinculándolos. La diferencia entre los dos procesos es la siguiente:

  • Al importar los datos, Access crea una copia de los datos de SQL Server y cualquier cambio posterior realizado en los datos de la base de datos de Access no se refleja en la base de datos de SQL Server. Del mismo modo, cualquier cambio posterior realizado en la tabla o en la vista de SQL Server no se refleja en Access.

  • Al vincular a los datos de SQL Server, está conectando directamente con el origen de datos, por lo que cualquier cambio posterior realizado en los datos en Access se refleja en SQL Server y viceversa.

Este artículo describe cómo importar o vincular a datos de SQL Server.

Decidir si desea importar o vincular

Situaciones en las que es adecuado importar

Normalmente, se importan datos de SQL Server a una base de datos de Access por estas razones:

  • Para mover permanentemente los datos de SQL Server a una base de datos de Access porque ya no necesita los datos en la base de datos de SQL Server. Después de importar los datos en Access, puede eliminarlos de la base de datos de SQL Server.

  • Su departamento o grupo de trabajo usa Access, pero en ocasiones se hace referencia a datos adicionales de una base de datos de SQL Server que deben combinarse en una de sus bases de datos de Access.

Como la importación de datos de SQL Server crea una copia de los datos en su base de datos de Access, durante el proceso de importación, especifique las tablas o vistas que desea copiar.

Situaciones en las que es adecuado vincular

Normalmente, se vincula a datos de SQL Server por estas razones:

  • Para conectarse directamente a los datos de origen para poder ver y editar la información más reciente en la base de datos de SQL Server y en la de Access.

  • La base de datos de SQL Server contiene tablas de gran tamaño y es posible que no pueda importarlas todas en un único archivo .accdb. El tamaño máximo de una base de datos de Access es de 2 GB, menos el espacio necesario para los objetos del sistema.

  • Si desea ejecutar consultas y generar informes basados en datos de SQL Server sin realizar una copia de los datos, puede vincular a SQL Server.

  • Su departamento o grupo de trabajo usa Access para elaborar informes y realizar consultas y SQL Server para almacenar datos. Los equipos individuales pueden crean tablas y vistas de SQL Server para un almacenamiento centralizado, pero, con frecuencia, es preciso reunir estos datos en programas de escritorio con fines de agregación y elaboración de informes. En estos casos lo mejor es recurrir a la vinculación, porque así los usuarios tanto de la base de datos de SQL Server como de la base de datos de Access pueden agregar y actualizar datos, así como ver y usar siempre los datos más recientes.

  • Es un usuario de Access que ha empezado a usar SQL Server hace poco. Ha migrado algunas de sus bases de datos a SQL Server y la mayoría de las tablas de estas bases de datos son vinculadas. A partir de ahora, en lugar de crear tablas de Access, creará tablas y vistas en SQL Server y, después, las vinculará desde las bases de datos de Access.

  • Quiere seguir almacenando sus datos en SQL Server, pero también quiere trabajar con los datos más recientes en Access para realizar consultas e imprimir informes que ha diseñado en Access.

Principio de página

Importar datos desde SQL Server

Prepararse para importar

Durante la importación, Access crea una tabla y, a continuación, copia los datos de la base de datos de SQL Server en esa tabla. Al final de la importación, puede elegir guardar los detalles de la operación como una especificación.

Nota: Una especificación de importación le ayuda a repetir la operación de importación en el futuro sin tener que seguir cada vez los pasos del Asistente para importación.

  1. Busque la base de datos de SQL Server que contiene los datos que desea importar. Para obtener información de conexión, póngase en contacto con el administrador de la base de datos.

  2. Identifique las tablas o vistas que quiera importar. Puede importar varios objetos en una sola operación.

  3. Revise los datos de origen y tenga en cuenta las siguientes consideraciones:

    • Access no admite más de 255 campos en una tabla, por lo que solo importará las primeras 255 columnas.

    • El tamaño máximo de una base de datos de Access es de 2 GB, menos el espacio necesario para los objetos del sistema. Si la base de datos de SQL Server contiene tablas de gran tamaño, es posible que no pueda importarlas todas en un único archivo .accdb. En ese caso, puede vincular los datos a la base de datos de Access.

    • Access no crea relaciones automáticamente entre las tablas relacionadas cuando la importación finaliza, por lo que deberá crear las relaciones manualmente entre las tablas nuevas y existentes usando las opciones de la ventana Relaciones. Para mostrar la ventana Relaciones:

      • Haga clic en Herramientas de base de datos > Relaciones.

  4. Identifique la base de datos de Access en la que quiere importar los datos de SQL Server.

    Asegúrese de que dispone de los permisos necesarios para agregar datos a la base de datos de Access. Si no quiere almacenar los datos en ninguna de las bases de datos existentes, cree una base de datos en blanco.

  5. Revise las tablas en la base de datos de Access, si hay alguna.

    Durante la importación se crea una tabla con el mismo nombre que el objeto de SQL Server. Si dicho nombre ya está en uso, Access le anexa “1” al nuevo nombre de la tabla (por ejemplo, en el caso de Contactos1, si Contactos1 ya está en uso, Access creará Contactos2 y, así, sucesivamente).

    Nota: Access nunca sobrescribe una tabla de la base de datos como parte de la importación y no se pueden anexar los datos de SQL Server a una tabla existente.

Importar los datos

  1. Abra la base de datos de destino.

    En la pestaña Datos externos, en el grupo Importar y vincular, haga clic en Base de datos ODBC.

  2. Haga clic en Importar el origen de datos en una nueva tabla de la base de datos actual y luego haga clic en Aceptar.

  3. En el cuadro de diálogo Seleccionar origen de datos, si el archivo .dsn que desea usar ya existe, selecciónelo en la lista.

    Necesito crear un nuevo archivo .dsn

    Nota: Los pasos de este procedimiento pueden variar ligeramente dependiendo del software instalado en su equipo.

    1. Haga clic en Nuevo para crear un nuevo nombre de origen de datos (DSN).

      Se iniciará el Asistente para crear nuevo origen de datos.

    2. En el asistente, seleccione SQL Server en la lista de controladores y, a continuación, haga clic en Siguiente.

    3. Escriba un nombre para el archivo .dsn o haga clic en Examinar para guardar el archivo en otra ubicación.

      Nota: Debe disponer de permisos de escritura en la carpeta para poder guardar el archivo .dsn.

    4. Haga clic en Siguiente para revisar la información de resumen y, después, haga clic en Finalizar para completar el asistente.

      Aparecerá el cuadro de diálogo Crear un nuevo origen de datos para SQL Server.

    5. Escriba una descripción del origen de datos en el cuadro Descripción. Este paso es opcional.

    6. En ¿Con qué servidor SQL Server desea conectarse?, en el cuadro Servidor, escriba o seleccione el nombre del SQL Server al que desea conectarse y, a continuación, haga clic en Siguiente para continuar.

    7. Es posible que necesite solicitar información al administrador de la base de datos de SQL Server, por ejemplo, si usa autenticación de Microsoft Windows NT o de SQL Server. Haga clic en Siguiente para continuar.

    8. Si desea conectarse a una base de datos específica, asegúrese de que la casilla Establecer la siguiente base de datos como predeterminada está activada. A continuación, seleccione la base de datos con la que desea trabajar y, después, haga clic en Siguiente.

    9. Haga clic en Finalizar.

    10. Revise la información de resumen y haga clic en Probar origen de datos.

    11. Revise los resultados de prueba y, a continuación, haga clic en Aceptar para cerrar el cuadro de diálogo.

      Si la prueba se realizó correctamente, vuelva a hacer clic en Aceptar o haga clic en Cancelar para cambiar la configuración.

  4. Haga clic en Aceptar para cerrar el cuadro de diálogo Seleccionar origen de datos.

    Access mostrará el cuadro de diálogo Importar objetos.

  5. En Tablas, haga clic en cada tabla o vista a la que desee importar y, a continuación, haga clic en Aceptar.

  6. Si aparece el cuadro de diálogo Seleccionar identificador de registro único, Access no ha podido determinar qué campo o campos identifican de forma exclusiva cada fila de un objeto determinado. En tal caso, seleccione el campo o la combinación de campos que son exclusivos para cada fila y, a continuación, haga clic en Aceptar. Si no está seguro, consulte al administrador de la base de datos de SQL Server.

    Access importará los datos. Si tiene pensado repetir la importación más adelante, puede guardar los pasos de la operación como una especificación de importación y volver a ejecutar fácilmente los mismos pasos de importación más adelante. Es necesario que tenga Microsoft Office Outlook instalado en su equipo para crear una tarea.

  7. Haga clic en Cerrar en Guardar los pasos de la importación, en el cuadro de diálogo Obtener datos externos: Base de datos ODBC. Access finaliza la importación y muestra la nueva tabla o las tablas importadas en el panel de navegación.

Si desea guardar la importación como una tarea para volver a usarla, continúe con la siguiente sección.

Principio de página

Vincular a datos de SQL Server

Como los datos se almacenan en tablas, cuando vincula a una tabla o vista en una base de datos de SQL Server, Access crea una nueva tabla (a menudo conocida como una tabla vinculada) que refleja la estructura y el contenido del objeto de origen. Puede cambiar datos en SQL Server o en la vista Hoja de datos o en la vista Formulario desde Access. Los cambios que realice en los datos en una ubicación se reflejan en la otra. Sin embargo, si desea realizar cambios estructurales, como eliminar o cambiar una columna, debe hacerlo desde la base de datos de SQL Server o desde un proyecto de Access conectado a esa base de datos. No puede agregar, eliminar o cambiar campos en una tabla vinculada mientras trabaja en Access.

Prepararse para vincular

  1. Busque la base de datos de SQL Server que contiene los datos a los que desea vincular. Si es necesario, póngase en contacto con el administrador de la base de datos para obtener información de conexión.

  2. Identifique las tablas y vistas a las que desea vincular. Puede vincular a varios objetos en una sola vinculación.

  3. Revise los datos de origen y tenga en cuenta las siguientes consideraciones:

    • Access no admite más de 255 campos en una tabla, por lo que la tabla vinculada contendrá únicamente los primeros 255 campos del objeto al que vincule.

    • Las columnas que son de solo lectura en un objeto de SQL Server también lo serán en Access.

    • No podrá agregar, eliminar o modificar columnas en la tabla vinculada en Access.

  4. Identifique la base de datos de Access en la que desea crear las tablas vinculadas. Asegúrese de que dispone de los permisos necesarios para agregar datos a la base de datos. Si no desea almacenar los datos en ninguna de las bases de datos existentes, cree una en blanco; para ello, haga clic en la pestaña Archivo y, a continuación, en la pestaña Nuevo, haga clic en Base de datos en blanco.

  5. Revise las tablas de la base de datos de Access. Cuando se vincula a una tabla o vista de SQL Server, Access crea una tabla vinculada con el mismo nombre que el objeto de origen. Si dicho nombre ya está en uso, Access le anexará “1”, por ejemplo, Contactos1 (si Contactos1 también está en uso, Access creará Contactos2, etc.).

  6. Para establecer un vínculo a los datos, abra la base de datos de destino.

  7. En la pestaña Datos externos, en el grupo Importar y vincular, haga clic en Base de datos ODBC.

  8. Haga clic en Vincular al origen de datos creando una tabla vinculada y luego haga clic en Aceptar.

  9. En el cuadro de diálogo Seleccionar origen de datos, haga clic en el archivo .dsn que desea usar o haga clic en Nuevo para crear un nuevo nombre de origen de datos (DSN).

  10. En el cuadro de diálogo Seleccionar origen de datos, si el archivo .dsn que desea usar ya existe, selecciónelo en la lista.

    Necesito crear un nuevo archivo .dsn

    Nota: Los pasos de este procedimiento pueden variar ligeramente dependiendo del software instalado en su equipo.

    1. Haga clic en Nuevo para crear un nuevo nombre de origen de datos (DSN).

      Se iniciará el Asistente para crear nuevo origen de datos.

    2. En el asistente, seleccione SQL Server en la lista de controladores y, a continuación, haga clic en Siguiente.

    3. Escriba un nombre para el archivo .dsn o haga clic en Examinar para guardar el archivo en otra ubicación.

      Nota: Debe disponer de permisos de escritura en la carpeta para poder guardar el archivo .dsn.

    4. Haga clic en Siguiente para revisar la información de resumen y, después, haga clic en Finalizar para completar el Asistente para crear nuevo origen de datos.

      Se iniciará el Asistente para crear un nuevo origen de datos para SQL Server.

    5. En el asistente, escriba una descripción del origen de datos en el cuadro Descripción. Este paso es opcional.

    6. En ¿Con qué servidor SQL Server desea conectarse?, en el cuadro Servidor, escriba o seleccione el nombre del equipo de SQL Server al que desea conectarse y, a continuación, haga clic en Siguiente para continuar.

    7. En esta página del asistente, es posible que necesite solicitar información al administrador de la base de datos de SQL Server, por ejemplo, si usa autenticación de Windows NT o de SQL Server. Haga clic en Siguiente para continuar.

    8. En la siguiente página del asistente, es posible que necesite solicitar más información al administrador de la base de datos de SQL Server. Si desea conectarse a una base de datos específica, asegúrese de que la casilla Establecer la siguiente base de datos como predeterminada está activada, seleccione la base de datos de SQL Server con la que desee trabajar y, a continuación, haga clic en Siguiente.

    9. Haga clic en Finalizar. Revise la información de resumen y, después, haga clic en Probar origen de datos.

    10. Revise los resultados de prueba y, a continuación, haga clic en Aceptar para cerrar el cuadro de diálogo Prueba del origen de datos ODBC de SQL Server.

      Si la prueba se realizó correctamente, vuelva a hacer clic en Aceptar para completar el asistente o haga clic en Cancelar para volver al asistente y cambiar la configuración.

  11. Haga clic en Aceptar.

    Access muestra el cuadro de diálogo Vincular tablas.

  12. En Tablas, haga clic en cada tabla o vista a la que desee vincular y, a continuación, haga clic en Aceptar.

    1. Si aparece el cuadro de diálogo Seleccionar identificador de registro único, Access no ha podido determinar qué campo o campos identifican de forma exclusiva cada fila del origen de datos. En tal caso, seleccione el campo o la combinación de campos que son exclusivos para cada fila y, a continuación, haga clic en Aceptar. Si no está seguro, consulte al administrador de la base de datos de SQL Server.

Access finaliza la vinculación y muestra la nueva tabla o las tablas vinculadas en el panel de navegación.

Importante: Cada vez que abra una tabla vinculada o el objeto de origen, se mostrarán los datos más recientes. Sin embargo, los cambios estructurales realizados en un objeto de SQL Server no se reflejan automáticamente en una tabla vinculada.

Actualizar una tabla vinculada aplicando la estructura de objeto más reciente de SQL Server

  1. Haga clic con el botón secundario en la tabla en el panel de navegación y, a continuación, haga clic en Administrador de tablas vinculadas en el menú contextual.

  2. Active la casilla situada junto a cada tabla vinculada que desea actualizar o bien, haga clic en Seleccionar todo para seleccionar todas las tablas vinculadas.

  3. Haga clic en Aceptar.

    Si la actualización se realiza correctamente, Access muestra un mensaje notificándolo. En caso contrario, Access mostrará un mensaje de error.

  4. Haga clic en Cerrar para cerrar el Administrador de tablas vinculadas.

Principio de página

¿Qué más debo saber?

Principio de página

Cómo detecta Access los tipos de datos de SQL Server

Como los tipos de datos de Access difieren de los tipos de datos de SQL Server, Access debe determinar el tipo de datos de Access más apropiado para cada columna de cada tabla o vista de SQL Server que importa o a la que vincula. Por ejemplo, una columna de SQL Server del tipo de datos bit se importa o se vincula en Access con el tipo de datos Sí/No. Otro ejemplo es que una columna del tipo de datos de SQL Server nvarchar (255) (o menor) se importa o se vincula con el tipo de datos Texto, pero una columna del tipo de datos nvarchar (256) (o mayor) se importa como un campo Memo de Access. Después de completar una importación o una vinculación, puede abrir la tabla en la vista Diseño y confirmar qué tipos de datos ha asignado Access a sus campos. Puede cambiar los tipos de datos de los campos de las tablas importadas. Sin embargo, no puede cambiar los tipos de datos de los campos de tablas vinculadas, excepto si lo hace en la misma base de datos de SQL Server o en un proyecto de Access conectado a esa base de datos.

En la tabla siguiente se enumeran los tipos de datos principales de SQL Server. La segunda y la tercera columna muestran cómo interpreta Access cada tipo.

Tipo de datos de SQL Server

Tipo de datos de Access

Tamaño de campo de Access

bigint

Texto

255

binary ( tamaño de campo )

Binario

Igual que el tamaño de campo de SQL Server

bit

Sí/No

char ( tamaño de campo ), donde el tamaño de campo es menor o igual que 255

Texto

Igual que el tamaño de campo de SQL Server

char ( tamaño de campo ), donde el tamaño de campo es mayor que 255

Memo

datetime

Fecha y hora

decimal ( precision , scale )

Número

Decimal (las propiedades Precision y Scale de Access coinciden con Precision y Scale de SQL Server)

float

Número

Doble

image

Objeto OLE

int

Número

Entero largo

money

Moneda

nchar ( tamaño de campo ), donde el tamaño de campo es menor o igual que 255

Texto

Igual que el tamaño de campo de SQL Server

nchar ( tamaño de campo ), donde el tamaño de campo es mayor que 255

Memo

ntext

Memo

numeric ( precision , scale )

Número

Decimal (las propiedades Precision y Scale de Access coinciden con Precision y Scale de SQL Server)

nvarchar ( tamaño de campo ), donde el tamaño de campo es menor o igual que 255

Texto

Igual que el tamaño de campo de SQL Server

nvarchar ( tamaño de campo ), donde el tamaño de campo es mayor que 255

Memo

nvarchar (MAX)

Memo

real

Número

Único

smalldatetime

Fecha y hora

smallint

Número

Entero

smallmoney

Moneda

sql_variant

Texto

255

text

Memo

timestamp

Binario

8

tinyint

Número

Byte

uniqueidentifier

Número

Id. de replicación

varbinary

Binario

Igual que el tamaño de campo de SQL Server

varbinary(MAX)

Objeto OLE

varchar ( tamaño de campo ), donde el tamaño de campo es menor o igual que 255

Texto

Igual que el tamaño de campo de SQL Server

varchar ( tamaño de campo), donde el tamaño de campo es mayor que 255

Memo

varchar (MAX)

Memo

xml

Memo

Principio de página

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×