Importar o exportar archivos de texto (.txt o .csv)

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Hay dos formas de importar datos de un archivo de texto en Microsoft Excel: puede abrir el archivo de texto en Excel o puede importarlo como rango de datos externos. Para exportar datos de Excel a un archivo de texto, utilice el comando Guardar como.

Son dos los formatos de archivo de texto que se utilizan habitualmente:

  • Archivos de texto delimitados (.txt), en los que el carácter de tabulación (el código de carácter ASCII 009) separa normalmente cada campo de texto.

  • Archivos de texto de valores separados por comas (.csv), en los que el carácter de coma (,) suele separar cada campo de texto.

Puede cambiar el carácter separador que se utiliza tanto en los archivos de texto delimitados como en los .csv. Esto puede ser necesario para asegurarse de que la operación de importación o de exportación se realizará de la manera deseada.

Notas    

  • Puede importar o exportar hasta 1.048.576 filas y 16.384 columnas.

¿Qué desea hacer?

Importar un archivo de texto abriéndolo en Excel

Importar un archivo de texto conectándose a él

Exportar datos a un archivo de texto guardándolo

Cambiar el delimitador que se utiliza en un archivo de texto

Cambiar el separador de todos los archivos de texto .csv

Importar un archivo de texto abriéndolo en Excel

Un archivo de texto creado con otro programa se puede abrir en un libro de Excel con el comando Abrir. Abrir un archivo de texto en Excel no cambia el formato del archivo: puede verlo en la barra de título de Excel, donde el nombre del archivo conserva la extensión del nombre del archivo de texto (por ejemplo, .txt or .csv).

  1. Haga clic en la pestaña Archivo y, a continuación, haga clic en Abrir.

    Si usa Excel 2007, haga clic en el botón de Microsoft Office Imagen del botón de Microsoft Office y, a continuación, haga clic en Abrir.

  2. Seleccione Archivos de texto en el cuadro de diálogo Abrir.

  3. Busque el archivo de texto que desee abrir y haga doble clic en él.

    • Si el archivo es un archivo de texto (.txt), Excel inicia el Asistente para importación de texto. Cuando termine de realizar los pasos del Asistente, haga clic en Finalizar para completar la operación de importación.

    • Vea: Importar datos mediante el Asistente para importar texto para obtener más información sobre los delimitadores y opciones avanzadas.

    • Si el archivo es un archivo .csv, Excel abre automáticamente el archivo de texto y muestra los datos en un libro nuevo.

      Nota    Cuando Excel abre un archivo .csv, utiliza la configuración de formato de datos predeterminada para interpretar el modo en que debe importar cada columna de datos. Si desea una mayor flexibilidad a la hora de cambiar las columnas en diferentes formatos, puede utilizar el Asistente para importar texto. Por ejemplo, el formato de los datos de una columna de fechas del archivo .csv podría ser MDA, pero el formato de datos predeterminado de Excel es AMD, o pudiera ser que deseara convertir en texto una columna de números precedida de ceros para conservar dichos ceros. Para forzar a Excel a ejecutar el Asistente para importar texto, puede cambiar la extensión del archivo de .csv a .txt antes de abrirlo, o bien, puede Importar un archivo de texto conectándose a él.

Principio de página

Importar un archivo de texto conectándose a él

Puede importar datos de un archivo de texto en una hoja de cálculo existente como un rango de datos externos.

  1. Haga clic en la celda en la que desea poner los datos del archivo de texto.

  2. En la pestaña Datos, en el grupo Obtener datos externos, haga clic en Desde texto.

    Imagen de la cinta de Excel

  3. Busque el archivo de texto que desee importar y haga doble clic en él.

    Siga las instrucciones del Asistente para importación de texto. Haga clic en Ayuda Imagen de botón en cualquier página del Asistente para importación de texto para obtener más información sobre el uso del asistente. Cuando termine de realizar los pasos del Asistente, haga clic en Finalizar para completar la operación de importación.

  4. En el cuadro de diálogo Importar datos, haga lo siguiente:

    • Si lo desea, haga clic en Propiedades para definir las opciones de actualización, formato y diseño de los datos importados.

    • En ¿Dónde desea situar los datos?, siga uno de los procedimientos siguientes:

      • Para devolver los datos a la ubicación seleccionada, haga clic en Hoja de cálculo existente.

      • Para devolver los datos a la esquina superior izquierda de una nueva hoja de cálculo, haga clic en Hoja de cálculo nueva.

  5. Haga clic en Aceptar.

    Excel coloca el rango de datos externos en la ubicación especificada.

Si Excel no convierte una columna de datos al formato que desea, puede convertir los datos después de importarlos. Para obtener más información, vea los temas sobre cómo convertir números almacenados como texto en números y cómo convertir fechas almacenadas como texto en fechas.

Principio de página

Exportar datos a un archivo de texto guardándolo

Puede convertir una hoja de cálculo de Excel en un archivo de texto con el comando Guardar como.

  1. Haga clic en la pestaña Archivo y, a continuación, haga clic en Guardar como.

    • Se abrirá el cuadro de diálogo Guardar como.

  2. En el cuadro Guardar como tipo, elija el formato de archivo de texto para la hoja de cálculo.

    • Por ejemplo, haga clic en Texto (delimitado por tabulaciones) o CSV (delimitado por comas).

    • Nota: Cada formato admite conjuntos de características diferentes. Para obtener más información sobre los conjuntos de características admitidos por los diferentes formatos de archivo de texto, vea el tema sobre los formatos de archivo admitidos en Excel.

  3. Busque la ubicación en la que desee guardar el nuevo archivo de texto y, a continuación, haga clic en Guardar.

  4. Aparecerá un cuadro de diálogo en el que se informa de que sólo la hoja de cálculo actual se va a guardar en el nuevo archivo. Si está seguro de que la hoja de cálculo actual es la que desea guardar como archivo de texto, haga clic en Aceptar. Puede guardar otras hojas de cálculo como archivos de texto distintos repitiendo este procedimiento para cada hoja.

  5. Aparecerá un segundo cuadro de diálogo en el que se indica que la hoja de cálculo puede contener características no compatibles con los formatos de archivo de texto. Si sólo está interesado en guardar los datos de la hoja de cálculo en el nuevo archivo de texto, haga clic en . Si no está seguro y desea más información sobre las características de Excel incompatibles con los formatos de archivo de texto, haga clic en Ayuda para obtener información.

Para obtener más información sobre cómo guardar archivos en otros formatos, vea Guardar un libro con otro formato de archivo.

Principio de página

Cambiar el delimitador que se utiliza en un archivo de texto

Si usa el Asistente para importar texto para importar un archivo de texto, puede cambiar el delimitador usado por un archivo de texto delimitado de un carácter de tabulación a cualquier otro carácter en el paso 2 del Asistente para importar texto. En este paso, puede cambiar también el modo en que se tratan los delimitadores consecutivos, como las comillas consecutivas.

Vea: Importar datos mediante el Asistente para importar texto para obtener más información sobre los delimitadores y opciones avanzadas.

Principio de página

Cambiar el separador de todos los archivos de texto .csv

  1. En Microsoft Windows, haga clic en el botón Inicio y, a continuación, en Panel de control.

  2. Abra el cuadro de diálogo para cambiar la configuración regional y de idioma.

  3. Escriba un nuevo separador en el cuadro Separador de listas.

  4. Haga clic dos veces en Aceptar.

Nota    Una vez cambiado el carácter separador de listas del equipo, todos los programas utilizarán el nuevo carácter como separador de listas. Puede volver a cambiar el carácter al predeterminado utilizando el mismo procedimiento.

Principio de página

¿Tiene alguna pregunta específica acerca de la función?

Publique una pregunta en el foro de la comunidad de Excel

Ayúdenos a mejorar Excel

¿Tiene alguna sugerencia sobre cómo podemos mejorar la siguiente versión de Excel? Si es así, consulte los temas en User Voice de Excel

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Vea también

Información general sobre fórmulas en Excel

Evitar fórmulas erróneas

Detectar y corregir errores en las fórmulas

Atajos de teclado y teclas de función de Excel

Funciones de Excel (orden alfabético)

Funciones de Excel (por categoría)

Compartir Facebook Facebook Twitter Twitter Enviar por correo electrónico Enviar por correo electrónico

¿Le ha sido útil esta información?

De acuerdo. ¿Algún comentario más?

¿Cómo podemos mejorarlo?

¡Gracias por sus comentarios!

×