Importar las bases de datos de Access 2.0 y Access 95 a las versiones actuales

Importar las bases de datos de Access 2.0 y Access 95 a las versiones actuales

Si usa una base de datos existente en los formatos Access 2.0 (.mdb) o Access 95 (.mdb), en algunos casos será posible importar tablas, consultas y macros a una versión más reciente de Access, que usa el formato de archivo .accdb.

Para importar formularios e informes que contienen código VBA (y también módulos), primero convierta su base de datos de Access 2.0 o Access 95 al formato de Access 2002-2003 o Access 2000 con Microsoft Office Access 2003, Access 2002 o Access 2000. Puede usar una versión más actual como Access 2007 para convertir ese archivo en el formato de archivo .accdb que podrá abrir con Access 2010, Access 2013 o Access 2016.

Las siguientes secciones de este artículo explican cómo realizar estas tareas.

¿Usa Access 2010, Access 2013 o Access 2016?

Access 2007 fue la última versión que permitía abrir, importar, vincular o exportar a Access 2.0 y Access 95. Necesitará Access 2007 para poder exportar, importar o vincular datos de archivos de Access 1.0 y 2.0 (Red 2 o Jet 2) y las bases de datos de Access 95. En este caso, deberá usar Access 2007 como un paso intermedio para convertir una base de datos de Access 2.0 a una de estas versiones.

¿Qué desea hacer?

Abrir una base de datos de Access 2.0 en Access 2007

Importar datos de una base de datos de Access 2.0 a Access 2007

Importar datos de una base de datos de Access 95 a Access 2007

Convertir una base de datos de Access 2.0 o Access 95 con Access 2003, Access 2002 o Access 2000

Abrir una base de datos de Access 2.0 en Access 2007

Cuando se abre una base de datos de Access 2.0 en Access 2007, Access muestra un número de pasos que, al seguirlos, terminan con el mensaje Esta base de datos se guardó con el formato de archivo de Microsoft Access 2.0.

Esta base de datos se guardó en el formato de archivo Microsoft Access 2.0.

Puede importar tablas, consultas y macros de una base de datos de Access 2.0 a una base de datos de Access 2007 (.accdb). Para importar formularios, informes o módulos a una base de datos de Access 2007, debe convertir primero la base de datos con una versión anterior de Access y, después, abrirla con Access 2007 para convertirla al formato de archivo de Access 2007 .accdb. Consulte la sección Convertir una base de datos de Access 2.0 o Access 95 con Access 2003, Access 2002 o Access 2000 para obtener más información.

Importar datos de una base de datos de Access 2.0 a Access 2007

Al importar objetos desde otra base de datos, se crean copias de los objetos que se importan en la base de datos de destino. No se modifica el origen. Para importar datos desde una base de datos de Access 2.0 a Access 2007, primero debe abrir la base de datos a la que desea importar los datos. A continuación, utilice los comandos de la pestaña Datos externos para continuar con el proceso de importación, que incluye utilizar el Asistente para importar.

  1. Abra Access 2007, haga clic en el botón Microsoft Office y luego en Abrir.

  2. En el cuadro de diálogo Abrir, seleccione y abra la base de datos a la que desee importar las tablas, consultas o macros.

  3. En la pestaña Datos externos, en el grupo Importar, haga clic en Access.

  4. En el cuadro de texto Nombre de archivo del Asistente para obtener datos externos, escriba el nombre de la base de datos de origen o haga clic en Examinar para mostrar el cuadro de diálogo Abrir archivo y elija o escriba el nombre de la base de datos de origen.

  5. Haga clic en Importar tablas, consultas, formularios, informes, macros y módulos en la base de datos actual y, después, haga clic en Aceptar.

  6. En el cuadro de diálogo Importar objetos, haga clic en cada pestaña y seleccione los objetos que quiera. Recuerde que solo puede importar tablas, consultas y macros de una base de datos de Access 2.0 a Access 2007.

    Cuadro de diálogo Importar objetos

    Para cancelar el objeto seleccionado, haga clic de nuevo en el objeto.

  7. Haga clic en Opciones para especificar ajustes adicionales.

    En la siguiente tabla se describe cómo afecta cada opción a los resultados de la operación.

    Elemento

    Descripción

    Casilla Relaciones

    Importa las relaciones entre las tablas seleccionadas.

    Casilla Menús y barras de herramientas

    Importa todos los menús y barras de herramientas personalizados que existen en la base de datos de origen. Los menús y las barras de herramientas se muestran en una pestaña llamada Complementos.

    Casilla Especificaciones de importación/exportación

    Importa todas las especificaciones de importación y exportación guardadas que existen en la base de datos de origen.

    Casilla Grupos del panel de exploración

    Importa todos los grupos del panel de exploración personalizados que existen en la base de datos de origen.

    Botón Definición y datos

    Importa la estructura y los datos de todas las tablas seleccionadas.

    Botón Solo definición

    Importa solo los campos de las tablas seleccionadas. No se importan los registros de origen.

    Botón Como consultas

    Importa las consultas seleccionadas como consultas. En este caso, recuerde importar todas las tablas subyacentes junto con las consultas.

    Botón Como tablas

    Importa las consultas como tablas. En este caso, no es necesario importar las tablas subyacentes.

  8. Haga clic en Aceptar para finalizar la operación.

    Access copia los datos y muestra mensajes de error si se produce algún problema. Si la operación importa los datos correctamente, la última página del asistente le permite guardar los detalles de la operación como una especificación de importación para usarla en el futuro.

Importar datos de una base de datos de Access 95 a Access 2007

Para importar datos desde una base de datos de Access 95 a Access 2007, primero debe abrir la base de datos de Access 2007 a la que desea importar los datos. A continuación, utilice los comandos de la pestaña Datos externos, que utilizan el Asistente para importar.

Puede importar tablas, consultas y macros de una base de datos de Access 95 (.mdb) a una base de datos de Access 2007 (.accdb). También puede importar formularios e informes que no utilicen el código VBA. Para importar formularios e informes que contienen código VBA (y también módulos), primero convierta su base de datos de Access 95 al formato de Access 2002-2003 o Access 2000 con Microsoft Office Access 2003, Access 2002 o Access 2000 y, después, use Access 2007 para convertir ese archivo al formato de Access 2007 (.accdb).

  1. Abra Access 2007, haga clic en el botón Microsoft Office y luego en Abrir.

  2. En el cuadro de diálogo Abrir, seleccione y abra la base de datos a la que desee importar las tablas, consultas o macros.

  3. En la pestaña Datos externos, en el grupo Importar, haga clic en Access.

  4. En el cuadro Nombre de archivo del Asistente para obtener datos externos, escriba el nombre de la base de datos de origen o haga clic en Examinar para mostrar el cuadro de diálogo Abrir archivo y elija o escriba el nombre de la base de datos de origen.

  5. Haga clic en Importar tablas, consultas, formularios, informes, macros y módulos en la base de datos actual y, después, haga clic en Aceptar.

  6. En el cuadro de diálogo Importar objetos, haga clic en cada pestaña y seleccione los objetos que quiera importar.

    Para cancelar la selección de un objeto, haga clic de nuevo en él.

  7. Haga clic en Opciones para especificar ajustes adicionales. Esta configuración adicional aparecerá en grupos debajo de la lista de objetos.

  8. Haga clic en Aceptar para finalizar la operación.

    Access copia los datos y muestra mensajes de error si se produce algún problema. Si la operación importa los datos correctamente, la última página del asistente le permite guardar los detalles de la operación como una especificación de importación para usarla en el futuro.

Convertir una base de datos de Access 2.0 o Access 95 con Access 2003, Access 2002 o Access 2000

Puede convertir una base de datos de Access 2.0 a al formato de archivo Access 2000 o Access 2002-2003 con una de las versiones de Access listadas en la tabla siguiente, siempre y cuando haya adquirido esa versión de Access y se encuentre instalada en su equipo. Según la versión de Access, el convertidor de Access 2.0 debería estar ya instalado.

Versión

Convertidor de Access 2.0

Microsoft Office Access 2003

Esta versión requiere descargar e instalar el convertidor de Access 2.0 para Access 2003. Sin embargo, esta herramienta ya no está disponible en el Centro de descarga de Microsoft porque Access 2003 ya ha perdido el soporte técnico ampliado.

Microsoft Access 2002

Incluido en el producto.

Microsoft Access 2000

Incluido en el producto.

Debe convertir el archivo de Access 2.0 o Access 95 al formato de archivo .mdb de Access 2000 o Access 2002-2003. A continuación, puede usar Access 2007 para convertir el archivo resultante en el formato de archivo .accdb de Access 2007. Después, puede usar la base de datos en Access 2007 o abrirla en Access 2010, Access 2013 o Access 2016. Según la versión anterior de Access que posea, realice lo siguiente:

  1. Inicie Access 2000, Access 2002 o Access 2003.

  2. En el menú Archivo, haga clic en Abrir y, después, haga clic en el nombre del archivo de la base de datos de Access 95 que quiera convertir.

  3. En el menú Herramientas, haga clic en Utilidades de la base de datos, haga clic en Convertir base de datos y, después, haga clic en A formato de archivo de Access 2000.

  4. En el cuadro de diálogo Convertir la base de datos en , escriba el nombre del nuevo archivo y, después, haga clic en Guardar.

    Es posible que vea un mensaje informativo que le advierte de que no podrá usar la base de datos convertida en versiones anteriores de Access. Si aparece este mensaje, haga clic en Aceptar.

    El archivo se guarda en el formato de archivo de Access 2000.

  5. Inicie Access 2007.

  6. Haga clic en el botón Microsoft Office y luego en Abrir.

  7. En el cuadro de diálogo Abrir, seleccione y abra la base de datos convertida.

  8. Haga clic en el botón Microsoft Office y, después, en Convertir.

  9. En el cuadro de diálogo Guardar como, escriba un nombre para el archivo de Access 2007 o acepte el que se proporciona y luego haga clic en Guardar.

    El archivo se guarda en el formato de archivo .accdb de Access 2007.

Principio de página

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×