INDICE (función INDICE)

Descripción

Devuelve un valor o la referencia a un valor de una tabla o rango. La función INDICE presenta dos formas: matriz y de referencia.

Si desea

Vea

Devolver el valor de una celda concreta o de una matriz de celdas

Forma matricial

Devolver una referencia a celdas especificadas

Forma de referencia

Forma de matriz

Descripción

Devuelve el valor de un elemento de una tabla o matriz seleccionado por los índices de número de fila y de columna.

Use la forma matricial si el primer argumento de INDICE es una constante matricial.

Sintaxis

INDICE(matriz; núm_fila; [núm_columna])

La sintaxis de la función INDICE tiene los siguientes argumentos:

  • Matriz    Obligatorio. Es un rango de celdas o una constante de matriz.

    • Si matriz contiene solo una fila o columna, el argumento núm_fila o núm_columna correspondiente es opcional.

    • Si matriz tiene varias filas y columnas, y solo usa núm_fila o núm_columna, INDICE devuelve una matriz de dicha fila o columna completa.

  • Núm_fila    Obligatorio. Selecciona la fila de la matriz desde la cual devolverá un valor. Si omite núm_fila, se necesita el argumento núm_columna.

  • Núm_columna    Opcional. Selecciona la columna de la matriz desde la cual devolverá un valor. Si omite núm_columna, se necesita el argumento núm_fila.

Observaciones

  • Si usa los argumentos núm_fila y núm_columna, INDICE devuelve el valor de la celda donde se produce la intersección de los argumentos.

  • Si define núm_fila o núm_columna como 0 (cero), INDICE devuelve la matriz de valores de toda la columna o fila, respectivamente. Para usar valores devueltos como una matriz, escriba la función INDICE como una fórmula de matriz en un rango horizontal de celdas para una fila y en un rango vertical de celdas para una columna. Para escribir una fórmula de matriz, presione CTRL+MAYÚS+ENTRAR.

    Nota  En Excel Web App no puede crear fórmulas de matriz.

  • Los argumentos núm_fila y núm_columna deben indicar una celda incluida en matriz; de lo contrario, INDICE devuelve el valor de error #¡REF!.

Ejemplos

Ejemplo 1

Estos ejemplos usan la función INDICE para buscar el valor de la celda de intersección de una fila y una columna.

Copie los datos de ejemplo en la tabla siguiente y péguelos en la celda A1 de una hoja de cálculo nueva de Excel. Para que las fórmulas muestren los resultados, selecciónelas, presione F2 y luego ENTRAR. Si lo necesita, puede ajustar el ancho de las columnas para ver todos los datos.

Datos

Datos

Manzanas

Limones

Plátanos

Peras

Fórmula

Descripción

Resultado

'=INDICE(A2:B3,2,2)

Valor en la intersección de la segunda fila y la segunda columna del rango A2:B3.

=INDICE(A2:B3,2,2)

'=INDICE(A2:B3,2,1)

Valor en la intersección de la segunda fila y la primera columna del rango A2:B3.

=INDICE(A2:B3,2,1)

Ejemplo 2

Este ejemplo usa la función INDICE en una fórmula de matriz para buscar los valores de dos celdas especificadas en una matriz de 2x2.

Fórmula

Descripción

Resultado

'=INDICE({1,2;3,4},0,2)

Valor encontrado en la primera fila, segunda columna de la matriz. La matriz contiene 1 y 2 en la primera fila y 3 y 4 en la segunda fila.

=INDICE({1,2;3,4},0,2)

Valor encontrado en la segunda fila, segunda columna de la matriz (misma matriz que arriba).

=INDICE({1,2;3,4},0,2)

Nota  La fórmula de la celda C2 es una fórmula de matriz. Para que esta fórmula devuelva valores en las celdas C2 y C3, seleccione C2 y C3, presione F2 y, a continuación, presione CTRL+Mayús+Entrar. De lo contrario, solo se devolverá un valor en la celda C2.

Principio de página

Forma de referencia

Descripción

Devuelve la referencia de la celda ubicada en la intersección de una fila y de una columna determinadas. Si la referencia se compone de selecciones no adyacentes, puede elegir la selección donde buscar.

Sintaxis

INDEX(ref, núm_fila, [núm_columna], [núm_área])

La sintaxis de la función INDICE tiene los siguientes argumentos:

  • Ref    Obligatorio. Es una referencia a uno o varios rangos de celdas.

    • Si especifica un rango no adyacente como argumento ref, escríbalo entre paréntesis.

    • Si cada área del argumento ref contiene una sola fila o columna, los argumentos núm_fila o núm_columna serán opcionales respectivamente. Por ejemplo, use INDICE(ref,,núm_columna) para un argumento ref con una sola fila.

  • Núm_fila    Obligatorio. Es el número de la fila en el argumento ref desde la que se devolverá una referencia.

  • Núm_columna    Opcional. Es el número de la columna en el argumento ref desde la que se devolverá una referencia.

  • Núm_área    Opcional. Selecciona un rango en el argumento ref desde el cual se devolverá la intersección de núm_fila y núm_columna. La primera área seleccionada o especificada se numera con 1, la segunda con 2 y así sucesivamente. Si omite núm_área, INDICE usa el área 1.

Por ejemplo, si ref describe las celdas (A1:B4;D1:E4;G1:H4), entonces núm_área 1 es el rango A1:B4, núm_área 2 es el rango D1:E4 y núm_área 3 es el rango G1:H4.

Observaciones

  • Después de que ref y núm_área hayan seleccionado un rango determinado, núm_fila y núm_columna seleccionan una celda específica: núm_fila 1 es la primera fila del rango, núm_columna 1 es la primera columna y así sucesivamente. La referencia devuelta por INDICE es la intersección entre núm_fila y núm_columna.

  • Si define núm_fila o núm_columna como 0 (cero), INDICE devuelve la referencia de toda la fila o columna, según corresponda.

  • Núm_fila, núm_columna y núm_área deben dirigirse a una celda en ref, de lo contrario la función INDICE devuelve el valor de error #¡REF!. Si omite núm_fila y núm_columna, INDICE devuelve el área del argumento ref definido por núm_área.

  • El resultado de la función INDICE es una referencia y será interpretado como tal por otras fórmulas. El valor devuelto por la función INDICE se puede usar como una referencia o como un valor, dependiendo de la fórmula. Por ejemplo, la fórmula CELDA("ancho";INDICE(A1:B2,1,2)) es igual a CELDA("ancho",B1). La función CELDA usa el valor devuelto por INDICE como referencia a una celda. Por otra parte, una fórmula como 2*INDICE(A1:B2,1,2) traduce el valor devuelto por INDICE al número de la celda B1.

Nota  La función CELDA no está disponible en Excel Web App.

Ejemplos

Copie los datos de ejemplo de la tabla siguiente y péguelos en la celda A1 de una nueva hoja de Excel. Para que las fórmulas muestren sus resultados, selecciónelas, pulse F2 y, a continuación, la tecla Entrar. Si lo necesita, puede ajustar el ancho de las columnas para ver todos los datos.

Fruta

Precio

Recuento

Manzanas

0,69 $

(40)

Plátanos

0,34 $

38

Limones

0,55 $

15

Naranjas

0,25 $

25

Peras

0,59 $

40

Almendras

2,80 $

10

Anacardos

3,55 $

16

Cacahuetes

1,25 $

20

Nueces

1,75 $

12

Fórmula

Descripción

Resultado

=INDICE(A2:C6; 2; 3)

Intersección de la segunda fila y la tercera columna en el intervalo A2:C6, que es el contenido de la celda C3.

38

=INDICE((A1:C6; A8:C11); 2; 2; 2)

Intersección de la segunda fila y la segunda columna en la segunda área de A8:C11, que es el contenido de la celda B9.

3,55

=SUMA(INDICE(A1:C11; 0; 3; 1))

Suma de la tercera columna en la primera área del rango A1:C11, que es la suma de C1:C6.

216

=SUMA(B2:INDICE(A2:C6; 5; 2))

Suma del rango que comienza en B2 y termina en la intersección de la quinta fila y la segunda columna del rango A2:A6, que es la suma de B2:B6.

2,42

Principio de página

Se aplica a: Excel 2016 for Mac, Excel 2007, Excel 2016 Preview, Excel Starter, Excel 2010, Excel Online, Excel 2013, Excel for Mac 2011



¿Le ha sido útil esta información?

No

¿Cómo podemos mejorarlo?

255 caracteres restantes

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!

Recursos de soporte técnico

Cambiar idioma