Guía visual: Mostrar un dibujo de Visio conectado a datos en un elemento web de SharePoint

Si necesita presentar información detallada y profunda rápidamente a mucha gente, cree un diagrama en Visio como un elemento web de SharePoint que sirva de informe visual. Visio 2010 permite extraer datos de fuentes externas como Servicios de Excel, SQL Server, listas de SharePoint u otras bases de datos OLEDB o ODBC. Seguidamente, puede aplicar gráficos de datos a las formas de su dibujo para visualizar los datos externos, publicar el dibujo en un sitio de SharePoint y, entonces, utilizar un elemento web Visio Web Access para mostrar el diagrama en el sitio de SharePoint.

Esta opción es ideal para crear paneles personalizados para potentes soluciones de inteligencia empresarial. Las personas responsables de tomar las decisiones pueden ver una representación visual del rendimiento de la empresa de un solo vistazo y actuar en consonancia y con celeridad. Si desea más información sobre cómo usar SharePoint para actividades de inteligencia empresarial, consulte el artículo ¿Qué es Business Intelligence de SharePoint?

Descargar la guía visual

Su explorador no admite vídeo. Instale Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

En este artículo

Requisitos

Descargar la plantilla

Paso 1: Importar datos en un dibujo de Visio

Paso 2: Aplicar gráficos de datos a formas

Paso 3: Mostrar el diagrama en un elemento web de SharePoint

Opcional: Dar interactividad al elemento web de Visio Web Access

Requisitos

El elemento web de Visio Web Access es una característica de los Servicios de Visio, un servicio incluido en Microsoft SharePoint Server 2010. Para utilizar los Servicios de Visio, debe tener la Microsoft SharePoint Server 2010 Licencia de acceso de cliente Enterprise (ECAL) y los Servicios de Visio deben estar implementados y abastecidos.

Además, necesita tener Microsoft Visio Professional 2010 o Microsoft Visio Premium 2010 para guardar un diagrama en un sitio de SharePoint.

Si desea más información sobre qué debe hacer para habilitar los Servicios de Visio en un sitio de SharePoint, consulte Administración de Servicio de gráficos de Visio.

Principio de página

Descargar la plantilla

Puede descargar y utilizar la plantilla que aparece en el vídeo y la guía visual antes mencionada. La plantilla incluye datos y gráficos de datos de muestra en los ejemplos.

Descargar el diagrama y los datos de muestra

Principio de página

Paso 1: Importar datos en un dibujo de Visio

  1. En Visio, en la ficha Datos, en el grupo Datos externos, haga clic en Vincular datos a las formas.

En la primera página del Asistente para selector de datos, seleccione el origen de datos que desea utilizar.

Importante:  Los Servicios de Access no se pueden utilizar como origen de datos para un dibujo web de los Servicios de Visio. Algunos tipos de diagrama, como los diagramas dinámicos, no se pueden actualizar después de publicarlos en el sitio de SharePoint. Para garantizar los mejores resultados, asegúrese de que guarda el origen de datos en el mismo sitio de SharePoint que el elemento web de Servicios de Visio.

  1. Siga las instrucciones del Asistente para selector de datos.

  2. Después de hacer clic en Finalizar en la última página del Asistente para selector de datos, aparece la ventana Datos externos con los datos importados mostrados en una tabla.

  3. Para aplicar datos de un origen externo a una forma de un dibujo, arrastre una fila desde la ventana Datos externos hasta la forma.

Si desea más información sobre cómo importar datos a Visio desde un origen de datos externo, consulte Importar datos de Excel, SQL Server, sitios de SharePoint y otros orígenes externos.

Principio de página

Paso 2: Aplicar gráficos de datos a formas

Para crear un nuevo gráfico de datos, haga lo siguiente:

  1. En Visio, en la ficha Datos, en el grupo Mostrar datos, haga clic en Gráficos de datos y, después, seleccione Crear nuevo gráfico de datos.

  2. En el cuadro de diálogo Nuevo elemento, realice lo siguiente:

    1. En Mostrar, en la lista Campo de datos, haga clic en el campo Datos de formas que desee representar visualmente.

    2. También en Mostrar, en la lista Aparece como, seleccione el gráfico que mejor represente el campo de datos (Texto, Barra de datos, Conjunto de iconos o Color por valor.)

    3. También en Mostrar, en la lista Estilo, seleccione el estilo de gráfico que desee. (Si selecciona Color por valor como tipo de gráfico, será la lista Método de colorear.)

    4. En Detalles, personalice el gráfico que desee.

    5. Cuando termine de editar el elemento gráfico, haga clic en Aceptar.

  3. Repita el paso anterior hasta que haya creado un elemento para cada campo de datos de forma que desee mostrar.

Para aplicar un gráfico de datos a las formas del dibujo, realice lo siguiente:

  1. En la página de dibujo, seleccione la forma a la que desee aplicar el gráfico de datos.

Nota:  Para seleccionar varias formas en la página de dibujo, mantenga pulsada la tecla CTRL y, a continuación, seleccione cada una de las formas a las que desee aplicar el gráfico de datos.

  1. En la ficha Datos, en el grupo Mostrar datos, haga clic en Gráficos de datos y, a continuación, en Gráficos de datos disponibles, haga clic en el gráfico de datos que desee.

Si desea más información sobre cómo crear y aplicar gráficos de datos, consulte Mejorar los datos con gráficos de datos.

Principio de página

Paso 3: Mostrar el diagrama en un elemento web de SharePoint

  1. En la página del sitio de SharePoint al que desee agregar el elemento web, en la ficha Página, en el grupo Editar, haga clic en Editar.

  2. En Herramientas de edición, en la ficha Insertar, en el grupo Elementos web, haga clic en Elemento web y realice lo siguiente:

    1. En Categorías, haga clic en Datos profesionales.

    2. En Elementos web, haga clic en Visio Web Access.

    3. Haga clic en Agregar.

  3. En el elemento web Visio Web Access, haga clic en el vínculo para abrir el panel de herramientas.

  4. En el panel de herramientas, expanda Presentación de dibujo web y, a continuación, en el cuadro Dirección URL del dibujo web, desplácese hasta el dibujo web de Visio que desee mostrar.

Importante:  Antes de que pueda utilizar Visio Web Access para mostrar su diagrama en un elemento web, tiene que publicar el archivo Visio en el sitio de SharePoint como un dibujo web. Si desea más información sobre cómo publicar un dibujo web de Visio en un sitio de SharePoint, consulte Roadmap: Publish Visio drawings to a SharePoint site (Guía básica: Publicar dibujos de Visio en un sitio de SharePoint).

  1. En la parte inferior del panel de herramientas, haga clic en Aplicar y, a continuación, haga clic en Aceptar.

Si desea más información sobre cómo mostrar un dibujo web de Visio en un elemento web, consulte Ver un dibujo web de Visio en un elemento web.

Principio de página

Opcional: Dar interactividad al elemento web de Visio Web Access

Si sabe escribir ECMAScript, puede personalizar el elemento web de Visio Web Access para incluir superposiciones visuales que muestren información adicional sobre las formas del dibujo de Visio.

Si desea más información sobre cómo programar un elemento interactivo para un dibujo de Visio en una página de elementos web, consulte MSDN: Crear un dibujo mediante un mashup con ECMAScript en Visio 2010 para mostrar en SharePoint Server 2010.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×