Grabación de macros en Visio

Nota:  Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Crear una macro para automatizar procesos que realiza repetidamente o pasos. Los comandos para grabar una macro están en la ficha Programador.

Nota: Las macros pueden desencadenar las alertas de seguridad, ya que se pueden crear y utilizarse con fines malintencionados. Para obtener más información acerca de los riesgos de macros y qué puede hacer con una alerta de seguridad, vea Habilitar o deshabilitar macros en archivos de Office.

  1. En la pestaña Desarrollador, haga clic en Grabar macro. (Si no ve la pestaña Desarrollador, consulte "Mostrar la pestaña Desarrollador", más abajo.)

    Comandos de macros

  2. En el cuadro Nombre de la macro, escriba un nombre para la macro.

  3. En el cuadro Tecla de método abreviado, escriba una tecla de método abreviado que se puede usar con la tecla CTRL para ejecutar la macro.

  4. En el cuadro Guardar macro en, haga clic en el documento en el que desea guardar la macro.

  5. En el cuadro Descripción, escriba una descripción para la macro.

  6. Haga clic en Aceptar para iniciar la grabación de la macro.

  7. Realice las acciones que desea incluir en la macro. En la pestaña Desarrollador, use Pausar grabación si es necesario.

    Cuando grabe una macro, puede usar el ratón para hacer clic en los comandos y las opciones, y para trabajar con formas y objetos en los dibujos.

  8. Para detener la grabación de la macro, haga clic en Detener grabación, en la pestaña Desarrollador.

También puede pausar o reanudar la grabación de la macro mediante la barra de herramientas Grabación.

Para visualizar el código resultante, en el menú Herramientas, seleccione Macros, haga clic en Macros, haga clic en el nombre de la macro y, a continuación, en Edición.

Mostrar la pestaña Desarrollador

  1. Haga clic en la pestaña Archivo y, a continuación, en Opciones.

  2. Haga clic en Personalizar cinta de opciones.

  3. En Personalizar la cinta de opciones y Pestañas principales, active la casilla Desarrollador.

    La pestaña Desarrollador aparecerá al final de la cinta de opciones, en el lado opuesto de la pestaña Archivo.

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×