Función SI

Use la función SI, una de las funciones lógicas, para devolver un valor si una condición es verdadera y otro si es falsa.

Sintaxis

SI(prueba_lógica; [valor_si_verdadero]; [valor_si_falso])

Por ejemplo:

  • =SI(A2>B2,"Presupuesto excedido";"Correcto")

  • =SI(A4=500,B4-A4,"")

Nombre del argumento

Descripción

prueba_lógica    (requerido)

El valor que quiere probar.

valor_si_verdadero    (requerido)

El valor que desea devuelto si el resultado de prueba_lógica es VERDADERO.

valor_si_falso    (opcional)

El valor que desea devuelto si el resultado de prueba_lógica es FALSO.

Ejemplos

Copie los datos de ejemplo en la tabla siguiente y péguelos en la celda A1 de la nueva hoja de datos de Excel. Para ver la fórmula en una celda de fórmula, selecciónela y presione F2.

Gastos reales

Gastos previstos

1 500 $

900 $

500 $

900 $

500 $

925 $

=SI(A2>B2,"Presupuesto excedido";"Correcto")

Debido a que el gasto real de 1.500 $ (A2) ha superado el gasto previsto de 900 $ (B2), el resultado devuelto es Presupuesto excedido.

=SI(A2<B2,VERDADERO, SI(A3>B3,"Presupuesto excedido" ; "Correcto"))

La primera función SI es falsa. Por tanto, la segunda instrucción SI se calcula y, dado que también es falsa, el resultado devuelto es Correcto.

=SI(A4=500,B4-A4,"")

Dado que A4 es igual a 500, el gasto real de 500 $ se resta del gasto previsto de 925 $ y el resultado es cuánto se está por encima del presupuesto que, en este caso, es 425. Si A4 no fuera igual a 500, el resultado devuelto sería un texto en blanco ("").

=SI(A2<B2,VERDADERO, SI(A3>B3,"Presupuesto excedido" ; "Correcto"))

La primera función SI es falsa. Por tanto, la segunda instrucción SI se calcula y, dado que también es falsa, el resultado devuelto es Correcto.

Problemas comunes

Problema

Qué ha fallado

0 (cero) en la celda

No había argumento para valor_si_verdadero ni para valor_si_falso. Para que se devuelva un valor correcto, agregue texto de argumento a los dos argumentos, o agregue VERDADERO o FALSO al argumento.

#¿NOMBRE? en la celda

Normalmente, esto significa que la fórmula se ha escrito mal.

Prácticas recomendadas

Realice este procedimiento

¿Por qué?

Con una función SI dentro de otra SI.

Es posible anidar hasta 64 funciones SI, unas dentro de otras, para los argumentos valor_si_verdadero y valor_si_falso,para elaborar pruebas más complejas.

Utilizar SI con matrices.

Si cualquiera de los argumentos de la función SI es una matriz, cada elemento de la matriz se evaluará cuando se ejecute la instrucción SI. Aprenda cómo crear una fórmula de matriz.

Relacionado

Se aplica a: Excel for Mac 2011, Excel 2010, Excel 2016 for Mac, Excel Online, Excel Starter, Excel 2013, Excel 2016 Preview, Excel 2007



¿Le ha sido útil esta información?

No

¿Cómo podemos mejorarlo?

255 caracteres restantes

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!

Recursos de soporte técnico

Cambiar idioma