Función INDICE

Devuelve un valor o la referencia a un valor en una tabla o rango. La función INDICE presenta dos formas: matriz y de referencia.

Si desea

Vea

Devolver el valor de una celda concreta o de una matriz de celdas

Forma matricial

Devolver una referencia a celdas especificadas

Forma de referencia

Forma matricial

Devuelve el valor de un elemento de una tabla o matriz seleccionado por los índices de número de fila y de columna.

Use la forma matricial si el primer argumento de INDICE es una constante matricial.

INDICE(matriz;núm_fila;núm_columna)

Matriz     es un rango de celdas o una constante de matriz.

  • Si matriz contiene sólo una fila o columna, el argumento núm_fila o núm_columna correspondiente es opcional.

  • Si matriz tiene más de una fila y más de una columna y sólo utiliza núm_fila o núm_columna, INDICE devuelve una matriz con toda una fila o columna.

Núm_fila     selecciona, en el rango matriz, la fila desde la cual se devolverá un valor. Si se omite núm_fila, se requiere el argumento núm_columna.

Núm_columna     selecciona, en el rango matriz, la columna desde la cual se devolverá un valor. Si se omite núm_columna, se requiere el argumento núm_fila.

Observaciones

  • Si se utilizan los argumentos núm_fila y núm_columna, INDICE devuelve el valor de la celda donde se produce la intersección de los argumentos.

  • Si se define núm_fila o núm_columna como 0 (cero), INDICE devuelve la matriz de valores de toda la columna o fila, respectivamente. Para utilizar valores devueltos como una matriz, escriba la función INDICE como una matrizfórmula de matriz en un rango horizontal de celdas para una fila y en un rango vertical de celdas para una columna. Para especificar una fórmula de matriz, presione CTRL+MAYÚS+ENTRAR.

  • Los argumentos núm_fila y núm_columna deben indicar una celda incluida en matriz; de lo contrario, INDICE devuelve el valor de error #¡REF!

Ejemplo 1

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

Cómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.

  2. Seleccione el ejemplo en el tema de Ayuda.

    Nota   No seleccione los encabezados de fila ni de columna.

    Seleccionar un ejemplo de la Ayuda

    Seleccionar un ejemplo de la Ayuda

  3. Presione CTRL+C.

  4. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

  5. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en el grupo Auditoría de fórmulas de la ficha Fórmulas, haga clic en el botón Mostrar fórmulas.

1

2

3

A

B

Datos

Datos

Manzanas

Limones

Bananas

Peras

Fórmula

Descripción (resultado)

=INDICE(A2:B3;2;2)

Valor situado en la intersección de la segunda fila y la segunda columna del rango (Peras)

=INDICE(A2:B3;2;1)

Valor situado en la intersección de la segunda fila y la primera columna del rango (Bananas)

Ejemplo 2

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

Cómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.

  2. Seleccione el ejemplo en el tema de Ayuda.

    Nota   No seleccione los encabezados de fila ni de columna.

    Seleccionar un ejemplo de la Ayuda

    Seleccionar un ejemplo de la Ayuda

  3. Presione CTRL+C.

  4. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

  5. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en el grupo Auditoría de fórmulas de la ficha Fórmulas, haga clic en el botón Mostrar fórmulas.

1

2

3

A

B

Fórmula

Descripción (resultado)

=INDICE({1;2;3;4};0;2)

Valor situado en la primera fila de la constante matricial (2)

Valor situado en la segunda fila, segunda columna de la constante matricial (4)

Nota   La fórmula del ejemplo debe especificarse como fórmula de matriz. Después de copiar el ejemplo en una hoja de cálculo en blanco, seleccione el rango A2:A3 comenzando por la celda de la fórmula. Presione F2 y, a continuación, CTRL+MAYÚS+ENTRAR. Si la fórmula no se especifica como fórmula de matriz, el resultado único es 2.

Volver al principio

Forma de referencia

Devuelve la referencia de la celda ubicada en la intersección de una fila y de una columna determinadas. Si el argumento ref es una selección múltiple, se podrá elegir la selección en la que se buscará la referencia.

INDICE(ref;núm_fila;núm_columna;núm_área)

Ref     es una referencia a uno o varios rangos de celdas.

  • Si especifica un rango no adyacente como argumento ref, escríbalo entre paréntesis.

  • Si cada área del argumento ref contiene una sola fila o columna, el argumento núm_fila o núm_columna respectivamente, es opcional. Por ejemplo, utilice INDICE(ref;;núm_columna) para un argumento ref con una sola fila.

Núm_fila     es el número de la fila en el argumento ref desde la que se devolverá una referencia.

Núm_columna     es el número de la columna en el argumento ref desde la que se devolverá una referencia.

Núm_área     selecciona un rango en el argumento ref desde el cual se devolverá la intersección de núm_fila y núm_columna. La primera área seleccionada o especificada se numera con 1, la segunda con 2 y así sucesivamente. Si se omite núm_área, INDICE usa área 1.

  • Por ejemplo, si ref describe las celdas (A1:B4;D1:E4;G1:H4), entonces núm_área 1 es el rango A1:B4, núm_área 2 será el rango D1:E4, y núm_área 3 es el rango G1:H4.

Observaciones

  • Después de que ref y núm_área hayan seleccionado un rango determinado, núm_fila y núm_columna seleccionan una celda específica: núm_fila 1 es la primera fila del rango, núm_columna 1 es la primera columna y así sucesivamente. La referencia devuelta por INDICE es la intersección entre núm_fila y núm_columna.

  • Si se define núm_fila o núm_columna como 0 (cero), INDICE devuelve la referencia de toda la fila o columna, según corresponda.

  • Núm_fila, núm_columna y núm_área deberán dirigirse a una celda en ref, de lo contrario la función INDICE devuelve el valor de error #¡REF! Si núm_fila y núm_columna se omiten, INDICE devuelve el área del argumento ref definido por núm_área.

  • El resultado de la función INDICE es una referencia y será interpretada como tal por otras fórmulas. El valor devuelto por la función INDICE se puede utilizar como una referencia o como un valor, dependiendo de la fórmula. Por ejemplo, la fórmula CELDA("ancho";INDICE(A1:B2;1;2)) es igual a CELDA("ancho";B1). La función CELDA utiliza el valor devuelto por INDICE como referencia a una celda. Por otra parte, una fórmula como 2*INDICE(A1:B2;1;2) traduce el valor devuelto por INDICE en el número de la celda B1.

Ejemplo

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

Cómo copiar un ejemplo

  1. Cree un libro o una hoja de cálculo en blanco.

  2. Seleccione el ejemplo en el tema de Ayuda.

    Nota   No seleccione los encabezados de fila ni de columna.

    Seleccionar un ejemplo de la Ayuda

    Seleccionar un ejemplo de la Ayuda

  3. Presione CTRL+C.

  4. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

  5. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en el grupo Auditoría de fórmulas de la ficha Fórmulas, haga clic en el botón Mostrar fórmulas.

1

2

3

4

5

6

7

8

9

10

11

A

B

C

Fruta

Precio

Cantidad

Manzanas

0,69

40

Bananas

0,34

38

Limones

0,55

15

Naranjas

0,25

25

Peras

0,59

40

Almendras

2,80

10

Anacardos

3,55

16

Cacahuetes

1,25

20

Nueces

1,75

12

Fórmula

Descripción (resultado)

=INDICE(A2:C6;2;3)

Intersección de la segunda fila y la tercera columna en el rango A2:C6, que es el contenido de la celda C3 (38).

=INDICE((A1:C6;A8:C11);2;2;2)

Intersección de la segunda fila y la segunda columna en la segunda área de A8:C11, que es el contenido de la celda B9 (3,55).

=SUMA(INDICE(A1:C11;0;3;1))

Suma de la tercera columna en la primera área del rango A1:C11, que es la suma de C1:C6 (216).

=SUMA(B2:INDICE(A2:C6;5;2))

Suma del rango que comienza en B2 y termina en la intersección de la quinta fila y la segunda columna del rango A2:A6, que es la suma de B2:B6 (2,42).

Volver al principio

Se aplica a: Excel 2007



¿Le ha sido útil esta información?

No

¿Cómo podemos mejorarlo?

255 caracteres restantes

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!

Recursos de soporte técnico

Cambiar idioma