Función BUSCARV

Use BUSCARV, una de las funciones de búsqueda y referencia, cuando necesite encontrar elementos en una tabla o en un rango por filas. Por ejemplo, busque los apellidos de un empleado por su número de empleado, o encuentre su número de teléfono mediante la búsqueda de sus apellidos (como en un listín telefónico).

El secreto de BUSCARV es organizar los datos de manera que el valor que busque (apellidos del empleado) esté a la izquierda del valor devuelto que desea buscar (número de teléfono del empleado).

Sintaxis

BUSCARV (valor_buscado, matriz_buscar_en, indicador_columnas, [ordenado])

Por ejemplo:

  • =BUSCARV(105,A2:C7,2,VERDADERO)

  • =BUSCARV("López",B2:E7,2,FALSO)

Nombre del argumento

Descripción

valor_buscado    (requerido)

El valor que desea buscar. El valor que se desea buscar debe estar en la primera columna del rango de celdas que especifique en matriz_buscar_en.

Por ejemplo, si matriz_buscar_en toma las celdas B2:D7, valor_buscado debe estar en la columna B. Consulte el siguiente gráfico. valor_buscado puede ser un valor o una referencia a una celda.

matriz_tabla    (obligatorio)

El rango de celdas en las que BUSCARV buscará valor_buscado y el valor devuelto.

La primera columna en el rango de celdas debe contener valor_buscado (por ejemplo, Apellidos en el siguiente gráfico). El rango de celdas también debe incluir el valor devuelto que desea encontrar (por ejemplo, Nombre en el siguiente gráfico).

Obtenga información sobre cómo seleccionar rangos en una hoja.

indicador_columnas    (requerido)

El número de columna (a partir de 1 para la columna situada más a la izquierda de matriz_tabla) que contiene el valor devuelto.

ordenado   (opcional)

Un valor lógico que especifica si BUSCARV va a buscar una coincidencia exacta o aproximada:

  • VERDADERO da por sentado que la primera columna está ordenada, ya sea alfabéticamente o numéricamente, y busca el valor más próximo. Este es el método predeterminado si no especifica uno.

  • FALSO busca el valor exacto en la primera columna.

En la siguiente imagen se muestra cómo se debe configurar la hoja de cálculo con =VLOOKUP("Akers",B2:D5,2,FALSE) para que devuelva Kim.

Ejemplo de valor y matriz necesarios para crear una fórmula BUSCARV en Excel

Ejemplos

Para utilizar estos ejemplos en Excel, copie los datos de la tabla de abajo y péguela en la celda A1 de una nueva hoja de cálculo.

ID

Apellidos

Nombre

Título

Fecha de nacimiento

101

Cornejo

Sara

Repr. ventas

8/12/1968

102

López

Arturo

Vicepresidente de ventas

19/2/1952

103

Leal

Karina

Repr. de ventas

30/8/1963

104

Escolar

Jesús

Repr. de ventas

19/9/1958

105

Navarro

Tomás

Jefe de ventas

4/3/1955

106

Gil

Luis

Repr. de ventas

2/7/1963

Fórmula

Descripción

=BUSCARV("López",B2:E7,FALSO)

Busca el valor López en la primera columna (columna B) de matriz_buscar_en B2:E7 y devuelve el valor Arturo encontrado en la segunda columna (columna C) de matriz_buscar_en. ordenado FALSO devuelve una coincidencia exacta.

=BUSCARV(102,A2:C7,2,FALSO)

Busca una coincidencia exacta del apellido para valor_buscado102 en la columna A. Se devuelve Fontana. Si el valor_buscado es 105, se devuelve Burke.

=SI(BUSCARV(103,A1:E7,2,FALSO)="Gil","Encontrado","No encontrado")

Comprueba si el apellido del empleado con el identificador 103 es Gil. Puesto que 103 es, en realidad, Leal, el resultado es No encontrado. Si cambia "Gil" a "Leal" en la fórmula, el resultado será Encontrado.

=ENTERO(FRAC.AÑO(FECHA(2014,6,30), BUSCARV(105,A2:E7,5, FALSO), 1))

Para el año fiscal 2014, busque la edad del empleado con el identificador 105. Usa la función FRAC.AÑO para to restar la fecha de nacimiento de la fecha final del año fiscal y muestra el resultado 59 como un entero usando la función ENTERO.

=SI(ESNOD(BUSCARV(105;A2:E7;2;FALSO)) = VERDADERO; "Empleado no encontrado"; BUSCARV(105;A2:E7;2;FALSO))

Si hay algún empleado con el identificador 105, muestra el apellido del empleado (Robledo). De lo contrario, muestra el mensaje Empleado no encontrado. La función ESNOD (consulte Funciones ES) devuelve un valor VERDADERO cuando la función BUSCARV devuelve un valor de error #N/A.

=BUSCARV(104,A2:E7,3,FALSO) & " " & BUSCARV(104,A2:E7,2,FALSO) & " es " & BUSCARV(104,A2:E7,4,FALSO)

Para un empleado con identificador 104, concatena (combina) los valores de tres celdas para formar una frase completa (Jesús Escolar es representante de ventas).

Problemas comunes

Problema

Qué ha fallado

Valor devuelto incorrecto

Si ordenado es VERDADERO o se omite, es necesario ordenar la primera columna alfabéticamente o numéricamente. Si la primera columna no está ordenada, el valor devuelto puede ser algo inesperado. Puede ordenar la primera columna o usar FALSO para obtener una coincidencia exacta.

#N/A en la celda

  • Si ordenado es VERDADERO y el valor en valor_buscado es más pequeño que el valor más pequeño de la primera columna de la matriz_buscar_en, el valor de resultado será #N/A.

  • Si ordenado es FALSO, el valor de error #N/A indica que no se ha encontrado el número exacto.

Más información sobre errores en las hojas de cálculo, como #N/A, #¡REF! y el resto.

#¡REF! en la celda

Si indicador_columnas es mayor que el número de columnas en matriz_buscar_en, el valor devuelto será #¡REF!

#¡VALOR! en la celda

Si matriz_buscar_en es menos de 1, el valor devuelto será #¡VALOR!

#¿NOMBRE? en la celda

El valor de error #¿NOMBRE? normalmente significa que en la fórmula faltan comillas. Para buscar el nombre de una persona, asegúrese de que el nombre aparece entre comillas en la fórmula. Por ejemplo, escriba el nombre como "López" en =BUSCARV( "López",B2:E7,2,FALSO).

Prácticas recomendadas

Realice este procedimiento

¿Por qué?

Use referencias absolutas para ordenado.

Las referencias absolutas le permiten rellenar hacia abajo una fórmula, de manera que siempre se busca en el mismo rango de búsqueda.

Aprenda a usar referencias de celda absolutas.

No almacene valores de fechas o números como texto.

Al buscar valores de fechas o números, asegúrese de que los datos de la primera columna de matriz_buscar_en no se almacenen como valores de texto, ya que, en ese caso, BUSCARV puede devolver un valor incorrecto o inesperado.

Ordene la primera columna.

Ordene la primera columna de la matriz_tabla antes de usar BUSCARV cuando ordenado sea VERDADERO.

Use caracteres comodín.

Si ordenado es FALSO y valor_buscado es un texto, se pueden usar los caracteres comodín de signo de interrogación (?) y asterisco (*) en valor_buscado. El signo de interrogación corresponde a un solo carácter cualquiera y el asterisco equivale a cualquier secuencia de caracteres. Si lo que desea buscar es un signo de interrogación o un asterisco, escriba una tilde (~) antes del carácter.

Por ejemplo, =VLOOKUP("Fontan?",B2:E7,2,FALSE) buscará todas las instancias de López con una última letra que podría variar.

Asegúrese de que los datos no contienen caracteres incorrectos.

Al buscar valores de texto en la primera columna, asegúrese de que los datos de la primera columna no contienen espacios al principio ni al final, de que no haya un uso incoherente de las comillas rectas (' o ") ni tipográficas (‘ o “) y de que no haya caracteres no imprimibles. En estos casos, BUSCARV puede devolver un valor inesperado o incorrecto.

Para obtener resultados, pruebe a usar la función LIMPIAR o la función SUPRESP para eliminar los espacios finales detrás de los valores de tabal en una celda.

Relacionado

Se aplica a: Excel Starter, Excel for Mac 2011, Excel 2016 for Mac, Excel 2010, Excel 2013, Excel 2016 Preview, Excel 2007, Excel Online



¿Le ha sido útil esta información?

No

¿Cómo podemos mejorarlo?

255 caracteres restantes

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!

Recursos de soporte técnico

Cambiar idioma