Firmar digitalmente un proyecto de macro

En este artículo se describe cómo se puede firmar digitalmente un proyecto de macros mediante certificado. Si aún no tiene ningún certificado digital, debe obtener uno. Para probar los proyectos de macro en su propio equipo, puede crear su propio certificado de firma con la herramienta Selfcert.exe.

Puede obtener un certificado digital de una entidad emisora de certificados comercial o del administrador de seguridad o de un profesional de las tecnologías de la información de su organización.

Para obtener más información sobre entidades emisoras de certificados que ofrecen servicios para productos de Microsoft, consulte la lista de Miembros del Programa de certificados raíz de Microsoft.

Principio de página

Dado que el certificado digital que crea no está emitido por una entidad de certificación formal de confianza, los proyectos de macro firmados con dichos certificados se conocen como proyectos con firma propia. Microsoft Office confía en los certificados de firma propia únicamente en los equipos que contienen el certificado de firma propia agregado en la carpeta de certificación raíz de confianza en el almacén de certificados del usuario actual.

Para obtener información sobre la creación de un certificado de firma propia, consulte la sección siguiente.

  1. Vaya a C:\Archivos de programa (x86)\Microsoft Office\root\.

  2. Haga clic en SelfCert.exe. Aparece el cuadro Crear certificado digital.

  3. En el cuadro Nombre del certificado, escriba un nombre descriptivo para el certificado.

  4. Haga clic en Aceptar.

  5. Cuando se observe el mensaje SelfCert se ha creado correctamente, haga clic en Aceptar.

  1. Vaya a C:\Archivos de programa\Microsoft Office\<versión de Office>\.

  2. Haga clic en SelfCert.exe. Aparece el cuadro Crear certificado digital.

  3. En el cuadro Nombre del certificado, escriba un nombre descriptivo para el certificado.

  4. Haga clic en Aceptar.

  5. Cuando se observe el mensaje SelfCert se ha creado correctamente, haga clic en Aceptar.

  1. Haga clic en el botón Inicio, elija Todos los programas, haga clic en Microsoft Office, en Herramientas de Microsoft Office y después en Certificado digital para proyectos de VBA.
    Aparecerá el cuadro Crear certificado digital.

  2. En el cuadro Nombre del certificado, escriba un nombre descriptivo para el certificado.

  3. Haga clic en Aceptar.

  4. Cuando se observe el mensaje SelfCert se ha creado correctamente, haga clic en Aceptar.

Cuadro de diálogo Crear firma digital

Para ver el certificado en el almacén de certificados personales, siga este procedimiento:

  1. Abra Internet Explorer.

  2. En el menú Herramientas, haga clic en Opciones de Internet y después en la pestaña Contenido.

  3. Haga clic en Certificados y después en la pestaña Personal.

Principio de página

  1. Abra el archivo que contiene el proyecto de macro que desee firmar.

  2. En la pestaña Programador, en el grupo Código, haga clic en Visual Basic.

    Nota: Si la pestaña Programador no está disponible: haga clic en la pestaña Archivo. Haga clic en Opciones. Haga clic en Personalizar cinta de opciones. En la lista Personalizar la Cinta, seleccione Programador y después haga clic en Aceptar.

  3. En Visual Basic, en el menú Herramientas haga clic en Firma digital.

  4. Se observa el cuadro de diálogo Firma digital.

  5. Seleccione un certificado y haga clic en Aceptar.

    Nota: Si no ha seleccionado previamente un certificado digital o desea usar otro, haga clic en Elegir, seleccione el certificado y haga clic en Aceptar.

    Notas: 

    • Se recomienda firmar las macros solamente después de haber probado la solución y de que esta esté lista para ser distribuida: cuando se modifica de algún modo el código de un proyecto de macro firmado, se elimina la firma digital. Sin embargo, si tiene el certificado digital válido que anteriormente se usó para firmar el proyecto en el equipo, el proyecto de macro se firmará automáticamente al guardarlo.

    • Si desea impedir que los usuarios de la solución modifiquen la macro accidentalmente e invaliden la firma, bloquee el proyecto de macro antes de firmarlo. La firma digital indica que el usuario garantiza que el proyecto no se ha manipulado después de haber sido firmado, no demuestra que el usuario lo haya escrito. Así pues, bloquear el proyecto no impide que otro usuario sustituya la firma digital por otra firma. Los administradores corporativos pueden volver a firmar las plantillas y los complementos para poder controlar qué usuarios podrían operar en sus equipos.

    • Si crea un complemento que agrega código a un proyecto de macro, el código debe determinar si el proyecto se ha firmado digitalmente e informar al usuario de las consecuencias de modificar un proyecto firmado antes de continuar.

    • Cuando firme macros digitalmente, es importante que obtenga una marca de tiempo para que otros usuarios puedan comprobar la firma si el certificado utilizado para la firma ha caducado o ha sido revocado después de firmar. Si firma macros sin ninguna marca de tiempo, la firma solo será válida durante el período de validez del certificado.

Principio de página

Puede obtener un certificado digital de una entidad emisora de certificados comercial o de su administrador de seguridad.

Para obtener más información sobre entidades emisoras de certificados que ofrecen servicios para productos de Microsoft, consulte la lista de Miembros del Programa de certificados raíz de Microsoft.

Principio de página

Dado que el certificado digital que cree no está emitido por una entidad de certificación de confianza formal, los proyectos de macro firmados con dichos certificados se conocen como proyectos con firma propia. Microsoft Office confía en los certificados con firma propia únicamente en los certificados alojados en el almacén de certificados personales.

  1. Haga clic en el botón Inicio, elija Todos los programas, haga clic en Microsoft Office, en Herramientas de Microsoft Office y después en Certificado digital para proyectos de VBA. En el cuadro Nombre del certificado, escriba un nombre descriptivo para el certificado.

  2. Cuando aparezca el mensaje de confirmación del certificado, haga clic en Aceptar.

Para ver el certificado en el almacén de certificados personales, siga este procedimiento:

  1. Abra Internet Explorer.

  2. En el menú Herramientas, haga clic en Opciones de Internet y después en la pestaña Contenido.

  3. Haga clic en Certificados y después en la pestaña Personal.

Principio de página

  1. Haga clic en Inicio, elija Todos los programas, Microsoft Office, Herramientas de Microsoft Office y, después, haga clic en Certificado digital para proyectos de VBA. En el cuadro Nombre del certificado, escriba un nombre descriptivo para el certificado.

  2. Cuando aparezca el mensaje de confirmación del certificado, haga clic en Aceptar.

Para ver el certificado en el almacén de certificados personales, siga este procedimiento:

  1. Abra Internet Explorer.

  2. En el menú Herramientas, haga clic en Opciones de Internet y después en la pestaña Contenido.

  3. Haga clic en Certificados y después en la pestaña Personal.

Principio de página

  1. Abra el archivo que contiene el proyecto de macro que desee firmar.

    • En la pestaña Desarrollador, en el grupo Código, haga clic en Visual Basic.

      Si la pestaña Desarrollador no se muestra, haga clic en el botón Microsoft Office Imagen del botón de Office y luego en Opciones de Excel. Después, haga clic en Populares y active la casilla Mostrar la pestaña Desarrollador en la cinta de opciones.

      Nota: La cinta forma parte del interfaz de usuario de Microsoft Office Fluent.

  2. En el Explorador de proyectos de Visual Basic, seleccione el proyecto que desea firmar.

  3. En el menú Herramientas, haga clic en Firma digital.

  4. Siga uno de estos procedimientos:

    • Si no ha seleccionado previamente un certificado digital o desea usar otro, haga clic en Elegir, seleccione el certificado y haga clic en Aceptar dos veces.

    • Para usar el certificado actual, haga clic en Aceptar.

      Notas: 

      • Firme macros solamente después de haber probado la solución y de que esta esté lista para ser distribuida, puesto que cuando se modifica de algún modo el código de un proyecto de macro firmado, se elimina la firma digital. Sin embargo, si tiene el certificado digital válido que anteriormente se usó para firmar el proyecto en su equipo, el proyecto de macro se firmará automáticamente al guardarlo.

      • Si desea impedir que los usuarios de su solución modifiquen el proyecto de macro e invaliden la firma accidentalmente, bloquee el proyecto de macro antes de firmarlo. Su firma digital indica únicamente que garantiza que el proyecto no se ha manipulado después de haber sido firmado, no demuestra que lo haya escrito. Así pues, bloquear el proyecto de macro no impide que otro usuario sustituya la firma digital por otra. Los administradores corporativos pueden volver a firmar las plantillas y los complementos para poder controlar qué usuarios pueden operar en sus equipos.

      • Si crea un complemento que agrega código a un proyecto de macro, el código debe determinar si el proyecto se ha firmado digitalmente e informar al usuario de las consecuencias de modificar un proyecto firmado antes de continuar.

      • Cuando firme macros digitalmente, es importante que obtenga una marca de tiempo para que otros usuarios puedan comprobar la firma incluso si el certificado utilizado para la firma ha caducado. Si firma macros sin ninguna marca de tiempo, la firma solo será válida durante el período de validez del certificado.

  1. Abra el archivo que contiene el proyecto de macro que desee firmar.

    • En el menú Herramientas, elija Macro y luego haga clic en Editor de Visual Basic.

  2. En el Explorador de proyectos de Visual Basic, seleccione el proyecto que desea firmar.

  3. En el menú Herramientas, haga clic en Firma digital.

  4. Siga uno de estos procedimientos:

    • Si no ha seleccionado previamente un certificado digital o desea usar otro, haga clic en Elegir, seleccione el certificado y haga clic en Aceptar dos veces.

    • Para usar el certificado actual, haga clic en Aceptar.

      Notas: 

      • Firme macros solamente después de haber probado la solución y de que esta esté lista para ser distribuida, puesto que cuando se modifica de algún modo el código de un proyecto de macro firmado, se elimina la firma digital. Sin embargo, si tiene el certificado digital válido que anteriormente se usó para firmar el proyecto en su equipo, el proyecto de macro se firmará automáticamente al guardarlo.

      • Si desea impedir que los usuarios de su solución modifiquen el proyecto de macro e invaliden la firma accidentalmente, bloquee el proyecto de macro antes de firmarlo. Su firma digital indica únicamente que garantiza que el proyecto no se ha manipulado después de haber sido firmado, no demuestra que lo haya escrito. Así pues, bloquear el proyecto de macro no impide que otro usuario sustituya la firma digital por otra. Los administradores corporativos pueden volver a firmar las plantillas y los complementos para poder controlar qué usuarios pueden operar en sus equipos.

      • Si crea un complemento que agrega código a un proyecto de macro, el código debe determinar si el proyecto se ha firmado digitalmente e informar al usuario de las consecuencias de modificar un proyecto firmado antes de continuar.

      • Cuando firme macros digitalmente, es importante que obtenga una marca de tiempo para que otros usuarios puedan comprobar la firma incluso si el certificado utilizado para la firma ha caducado. Si firma macros sin ninguna marca de tiempo, la firma solo será válida durante el período de validez del certificado.

Principio de página

  1. Abra el archivo que contiene el proyecto de macro que desee firmar.

    • En la pestaña Programador, en el grupo Código, haga clic en Visual Basic.

      Si la pestaña Desarrollador no se muestra, haga clic en el botón Microsoft Office Imagen del botón de Office y luego en Opciones de PowerPoint. Después, haga clic en Populares y active la casilla Mostrar la pestaña Desarrollador en la cinta de opciones.

      Nota: La cinta forma parte del interfaz de usuario de Microsoft Office Fluent.

  2. En el Explorador de proyectos de Visual Basic, seleccione el proyecto que desea firmar.

  3. En el menú Herramientas, haga clic en Firma digital.

  4. Siga uno de estos procedimientos:

    • Si no ha seleccionado previamente un certificado digital o desea usar otro, haga clic en Elegir, seleccione el certificado y haga clic en Aceptar dos veces.

    • Para usar el certificado actual, haga clic en Aceptar.

      Notas: 

      • Firme macros solamente después de haber probado la solución y de que esta esté lista para ser distribuida, puesto que cuando se modifica de algún modo el código de un proyecto de macro firmado, se elimina la firma digital. Sin embargo, si tiene el certificado digital válido que anteriormente se usó para firmar el proyecto en su equipo, el proyecto de macro se firmará automáticamente al guardarlo.

      • Si desea impedir que los usuarios de su solución modifiquen el proyecto de macro e invaliden la firma accidentalmente, bloquee el proyecto de macro antes de firmarlo. Su firma digital indica únicamente que garantiza que el proyecto no se ha manipulado después de haber sido firmado, no demuestra que lo haya escrito. Así pues, bloquear el proyecto de macro no impide que otro usuario sustituya la firma digital por otra. Los administradores corporativos pueden volver a firmar las plantillas y los complementos para poder controlar qué usuarios pueden operar en sus equipos.

      • Si crea un complemento que agrega código a un proyecto de macro, el código debe determinar si el proyecto se ha firmado digitalmente e informar al usuario de las consecuencias de modificar un proyecto firmado antes de continuar.

      • Cuando firme macros digitalmente, es importante que obtenga una marca de tiempo para que otros usuarios puedan comprobar la firma incluso si el certificado utilizado para la firma ha caducado. Si firma macros sin ninguna marca de tiempo, la firma solo será válida durante el período de validez del certificado.

Principio de página

  1. Abra el archivo que contiene el proyecto de macro que desee firmar.

    • En el menú Herramientas, elija Macro y luego haga clic en Editor de Visual Basic.

  2. En el Explorador de proyectos de Visual Basic, seleccione el proyecto que desea firmar.

  3. En el menú Herramientas, haga clic en Firma digital.

  4. Siga uno de estos procedimientos:

    • Si no ha seleccionado previamente un certificado digital o desea usar otro, haga clic en Elegir, seleccione el certificado y haga clic en Aceptar dos veces.

    • Para usar el certificado actual, haga clic en Aceptar.

      Notas: 

      • Firme macros solamente después de haber probado la solución y de que esta esté lista para ser distribuida, puesto que cuando se modifica de algún modo el código de un proyecto de macro firmado, se elimina la firma digital. Sin embargo, si tiene el certificado digital válido que anteriormente se usó para firmar el proyecto en su equipo, el proyecto de macro se firmará automáticamente al guardarlo.

      • Si desea impedir que los usuarios de su solución modifiquen el proyecto de macro e invaliden la firma accidentalmente, bloquee el proyecto de macro antes de firmarlo. Su firma digital indica únicamente que garantiza que el proyecto no se ha manipulado después de haber sido firmado, no demuestra que lo haya escrito. Así pues, bloquear el proyecto de macro no impide que otro usuario sustituya la firma digital por otra. Los administradores corporativos pueden volver a firmar las plantillas y los complementos para poder controlar qué usuarios pueden operar en sus equipos.

      • Si crea un complemento que agrega código a un proyecto de macro, el código debe determinar si el proyecto se ha firmado digitalmente e informar al usuario de las consecuencias de modificar un proyecto firmado antes de continuar.

      • Cuando firme macros digitalmente, es importante que obtenga una marca de tiempo para que otros usuarios puedan comprobar la firma incluso si el certificado utilizado para la firma ha caducado. Si firma macros sin ninguna marca de tiempo, la firma solo será válida durante el período de validez del certificado.

Principio de página

  1. Abra el archivo que contiene el proyecto de macro que desee firmar.

    • En el menú Herramientas, elija Macro y luego haga clic en Editor de Visual Basic.

  2. En el Explorador de proyectos de Visual Basic, seleccione el proyecto que desea firmar.

  3. En el menú Herramientas, haga clic en Firma digital.

  4. Siga uno de estos procedimientos:

    • Si no ha seleccionado previamente un certificado digital o desea usar otro, haga clic en Elegir, seleccione el certificado y haga clic en Aceptar dos veces.

    • Para usar el certificado actual, haga clic en Aceptar.

      Notas: 

      • Firme macros solamente después de haber probado la solución y de que esta esté lista para ser distribuida, puesto que cuando se modifica de algún modo el código de un proyecto de macro firmado, se elimina la firma digital. Sin embargo, si tiene el certificado digital válido que anteriormente se usó para firmar el proyecto en su equipo, el proyecto de macro se firmará automáticamente al guardarlo.

      • Si desea impedir que los usuarios de su solución modifiquen el proyecto de macro e invaliden la firma accidentalmente, bloquee el proyecto de macro antes de firmarlo. Su firma digital indica únicamente que garantiza que el proyecto no se ha manipulado después de haber sido firmado, no demuestra que lo haya escrito. Así pues, bloquear el proyecto de macro no impide que otro usuario sustituya la firma digital por otra. Los administradores corporativos pueden volver a firmar las plantillas y los complementos para poder controlar qué usuarios pueden operar en sus equipos.

      • Si crea un complemento que agrega código a un proyecto de macro, el código debe determinar si el proyecto se ha firmado digitalmente e informar al usuario de las consecuencias de modificar un proyecto firmado antes de continuar.

      • Cuando firme macros digitalmente, es importante que obtenga una marca de tiempo para que otros usuarios puedan comprobar la firma incluso si el certificado utilizado para la firma ha caducado. Si firma macros sin ninguna marca de tiempo, la firma solo será válida durante el período de validez del certificado.

  1. Abra el archivo que contiene el proyecto de macro que desee firmar.

    • En la pestaña Programador, en el grupo Código, haga clic en Visual Basic.

      Si la pestaña Desarrollador no se muestra, haga clic en el botón Microsoft Office Imagen del botón de Office y luego en Opciones de Word. Después, haga clic en Populares y active la casilla Mostrar la pestaña Desarrollador en la cinta de opciones.

      Nota: La cinta forma parte del interfaz de usuario de Microsoft Office Fluent.

  2. En el Explorador de proyectos de Visual Basic, seleccione el proyecto que desea firmar.

  3. En el menú Herramientas, haga clic en Firma digital.

  4. Siga uno de estos procedimientos:

    • Si no ha seleccionado previamente un certificado digital o desea usar otro, haga clic en Elegir, seleccione el certificado y haga clic en Aceptar dos veces.

    • Para usar el certificado actual, haga clic en Aceptar.

      Notas: 

      • Firme macros solamente después de haber probado la solución y de que esta esté lista para ser distribuida, puesto que cuando se modifica de algún modo el código de un proyecto de macro firmado, se elimina la firma digital. Sin embargo, si tiene el certificado digital válido que anteriormente se usó para firmar el proyecto en su equipo, el proyecto de macro se firmará automáticamente al guardarlo.

      • Si desea impedir que los usuarios de su solución modifiquen el proyecto de macro e invaliden la firma accidentalmente, bloquee el proyecto de macro antes de firmarlo. Su firma digital indica únicamente que garantiza que el proyecto no se ha manipulado después de haber sido firmado, no demuestra que lo haya escrito. Así pues, bloquear el proyecto de macro no impide que otro usuario sustituya la firma digital por otra. Los administradores corporativos pueden volver a firmar las plantillas y los complementos para poder controlar qué usuarios pueden operar en sus equipos.

      • Si crea un complemento que agrega código a un proyecto de macro, el código debe determinar si el proyecto se ha firmado digitalmente e informar al usuario de las consecuencias de modificar un proyecto firmado antes de continuar.

      • Cuando firme macros digitalmente, es importante que obtenga una marca de tiempo para que otros usuarios puedan comprobar la firma incluso si el certificado utilizado para la firma ha caducado. Si firma macros sin ninguna marca de tiempo, la firma solo será válida durante el período de validez del certificado.

Principio de página

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×