Evaluar una fórmula anidada paso a paso

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

A veces, es difícil comprender cómo calcula el resultado final una fórmula anidada es difícil porque hay varios cálculos intermedios y pruebas lógicas. Pero, mediante el cuadro de diálogo Evaluar fórmula, puede ver las distintas partes de la fórmula anidada evaluadas en el orden en el que se calcula la fórmula. Por ejemplo, la fórmula =SI(PROMEDIO(F2:F5)>50,SUMA(G2:G5),0) es más fácil de comprender cuando puede ver los siguientes resultados intermedios:

Pasos que aparecen en el cuadro de diálogo

Descripción

=SI(PROMEDIO(F2:F5)>50;SUMA(G2:G5);0)

La fórmula anidada se muestra al principio. Las funciones PROMEDIO y SUMA se anidan dentro de la función SI.

=SI(40>50,SUMA(G2:G5),0)

El rango de celdas F2:F5 contiene los valores 55, 35, 45 y 25, etc., así el resultado de la función PROMEDIO(F2:F5) es 40.

=SI(Falso,SUMA(G2:G5),0)

40 no es mayor que 50, por lo que la expresión en el primer argumento de la función si (el argumento prueba_lógica) es falsa.

0

La función si devuelve el valor del tercer argumento (el argumento valor_si_falso). La función suma no se evalúa porque es el segundo argumento de la función si (argumento valor_si_verdadero) y se devuelve solo cuando la expresión es true.

  1. Una vez más, seleccione la celda a la que desea dar formato. Solo se puede evaluar una celda a la vez.

  2. En el grupo Auditoría de fórmulas de la pestaña Fórmulas, haga clic en Evaluar fórmula.

    Grupo Auditoría de fórmulas en la ficha Fórmulas

  3. Haga clic en Evaluar para examinar el valor de la referencia subrayada. El resultado de la evaluación se muestra en cursiva.

    Si la parte subrayada de la fórmula es una referencia a otra fórmula, haga clic en Paso a paso para entrar para mostrar la otra fórmula en el cuadro Evaluación. Haga clic en Paso a paso para salir para volver a la celda y fórmula anteriores.

    Nota: El botón Paso a paso para entrar no está disponible la segunda vez que la referencia aparece en la fórmula o si la fórmula hace referencia a una celda de otro libro.

  4. Continúe hasta que se haya evaluado cada parte de la fórmula.

  5. Para volver a ver la evaluación, haga clic en Reiniciar.

    Para finalizar la evaluación, haga clic en Cerrar.

    Notas: 

    • Algunas partes de las fórmulas que utilizan el concepto si y elegir funciones no se evalúan y #N/A se muestra en el cuadro evaluación.

    • Si una referencia está en blanco, un valor de cero (0) se muestra en el cuadro Evaluación.

    • Las siguientes funciones se actualizan cada vez que los cambios de la hoja de cálculo y puede provocar que Evaluar fórmula dé resultados diferentes de lo que aparece en la celda: aleatorio, áreas, índice, DESREF, celda, indirecto, filas, columnas, ahora, hoy, aleatorio.

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

¿Le ha sido útil esta información?

De acuerdo. ¿Algún comentario más?

¿Cómo podemos mejorarlo?

¡Gracias por sus comentarios!

×